lien symbolique /dev/dvd détruit quand on met dvd dans le lecteur

Le
François Patte
Bonjour,

Je suis dans la perplexité la plus totale: il suffit de mettre un DVD
dans le lecteur et de l'enfourner dans la machine pour que, une fois le
dvd monté, les liens symboliques /dev/dvd, /dev/cdrom, etc. soit
détruits.

Et seul un redémarrage les recrée.

C'est sous fedora 12.

Bien sûr, ça n'empèche pas de lire les disques, mais pas avec toutes les
applications: kaffeine ne marche plus par exemple.

Quelqu'un peut-il m'expliquer ça et m'indiquer un remède?

Ou bien me donner un moyen pour partir en chasse et débusquer le
coupable (rien dans les log).


Merci.

--
François Patte
Université Paris Descartes
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #21064591
François Patte
wrote in message
Et seul un redémarrage les recrée....



Je suis sûr qu'un ln -s, éventuellement aidé de su ou sudo, en serait
également capable.

C'est sous fedora 12.



Ah bien forcément.
François Patte
Le #21064721
Le 27/01/2010 18:27, Nicolas George a écrit :
François Patte
wrote in message
Et seul un redémarrage les recrée....



Je suis sûr qu'un ln -s, éventuellement aidé de su ou sudo, en serait
également capable.



Ben moi aussi... Mais, vais-je expliquer à mon fils que lorsqu'il veut
regarder un dvd avec kaffeine, il n'a qu'à passer root et créer le bon
lien là où il faut....


C'est sous fedora 12.



Ah bien forcément.



?? Mais encore...?

--
François Patte
Université Paris Descartes
Alban Taraire
Le #21068171
François Patte wrote:

Bien sûr, ça n'empèche pas de lire les disques, mais pas avec toutes les
applications: kaffeine ne marche plus par exemple....



Regarde quel device/lien est créé à la place (genre /dev/sr0), et configure
kaffeine pour lire sur /dev/sr0 au liey de /dev/dvd.

Et si kaffeine n'est pas configurable pour ça, utilise VLC ou SMPlayer ou
n'importe quoi de configurable.

--
Alban
Dominique MICOLLET
Le #21068401
François Patte wrote:

Le 27/01/2010 18:27, Nicolas George a écrit :
François Patte
C'est sous fedora 12.



Ah bien forcément.



?? Mais encore...?



Je crois que Nicolas veut dire que certaines distributions sont tellement
Windows-like, qu'il est préférable d'utiliser Windows : on a les mêmes
inconvénients, mais on a aussi les avantages, comme par exemple
l'inexistence des liens symboliques. :-)

Autrement dit, passez à CentOS, ou Ubuntu, voir Debian. :-)

--
Dominique MICOLLET
Adresse email : enlever deux francs
frpatte
Le #21068801
On 28 jan, 07:58, Dominique MICOLLET
bourgogne.fr.fr.fr> wrote:
Fran ois Patte wrote:
>> Le 27/01/2010 18:27, Nicolas George a crit :
>>> Fran ois Patte
>>> C'est sous fedora 12.

>> Ah bien forc ment.

> ?? Mais encore...?

Je crois que Nicolas veut dire que certaines distributions sont tellement
Windows-like, qu'il est pr f rable d'utiliser Windows : on a les m mes
inconv nients, mais on a aussi les avantages, comme par exemple
l'inexistence des liens symboliques. :-)

Autrement dit, passez CentOS, ou Ubuntu, voir Debian. :-)



Je ne pense pas que fedora soit "windows-like" et , dans ce cas,
préconniser CentOS qui en est la version non-"bleeding edges" paraît
bizarre.

D'autre part, j'ai vu sur le ouèbe ubuntu, des plaintes analogues à la
mienne sans être tout à fait la même. Je n'ai pas vu de solution,
jusqu'à présent.

Le problème n'est pas que les liens n'existent pas, mais qu'ils sont
effacés au montage d'un disque, de là à soupçonner HAL.... Quelqu'u n a
dû mettre une ligne dans un fichier de config de HAL, pour je ne sais
quelles raisons, et l'a sans doute oublié ou non testé.

Mais quel est ce fichier? Je ne sais et ne sais pas le trouver.

Quant à configurer kafféine pour lire sur /dev/sr0, je ne sais pas
faire: la seule configuration possible que j'ai trouvée, permet de
configurer les raccourcis clavier.

Si quelqu'un a une idée, merci.
debug this fifo
Le #21069641
frpatte wrote:

dû mettre une ligne dans un fichier de config de HAL, pour je ne sais
quelles raisons, et l'a sans doute oublié ou non testé.



HAL, ou peut-être udev ?
Erwan David
Le #21070021
Dominique MICOLLET
François Patte wrote:

Le 27/01/2010 18:27, Nicolas George a écrit :
François Patte
C'est sous fedora 12.



Ah bien forcément.



?? Mais encore...?



Je crois que Nicolas veut dire que certaines distributions sont tellement
Windows-like, qu'il est préférable d'utiliser Windows : on a les mêmes
inconvénients, mais on a aussi les avantages, comme par exemple
l'inexistence des liens symboliques. :-)



Ils existent dans NTFS, mais uniquement pour les répertoires.
http://en.wikipedia.org/wiki/NTFS_junction_point

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Erwan David
Le #21070201
Erwan David
Dominique MICOLLET
François Patte wrote:

Le 27/01/2010 18:27, Nicolas George a écrit :
François Patte
C'est sous fedora 12.



Ah bien forcément.



?? Mais encore...?



Je crois que Nicolas veut dire que certaines distributions sont tellement
Windows-like, qu'il est préférable d'utiliser Windows : on a les mêmes
inconvénients, mais on a aussi les avantages, comme par exemple
l'inexistence des liens symboliques. :-)



Ils existent dans NTFS, mais uniquement pour les répertoires.
http://en.wikipedia.org/wiki/NTFS_junction_point



Humm correction depuis Vista ils existent complètement...

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Nicolas George
Le #21071131
frpatte wrote in message
Je ne pense pas que fedora soit "windows-like"



Fedora est une bêta de RedHat. Si tu ne veux pas utiliser une version bêta,
n'utilise pas Fedora.
François Patte
Le #21071821
Le 28/01/2010 13:30, Nicolas George a écrit :
frpatte wrote in message
Je ne pense pas que fedora soit "windows-like"



Fedora est une bêta de RedHat. Si tu ne veux pas utiliser une version bêta,
n'utilise pas Fedora.



Il doit y avoir un malentendu: ce n'est pas moi qui qualifie fedora de
ci ou ça.

D'autre part, j'utilise fedora depuis sa création, après avoir utilisé
redhat. Que ce soit plus ou moins beta, j'en suis persuadé.

Je pensais que le forum, était une aide à la configuration de linux et
je pense que le problème que je pose en fait partie, fut-il,
éventuellement, un pb beta.

Je n'ai pas demandé qu'on résolve mon problème, ou que l'on donne son
avis sur ce que j'utilise, mais qu'on me donne une idée sur "où
chercher"....

Si tout était configuré correctement d'emblée, le forum serait une
aimable liste de discussions autour d'un léger thé avec des petits
fours. Il ne me semble pas que ce soit sa destination...

Si personne n'a d'idée sur mon problème, je n'en voudrais à personne. Si
quelqu'un a rencontré le même problème, il serait intéressant qu'on en
discute....

Enfin, voilà.

--
François Patte
Université Paris Descartes
Publicité
Poster une réponse
Anonyme