Liste de dates pour remplir ComboBox

Le
danielos
Bonjour,

Beaucoup de posts ou d'articles concernent les dates ou les opérations
avec mais je n'ai pourtant pas réussi à trouver la réponse à mon problème.

J'ai un USF qui permet de récupérer une date de début d'évènement
(jj/mm/aaaa) et une durée en jours (x) ces 2 valeurs sont récupérées
dans des cellules.
A1 : jj/mm/aaaa
A2 : x

Je souhaiterai avoir dans la colonne C la liste des jours
jj/mm/aaaa
jj/mm/aaaa+1
jj/mm/aaaa+2

jj/mm/aaaa+x

qui me servira à remplir une ComboBox style 2 (non modifiable) d'un
autre USF.

J'ai essayé la chose suivante :
C1 = A1
C2 = SI(($A$1+$A$2)>(C1+1);C1+1;"")
que je recopie en C3, C4, . jusqu'en C100 car je n'aurai jamais de
liste supérieure à 100 jours à afficher.

Cela marche bien sauf que lorsque j'atteins la fin de ma liste
"souhaitée" j'ai l'affichage suivant : 1 cellule vide puis #VALEUR pour
les cellules suivantes.

Cela me pose un problème car je ne peux ensuite nommer ma colonne C avec
la fonction décaler() qui va aller jusqu'à C100 !
J'ai bien essayé de copier/coller les valeurs de la colonne C dans une
autre colonne mais ça ne change rien car en fait la cellule soi-disant
vide à la fin de ma liste ne l'est pas

Je me permet donc de faire appel à vos connaissances.
- Y a t-il autre chose à mettre dans la fonction SI à la place de ""
lorsque la condition est fausse ?
Ma démarche n'est peut-être pas la bonne pour avoir cette liste de dates
dans la combobox.

Merci d'avance de votre aide

Daniel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #23641431
Bonjour,
Utilise en C2 :
=SI(C1="";"";SI(($A$1+$A$2)>(C1+1);C1+1;""))
et pour ta liste :
ÞCALER(Feuil3!$C$1;;;SOMMEPROD(N(Feuil3!$C:$C<>"")))
Daniel


Bonjour,

Beaucoup de posts ou d'articles concernent les dates ou les opérations avec
mais je n'ai pourtant pas réussi à trouver la réponse à mon problème.

J'ai un USF qui permet de récupérer une date de début d'évènement
(jj/mm/aaaa) et une durée en jours (x) ces 2 valeurs sont récupérées dans des
cellules.
A1 : jj/mm/aaaa
A2 : x

Je souhaiterai avoir dans la colonne C la liste des jours
jj/mm/aaaa
jj/mm/aaaa+1
jj/mm/aaaa+2
...
jj/mm/aaaa+x

qui me servira à remplir une ComboBox style 2 (non modifiable) d'un autre
USF.

J'ai essayé la chose suivante :
C1 = A1
C2 = SI(($A$1+$A$2)>(C1+1);C1+1;"")
que je recopie en C3, C4, .... jusqu'en C100 car je n'aurai jamais de liste
supérieure à 100 jours à afficher.

Cela marche bien sauf que lorsque j'atteins la fin de ma liste "souhaitée"
j'ai l'affichage suivant : 1 cellule vide puis #VALEUR pour les cellules
suivantes.

Cela me pose un problème car je ne peux ensuite nommer ma colonne C avec la
fonction décaler() qui va aller jusqu'à C100 !
J'ai bien essayé de copier/coller les valeurs de la colonne C dans une autre
colonne mais ça ne change rien car en fait la cellule soi-disant vide à la
fin de ma liste ne l'est pas...

Je me permet donc de faire appel à vos connaissances.
- Y a t-il autre chose à mettre dans la fonction SI à la place de "" lorsque
la condition est fausse ?
Ma démarche n'est peut-être pas la bonne pour avoir cette liste de dates dans
la combobox.

Merci d'avance de votre aide

Daniel



--
Pour plus de facilité, veuillez préciser votre version d'Excel
Cordialement.
Daniel
Publicité
Poster une réponse
Anonyme