LVM m'a tuer

Le
Guillaume
Bonjour tout le monde,


Je viens poster ici parce que je suis un imbécile (si, si).

Sur une Debian destinée à faire serveur de fichiers et de sauvegardes,
je destinais (/dev/)hda à / + /home (il sera ignoré ici), et hdb,hdc et
hdd aux données et autres sauvegardes (Le CD a été remplacé).

Il était plus commode pour moi d'en agréger deux avec LVM et de garder
le dernier pour les sauvegardes. J'ai donc renvoyé toutes les données
utiles sur hdc1 pour vider hdb1 et hdd1 afin de les agréger en un volume
logique. Il y a eu les difficultés d'usage, recompilation nécessaire,
puis "device mapper" manquait, et deux-trois bricoles pour lancer lvm2
proprement, bref en toute fin de soirée je parviens à mes fins et je
me trompe de disque pour l'agrégation de mon volume logique (là, je vous
l'avais bien dit !).

J'obtiens donc un beau volume logique sur deux partitions (hdb1 + hdc1)
dont l'un des deux contenait toutes mes sauvegardes et hdd1, qui est
vierge :,-( .

La partition précédente était en XFS. Je n'ai encore fait aucune
écriture dans le volume LVM, que j'ai démounté aussitôt après avoir vu.

Après recherches, xfsrestore ne convient pas, xfsrepair ne trouve rien
d'adéquat, et checkdisk ( http://www.cgsecurity.org/wiki/TestDisk ) ne
voit que du LVM sur ce disque, et pas la partition XFS précédente, ce
qui m'aurait intéressé.

Est-ce que c'est vraiment mort, ou y a-t-il à votre connaissance encore
un moyen de récupérer des données dans un cas pareil ?



--
Guillaume
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guillaume
Le #1885294
Guillaume a wroté :

Est-ce que c'est vraiment mort, ou y a-t-il à votre connaissance
encore un moyen de récupérer des données dans un cas pareil ?



Salut,

Laissez tomber : finalement xfsrepair est bien meilleur qu'il n'en a
l'air ;).

Merci, aplusse.


--
Guillaume

Samuel Colin
Le #1887943
Dixit Guillaume :
Guillaume a wroté :

Est-ce que c'est vraiment mort, ou y a-t-il à votre connaissance
encore un moyen de récupérer des données dans un cas pareil ?



Salut,

Salut,


Laissez tomber : finalement xfsrepair est bien meilleur qu'il n'en a
l'air ;).

Une rapide description, en mettant [Résolu] en sujet en plus ?

C'est pas vraiment pour moi, c'est surtout pour que ça soit archivé
quelque part (google groups) et que ça puisse être retrouvé par
quelqu'un dans le même cas que toi. Enfin, jdçjdr.


Guillaume
Le #1887922

Salut,



Salut Samuel,

Laissez tomber : finalement xfsrepair est bien meilleur qu'il n'en a
l'air ;).

Une rapide description, en mettant [Résolu] en sujet en plus ?



Mouais, mais en fait c'était plutôt trivial finalement ... en gros :
# /etc/init.d/lvm stop
# lvremove Mon_volume_Logique
... Puis après avoir essayé en vain de mounter /dev/hdc1 en précisant
son précédent filesystem (XFS, mais mount répondait "wrong FS type,
bad superblock" etc.), j'ai lancé un # xfsrepair /dev/hdc1 qui a bien
pris une quinzaine d'heures (je n'ai pas été assez patient et j'avais
posté ici en pensant que s'il ne me renvoyait aucune info positive,
c'est que c'était mort), ce qui m'a permis de mounter ensuite ma
partition en XFS très normalement, et surtout d'y retrouver son
contenu.

C'est pas vraiment pour moi, c'est surtout pour que ça soit archivé
quelque part (google groups) et que ça puisse être retrouvé par
quelqu'un dans le même cas que toi. Enfin, jdçjdr.


OK, j'entends bien :).
Mais je ne pense pas que ce descriptif de résolution de pb soit
vraiment édifiant, c'était somme toute assez simple, tout ce qu'on en
retiendra, c'est qu'il faut chercher parmi tout ce qui a rapport avec
un filesystem donné pour trouver le binaire qui permettra de le
réparer (ce qui m'a sauvé sans doute, c'est de n'avoir fait aucune
écriture sur le volume LVM avant de tenter la restauration), qu'il
vaut mieux être patient avant de jeter l'éponge, ... et que XFS, ça
roulaize :).

Bonne nuit !

--
Guillaume


Samuel Colin
Le #1885463
Dixit Guillaume :

Mouais, mais en fait c'était plutôt trivial finalement ... en gros :
# /etc/init.d/lvm stop
# lvremove Mon_volume_Logique
... Puis après avoir essayé en vain de mounter /dev/hdc1 en précisant
son précédent filesystem (XFS, mais mount répondait "wrong FS type,
bad superblock" etc.), j'ai lancé un # xfsrepair /dev/hdc1 qui a bien
pris une quinzaine d'heures (je n'ai pas été assez patient et j'avais
posté ici en pensant que s'il ne me renvoyait aucune info positive,
c'est que c'était mort), ce qui m'a permis de mounter ensuite ma
partition en XFS très normalement, et surtout d'y retrouver son
contenu.

Rien que pour le coup de devoir attendre un bout de temps, c'est bon à

savoir.

Guillaume
Le #1885405
Rien que pour le coup de devoir attendre un bout de temps, c'est bon à
savoir.



Tu as raison :) .
Ceci dépend très probablement de la taille de la partition à
restaurer, et du volume des données (80 Go ici, plein à 97 %).

(zêzr fv crefbaar a'ninvg qr fbyhgvba à zba ceboyèzr, p'rfg enffhenag
qr fnibve dh'ba rfg yh :) )

A bientôt !

--
Guillaume

Publicité
Poster une réponse
Anonyme