MacAranym -- ATARI / OSX

Le
Francois LE COAT
Bonjour,

Une mise à jour majeure de <http://eureka.atari.org/MacAranym.zip> a
été effectuée, qui correspond à une compatibilité et une effica=
cité
améliorées.

C'est un *Mini Pack* pour OSX qui est livré en /Universal Binary/,
de la machine virtuelle *ATARI*. Il fonctionne directement après le
désarchivage sur toutes les machines avec un OS >= à 10.3.9 (Intel
et PPC).

Je vous laisse commenter cette mise à jour majeure :-)

ATARIstiquement,

-- François LE COAT
Auteur de Eurêka 2.12 (Grapheur 2D, Modeleur 3D)
<http://eureka.atari.org/>
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jerome Vernet
Le #2214851
Bonjour,

Une mise à jour majeure de été effectuée, qui correspond à une compatibilité et une efficacité
améliorées.

C'est un *Mini Pack* pour OSX qui est livré en /Universal Binary/,
de la machine virtuelle *ATARI*. Il fonctionne directement après le
désarchivage sur toutes les machines avec un OS >= à 10.3.9 (Intel
et PPC).

Je vous laisse commenter cette mise à jour majeure :-)
Chez moi, Pomme virgule n'appelle pas le GUI SDL... Une fois pour toute,

il ne srais pas plus pratique que le menu "Preference" appelle l'ecran
de config ??

--
-----
Jerome Vernet
Petite Collection de vieux micros
http://perso.orange.fr/jerome.vernet/

Francois LE COAT
Le #2214841
Bonjour Jérôme,

Merci pour l'intérêt porté à MacAranym.

Une mise à jour majeure de été effectuée, qui correspond à une compatibilité et une eff icacité
améliorées.

C'est un *Mini Pack* pour OSX qui est livré en /Universal Binary/,
de la machine virtuelle *ATARI*. Il fonctionne directement après le
désarchivage sur toutes les machines avec un OS >= à 10.3.9 (Int el
et PPC).

Je vous laisse commenter cette mise à jour majeure :-)


Chez moi, Pomme virgule n'appelle pas le GUI SDL... Une fois pour toute ,
il ne srais pas plus pratique que le menu "Preference" appelle l'ecran
de config ??


En fait, le SDL GUI n'existe pas. Il faut comprendre que MacAranym
est en cours de développements, et que le SDL GUI n'est pas activé
lorsque l'accélération OpenGL est elle activée.

On a le choix. Soit l'accélération d'affichage, soit le SDL GUI.

Là, pour le Mini Pack MacAranym j'ai choisi la vitesse d'affichage.
Il est possible d'avoir accès au GUI, mais il faut aller trifouiller
dans le moteur ... C'est à dire le fichier texte "config".

Qu'on se le dise ;)

ATARIstiquement,

-- François LE COAT
Auteur de Eurêka 2.12 (Grapheur 2D, Modeleur 3D)


Jerome Vernet
Le #2214821

En fait, le SDL GUI n'existe pas. Il faut comprendre que MacAranym
est en cours de développements, et que le SDL GUI n'est pas activé
lorsque l'accélération OpenGL est elle activée.
Exact, j'avais oublié ça. Effectivement, avec Opengl, ça booste, sans,

ça rame. C'est d'ailleurs comme ça avec d'autres emu (U-UAE, par exemple).

Au fait, je peux tourner des démos Falcon avec MacAranym ?

--
-----
Jerome Vernet
Petite Collection de vieux micros
http://perso.orange.fr/jerome.vernet/

Francois LE COAT
Le #2203541
Bonjour Jérôme,


En fait, le SDL GUI n'existe pas. Il faut comprendre que MacAranym
est en cours de développements, et que le SDL GUI n'est pas activé
lorsque l'accélération OpenGL est elle activée.


Exact, j'avais oublié ça. Effectivement, avec Opengl, ça booste, sans,
ça rame. C'est d'ailleurs comme ça avec d'autres emu (U-UAE, par ex emple).


Exact.

Au fait, je peux tourner des démos Falcon avec MacAranym ?


Oui. On fait tourner certaines démos en provenance de On fait aussi tourner Quake par exemple trouvé sur
Etc.

De + en + avec les progrès de
ATARIstiquement,

-- François LE COAT
Auteur de Eurêka 2.12 (Grapheur 2D, Modeleur 3D)


jacques
Le #2202031
Francois LE COAT
C'est un *Mini Pack* pour OSX qui est livré en /Universal Binary/,
de la machine virtuelle *ATARI*. Il fonctionne directement après le
désarchivage sur toutes les machines avec un OS >= à 10.3.9 (Intel
et PPC).


Moi, j'veux bien essayé, mais j'ai besoin d'un GFA Basic 3.0 pour faire
tourner mes applis :-)

Jacques
--
« Mac OS X Server à votre Service » en vente au Monde en Tique.
Attention, plus que 14 exemplaires.

Francois LE COAT
Le #2214721
Bonjour Jacques,

Merci pour l'intérêt porté à MacAranym.


C'est un *Mini Pack* pour OSX qui est livré en /Universal Binary/,
de la machine virtuelle *ATARI*. Il fonctionne directement après le
désarchivage sur toutes les machines avec un OS >= à 10.3.9 (Int el
et PPC).


Moi, j'veux bien essayer, mais j'ai besoin d'un GFA Basic 3.0 pour fair e
tourner mes applis :-)


D'accord. Pour le GFA Basic c'est là


Je ne l'utilise pas, mais on trouve des personnes intéressées sur


ATARIstiquement,

-- François LE COAT
Auteur de Eurêka 2.12 (Grapheur 2D, Modeleur 3D)


jacques
Le #2204721
Francois LE COAT
D'accord. Pour le GFA Basic c'est là



Damned, me voilà pris à mon propre piège :-)

Dès que j'ai le temps, je teste.

Jacques
--
« Mac OS X Server à votre Service » en vente au Monde en Tique.
Attention, plus que 14 exemplaires.

Francois LE COAT
Le #2214051
Bonjour Jacques,


D'accord. Pour le GFA Basic c'est là



Damned, me voilà pris à mon propre piège :-)


Il y a un renouveau du langage GFA Basic depuis qu'un
américain, nommé Lonny Pursell de Pandora Ohio a décidé de
réécrire le fameux éditeur/interpréteur pour qu'il tourne
en fenêtres et puisse se lancer sous GEM sur n'importe
quelle machine.

Qu'il a réussi aussi à embarquer dans son aventure une
société RUN!Software qu'il maintient un blog à ce sujet


LP est aussi à l'origine de la mise à disposition GPL des
sources (en C) du TOS, d'où la parution présente de la
mise à jour de bénéficie de la publication de ces sources, pour offrir une
bien meilleure compatibilité aux applications GEM avec ARAnyM.

Dès que j'ai le temps, je teste.


Ne pas hésiter à intervenir sur où le sujet est plus "en charte", et les participants
concernés, si le besoin s'en fait sentir :)

ATARIstiquement,

-- François LE COAT
Auteur de Eurêka 2.12 (Grapheur 2D, Modeleur 3D)


OL
Le #2213841

LP est aussi à l'origine de la mise à disposition GPL des
sources (en C) du TOS, d'où la parution présente de la
mise à jour de bénéficie de la publication de ces sources, pour offrir une
Ah bon je ne sais pas ou tu as vu cela? cf changelog

http://emutos.cvs.sourceforge.net/emutos/emutos/doc/changelog.txt?revision=1.410&view=markup
bien meilleure compatibilité aux applications GEM avec ARAnyM.



Ah? nf_bootstrap n'était sans doute pas dans la version 0.8.1 mais bon
on l'avait depuis un moment pour faire démarrer Mint sans disques,
ensuite il n'y a pas grand chose pour les applis et Aranym. En plus dans
tout cela Emutos n'est utilisé dans l'archive que pour lancer Mint,
Xaaes et fvdi qui remplacent au moins à 95% Emutos qui n'est donc
pratiquement pas utilisé, donc pour la rapidité, la stabilité et le coté
majeur de la chose, peut être peux tu le faire croire à des néophites,
mais pas aux autres.

Ceci dit cela n'en enleve pas pour autant que le paquet n'est pas mal et
léger

Vous avez aussi en beaucoup plus lourd mais sans disque le pack 3D

http://helijah.free.fr/Pack_3D/Pack_3D.html

Qui n'a pas de disque virtuel et n'utilise que le système de fichier
hôte, l'archive est lourde car toutes les versions y sont installées
(Mac OSX, Windows et Linux)

Aranym est disponible ici avec aussi ses versions officielles et son
disque de boot 100% opensource, c'est bien moins souvent mis à jours
mais cela marche aussi.

Vous pouvez aussi être intéressé par:
http://donzé.ch/atari/software/macaranym/

Enfin si vous êtes persévérant vous pouvez avoir envi d'installer un
autre AES
http://myaes.lutece.net/
Pour bien fonctionner avec certains logiciels il a besoin de ndialog qui
n'est pas libre.


Olivier

[ProToS]
Le #2213421
Francois LE COAT wrote:

LP est aussi à l'origine de la mise à disposition GPL des
sources (en C) du TOS,


heuuu non, les sources etait deja disponible, LP a fournit un espace
web pour "archivé" tout cela.

beaucoup de sources viennent de Belboz suite a un post sur atari-forum.com
celle incomplète du tos 4.04 viennet de AEX

donc LP n'est pas du tout a l'origine ....

Publicité
Poster une réponse
Anonyme