Macro extraction doublon

Le
sebastien.guitera
Bonjour,

J'ai un tableau comportant plus 1000 de lignes
Certaines de ces lignes sont en doublon suivant le critère de la
cellule B (n° de ligne)

J'aimerai appliquer une macro qui :
- Copie toutes les lignes en doublon (critère cellule Bxx) dans une
nouvelle feuille.
- La nouvelle feuille doit avoir les mêmes en-tête de colonne que ma
feuille initiale.

Merci d'avance les experts !

Knolram
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #5285921
Bonjour,


Critère en E2:
=NB.SI($B$2:$B$1000;B2)>1


Sub Macro1()
Sheets("feuil1").[A1:B1000].AdvancedFilter Action:=xlFilterCopy, _
CriteriaRange:=Sheets("feuil1").[E1:E2],
CopyToRange:=Sheets("feuil2").[G1:H1]
End Sub

http://cjoint.com/?bEnuxRcgQU

JB
http://boisgontierjacques.free.fr

On 30 jan, 12:42, wrote:
Bonjour,

J'ai un tableau comportant plus 1000 de lignes
Certaines de ces lignes sont en doublon suivant le critère de la
cellule B (n° de ligne)

J'aimerai appliquer une macro qui :
- Copie toutes les lignes en doublon (critère cellule Bxx) dans une
nouvelle feuille.
- La nouvelle feuille doit avoir les mêmes en-tête de colonne que ma
feuille initiale.

Merci d'avance les experts !

Knolram


francois.forcet
Le #5285891
On 30 jan, 12:42, wrote:
Bonjour,

J'ai un tableau comportant plus 1000 de lignes
Certaines de ces lignes sont en doublon suivant le critère de la
cellule B (n° de ligne)

J'aimerai appliquer une macro qui :
- Copie toutes les lignes en doublon (critère cellule Bxx) dans une
nouvelle feuille.
- La nouvelle feuille doit avoir les mêmes en-tête de colonne que ma
feuille initiale.

Merci d'avance les experts !

Knolram


Salut à toi

Feuil1 colonne B à traiter
Recopie des doublons en Feuil2

Cette macro :

Sheets("Feuil1").Activate
Range("A1", "A" &
Range("A1").SpecialCells(xlLastCell).Row).EntireRow.Sort
Key1:=Range("B1"), Order1:=xlAscending, Header:=xlGuess, _
OrderCustom:=1, MatchCase:úlse, Orientation:=xlTopToBottom,
_
DataOption1:=xlSortNormal
i = 0
j = 1
Do While Range("B1").Offset(i, 0) <> ""
If Range("B1").Offset(i, 0) = Range("B1").Offset(i + 1, 0) Then
Range(Range("B1").Offset(i, 0), Range("B1").Offset(i + 1,
0)).EntireRow.Copy Sheets("Feuil2").Range("A" & j)
j = j + 2
End If
i = i + 1
Loop

Je pense que celà devrait te convenir

Dis moi !!!

Christian
Le #5285821
On 30 jan, 12:42, wrote:
Bonjour,

J'ai un tableau comportant plus 1000 de lignes
Certaines de ces lignes sont en doublon suivant le critère de la
cellule B (n° de ligne)

J'aimerai appliquer une macro qui :
- Copie toutes les lignes en doublon (critère cellule Bxx) dans une
nouvelle feuille.
- La nouvelle feuille doit avoir les mêmes en-tête de colonne que ma
feuille initiale.

Merci d'avance les experts !

Knolram


Bonjour,

Et tout simplement le filtre élaboré, en cochant "sans doublon"?

Cdlt.

sebastien.guitera
Le #5145201
J'ai essayé la méthode de françois et JB :
Les 2 fonctionnent à merveille

Merci à tous les 2 !

KNOLRAM




On 30 jan, 13:20, JB
Bonjour,

Critère en E2:
=NB.SI($B$2:$B$1000;B2)>1

Sub Macro1()
    Sheets("feuil1").[A1:B1000].AdvancedFilter Action:=xlFilterCopy, _
      CriteriaRange:=Sheets("feuil1").[E1:E2],
CopyToRange:=Sheets("feuil2").[G1:H1]
End Sub

http://cjoint.com/?bEnuxRcgQU

JBhttp://boisgontierjacques.free.fr

On 30 jan, 12:42, wrote:



Bonjour,

J'ai un tableau comportant plus 1000 de lignes
Certaines de ces lignes sont endoublonsuivant le critère de la
cellule B (n° de ligne)

J'aimerai appliquer une macro qui :
- Copie toutes les lignes endoublon(critère cellule Bxx) dans une
nouvelle feuille.
- La nouvelle feuille doit avoir les mêmes en-tête de colonne que ma
feuille initiale.

Merci d'avance les experts !

Knolram- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme