Mail : images encodées en base64 et html

Le
paul
Bonjour,

j'envoie à une petite mailing list un mail en html contenant une image
map. (nan : promis juré, c'est pas du spam mais une vraie lettre d'info
mise en forme)

Certains softs de mail (Outlook par exemple) ne chargent pas les images
automatiquement.

J'ai essayé de joindre l'image de l'image map en base64

Content-Transfer-Encoding: base64
Content-ID: <6918ef982fbd8155907da9964ce36c16>
Content-Disposition: inline; filename="flyer_2.jpg"
/9j/4AAQSkZJRgABAgAAZABkAAD/7AARRHVja3kAAQAEAAAAPAAA/+4AJkFkb2JlAGTAAAAAA
FQQDBgoNAABCXAAAbb4AALoMAAFDef/bAIQABgQEBAUEBgUFBgkGBQYJCwgGBggLDAoKCwoKD
DAwMDAwQDA4PEA8ODBMTFBQTExwbGxscHx8fHx8fHx8fHwEHBwcNDA0YEBAYGhURFRofHx8fH
Hx8fHx8fHx8fHx8fHx8fHx8fHx8fHx8fHx8fHx8fHx8fHx8fHx8fHx8f/8IAEQgB9ALwAwERA
ETC.

Et d'appeler l'image ainsi :

<img src="cid:6918ef982fbd8155907da9964ce36c16" width="752" height="500"
border="0" usemap="#Map">

Parfait sur Outlook 2003 : je charge bien l'image et le code de l'image
map fonctionne

Mais patatras sur Mail :
si l'image est bien chargée, elle n'est plus reliée au code de l'image
map : plus aucun lien
:-((


Que faudrait-il faire ?
Quelque chose à ajouter au code ?

Merci pour l'aide
Paul
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
paul
Le #5925941
Enfin pour préciser :
sur Mail, je vois bien le code de l'image map dans le contenu du mail.
Mais il ne semble pas interprété du tout...
:-((
paul
Le #5925921
In article paul
Enfin pour préciser :
sur Mail, je vois bien le code de l'image map dans le contenu du mail.
Mais il ne semble pas interprété du tout...
:-((


Ben dans la dernière version de Panther (Mail 1.3.11 je crois...) :
ça fonctionne impec !
:-((

Un bug dans la version de Leopard ???

touix
Le #20739271
paul a écrit le 21/04/2008 à 19h33 :
In article ,
paul wrote:

Enfin pour préciser :
sur Mail, je vois bien le code de l'image map dans le contenu du mail.
Mais il ne semble pas interprété du tout...
:-((



Ben dans la dernière version de Panther (Mail 1.3.11 je crois...) :
ça fonctionne impec !
:-((

Un bug dans la version de Leopard ???


Paul,

J'ai un projet similaire, mais j'ai du mal à utiliser le content-type. Pourriez-vous m'aider en me donnant un coup de pouce? J'aimerai afficher mes images sur Outlook 2003.
Cordialement,
Touix
Publicité
Poster une réponse
Anonyme