Majuscule sur la première lettre du jour

Le
John
Bonsoir,

Avec le format suivant jjjj-jj j'obtiens par exemple jeudi-01 comment mettre
en plus de ce format la première lettre du jour ?

Si la cellule précedente contient Dimanche comment dire à Excel de mettre
"Total"
alors que la cellule en dessous commencera de nouveau à Lundi ?

De même lorsque le mois se termine il faudrait dans la dernière cellule en
dessous du dernier jour qu'Excel inscrive "Total général"

Vendredi
Samedi
Dimanche
MonTotal
Lundi
"Lundi est le dernier jour du mois" : Total Général"
Merci d'avance
--
John.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Mgr.Abile
Le #6687261
Bonsoir,
=NOMPROPRE(TEXTE(DATE(2008;2;24);"jjjj jj"))
donnera Dimanche 24
--
News://news.microsoft.com/microsoft.public.fr.excel
Allez en paix
T.Abile
"John" news:
Bonsoir,

Avec le format suivant jjjj-jj j'obtiens par exemple jeudi-01 comment
mettre
en plus de ce format la première lettre du jour ?

Si la cellule précedente contient Dimanche comment dire à Excel de mettre
"Total"
alors que la cellule en dessous commencera de nouveau à Lundi ?

De même lorsque le mois se termine il faudrait dans la dernière cellule en
dessous du dernier jour qu'Excel inscrive "Total général"

Vendredi
Samedi
Dimanche
MonTotal
Lundi
"Lundi est le dernier jour du mois" : Total Général"
Merci d'avance
--
John.


Mgr.Abile
Le #6687611
Bonsoir,
Pour aller plus loin :
=SI(JOURSEM(DATE(2008;2;LIGNE()))=2;"Total";NOMPROPRE(TEXTE(DATE(2008;2;LIGNE());"jjjj
jj")))
à recopier vers le bas
--
News://news.microsoft.com/microsoft.public.fr.excel
Allez en paix
T.Abile
"John" news:
Bonsoir,

Avec le format suivant jjjj-jj j'obtiens par exemple jeudi-01 comment
mettre
en plus de ce format la première lettre du jour ?

Si la cellule précedente contient Dimanche comment dire à Excel de mettre
"Total"
alors que la cellule en dessous commencera de nouveau à Lundi ?

De même lorsque le mois se termine il faudrait dans la dernière cellule en
dessous du dernier jour qu'Excel inscrive "Total général"

Vendredi
Samedi
Dimanche
MonTotal
Lundi
"Lundi est le dernier jour du mois" : Total Général"
Merci d'avance
--
John.


John
Le #6687591
Merci beaucoup,

J'ai toujours mon problème avec la fonction SI, en effet j'ai formaté mes
cellules en date par exemple en D4 Mardi 1 juin 2008 par exemple
En C4 avec la fonction JOURSEM j'obtiens les numéros de semaine 1 2 3 etc.

Donc si la cellule au dessus a pour valeur 7 on met un "T" sinon on met
cellule au dessus +1

ça fonctionne bien, seulement voila aprés Dimanche c'est Lundi donc dans ce
cas la formule doit passer non pas à + 1 mais + 2 .

Vous comprenez ce que je veux dire ?
Exemple : SI(C4=7;"T";D4+1;D4+2)) mais comme ça pas possible.

Vous avez une idée ?

Merci
--
John.



Bonsoir,
=NOMPROPRE(TEXTE(DATE(2008;2;24);"jjjj jj"))
donnera Dimanche 24
--
News://news.microsoft.com/microsoft.public.fr.excel
Allez en paix
T.Abile
"John" news:
Bonsoir,

Avec le format suivant jjjj-jj j'obtiens par exemple jeudi-01 comment
mettre
en plus de ce format la première lettre du jour ?

Si la cellule précedente contient Dimanche comment dire à Excel de mettre
"Total"
alors que la cellule en dessous commencera de nouveau à Lundi ?

De même lorsque le mois se termine il faudrait dans la dernière cellule en
dessous du dernier jour qu'Excel inscrive "Total général"

Vendredi
Samedi
Dimanche
MonTotal
Lundi
"Lundi est le dernier jour du mois" : Total Général"
Merci d'avance
--
John.






isabelle
Le #6688311
bonjour John et Mgr.Abile,

et pour aller un peu plus loin, ;-)
cependant la formule doit commencer en A3 en supposant qu'il y est des dates succesive en A1 et A2
ne debutant pas par un dimanche ou la journée de fin de mois

=SI(ESTERREUR(SI(OU(JOURSEM(A2+1;1)=1;A2=FIN.MOIS(A2;0));"Total";A2+2));A1+1;SI(OU(JOURSEM(A2+1;1)=1;A2=FIN.MOIS(A2;0));"Total";A2+1))

isabelle
ps jps/ bien le bonjour par dela ma cabane au fond des bois d'orford, là ou internet est intermitant,
en attadant le retour à la civilisation vers la mi-juin, bisou**

Bonsoir,
Pour aller plus loin :
=SI(JOURSEM(DATE(2008;2;LIGNE()))=2;"Total";NOMPROPRE(TEXTE(DATE(2008;2;LIGNE());"jjjj
jj")))
à recopier vers le bas


John
Le #6688651
Bonjour et un trés grand merci à vous deux,

Cependant la formule de Mgr Abile fonctionne trés bien mais ne s'arrête pas
le dernier jour du mois avec le Nom "Total" sous ce dernier.

Pour Isabelle le nom "Total" ne s'inscrit pas sur aucune ligne, de plus
comment Excel va pouvoir calculer la colonne droite du nom total pour chaque
semaine ?

Encore Merci.

--
John.



bonjour John et Mgr.Abile,

et pour aller un peu plus loin, ;-)
cependant la formule doit commencer en A3 en supposant qu'il y est des dates succesive en A1 et A2
ne debutant pas par un dimanche ou la journée de fin de mois

=SI(ESTERREUR(SI(OU(JOURSEM(A2+1;1)=1;A2=FIN.MOIS(A2;0));"Total";A2+2));A1+1;SI(OU(JOURSEM(A2+1;1)=1;A2=FIN.MOIS(A2;0));"Total";A2+1))

isabelle
ps jps/ bien le bonjour par dela ma cabane au fond des bois d'orford, là ou internet est intermitant,
en attadant le retour à la civilisation vers la mi-juin, bisou**

Bonsoir,
Pour aller plus loin :
=SI(JOURSEM(DATE(2008;2;LIGNE()))=2;"Total";NOMPROPRE(TEXTE(DATE(2008;2;LIGNE());"jjjj
jj")))
à recopier vers le bas





Guy72
Le #6688931
Bonjour,
Si possible, je voudrais profiter de ce post pour poser une question ayant
rapport avec c'elle de John.
Quelle formule faut-il mettre pour avoir la majuscule du jour avec la
fonction =AUJOURDHUI().
Merci de votre aide
--
Cordialement
Guy

"Mgr.Abile"
Bonsoir,
=NOMPROPRE(TEXTE(DATE(2008;2;24);"jjjj jj"))
donnera Dimanche 24
--
News://news.microsoft.com/microsoft.public.fr.excel
Allez en paix
T.Abile
"John" news:
Bonsoir,

Avec le format suivant jjjj-jj j'obtiens par exemple jeudi-01 comment
mettre
en plus de ce format la première lettre du jour ?

Si la cellule précedente contient Dimanche comment dire à Excel de mettre
"Total"
alors que la cellule en dessous commencera de nouveau à Lundi ?

De même lorsque le mois se termine il faudrait dans la dernière cellule
en
dessous du dernier jour qu'Excel inscrive "Total général"

Vendredi
Samedi
Dimanche
MonTotal
Lundi
"Lundi est le dernier jour du mois" : Total Général"
Merci d'avance
--
John.





isabelle
Le #6691331
bonjour Guy,

=NOMPROPRE(TEXTE(AUJOURDHUI();"jjjj"))
mais ce ne sera plus une date valide mais du texte.

isabelle

Bonjour,
Si possible, je voudrais profiter de ce post pour poser une question ayant
rapport avec c'elle de John.
Quelle formule faut-il mettre pour avoir la majuscule du jour avec la
fonction =AUJOURDHUI().
Merci de votre aide


John
Le #6692191
Isabelle,

Toutes mes excuses, ta formule tourne trés bien, je n'avais pas tout compris.
Il ne me reste plus qu'a trouver une solution pour calculer automatiquement
les sommes dans les trois colonnes de droite aprés les dates, je t'explique.

Trois colonnes dans lesquelles on va entrer des heures aux format hh:mm, à
chaque fois que Excel va voir dans la colonne A qu'il y a "Total" il devra
calculer la somme du premier au dernier jour de la semaine, mais la
difficultée vient du fait que d'un mois à l'autre la ligne total bouge, il
peut y avoir une solution avec somme.si() ou en VBA ?

Tu veux bien m'aider ? ou un autre pro d'Excel ?

Merci à tous

--
John.



Bonjour et un trés grand merci à vous deux,

Cependant la formule de Mgr Abile fonctionne trés bien mais ne s'arrête pas
le dernier jour du mois avec le Nom "Total" sous ce dernier.

Pour Isabelle le nom "Total" ne s'inscrit pas sur aucune ligne, de plus
comment Excel va pouvoir calculer la colonne droite du nom total pour chaque
semaine ?

Encore Merci.

--
John.



bonjour John et Mgr.Abile,

et pour aller un peu plus loin, ;-)
cependant la formule doit commencer en A3 en supposant qu'il y est des dates succesive en A1 et A2
ne debutant pas par un dimanche ou la journée de fin de mois

=SI(ESTERREUR(SI(OU(JOURSEM(A2+1;1)=1;A2=FIN.MOIS(A2;0));"Total";A2+2));A1+1;SI(OU(JOURSEM(A2+1;1)=1;A2=FIN.MOIS(A2;0));"Total";A2+1))

isabelle
ps jps/ bien le bonjour par dela ma cabane au fond des bois d'orford, là ou internet est intermitant,
en attadant le retour à la civilisation vers la mi-juin, bisou**

Bonsoir,
Pour aller plus loin :
=SI(JOURSEM(DATE(2008;2;LIGNE()))=2;"Total";NOMPROPRE(TEXTE(DATE(2008;2;LIGNE());"jjjj
jj")))
à recopier vers le bas







Guy72
Le #6693361
Merci isabelle, ça me convient parfaitement.
--
Cordialement
Guy

"isabelle" a écrit dans le message de news:

bonjour Guy,

=NOMPROPRE(TEXTE(AUJOURDHUI();"jjjj"))
mais ce ne sera plus une date valide mais du texte.

isabelle

Bonjour,
Si possible, je voudrais profiter de ce post pour poser une question
ayant rapport avec c'elle de John.
Quelle formule faut-il mettre pour avoir la majuscule du jour avec la
fonction =AUJOURDHUI().
Merci de votre aide




John
Le #6693351
Il me vient une idée, pour calculer la somme des heures d'une semaine ne
serait-il pas plus simple en inscrivant les numéros de semaine devant chaque
jours (suite à partir du premier jour de mois inscrit) et ensuite les
rassembler dans un tableau en dessous de ces jours, le tout doit pouvoir se
faire automatiquement.

Dans ce cas plus besoin d'une ligne total mélangée dans les jours.

Merci pour vos idées
--
John.



Isabelle,

Toutes mes excuses, ta formule tourne trés bien, je n'avais pas tout compris.
Il ne me reste plus qu'a trouver une solution pour calculer automatiquement
les sommes dans les trois colonnes de droite aprés les dates, je t'explique.

Trois colonnes dans lesquelles on va entrer des heures aux format hh:mm, à
chaque fois que Excel va voir dans la colonne A qu'il y a "Total" il devra
calculer la somme du premier au dernier jour de la semaine, mais la
difficultée vient du fait que d'un mois à l'autre la ligne total bouge, il
peut y avoir une solution avec somme.si() ou en VBA ?

Tu veux bien m'aider ? ou un autre pro d'Excel ?

Merci à tous

--
John.



Bonjour et un trés grand merci à vous deux,

Cependant la formule de Mgr Abile fonctionne trés bien mais ne s'arrête pas
le dernier jour du mois avec le Nom "Total" sous ce dernier.

Pour Isabelle le nom "Total" ne s'inscrit pas sur aucune ligne, de plus
comment Excel va pouvoir calculer la colonne droite du nom total pour chaque
semaine ?

Encore Merci.

--
John.



bonjour John et Mgr.Abile,

et pour aller un peu plus loin, ;-)
cependant la formule doit commencer en A3 en supposant qu'il y est des dates succesive en A1 et A2
ne debutant pas par un dimanche ou la journée de fin de mois

=SI(ESTERREUR(SI(OU(JOURSEM(A2+1;1)=1;A2=FIN.MOIS(A2;0));"Total";A2+2));A1+1;SI(OU(JOURSEM(A2+1;1)=1;A2=FIN.MOIS(A2;0));"Total";A2+1))

isabelle
ps jps/ bien le bonjour par dela ma cabane au fond des bois d'orford, là ou internet est intermitant,
en attadant le retour à la civilisation vers la mi-juin, bisou**

Bonsoir,
Pour aller plus loin :
=SI(JOURSEM(DATE(2008;2;LIGNE()))=2;"Total";NOMPROPRE(TEXTE(DATE(2008;2;LIGNE());"jjjj
jj")))
à recopier vers le bas









Publicité
Poster une réponse
Anonyme