[mandriva 2007] une esquisse de solution pour le chipset nvidia nForce MCP61 ?

Le
claude
bonjour,

j'ai trouvé cet article :
http://www.nvnews.net/vbulletin/showthread.php?tu920

comment le mettre en oeuvre sous MDV2007, noyau 2.6.20 ? la partie
évoquée : "/* it should add in pci_ids.h */" n'existe pas ds forcedeth.c

merci

Claude
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
BARANGER Emmanuel
Le #1881219
bonjour,

j'ai trouvé cet article :
http://www.nvnews.net/vbulletin/showthread.php?tu920

comment le mettre en oeuvre sous MDV2007, noyau 2.6.20 ? la partie
évoquée : "/* it should add in pci_ids.h */" n'existe pas ds forcedeth.c

merci

Claude

Et bien voilà, tu l'as ta réponse. Le MCP61 est encore trop jeune pour

être supporté par défaut dans le noyau. Alors soit tu passe encore
beaucoup de temps à tenter ta chance en modifications et recompilation
soit tu attends encore un peu et tout rentrera dans l'ordre. Sans
compter, que tu peu avoir le net à la main mais il me semble que pour le
son ce n'est pas encore cela. Bref, pour le PC de ma mère je vais
attendre que tout rentre dans l'ordre ;)

Amcialement

claude
Le #1881218
bonjour,

j'ai trouvé cet article :
http://www.nvnews.net/vbulletin/showthread.php?tu920

comment le mettre en oeuvre sous MDV2007, noyau 2.6.20 ? la partie
évoquée : "/* it should add in pci_ids.h */" n'existe pas ds forcedeth.c

merci

Claude

Et bien voilà, tu l'as ta réponse. Le MCP61 est encore trop jeune pour

être supporté par défaut dans le noyau.


si tu lis bien (Elconqueror qui tourne avec le noyau 2.6.17 !!) :
"Great, I managed to have the sata, network and ide dma work perfectly,
The only thing left is the soundcard. " le type a aplliqué la méthode,
et ça marche.

pour le moment, le reseau, et la vga me permettraient de travailler sous
linux. la carte son est secondiare.

Alors soit tu passe encore
beaucoup de temps à tenter ta chance en modifications et recompilation


il est vrai que j'ai bien galéré depuis qques semaines. mais, c'est
aussi une manière d'apprendre et comprendre plein de choses connexes.

soit tu attends encore un peu et tout rentrera dans l'ordre. Sans
compter, que tu peu avoir le net à la main


je suis preneur de la solution ;-)

amicalement

Claude


claude
Le #1881217
bonjour,

j'ai trouvé cet article :
http://www.nvnews.net/vbulletin/showthread.php?tu920

comment le mettre en oeuvre sous MDV2007, noyau 2.6.20 ? la partie
évoquée : "/* it should add in pci_ids.h */" n'existe pas ds forcedeth.c

merci

Claude

Et bien voilà, tu l'as ta réponse. Le MCP61 est encore trop jeune pour

être supporté par défaut dans le noyau. Alors soit tu passe encore
beaucoup de temps à tenter ta chance en modifications et recompilation
soit tu attends encore un peu et tout rentrera dans l'ordre. Sans
compter, que tu peu avoir le net à la main mais il me semble que pour le
son ce n'est pas encore cela. Bref, pour le PC de ma mère je vais
attendre que tout rentre dans l'ordre ;)

Amcialement


d'après Emmanuel F, je dois refaire un make modules_install pour mettre
à jour /lib/modules. Or, qd je l'ai fair lors de la derniere compil
(sous /home/linux-2.6.20), /lib/modules n'a pas été impacté.
quelle commande exacte (quelles options du make ?) dois je faire pour
mettre à jour /lib/modules ?

autre question : je voudrais récupérer la séquence de boot. je ne vois
pas ds /var/log un fichier contenant cette sequence.

merci

Claude


Emmanuel Florac
Le #1881204
Le Tue, 27 Feb 2007 17:30:40 +0100, claude a écrit :


d'après Emmanuel F, je dois refaire un make modules_install pour mettre
à jour /lib/modules. Or, qd je l'ai fair lors de la derniere compil
(sous /home/linux-2.6.20), /lib/modules n'a pas été impacté.
quelle commande exacte (quelles options du make ?) dois je faire pour
mettre à jour /lib/modules ?



Tu as bien fait make modules_install en tant que root? Est-ce qu'il y a
des messages d'erreur ?

--
on passe la moitié de son temps à refaire ce que l'on n'a pas eu le
temps de faire correctement.
Loi de Myers.

claude
Le #1881202

d'après Emmanuel F, je dois refaire un make modules_install pour mettre
à jour /lib/modules. Or, qd je l'ai fair lors de la derniere compil
(sous /home/linux-2.6.20), /lib/modules n'a pas été impacté.
quelle commande exacte (quelles options du make ?) dois je faire pour
mettre à jour /lib/modules ?



Tu as bien fait make modules_install en tant que root? Est-ce qu'il y a
des messages d'erreur ?



je ne travaille plus qu'en root. comme cela, je ne me prends pas la tete.
aucun msg d'erreur. tout est clean.

on est bien d'accor : je ne fais que "make modules_install" , lilo,
reboot et nothing else ? (pas de mkinitrd, modprobe -options etc...)


claude
Le #1881200

d'après Emmanuel F, je dois refaire un make modules_install pour mettre
à jour /lib/modules. Or, qd je l'ai fair lors de la derniere compil
(sous /home/linux-2.6.20), /lib/modules n'a pas été impacté.
quelle commande exacte (quelles options du make ?) dois je faire pour
mettre à jour /lib/modules ?



Tu as bien fait make modules_install en tant que root? Est-ce qu'il y a
des messages d'erreur ?



la dernière ligne affichée de "make modules_install" est :
"if [ -r System.map -a -x /sbin/depmod]; then /sbin/depmod -ae -F
System.map 2.6.20; fi"

j'ai lu qu'on devait lancer cette commande à la main si on installe des
modules non fournis par le noyau. c'est mon cas. apparemment, le systeme
s'en occupe. correct ?
ou dois je recopier System.map ds /boot ?


Emmanuel Florac
Le #1881184
Le Tue, 27 Feb 2007 23:02:10 +0100, claude a écrit :


on est bien d'accor : je ne fais que "make modules_install" , lilo,
reboot et nothing else ? (pas de mkinitrd, modprobe -options etc...)


Oui, oui. DIs donc, entre deux compilations du noyau, tu as bien fait
"make clean"?

--
De longs désirs, une longue admiration sans espérance, voilà le moyen
d'adorer les femmes, et de rendre l'amour une passion délicieuse!
N. Rétif de la Bretonne.

Emmanuel Florac
Le #1881183
Le Tue, 27 Feb 2007 23:49:57 +0100, claude a écrit :


j'ai lu qu'on devait lancer cette commande à la main si on installe des
modules non fournis par le noyau. c'est mon cas. apparemment, le systeme
s'en occupe. correct ?


Oui.

ou dois je recopier System.map ds /boot ?


Ce n'est pas indispensable.

--
Si ça a l'air facile, c'est difficile. Si ça a l'air difficile, c'est
carrément impossible. Si ça a l'air impossible, c'est un compilateur
Ada.
Théorème de Stockmayer.

claude
Le #1881177

on est bien d'accor : je ne fais que "make modules_install" , lilo,
reboot et nothing else ? (pas de mkinitrd, modprobe -options etc...)


Oui, oui. DIs donc, entre deux compilations du noyau, tu as bien fait
"make clean"?

non. je fais un mv 2.6.20 ds 2.6.20.old sous /lib/modules.


bon, j'ai le réseau, enfin presque. j'ai revu menuconfig et détaillé
ttes les options network : en cochant PCI ...., j'ai eu d'autres options
avec celle-là : chip on board : et là, y'avait ethernet, forcedeth etc....
donc, j'ai now le reseau,
ping mon interface : ok
ping le nom de mon pc : ok (donc résolution de nom ok.

mais je ne sors pas. curieusement, à chaque reboot, il m'ajoute une
route incorrect :
169.x.x.x 255.255.0.0 eth0. je fais un route del. mais ça ne suffit pas.
je ping pas le dns de free. en bref, je ne sors pas.

/etc/resolv.conf, /etc/hosts et
/ets/sysconfig/networking/script-network/ifcfg-eth0 semblent coorects.

forcedeth.ko et ses amis sont ds /home/linux-2.6.20/kernel/drviers/net
et pas ds /lib/modules/...

je vais ouvrir un autre post.

merci à toi


claude
Le #1881175

on est bien d'accor : je ne fais que "make modules_install" , lilo,
reboot et nothing else ? (pas de mkinitrd, modprobe -options etc...)


Oui, oui. DIs donc, entre deux compilations du noyau, tu as bien fait
"make clean"?

oubli : j'au dû rajouter à la main ds /etc/hosts:

mon_IP monpc

comme si dhcp n'avait pas fait tout son job (j'ai configuré le reseau
avec dhcp à partir du CCM : pas d'erreur)


Publicité
Poster une réponse
Anonyme