Matrice ?

Le
Manu
Bonjour,

Je tente de bien comprendre la logique des formules matricielles. Je suis en
ce moment sur celle ci =SOMMEPROD(1/NB.SI(A1:A50;A1:A50)) qui à pour but de
ne pas compter les doublons, mais est ce que quelqu'un peut expliquer comme
elle foctionne techniquement.

Merci

Manu
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4869501
Bonjour.
La formule est équivalente à :
=1/NB.SI(A1:A50;A1)+1/NB.SI(A1:A50;A2) etc jusquà 1/NB.SI(A1:A50;A50)
Mettons que tu aies 3 fois la même valeur dans la plage A1:A50. la formule :
NB.SI(A1:A50;A1:A50) va effectuer l'opération NB.SI pour chaque valeur de la
plage. Pour les 3 doublons, la formule va renvoyer 3 et
1/NB.SI(A1:A50;A1:A50) va renvoyer 3 fois un tiers, soit 1 pour les trois
valeurs.
Pour mieux comprendre, clique sur la cellule contenant la formule, et, dans
la barre de formule, sélectionne : NB.SI(A1:A50;A1:A50) et appuie sur la
touche F9, ce qui remplace la formule par son résultat., fais de même pour
1/NB.SI(A1:A50;A1:A50).
Cordialement.
Daniel
"Manu"
Bonjour,

Je tente de bien comprendre la logique des formules matricielles. Je suis
en ce moment sur celle ci =SOMMEPROD(1/NB.SI(A1:A50;A1:A50)) qui à pour
but de ne pas compter les doublons, mais est ce que quelqu'un peut
expliquer comme elle foctionne techniquement.

Merci

Manu




JB
Le #4869491
Bonjour,

http://cjoint.com/?hqmLTaCJu3

JB

On 16 juil, 12:13, "Manu"
Bonjour,

Je tente de bien comprendre la logique des formules matricielles. Je suis en
ce moment sur celle ci =SOMMEPROD(1/NB.SI(A1:A50;A1:A50)) qui à pour but de
ne pas compter les doublons, mais est ce que quelqu'un peut expliquer com me
elle foctionne techniquement.

Merci

Manu


Manu
Le #4869481
Merci Daniel, c'est tres clair, je risque de poser + de questions sur ce
sujet malgrés que je me fait deja bien aidé par le site
http://www.excelabo.net
Manu

"Daniel"
Bonjour.
La formule est équivalente à :
=1/NB.SI(A1:A50;A1)+1/NB.SI(A1:A50;A2) etc jusquà 1/NB.SI(A1:A50;A50)
Mettons que tu aies 3 fois la même valeur dans la plage A1:A50. la formule
: NB.SI(A1:A50;A1:A50) va effectuer l'opération NB.SI pour chaque valeur
de la plage. Pour les 3 doublons, la formule va renvoyer 3 et
1/NB.SI(A1:A50;A1:A50) va renvoyer 3 fois un tiers, soit 1 pour les trois
valeurs.
Pour mieux comprendre, clique sur la cellule contenant la formule, et,
dans la barre de formule, sélectionne : NB.SI(A1:A50;A1:A50) et appuie sur
la touche F9, ce qui remplace la formule par son résultat., fais de même
pour 1/NB.SI(A1:A50;A1:A50).
Cordialement.
Daniel
"Manu"
Bonjour,

Je tente de bien comprendre la logique des formules matricielles. Je suis
en ce moment sur celle ci =SOMMEPROD(1/NB.SI(A1:A50;A1:A50)) qui à pour
but de ne pas compter les doublons, mais est ce que quelqu'un peut
expliquer comme elle foctionne techniquement.

Merci

Manu








Manu
Le #4868761
Merci JB, c'est clair, je poursuis mon apprentissage.

Manu

"JB"
Bonjour,

http://cjoint.com/?hqmLTaCJu3

JB

On 16 juil, 12:13, "Manu"
Bonjour,

Je tente de bien comprendre la logique des formules matricielles. Je suis
en
ce moment sur celle ci =SOMMEPROD(1/NB.SI(A1:A50;A1:A50)) qui à pour but
de
ne pas compter les doublons, mais est ce que quelqu'un peut expliquer
comme
elle foctionne techniquement.

Merci

Manu


Publicité
Poster une réponse
Anonyme