Message erreur d'exécution

Le
Jacques
Bonjour,

Ce code à toujours fonctionner et aujourd’hui il m’affiche une erreu=
r
d’exécution « Impossible d’attribuer une valeur à cet objet.

If Left(cmbStatut.Value, 3) = "RPS" Then
cmbEnvoi.Visible = False
cmbEnvoi = "" ‘……………… Ligne ou se pr=
oduit
l’erreur
Else
cmbEnvoi.Visible = True
End If

Avez-vous une idée de la cause du problème ? Et quelles sont les
vérifications
que je pourrais effectuer ?

Merci de votre aide.

Salutations
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry
Le #18611831
Bonjour,
et en mettant :
cmbEnvoi.value = ""

qu'est ce que ça donne ?


"Jacques"
Bonjour,

Ce code à toujours fonctionner et aujourd’hui il m’affiche une erreur
d’exécution « Impossible d’attribuer une valeur à cet objet.

If Left(cmbStatut.Value, 3) = "RPS" Then
cmbEnvoi.Visible = False
cmbEnvoi = "" ‘……………… Ligne ou se produit
l’erreur
Else
cmbEnvoi.Visible = True
End If

Avez-vous une idée de la cause du problème ? Et quelles sont les
vérifications
que je pourrais effectuer ?

Merci de votre aide.

Salutations


Jacques
Le #18618041
On 7 fév, 20:06, "Thierry"
Bonjour,
et en mettant :
cmbEnvoi.value = ""

qu'est ce que ça donne ?

"Jacques"



> Bonjour,

> Ce code à toujours fonctionner et aujourd’hui il m’affiche  une erreur
> d’exécution « Impossible d’attribuer une valeur à cet objet.

>   If Left(cmbStatut.Value, 3) = "RPS" Then
>        cmbEnvoi.Visible = False
>        cmbEnvoi = ""                ‘…… ………… Ligne ou se produit
> l’erreur
>     Else
>        cmbEnvoi.Visible = True
>     End If

> Avez-vous une idée de la cause du problème ? Et quelles sont les
> vérifications
> que je pourrais effectuer ?

> Merci de votre aide.

> Salutations- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Bonjour Thierry,

Merci pour ta réponse, mais en mettant .value le problème persite.

Salutations.
CErnst
Le #18621551
ben faudrait nous préciser quel est le type d'objet de cmbEnvoi....
et si cet objet permet les chaînes vides....
car certain objets représentent des champs dans les tables, et ces champs
n'autorisent pas la chaine vide "" (propriété "Chaîne vide autorisée")...


"Jacques"
Bonjour,

Ce code à toujours fonctionner et aujourd’hui il m’affiche une erreur
d’exécution « Impossible d’attribuer une valeur à cet objet.

If Left(cmbStatut.Value, 3) = "RPS" Then
cmbEnvoi.Visible = False
cmbEnvoi = "" ‘……………… Ligne ou se produit
l’erreur
Else
cmbEnvoi.Visible = True
End If

Avez-vous une idée de la cause du problème ? Et quelles sont les
vérifications
que je pourrais effectuer ?

Merci de votre aide.

Salutations
Jacques
Le #18634131
On 8 fév, 23:55, "CErnst"
ben faudrait nous préciser quel est le type d'objet de cmbEnvoi....
et si cet objet permet les chaînes vides....
car certain objets représentent des champs dans les tables, et ces cham ps
n'autorisent pas la chaine vide "" (propriété "Chaîne vide autoris ée")...

"Jacques"
Bonjour,

Ce code à toujours fonctionner et aujourd’hui il m’affiche  une e rreur
d’exécution « Impossible d’attribuer une valeur à cet objet.

   If Left(cmbStatut.Value, 3) = "RPS" Then
        cmbEnvoi.Visible = False
        cmbEnvoi = ""                ‘…… ………… Ligne ou se produit
l’erreur
     Else
        cmbEnvoi.Visible = True
     End If

Avez-vous une idée de la cause du problème ? Et quelles sont les
vérifications
que je pourrais effectuer ?

Merci de votre aide.

Salutations



Bonjour,

Merci pour vos réponses

le code fonctionne.

Salutations
Publicité
Poster une réponse
Anonyme