Messages "Accès refusé" sur "Services Internet (IIS)"

Le
Richard M.
Bonjour,

J'ai un problème un peu baroque sur un serveur web (2003, IIS 6)

Dans "Gestion de l'ordinateur", je clique sur l'applet "Services Internet
(IIS)", je me prend un message "Accès refusé, veuillez utiliser un compte
administrateur, etc", puis la mire de connexion.

Je rentre le compte et le mot de passe avec lequels j'ai déjà ouvert la
session actuelle (bien sûr compte admin du serveur) => je peux gérer IIS.

Comment se fait-t-il qu'il faille réentrer le mdp du compte interactif ?

Pareil avec l'autre compte admin du serveur. Pareil après reboot.

Du coup, les "iisreset" échouent (access denied). Là, je n'ai pas de
contournement (à part redémarrage du service, mais bon)
De même, j'ai des soucis "d'accès refusé" quand je veux mettre des
certificats sur les sites web

Une idée ?

par avance merci,

--RiM.
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jbongran
Le #11334401
"Richard M." news:
Bonjour,

J'ai un problème un peu baroque sur un serveur web (2003, IIS 6)

Dans "Gestion de l'ordinateur", je clique sur l'applet "Services Internet
(IIS)", je me prend un message "Accès refusé, veuillez utiliser un compte
administrateur, etc", puis la mire de connexion.

Je rentre le compte et le mot de passe avec lequels j'ai déjà ouvert la
session actuelle (bien sûr compte admin du serveur) => je peux gérer IIS.

Comment se fait-t-il qu'il faille réentrer le mdp du compte interactif ?

Pareil avec l'autre compte admin du serveur. Pareil après reboot.

Du coup, les "iisreset" échouent (access denied). Là, je n'ai pas de
contournement... (à part redémarrage du service, mais bon...)
De même, j'ai des soucis "d'accès refusé" quand je veux mettre des
certificats sur les sites web...

Une idée ?

par avance merci,

--RiM.



Il s'agit bien de comptes admin locaux du serveur ?
De prime abord je vérifierai les permissions NTFS sur la métabase de IIS
(fichier MetaBase.xml dans le repertoire system32inetsrv)
Les fiches suivantes de la base de connaissances sont un très bon début
(voire une référence) pour "recaler" droits et permissions pour IIS:
http://support.microsoft.com/kb/271071
http://support.microsoft.com/kb/326902
L'usage de process monitor
(http://www.microsoft.com/technet/sysinternals/processesandthreads/processmonitor.mspx)
est conseillé pour trouver où et pour qui se trouve les accès refusés.
Ps: ce groupe n'est pas en écriture seule, cf mon post du 14 à 1h17
Richard M.
Le #11334391
Bonjour,

"jbongran"
"Richard M."
Bonjour,

J'ai un problème un peu baroque sur un serveur web (2003, IIS 6)

Dans "Gestion de l'ordinateur", je clique sur l'applet "Services Internet
(IIS)", je me prend un message "Accès refusé, veuillez utiliser un compte
administrateur, etc", puis la mire de connexion.

Je rentre le compte et le mot de passe avec lequels j'ai déjà ouvert la
session actuelle (bien sûr compte admin du serveur) => je peux gérer IIS.

Comment se fait-t-il qu'il faille réentrer le mdp du compte interactif ?

Pareil avec l'autre compte admin du serveur. Pareil après reboot.

Du coup, les "iisreset" échouent (access denied). Là, je n'ai pas de
contournement... (à part redémarrage du service, mais bon...)
De même, j'ai des soucis "d'accès refusé" quand je veux mettre des
certificats sur les sites web...

Une idée ?

par avance merci,

--RiM.



Il s'agit bien de comptes admin locaux du serveur ?
De prime abord je vérifierai les permissions NTFS sur la métabase de IIS
(fichier MetaBase.xml dans le repertoire system32inetsrv)
Les fiches suivantes de la base de connaissances sont un très bon début
(voire une référence) pour "recaler" droits et permissions pour IIS:
http://support.microsoft.com/kb/271071
http://support.microsoft.com/kb/326902
L'usage de process monitor
(http://www.microsoft.com/technet/sysinternals/processesandthreads/processmonitor.mspx)
est conseillé pour trouver où et pour qui se trouve les accès refusés.
Ps: ce groupe n'est pas en écriture seule, cf mon post du 14 à 1h17



Bonjour,

Comme noté dans mon message, j'ai essayé avec les 2 comptes administrateurs
du serveur.

Avant de poster ma question, j'avais bien pris soin de parcourir ce
newsgroup et donc d'apprécier vos contributions décisives sur ce groupe.

Ainsi, j'avais déjà glané les liens que vous me rappelez dans votre réponse
et je les avais mis à profit.

J'ai malheureusement omis de faire état de ces tests.

Les ACL sur NTFS étaient nickel, à l'exception de "creater owner" sur "IIS
temporary compressed (...)"
Les droits sur le fichier MetaBase et à l'intérieur de la MetaBase sont
parfaits. (A part que je n'ai pas de "W3SVC/1/Filters")

J'avais également utilisé ProcMon. Il n'en ressort absolument rien.

J'avais également installé AuthDiag.

Les diagnostiques de "diagnostic tools" sont tous "clean" (tout vert).

Par contre, je n'arrive pas à utiliser les 4 diagnostiques accessibles sous
"tasks".

Une bonne raison est que je n'ai pas de site sous "localhost". (Ils sont
tous sont des adresses IP supplémentaires du serveur.) AuthDiag me répond
que mon URL est donc invalide.
Dans le meilleur des cas, AuthDiag n'arrive pas à redémarrer IIS pour
installer authmon.dll.
Dans le pire des cas, AuthDiag se fige purement et simplement.

Depuis, j'ai trouvé une autre piste et peut-être la cause profonde :
quand je clique sur "dépendence" sur un service, j'obtiens un message
d'erreur "Win32 : Accès refusé".
La KB Microsoft me renvoye sur un problème "d'impersonification".
Malheureusement, le paramétrage dans les stratégies locales sont bien
conforme aux articles Microsoft. (Et le compte a bien ce rôle : c'est listé
dans le log de sécurité.)

Du coup, je pense que IIS en tant que tel est hors de cause...

--RiM.
Publicité
Poster une réponse
Anonyme