MFC avec #N/A

Le
syleg35
Bonjour vous;
voil mon pb, j'ai deux colonne de 250 lignes, qui sont le rsultat
d'une RECHERCHEV d'une autre feuille, savoir que normalement quand
dans la (col 1) j'ai un montant, dans la (col 2) j'ai #N/A et vise
vers sa, mais il peut arriver que dans la col 1 et 2 j'ai #N/A ou deux
montants c'est pour cela que je voudrais mettre une MFC dans la
colonne suivante pour avoir une couleur quand sur la mme ligne j'ai
deux montants ou deux #N/A

Merci vous
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #19080461
Bonjour.
Utilise la formule :
=SI(ET(ESTNA(A1);ESTNA(B1));1;A1±)
Daniel

Bonjour à vous;
voilà mon pb, j'ai deux colonne de 250 lignes, qui sont le résultat
d'une RECHERCHEV d'une autre feuille, à savoir que normalement quand
dans la (col 1) j'ai un montant, dans la (col 2) j'ai #N/A et vise
vers sa, mais il peut arriver que dans la col 1 et 2 j'ai #N/A ou deux
montants c'est pour cela que je voudrais mettre une MFC dans la
colonne suivante pour avoir une couleur quand sur la même ligne j'ai
deux montants ou deux #N/A

Merci à vous


MichDenis
Le #19080291
Bonjour Sylvie,

Je préfère cette formule :
=SOMME(ESTNA($A1:$B1)*1)+SOMME(ESTNUM($A1:$B1)*1)=2
Daniel.C
Le #19080281
Heu, j'ai loupé quelque chose, mais quand A1 et B1 sont égales à #NA!,
ta formule donne 0 ?
Daniel

Bonjour Sylvie,

Je préfère cette formule :
=SOMME(ESTNA($A1:$B1)*1)+SOMME(ESTNUM($A1:$B1)*1)=2


MichDenis
Le #19080991
Mon test était comme ceci :
Si F1 et G1 affiche NA
cette formule = 2
Mise dans une cellule, il faut valider par Ctrl + Maj + Enter
=SOMME(ESTNA($F1:$G1)*1)+SOMME(ESTNUM($F1:$G1)*1)

Si dans les mêmes cellules, on a des valeurs numériques,
on obtient aussi 2.

pour la mise en forme conditionnelle, il faut transformer comme ceci :

=SOMME(ESTNA($F1:$G1)*1)+SOMME(ESTNUM($F1:$G1)*1)=2
Évidemment, nul besoin de valider cette formule par Ctrl + maj + enter
dans la fenêtre de mise en forme conditionnelle.

Sinon, mon excel est brisé... !




"Daniel.C"
Heu, j'ai loupé quelque chose, mais quand A1 et B1 sont égales à #NA!,
ta formule donne 0 ?
Daniel

Bonjour Sylvie,

Je préfère cette formule :
=SOMME(ESTNA($A1:$B1)*1)+SOMME(ESTNUM($A1:$B1)*1)=2


PLG
Le #19080981
Bonjour

Il me semble avoir compris ta demande.
Une MFC en colonne C
Sélectionnes toute les cellules.
Dans ta mfc entre dans la formule est :

=SI(ET(ESTNA(A1);ESTNA(B1));VRAI)
et 2ème condition ( formule ) remplace ESTNA par ESTNUM

Chosis ton motif.
J'ai fait avec mes connaissances, peut être qu'avec une seule formule c'est
faisable.
Ce qui est sur c'est que ça marche !
Cordialement

"" a écrit :

Bonjour à vous;
voilà mon pb, j'ai deux colonne de 250 lignes, qui sont le résultat
d'une RECHERCHEV d'une autre feuille, à savoir que normalement quand
dans la (col 1) j'ai un montant, dans la (col 2) j'ai #N/A et vise
vers sa, mais il peut arriver que dans la col 1 et 2 j'ai #N/A ou deux
montants c'est pour cela que je voudrais mettre une MFC dans la
colonne suivante pour avoir une couleur quand sur la même ligne j'ai
deux montants ou deux #N/A

Merci à vous



Fredo P.
Le #19080851
Bonjour
MFC 1
=(ESTNA(B10)*1+ESTNA(C10)*1)=2
MFC 2
=(ESTNUM(B10)*1+ESTNUM(C10)*1)=2

o P.
news:
Bonjour à vous;
voilà mon pb, j'ai deux colonne de 250 lignes, qui sont le résultat
d'une RECHERCHEV d'une autre feuille, à savoir que normalement quand
dans la (col 1) j'ai un montant, dans la (col 2) j'ai #N/A et vise
vers sa, mais il peut arriver que dans la col 1 et 2 j'ai #N/A ou deux
montants c'est pour cela que je voudrais mettre une MFC dans la
colonne suivante pour avoir une couleur quand sur la même ligne j'ai
deux montants ou deux #N/A

Merci à vous
Fredo P.
Le #19080831
Hum! il n'est nul besoin de multiplication!!
et encore + court!
=ESTNA(B10)+ESTNA(C10)=2
--
Fredo P.
news:
Bonjour à vous;
voilà mon pb, j'ai deux colonne de 250 lignes, qui sont le résultat
d'une RECHERCHEV d'une autre feuille, à savoir que normalement quand
dans la (col 1) j'ai un montant, dans la (col 2) j'ai #N/A et vise
vers sa, mais il peut arriver que dans la col 1 et 2 j'ai #N/A ou deux
montants c'est pour cela que je voudrais mettre une MFC dans la
colonne suivante pour avoir une couleur quand sur la même ligne j'ai
deux montants ou deux #N/A

Merci à vous
syleg35
Le #19080651
Bonsoir à vous;

et merci pour vos réponse cela ma permis de trouver mon bonheur

bonne soirée

On 8 avr, 18:20, Daniel.C
Bonjour.
Utilise la formule :
=SI(ET(ESTNA(A1);ESTNA(B1));1;A1)
Daniel



> Bonjour vous;
> voil mon pb, j'ai deux colonne de 250 lignes, qui sont le r sultat
> d'une RECHERCHEV d'une autre feuille, savoir que normalement quand
> dans la (col 1) j'ai un montant, dans la (col 2) j'ai #N/A et vise
> vers sa, mais il peut arriver que dans la col 1 et 2 j'ai #N/A ou deux
> montants c'est pour cela que je voudrais mettre une MFC dans la
> colonne suivante pour avoir une couleur quand sur la m me ligne j'ai
> deux montants ou deux #N/A

> Merci vous- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Daniel.C
Le #19081281
OK. Pigé (enfin ;-(( ) je n'avais pas validé en matricielle (test
dans la feuille).
Daniel
Mon test était comme ceci :
Si F1 et G1 affiche NA
cette formule = 2
Mise dans une cellule, il faut valider par Ctrl + Maj + Enter
=SOMME(ESTNA($F1:$G1)*1)+SOMME(ESTNUM($F1:$G1)*1)

Si dans les mêmes cellules, on a des valeurs numériques,
on obtient aussi 2.

pour la mise en forme conditionnelle, il faut transformer comme ceci :

=SOMME(ESTNA($F1:$G1)*1)+SOMME(ESTNUM($F1:$G1)*1)=2
Évidemment, nul besoin de valider cette formule par Ctrl + maj + enter
dans la fenêtre de mise en forme conditionnelle.

Sinon, mon excel est brisé... !




"Daniel.C" discussion :
Heu, j'ai loupé quelque chose, mais quand A1 et B1 sont égales à #NA!,
ta formule donne 0 ?
Daniel

Bonjour Sylvie,

Je préfère cette formule :
=SOMME(ESTNA($A1:$B1)*1)+SOMME(ESTNUM($A1:$B1)*1)=2




Publicité
Poster une réponse
Anonyme