MFC doublon partie de cellule

Le
PhildeParis
Bonjour,

J'ai dans la colonne A, dans une cellule, un nom parfois suivi d'une autre
donnée :

Paul 127
Gérard 127
Paul mistral
Paul

Je souhaite faire apparaître avec mise en forme conditionnelle les doublons
avec le nom :
dans cet exemple les Paul.

J'ai une formule qui fonctionne sur la totalité de la cellule
=NB.SI($A$3:$A$8;A3)>1
mais par sur une partie

Savez vous comment l'adapter ?

avec mes remerciements pour votre aide,

Phil.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #5291951
bonjour Phil.

sélectionne la plage, par exemple A3:A8

MEFC, la formule est :
=NB.SI(A3;"*Paul*")>0

isabelle

Bonjour,

J'ai dans la colonne A, dans une cellule, un nom parfois suivi d'une
autre donnée :

Paul 127
Gérard 127
Paul mistral
Paul

Je souhaite faire apparaître avec mise en forme conditionnelle les
doublons avec le nom :
dans cet exemple les Paul.

J'ai une formule qui fonctionne sur la totalité de la cellule
=NB.SI($A$3:$A$8;A3)>1
mais par sur une partie...

Savez vous comment l'adapter ?

avec mes remerciements pour votre aide,

Phil.


PhildeParis
Le #5291871
Bonjour,
Merci pour cette formule, mais ce ne sont pas que les Paul que je souhaite
ainsi repérer mais tous les doublons...

Ph.

"isabelle" a écrit dans le message de
news:
bonjour Phil.

sélectionne la plage, par exemple A3:A8

MEFC, la formule est :
=NB.SI(A3;"*Paul*")>0

isabelle

Bonjour,

J'ai dans la colonne A, dans une cellule, un nom parfois suivi d'une
autre donnée :

Paul 127
Gérard 127
Paul mistral
Paul

Je souhaite faire apparaître avec mise en forme conditionnelle les
doublons avec le nom :
dans cet exemple les Paul.

J'ai une formule qui fonctionne sur la totalité de la cellule
=NB.SI($A$3:$A$8;A3)>1
mais par sur une partie...

Savez vous comment l'adapter ?

avec mes remerciements pour votre aide,

Phil.




JB
Le #5291781
Bonjour,

-Sélectionner A1:A10
-Format/MFC
=doublons(A1;$A$1:$A$10)>1

Function doublons(a As Range, b As Range)
temp = Split(a, " ")
temp2 = b
n = 0
For i = LBound(temp) To UBound(temp)
For j = LBound(temp2) To UBound(temp2)
If InStr(temp2(j, 1), temp(i)) > 0 Then n = n + 1
Next j
Next i
doublons = n - UBound(temp)
End Function

http://cjoint.com/?btrsR5T2DB

JB


On 19 jan, 04:12, "PhildeParis"
Bonjour,

J'ai  dans la colonne A, dans une cellule, un nom parfois suivi d'une au tre
donnée :

Paul 127
Gérard 127
Paul  mistral
Paul

Je souhaite faire apparaître avec mise en forme conditionnelle les doubl ons
avec le nom :
dans cet exemple les Paul.

J'ai une formule  qui fonctionne sur la totalité de la cellule
=NB.SI($A$3:$A$8;A3)>1
mais par sur une partie...

Savez vous comment l'adapter ?

avec mes remerciements pour votre aide,

Phil.


JB
Le #5291731
Function doublons(a As Range, b As Range)
temp = Split(a, " ")
temp2 = b
n = 0
For i = LBound(temp) To UBound(temp)
For j = LBound(temp2) To UBound(temp2)
If Not IsError(Application.Match(temp(i), Split(temp2(j, 1), "
"), 0)) Then n = n + 1
Next j
Next i
doublons = n - UBound(temp)
End Function

http://cjoint.com/?btrSn07vhk

JB



On 19 jan, 17:18, JB
Bonjour,

-Sélectionner A1:A10
-Format/MFC
=doublons(A1;$A$1:$A$10)>1

Function doublons(a As Range, b As Range)
   temp = Split(a, " ")
   temp2 = b
   n = 0
   For i = LBound(temp) To UBound(temp)
     For j = LBound(temp2) To UBound(temp2)
      If InStr(temp2(j, 1), temp(i)) > 0 Then n = n + 1
     Next j
   Next i
   doublons = n - UBound(temp)
End Function

http://cjoint.com/?btrsR5T2DB

JB

On 19 jan, 04:12, "PhildeParis"


Bonjour,

J'ai  dans la colonne A, dans une cellule, un nom parfois suivi d'une autre
donnée :

Paul 127
Gérard 127
Paul  mistral
Paul

Je souhaite faire apparaître avec mise en forme conditionnelle les dou blons
avec le nom :
dans cet exemple les Paul.

J'ai une formule  qui fonctionne sur la totalité de la cellule
=NB.SI($A$3:$A$8;A3)>1
mais par sur une partie...

Savez vous comment l'adapter ?

avec mes remerciements pour votre aide,

Phil.- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



PhildeParis
Le #5291571
Ca marche !

MERCI JB

Bien cordialement,

Philippe

"JB" news:

Function doublons(a As Range, b As Range)
temp = Split(a, " ")
temp2 = b
n = 0
For i = LBound(temp) To UBound(temp)
For j = LBound(temp2) To UBound(temp2)
If Not IsError(Application.Match(temp(i), Split(temp2(j, 1), "
"), 0)) Then n = n + 1
Next j
Next i
doublons = n - UBound(temp)
End Function

http://cjoint.com/?btrSn07vhk

JB



On 19 jan, 17:18, JB
Bonjour,

-Sélectionner A1:A10
-Format/MFC
=doublons(A1;$A$1:$A$10)>1

Function doublons(a As Range, b As Range)
temp = Split(a, " ")
temp2 = b
n = 0
For i = LBound(temp) To UBound(temp)
For j = LBound(temp2) To UBound(temp2)
If InStr(temp2(j, 1), temp(i)) > 0 Then n = n + 1
Next j
Next i
doublons = n - UBound(temp)
End Function

http://cjoint.com/?btrsR5T2DB

JB

On 19 jan, 04:12, "PhildeParis"


Bonjour,

J'ai dans la colonne A, dans une cellule, un nom parfois suivi d'une
autre
donnée :

Paul 127
Gérard 127
Paul mistral
Paul

Je souhaite faire apparaître avec mise en forme conditionnelle les
doublons
avec le nom :
dans cet exemple les Paul.

J'ai une formule qui fonctionne sur la totalité de la cellule
=NB.SI($A$3:$A$8;A3)>1
mais par sur une partie...

Savez vous comment l'adapter ?

avec mes remerciements pour votre aide,

Phil.- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme