Migration non aboutie vers squeeze

Le
Christophe Moille
Salut,

J'ai mis à jour une lenny vers squeeze en m'aidant de la note de
migration debian
http://www.debian.org/releases/stable/i386/release-notes/

jusqu'au dist-upgrade tout va bien. Mais j'ai un soucis qui semble lié
au paquet apt-listbugs

apt-get m'indique

-8<-8<-8<-8<-8<-8<-8<-8<-8<-8<-8<-
Les paquets suivants contiennent des dépendances non satisfaites :
apt-listbugs: Dépend: libdpkg-ruby1.8 (>= 0.3.3) mais 0.3.2 devra être
installé
libgettext-ruby1.8: Dépend: ruby1.8 (>= 1.8.7.249-3) mais
1.8.7.72-3lenny1 devra être installé ou
irb1.8 (>= 1.4.3)
Dépend: liblocale-ruby1.8 (>= 2.0.0) mais ne sera
pas installé
Dépend: libruby (>= 1.8.2) mais ne sera pas
installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans
paquet
-8<-8<-8<-8<-8<-8<-8<-8<-8<-8<-8<-



apt-get -f install me sort ça après le téléchargement des paquets:




-8<-8<-8<-8<-8<-8<-8<-8<-8<-8<-8<-
/usr/lib/ruby/1.8/gettext.rb:25:in `require': no such file to load --
locale (LoadError)
from /usr/lib/ruby/1.8/gettext.rb:25
from /usr/sbin/apt-listbugs:240:in `require'
from /usr/sbin/apt-listbugs:240
E: Le sous-processus /usr/sbin/apt-listbugs apt || exit 10 a renvoyé un
code d'erreur (10)
E: Failure running script /usr/sbin/apt-listbugs apt || exit 10
-8<-8<-8<-8<-8<-8<-8<-8<-8<-8<-8<-


Je ne vois pas trop quoi, j'ai un peu farfouillé mais sans grand succès.
Comment puis-je avancer vers une solution ?
Je peux fournir les enregistrements de l'opération de migration
upgrade-squeeze.script et upgrade-squeeze.time ou encore la liste des
paquets avant ou après la migration.

Merci de vos tuyaux

--
Christophe Moille
+33 (0) 950 727 525

“Lorsqu’on ne s’étonne plus du traçage, de la vidéosurveillance ou de la
conservation des données, c’est justement le signal qu’on est entré dans
un monde orwellien.”
– Alex Türk, président de la CNIL

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/1297462647.5018.8.camel@sevengrey
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Etilem
Le #23116261
bonsoir,

Le ven. 11 févr. 2011 23:19:15 CET, Christophe Moille a écrit:

Le vendredi 11 février 2011 à 23:17 +0100, Christophe Moille a écrit :
> Je ne vois pas trop quoi, j'ai un peu farfouillé mais sans grand
> succès. Comment puis-je avancer vers une solution ?
> Je peux fournir les enregistrements de l'opération de migration
> upgrade-squeeze.script et upgrade-squeeze.time ou encore la liste
> des paquets avant ou après la migration.
>
> Merci de vos tuyaux
>

En fait si, ya quand même une page qui semble approcher le même sujet
http://us.generation-nt.com/answer/bug-611913-apt-listbugs-breaks-install ation-removed-not-purged-broke-upgrade-squeeze-process-me-help-201997382.ht ml
Mais de là à pouvoir l'exploiter moi-même...



j'ai eu le même problème et j'ai utilisé la commande :

dpkg -r apt-listbugs

avant de continuer la dist-upgrade vers Squeeze.

HTH,

--
Etilem

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe Moille
Le #23116631
Le vendredi 11 février 2011 à 23:53 +0100, Etilem a écrit :

j'ai eu le même problème et j'ai utilisé la commande :

dpkg -r apt-listbugs

avant de continuer la dist-upgrade vers Squeeze.



Super ! Ça marche tout seul. Merci bien.


--
Christophe Moille
+33 (0) 950 727 525

“Lorsqu’on ne s’étonne plus du traçage, de la vidéosurveillance ou de la
conservation des données, c’est justement le signal qu’on est entré dans
un monde orwellien.”
– Alex Türk, président de la CNIL

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme