Mise en forme

Le
Apitos
Bonjour,

Dans la colonne A, j'ai les valeurs suivantes :

1- 20 - 0.56 - 1.5689 - 385.19006 - 0.24

Comment mettre en forme ces valeurs pour que je puisse les avoir sous
la forme :

1 - 20 - 0.56 - 1.57 - 385.19 - .24

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
dre
Le #4480881
Bonjour,

Peux-tu préciser pourquoi 0.56 reste 0.56 alors que 0.24 devient .24 ?

Si c'est une erreur de frappe, cela doit être faisable dans une autre
colonne, mais en format texte :
=SI(MOD(A1;1)=0;TEXTE(A1;"0");TEXTE(A1;"0.00"))

dré





Bonjour,

Dans la colonne A, j'ai les valeurs suivantes :

1- 20 - 0.56 - 1.5689 - 385.19006 - 0.24

Comment mettre en forme ces valeurs pour que je puisse les avoir sous
la forme :

1 - 20 - 0.56 - 1.57 - 385.19 - .24

Merci.




Alicante
Le #4480851
On 1 mai, 13:56, dre
Bonjour,

Peux-tu préciser pourquoi 0.56 reste 0.56 alors que 0.24 devient .24 ?



Precision non-obligatoire !
J'ai pris l'habitude de commencer par taper le point lorsqu'il sagit
d'un nombre a virgule.
Excel fait le reste.
Donc c'est 0.24 reste 0.24 !!

Si c'est une erreur de frappe, cela doit être faisable dans une autre
colonne, mais en format texte :
=SI(MOD(A1;1)=0;TEXTE(A1;"0");TEXTE(A1;"0.00"))

dré


Merci dré.

Apitos
Le #4480831
On 1 mai, 13:56, dre
Bonjour,

Peux-tu préciser pourquoi 0.56 reste 0.56 alors que 0.24 devient .24 ?



Juste une habitude de taper un point lorsqu'il sagit d'un chiffre a
virgule.

Excel fait le reste.

Donc c'est 0.24 au lieu de .24 !

Si c'est une erreur de frappe, cela doit être faisable dans une autre
colonne, mais en format texte :
=SI(MOD(A1;1)=0;TEXTE(A1;"0");TEXTE(A1;"0.00"))

dré


J'ai un problème dré.

Dans A1, le chiffre est un résultant d'une formule :

A1 = SOMME.SI(B$2:B$1000;I1;D$2:D$1000)

Alors comment integrer la mis en forme des chiffres avec en A1 cette
formule ?

Merci.

AV
Le #4480821
Dans la colonne A, j'ai les valeurs suivantes :
Comment mettre en forme ces valeurs ...


Et si tu appliquais simplement un format ("..mettre en forme..")
Sélection de la plage > Format > Nombre > 0.00

AV

Apitos
Le #4480751
On 1 mai, 15:45, "AV"
Dans la colonne A, j'ai les valeurs suivantes :
Comment mettre en forme ces valeurs ...


Et si tu appliquais simplement un format ("..mettre en forme..")
Sélection de la plage > Format > Nombre > 0.00

AV


J'ai deja essaye ça, et ça pose probleme dans les nombres entiers.

de l'exemple donné on onbtient :

1.00- 20.00 - 0.56 - 1.57 - 385.19 - 0.24

au lieu :

1- 20 - 0.56 - 1.57- 385.19 - 0.24


AV
Le #4480741
J'ai deja essaye ça, et ça pose probleme dans les nombres entiers.


Sans avoir à ajouter une colonne, l'intérêt (?) est d'agir seulement sur le
format en gardant des valeurs numériques
Capital si tu veux faire des calculs ultérieurs sur ces résultats !

Tu peux aussi employer cette méthode :
=ARRONDI(A1*100;0.5)/100

AV

dre
Le #4480721
Re,

Le plus facile est de nommer ta formule.
Tu sélectionnes la cellule dans laquelle tu as ta formule SOMME(...)
Menu Insertion / Nom / Définir
Tu y colles ta formule (en bas) et tu lui donnes un nom (en haut), par
exemple : form
Ensuite tu remplaces ta fomule (dans la cellule sélectionnée) par la formule
que je t'ai proposée en remplaçant A1 par form (ou le nom que tu lui as
donnée).

Comme tu travailles en valeurs relatives tu dois necessairement partir
depuis la cellule dans laquelle tu as mis ta formule.

dre


On 1 mai, 15:45, "AV"
Dans la colonne A, j'ai les valeurs suivantes :
Comment mettre en forme ces valeurs ...


Et si tu appliquais simplement un format ("..mettre en forme..")
Sélection de la plage > Format > Nombre > 0.00

AV


J'ai deja essaye ça, et ça pose probleme dans les nombres entiers.

de l'exemple donné on onbtient :

1.00- 20.00 - 0.56 - 1.57 - 385.19 - 0.24

au lieu :

1- 20 - 0.56 - 1.57- 385.19 - 0.24











dre
Le #4480691
Oups ! deux erreurs !

"Le nom que tu lui as donné" (sans "e" final).

Tes valeurs ne sont pas tout à fait relatives, donc se mettre dans la bonne
colonne avant de nommer la formule est suffisant.

dré.




Re,

Le plus facile est de nommer ta formule.
Tu sélectionnes la cellule dans laquelle tu as ta formule SOMME(...)
Menu Insertion / Nom / Définir
Tu y colles ta formule (en bas) et tu lui donnes un nom (en haut), par
exemple : form
Ensuite tu remplaces ta fomule (dans la cellule sélectionnée) par la formule
que je t'ai proposée en remplaçant A1 par form (ou le nom que tu lui as
donnée).

Comme tu travailles en valeurs relatives tu dois necessairement partir
depuis la cellule dans laquelle tu as mis ta formule.

dre


On 1 mai, 15:45, "AV"
Dans la colonne A, j'ai les valeurs suivantes :
Comment mettre en forme ces valeurs ...


Et si tu appliquais simplement un format ("..mettre en forme..")
Sélection de la plage > Format > Nombre > 0.00

AV


J'ai deja essaye ça, et ça pose probleme dans les nombres entiers.

de l'exemple donné on onbtient :

1.00- 20.00 - 0.56 - 1.57 - 385.19 - 0.24

au lieu :

1- 20 - 0.56 - 1.57- 385.19 - 0.24













Apitos
Le #4480281
Ca ne marche toujours pas pour moi.

J'essaye depuis des heures de joindre un exemple sur cjoint.com, mais
le service ne marche pas.
Publicité
Poster une réponse
Anonyme