Modification format date

Le
marco
Bonjour à tous,

Pourriez vous m'aider sur le point suivant:
Je dispose dans une colonne de dates récupérées dans ce format 20071031.
Je souhaite les transformer sous ce format 31102007 afin de calculer un
nombre de mois entre cette date et aujourd'hui par exemple.

Merci pour votre participation

Marco
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5275381
Pas besoin de changer tes dates :
=SI(CNUM(STXT(A1;5;2))>MOIS(AUJOURDHUI());1;0)
Si tu veux quand même les retourner :
=CNUM(DROITE(A1;2)&STXT(A1;5;2)&GAUCHE(A1;4))
Cordialement.
Daniel
"marco"
Bonjour à tous,

Pourriez vous m'aider sur le point suivant:
Je dispose dans une colonne de dates récupérées dans ce format 20071031.
Je souhaite les transformer sous ce format 31102007 afin de calculer un
nombre de mois entre cette date et aujourd'hui par exemple.

Merci pour votre participation

Marco


JB
Le #5275351
Bonjour,

ÚTEDIF(DATE(GAUCHE(A1;4);STXT(A1;5;2);DROITE(A1;2));AUJOURDHUI();"m")

http://cjoint.com/?ctrY2sXzQV

JB

On 19 fév, 17:18, "Daniel.C"
Pas besoin de changer tes dates :
=SI(CNUM(STXT(A1;5;2))>MOIS(AUJOURDHUI());1;0)
Si tu veux quand même les retourner :
=CNUM(DROITE(A1;2)&STXT(A1;5;2)&GAUCHE(A1;4))
Cordialement.
Daniel
"marco"



Bonjour à tous,

Pourriez vous m'aider sur le point suivant:
Je dispose dans une colonne de dates récupérées dans ce format 200 71031.
Je souhaite les transformer sous ce format 31102007 afin de calculer un
nombre de mois entre cette date et aujourd'hui par exemple.

Merci pour votre participation

Marco- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



marco
Le #5274901
Merci à vous 2,
et si je souhaite remplacer aujourd'hui par une date dans le temps à venir,
cette date se trouverai dans une cellule
Je n'y arrive pas
Merci à nouveau pour votre contribution
marco



Bonjour,

ÚTEDIF(DATE(GAUCHE(A1;4);STXT(A1;5;2);DROITE(A1;2));AUJOURDHUI();"m")

http://cjoint.com/?ctrY2sXzQV

JB

On 19 fév, 17:18, "Daniel.C"
Pas besoin de changer tes dates :
=SI(CNUM(STXT(A1;5;2))>MOIS(AUJOURDHUI());1;0)
Si tu veux quand même les retourner :
=CNUM(DROITE(A1;2)&STXT(A1;5;2)&GAUCHE(A1;4))
Cordialement.
Daniel
"marco"



Bonjour à tous,

Pourriez vous m'aider sur le point suivant:
Je dispose dans une colonne de dates récupérées dans ce format 20071031.
Je souhaite les transformer sous ce format 31102007 afin de calculer un
nombre de mois entre cette date et aujourd'hui par exemple.

Merci pour votre participation

Marco- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -







Daniel.C
Le #5274871
=SI(CNUM(STXT(A1;5;2))>MOIS(B1);1;0)
Daniel
"marco"
Merci à vous 2,
et si je souhaite remplacer aujourd'hui par une date dans le temps à
venir,
cette date se trouverai dans une cellule
Je n'y arrive pas
Merci à nouveau pour votre contribution
marco



Bonjour,

ÚTEDIF(DATE(GAUCHE(A1;4);STXT(A1;5;2);DROITE(A1;2));AUJOURDHUI();"m")

http://cjoint.com/?ctrY2sXzQV

JB

On 19 fév, 17:18, "Daniel.C"
Pas besoin de changer tes dates :
=SI(CNUM(STXT(A1;5;2))>MOIS(AUJOURDHUI());1;0)
Si tu veux quand même les retourner :
=CNUM(DROITE(A1;2)&STXT(A1;5;2)&GAUCHE(A1;4))
Cordialement.
Daniel
"marco" news:




Bonjour à tous,

Pourriez vous m'aider sur le point suivant:
Je dispose dans une colonne de dates récupérées dans ce format
20071031.
Je souhaite les transformer sous ce format 31102007 afin de calculer
un
nombre de mois entre cette date et aujourd'hui par exemple.

Merci pour votre participation

Marco- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -









marco
Le #5274831
Merci à nouveau,
mais dans l'hypothèse ou je souhaite le nombre de mois par rapport à une
date au dela de aujourd'hui.
Plus clairement je souhaite un nombre de mois à partir d'aujourd'hui par
raport à une date supérieure.
Dans ma colonne je dispose de dates allant de 2003 à 2010 et je ne veux mon
calcul du nombre de mois restant qu'a partir d'aujourd'hui ou une date
déterminée après "aujourd'hui".

Merci à nouveau


=SI(CNUM(STXT(A1;5;2))>MOIS(B1);1;0)
Daniel
"marco"
Merci à vous 2,
et si je souhaite remplacer aujourd'hui par une date dans le temps à
venir,
cette date se trouverai dans une cellule
Je n'y arrive pas
Merci à nouveau pour votre contribution
marco



Bonjour,

ÚTEDIF(DATE(GAUCHE(A1;4);STXT(A1;5;2);DROITE(A1;2));AUJOURDHUI();"m")

http://cjoint.com/?ctrY2sXzQV

JB

On 19 fév, 17:18, "Daniel.C"
Pas besoin de changer tes dates :
=SI(CNUM(STXT(A1;5;2))>MOIS(AUJOURDHUI());1;0)
Si tu veux quand même les retourner :
=CNUM(DROITE(A1;2)&STXT(A1;5;2)&GAUCHE(A1;4))
Cordialement.
Daniel
"marco" news:




Bonjour à tous,

Pourriez vous m'aider sur le point suivant:
Je dispose dans une colonne de dates récupérées dans ce format
20071031.
Je souhaite les transformer sous ce format 31102007 afin de calculer
un
nombre de mois entre cette date et aujourd'hui par exemple.

Merci pour votre participation

Marco- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -














Daniel.C
Le #5274811
En adaptant la formule de JB (les dates étant en colonne A) :
=SI(DATE(GAUCHE(A1;4);STXT(A1;5;2);DROITE(A1;2))<AUJOURDHUI();DATEDIF(DATE(GAUCHE(A1;4);STXT(A1;5;2);DROITE(A1;2));AUJOURDHUI();"m");DATEDIF(AUJOURDHUI();DATE(GAUCHE(A1;4);STXT(A1;5;2);DROITE(A1;2));"m"))
Formule à recopier vers le bas.
Tu peux remplacer AUJOURDHUI() par une cellule dans laquelle tu auras mis
une date quelconque.
Daniel
"marco"
Merci à nouveau,
mais dans l'hypothèse ou je souhaite le nombre de mois par rapport à une
date au dela de aujourd'hui.
Plus clairement je souhaite un nombre de mois à partir d'aujourd'hui par
raport à une date supérieure.
Dans ma colonne je dispose de dates allant de 2003 à 2010 et je ne veux
mon
calcul du nombre de mois restant qu'a partir d'aujourd'hui ou une date
déterminée après "aujourd'hui".

Merci à nouveau


=SI(CNUM(STXT(A1;5;2))>MOIS(B1);1;0)
Daniel
"marco" news:

Merci à vous 2,
et si je souhaite remplacer aujourd'hui par une date dans le temps à
venir,
cette date se trouverai dans une cellule
Je n'y arrive pas
Merci à nouveau pour votre contribution
marco



Bonjour,

ÚTEDIF(DATE(GAUCHE(A1;4);STXT(A1;5;2);DROITE(A1;2));AUJOURDHUI();"m")

http://cjoint.com/?ctrY2sXzQV

JB

On 19 fév, 17:18, "Daniel.C"
Pas besoin de changer tes dates :
=SI(CNUM(STXT(A1;5;2))>MOIS(AUJOURDHUI());1;0)
Si tu veux quand même les retourner :
=CNUM(DROITE(A1;2)&STXT(A1;5;2)&GAUCHE(A1;4))
Cordialement.
Daniel
"marco" news:




Bonjour à tous,

Pourriez vous m'aider sur le point suivant:
Je dispose dans une colonne de dates récupérées dans ce format
20071031.
Je souhaite les transformer sous ce format 31102007 afin de
calculer
un
nombre de mois entre cette date et aujourd'hui par exemple.

Merci pour votre participation

Marco- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -
















Publicité
Poster une réponse
Anonyme