modprobe et initramfs

Le
Joël
Bonjour,

Je rencontre un souci sur ma debian avec un noyau 2.6.26.2 fraîchement
compilé.
Lors du démarrage, un message d'erreur indiquant que le fichier
modules.dep est manquant dans /lib/modules/2.6.26.2. Pourtant le
fichier est présent.
Je pensais que le problème venait d'initramfs car il se produisait
avant le lancement d'init.
J'ai donc utilisé mkinitramfs en ajoutant dans le repertoire /etc/
initramfs-tools/conf.d/ un fichier root contenant ROOT=/dev/sda2 à
l'image de ce qu'il y a dans le fichier resume. Ça n'as pas
fonctionné, je suis à court de solutions.

Le noyau ne reconnaît par ailleurs qu'un seul coeur sur mon turion X2.
Est-il possible que ça soit lié avec le problème de modprobe ou
directement de la configuration du noyau?

Cordialement
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Kevin Denis
Le #16618071
Le 23-08-2008, Joël

Je rencontre un souci sur ma debian avec un noyau 2.6.26.2 fraîchement
compilé.
Lors du démarrage, un message d'erreur indiquant que le fichier
modules.dep est manquant dans /lib/modules/2.6.26.2. Pourtant le
fichier est présent.
Je pensais que le problème venait d'initramfs car il se produisait
avant le lancement d'init.
J'ai donc utilisé mkinitramfs en ajoutant dans le repertoire /etc/
initramfs-tools/conf.d/ un fichier root contenant ROOT=/dev/sda2 à
l'image de ce qu'il y a dans le fichier resume. Ça n'as pas
fonctionné, je suis à court de solutions.



Il manque un fichier 'modules.dep' et tu ajoutes un fichier 'root' ?

Le noyau ne reconnaît par ailleurs qu'un seul coeur sur mon turion X2.
Est-il possible que ça soit lié avec le problème de modprobe ou
directement de la configuration du noyau?



:/bin$ zgrep CONFIG_SMP /proc/config.gz
# CONFIG_SMP is not set

Si c'est écrit yes chez toi, c'est que le SMP est activé. Si c'est
affiché comme moi, c'est que le SMP n'est pas activé, et donc tu ne
verras qu'un seul coeur.
--
Kevin
Joël
Le #16630531
On 25 août, 10:52, Kevin Denis
Le 23-08-2008, Joël
> Je rencontre un souci sur ma debian avec un noyau 2.6.26.2 fraîchemen t
> compilé.
> Lors du démarrage, un message d'erreur indiquant que le fichier
> modules.dep est manquant dans /lib/modules/2.6.26.2. Pourtant le
> fichier est présent.
> Je pensais que le problème venait d'initramfs car il se produisait
> avant le lancement d'init.
> J'ai donc utilisé mkinitramfs en ajoutant dans le repertoire /etc/
> initramfs-tools/conf.d/ un fichier root contenant ROOT=/dev/sda2 à
> l'image de ce qu'il y a dans le fichier resume. Ça n'as pas
> fonctionné, je suis à court de solutions.

Il manque un fichier 'modules.dep' et tu ajoutes un fichier 'root' ?

> Le noyau ne reconnaît par ailleurs qu'un seul coeur sur mon turion X2 .
> Est-il possible que ça soit lié avec le problème de modprobe ou
> directement de la configuration du noyau?

:/bin$ zgrep CONFIG_SMP /proc/config.gz
# CONFIG_SMP is not set

Si c'est écrit yes chez toi, c'est que le SMP est activé. Si c'est
affiché comme moi, c'est que le SMP n'est pas activé, et donc tu ne
verras qu'un seul coeur.
--
Kevin




Il manque un fichier 'modules.dep' et tu ajoutes un fichier 'root' ?


Le fichier modules.dep existe déjà!
Mon impression était qu'initramfs montait mal la partition racine (ou
trop tard) et que modprobe ne trouvait donc pas le fichier. D'après ce
que j'ai compris, ce fichier root servait à spécifier quelle était la
partition racine que devait monter initrd mais ça n'as pas fonctionné.

Pour le problème de double coeur, il a été résolu. En effet, SMP était
désactivé et pensant qu'il était activé par défaut, j'ai sauté
l'option.
Publicité
Poster une réponse
Anonyme