module b43 pour carte bcm4312 plante.

Le
Guillemin
Bonjour,

J'utilise le module b43 pour ma carte broadcom bcm4312. Depuis que j'ai
installé quelques paquets de sid (je suis principalement sous squeeze),
dont le noyau 2.6.38, ma connexion plante régulièrement après ces
messages d'erreurs :

$ dmesg | grep b43

[ 176.268414] b43-phy0 ERROR: Fatal DMA error: 0x00000800, 0x00000000,
0x00000000, 0x00000000, 0x00000000, 0x00000000
[ 176.268423] b43-phy0 ERROR: This device does not support DMA on your
system. It will now be switched to PIO.
[ 176.268429] b43-phy0: Controller RESET (DMA error)
[ 176.484261] b43-phy0: Loading firmware version 410.2160 (2007-05-26
15:32:10)
[ 182.005423] b43-phy0: Controller restarted
[ 263.916095] b43-phy0 ERROR: MAC suspend failed

Avec évidemment, pleins de lignes d'erreurs comme la dernière à la
suite. J'observe aussi ce bug maintenant avec les noyaux de squeeze. Ces
modules sont-ils fournis avec le paquet du noyau ( linux-image-$(uname
-r) ) ou dans un autre paquets? Et donc, sur quel paquet envoyer le
rapport de bug ? Au passage, si je dois fournir d'autres information,
n'hésitez pas à me le signaler. Ou si vous avez une solution.

Merci.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/1302892396.2697.10.camel@acid-cola.home
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bernard Schoenacker
Le #23287381
Le Fri, 15 Apr 2011 20:33:16 +0200,
Guillemin
Bonjour,

J'utilise le module b43 pour ma carte broadcom bcm4312. Depuis que
j'ai installé quelques paquets de sid (je suis principalement sous
squeeze), dont le noyau 2.6.38, ma connexion plante régulièrement
après ces messages d'erreurs :

$ dmesg | grep b43

[ 176.268414] b43-phy0 ERROR: Fatal DMA error: 0x00000800,
0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
[ 176.268423] b43-phy0 ERROR: This device does not support DMA on
your system. It will now be switched to PIO.
[ 176.268429] b43-phy0: Controller RESET (DMA error) ...
[ 176.484261] b43-phy0: Loading firmware version 410.2160 (2007-05-26
15:32:10)
[ 182.005423] b43-phy0: Controller restarted
[ 263.916095] b43-phy0 ERROR: MAC suspend failed

Avec évidemment, pleins de lignes d'erreurs comme la dernière à la
suite. J'observe aussi ce bug maintenant avec les noyaux de squeeze.
Ces modules sont-ils fournis avec le paquet du noyau
( linux-image-$(uname -r) ) ou dans un autre paquets? Et donc, sur
quel paquet envoyer le rapport de bug ? Au passage, si je dois
fournir d'autres information, n'hésitez pas à me le signaler. Ou si
vous avez une solution.

Merci.




bonjour,

serait il possible de vérifier la liste des paquet installés ?


version pour :

dkms
firmware
modules chargés ( /etc/modules)



apt-cache search broadcom

b43-fwcutter - Utility for extracting Broadcom 43xx firmware
bluez-firmware - Firmware for Bluetooth devices
broadcom-sta-common - Common files for the Broadcom STA Wireless driver
broadcom-sta-source - Source for the Broadcom STA Wireless driver
firmware-bnx2 - Binary firmware for Broadcom NetXtremeII
firmware-bnx2x - Binary firmware for Broadcom NetXtreme II 10Gb
firmware-brcm80211 - Binary firmware for Broadcom 802.11 wireless cards
firmware-linux-nonfree - Binary firmware drivers in the Linux kernel
libcrystalhd2 - Crystal HD Video Decoder (shared library)
bcm43xx-fwcutter - Utility for extracting Broadcom 43xx firmware


slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
jour
Le #23287511
Alors,
$ apt-cache policy dkms
dkms:
Installé : 2.1.1.2-6
Candidat : 2.1.1.2-6
Table de version :
*** 2.1.1.2-6 0
500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
100 /var/lib/dpkg/status
2.1.1.2-5 0
80 http://ftp.fr.debian.org/debian/ squeeze/main amd64 Packages

$ cat /etc/modules

firewire-sbp2
loop
vesafb

$ apt-cache policy firmware-linux-free
firmware-linux-free:
Installé : 3
Candidat : 3
Table de version :
*** 3 0
500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
100 /var/lib/dpkg/status
2.6.32-31 0
80 http://ftp.fr.debian.org/debian/ squeeze/main amd64 Packages

C'est le seul paquet firmware* d'installé, les autres ne le sont pas. Je
n'ai pas non plus d'autres paquets liés à broadcom (b43-fwcutter,
broadcom-sta-*)

Le vendredi 15 avril 2011 à 21:16 +0200, Bernard Schoenacker a écrit :
Le Fri, 15 Apr 2011 20:33:16 +0200,
Guillemin
> Bonjour,
>
> J'utilise le module b43 pour ma carte broadcom bcm4312. Depuis que
> j'ai installé quelques paquets de sid (je suis principalement sous
> squeeze), dont le noyau 2.6.38, ma connexion plante régulièrement
> après ces messages d'erreurs :
>
> $ dmesg | grep b43
>
> [ 176.268414] b43-phy0 ERROR: Fatal DMA error: 0x00000800,
> 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
> [ 176.268423] b43-phy0 ERROR: This device does not support DMA on
> your system. It will now be switched to PIO.
> [ 176.268429] b43-phy0: Controller RESET (DMA error) ...
> [ 176.484261] b43-phy0: Loading firmware version 410.2160 (2007-05-26
> 15:32:10)
> [ 182.005423] b43-phy0: Controller restarted
> [ 263.916095] b43-phy0 ERROR: MAC suspend failed
>
> Avec évidemment, pleins de lignes d'erreurs comme la dernière à la
> suite. J'observe aussi ce bug maintenant avec les noyaux de squeeze.
> Ces modules sont-ils fournis avec le paquet du noyau
> ( linux-image-$(uname -r) ) ou dans un autre paquets? Et donc, sur
> quel paquet envoyer le rapport de bug ? Au passage, si je dois
> fournir d'autres information, n'hésitez pas à me le signaler. Ou si
> vous avez une solution.
>
> Merci.
>

bonjour,

serait il possible de vérifier la liste des paquet installés ?


version pour :

dkms
firmware
modules chargés ( /etc/modules)



apt-cache search broadcom

b43-fwcutter - Utility for extracting Broadcom 43xx firmware
bluez-firmware - Firmware for Bluetooth devices
broadcom-sta-common - Common files for the Broadcom STA Wireless driver
broadcom-sta-source - Source for the Broadcom STA Wireless driver
firmware-bnx2 - Binary firmware for Broadcom NetXtremeII
firmware-bnx2x - Binary firmware for Broadcom NetXtreme II 10Gb
firmware-brcm80211 - Binary firmware for Broadcom 802.11 wireless cards
firmware-linux-nonfree - Binary firmware drivers in the Linux kernel
libcrystalhd2 - Crystal HD Video Decoder (shared library)
bcm43xx-fwcutter - Utility for extracting Broadcom 43xx firmware


slt
bernard





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Francois Mescam
Le #23288241
On 15/04/2011 20:33, Guillemin wrote:
Bonjour,

J'utilise le module b43 pour ma carte broadcom bcm4312. Depuis que j'ai
installé quelques paquets de sid (je suis principalement sous squeeze),
dont le noyau 2.6.38, ma connexion plante régulièrement après ces
messages d'erreurs :



Je suis en testing, lorsque le kernel 2.6.38 est arrivé j'ai testé b43
et il s'avère qu'il me rempli les log de messages d'erreurs et surtout
la connexion wifi n'est pas stable aussi je suis vite repassé, comme
pour les versions précédentes du kernel, à l'emploi de
broadcom-sta-source (module wl) qui donne un wifi stable et ne rempli
pas les log.

De plus lors du boot c'est le module wl qui est chargé automatiquement
alors que b43 doit être chargé par /etc/modules.

--
F.Mescam

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/iobfss$dhl$
jour
Le #23288371
Oui, mais s'il y a un driver libre, autant essayer de le faire
fonctionner correctement, non ?

Le samedi 16 avril 2011 à 09:18 +0200, Francois Mescam a écrit :
On 15/04/2011 20:33, Guillemin wrote:
> Bonjour,
>
> J'utilise le module b43 pour ma carte broadcom bcm4312. Depuis que j'ai
> installé quelques paquets de sid (je suis principalement sous squeeze),
> dont le noyau 2.6.38, ma connexion plante régulièrement après ces
> messages d'erreurs :

Je suis en testing, lorsque le kernel 2.6.38 est arrivé j'ai testé b43
et il s'avère qu'il me rempli les log de messages d'erreurs et surtout
la connexion wifi n'est pas stable aussi je suis vite repassé, comme
pour les versions précédentes du kernel, à l'emploi de
broadcom-sta-source (module wl) qui donne un wifi stable et ne rempli
pas les log.

De plus lors du boot c'est le module wl qui est chargé automatiquement
alors que b43 doit être chargé par /etc/modules.

--
F.Mescam





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Francois Mescam
Le #23288401
On 16/04/2011 10:08, jour wrote:
Oui, mais s'il y a un driver libre, autant essayer de le faire
fonctionner correctement, non ?



Tout à fait d'accord et c'est pour cela qu'à chaque nouvelle version du
kernel je fais un test de b43.


Le samedi 16 avril 2011 à 09:18 +0200, Francois Mescam a écrit :
On 15/04/2011 20:33, Guillemin wrote:
Bonjour,

J'utilise le module b43 pour ma carte broadcom bcm4312. Depuis que j'ai
installé quelques paquets de sid (je suis principalement sous squeeze),
dont le noyau 2.6.38, ma connexion plante régulièrement après ces
messages d'erreurs :



Je suis en testing, lorsque le kernel 2.6.38 est arrivé j'ai testé b43
et il s'avère qu'il me rempli les log de messages d'erreurs et surtout
la connexion wifi n'est pas stable aussi je suis vite repassé, comme
pour les versions précédentes du kernel, à l'emploi de
broadcom-sta-source (module wl) qui donne un wifi stable et ne rempli
pas les log.

De plus lors du boot c'est le module wl qui est chargé automatiquement
alors que b43 doit être chargé par /etc/modules.

--
F.Mescam









--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/iobjds$sh9$
Publicité
Poster une réponse
Anonyme