[MOSS] question sur les accents

Le
e.issaly
Salut,

Si je fais une recherche full text, moss trouve bien "présentation" et
"presentation"
(accent insensitive)

Par contre, si je cherche sur une propriété (par exemple TITRE), il
fait la différence, c'est à dire que "presentation" ne trouve pas
"présentation" :/

Il y a quelque chose que je devrais savoir sur la recherche ??
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
e.issaly
Le #18153281
En complément, les bases de contenu sont installées en accent
sensitive (_AI)
C'est peut être le problème, mais je fais toujours ca à cause des nom s
de fichiers NTFS (évite l'écrasement)

On 16 déc, 10:51, wrote:
Salut,

Si je fais une recherche full text, moss trouve bien "présentation" et
"presentation"
(accent insensitive)

Par contre, si je cherche sur une propriété (par exemple TITRE), il
fait la différence, c'est à dire que "presentation" ne trouve pas
"présentation"... :/

Il y a quelque chose que je devrais savoir sur la recherche ??


Lognoul, Marc \(Private\)
Le #18155701
Bonjour,

je ne sais pas si c'est la cause de ton problème, mais les BDD doivent en
effet être absolument paramétrées en Latin1_General_CI_AS_KS_WS.

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]
[Blog: http://www.marc-antho-etc.net/blog/]

news:
En complément, les bases de contenu sont installées en accent
sensitive (_AI)
C'est peut être le problème, mais je fais toujours ca à cause des noms
de fichiers NTFS (évite l'écrasement)

On 16 déc, 10:51, wrote:
Salut,

Si je fais une recherche full text, moss trouve bien "présentation" et
"presentation"
(accent insensitive)

Par contre, si je cherche sur une propriété (par exemple TITRE), il
fait la différence, c'est à dire que "presentation" ne trouve pas
"présentation"... :/

Il y a quelque chose que je devrais savoir sur la recherche ??





e.issaly
Le #18155991
Bonjour,

Merci pour la réponse... mais j'ai vérifié en premier. Install par
défaut, donc CI AS KS WS, master et contents DB, soupir.

est ce que quelqu'un qui a installé un language pack FR pourrait
tester chez lui?
(je soupconne le pack FR donc, car en MOSS FR sans pack, ca marche, de
mémoire)

La démarche c'est de créer deux docs, un de titre "testé", un de titr e
"teste"
recherche avancée -> chercher pour "documents", propriété "titre",
contient "testé"
-> retourne un doc (KO) ou deux (OK)

En passant, j'ai trouvé le moyen de forcer les alertes "daily" : il
suffit de modifier la propriété "notify time" dans la table
"scheduledSubscriptions" de la base de contenu. La mettre à dans 5mn,
et voila, ca permet de tester. Le flag job-daily-alerts devait servir
sur SPS, il fait rien de perceptible ;)

évidamment, à ne pas tenter en prod sous peine de combustion spontané e
du support MS ^^



On 16 déc, 16:31, "Lognoul, Marc (Private)" wrote:
Bonjour,

je ne sais pas si c'est la cause de ton problème, mais les BDD doivent en
effet être absolument paramétrées en Latin1_General_CI_AS_KS_WS.

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]
[Blog:http://www.marc-antho-etc.net/blog/]


news:



> En complément, les bases de contenu sont installées en accent
> sensitive (_AI)
> C'est peut être le problème, mais je fais toujours ca à cause des noms
> de fichiers NTFS (évite l'écrasement)

> On 16 déc, 10:51, wrote:
>> Salut,

>> Si je fais une recherche full text, moss trouve bien "présentation" et
>> "presentation"
>> (accent insensitive)

>> Par contre, si je cherche sur une propriété (par exemple TITRE), i l
>> fait la différence, c'est à dire que "presentation" ne trouve pas
>> "présentation"... :/

>> Il y a quelque chose que je devrais savoir sur la recherche ??- Masque r le texte des messages précédents -

- Afficher le texte des messages précédents -


EROL MVP MOSS
Le #18190781
Bonjour Emmanuel,

Exacte, cela fonctionne.

Cdlt
----
--
P. Erol GIRAUDY
MVP MOSS
www.clubmoss2007.org
http://www.new.facebook.com/event.php?eid288548930


Bonjour,

Merci pour la réponse... mais j'ai vérifié en premier. Install par
défaut, donc CI AS KS WS, master et contents DB, soupir.

est ce que quelqu'un qui a installé un language pack FR pourrait
tester chez lui?
(je soupconne le pack FR donc, car en MOSS FR sans pack, ca marche, de
mémoire)

La démarche c'est de créer deux docs, un de titre "testé", un de titre
"teste"
recherche avancée -> chercher pour "documents", propriété "titre",
contient "testé"
-> retourne un doc (KO) ou deux (OK)

En passant, j'ai trouvé le moyen de forcer les alertes "daily" : il
suffit de modifier la propriété "notify time" dans la table
"scheduledSubscriptions" de la base de contenu. La mettre à dans 5mn,
et voila, ca permet de tester. Le flag job-daily-alerts devait servir
sur SPS, il fait rien de perceptible ;)

évidamment, à ne pas tenter en prod sous peine de combustion spontanée
du support MS ^^



On 16 déc, 16:31, "Lognoul, Marc (Private)" wrote:
Bonjour,

je ne sais pas si c'est la cause de ton problème, mais les BDD doivent en
effet être absolument paramétrées en Latin1_General_CI_AS_KS_WS.

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]
[Blog:http://www.marc-antho-etc.net/blog/]


news:



> En complément, les bases de contenu sont installées en accent
> sensitive (_AI)
> C'est peut être le problème, mais je fais toujours ca à cause des noms
> de fichiers NTFS (évite l'écrasement)

> On 16 déc, 10:51, wrote:
>> Salut,

>> Si je fais une recherche full text, moss trouve bien "présentation" et
>> "presentation"
>> (accent insensitive)

>> Par contre, si je cherche sur une propriété (par exemple TITRE), il
>> fait la différence, c'est à dire que "presentation" ne trouve pas
>> "présentation"... :/

>> Il y a quelque chose que je devrais savoir sur la recherche ??-
>> Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -





e.issaly
Le #18199451
Pour la petite histoire, le moteur moss va rechercher dans le fichier
index à plat dans le cas de la recherche "full text", mais tape
directement sur SQL si on cherche sur une propriété.

D'ou la différence de comportement, full text = pas d'accents,
propriété = AS est on par défaut dans SQL, accents significatifs.

Donc pas de solution que je puisse voir, installer moss avec des bases
SQL en AI n'est pas supporté par MS.
Je soupconne que ca pourrait poser des problèmes de nom de fichiers FR
si on l'enlevait anyway.

Prochain essai : tenter de coller un collate dans une requete
SQLfullText... quelqu'un a déjà essayé? :)


> Bonjour,

> Merci pour la réponse... mais j'ai vérifié en premier. Install pa r
> défaut, donc CI AS KS WS, master et contents DB, soupir.

> est ce que quelqu'un qui a installé un language pack FR pourrait
> tester chez lui?
> (je soupconne le pack FR donc, car en MOSS FR sans pack, ca marche, de
> mémoire)

> La démarche c'est de créer deux docs, un de titre "testé", un de titre
> "teste"
> recherche avancée -> chercher pour "documents", propriété "titre" ,
> contient "testé"
> -> retourne un doc (KO) ou deux (OK)

> En passant, j'ai trouvé le moyen de forcer les alertes "daily" : il
> suffit de modifier la propriété "notify time" dans la table
> "scheduledSubscriptions" de la base de contenu. La mettre à dans 5mn,
> et voila, ca permet de tester. Le flag job-daily-alerts devait servir
> sur SPS, il fait rien de perceptible ;)

> évidamment, à ne pas tenter en prod sous peine de combustion sponta née
> du support MS ^^

> On 16 déc, 16:31, "Lognoul, Marc (Private)" > wrote:
>> Bonjour,

>> je ne sais pas si c'est la cause de ton problème, mais les BDD doive nt en
>> effet être absolument paramétrées en Latin1_General_CI_AS_KS_WS.

>> --
>> Marc
>> [Heureux celui qui a pu pénétrer les causes secrètes des choses]
>> [Blog:http://www.marc-antho-etc.net/blog/]

>>
>>news: ..

>> > En complément, les bases de contenu sont installées en accent
>> > sensitive (_AI)
>> > C'est peut être le problème, mais je fais toujours ca à cause des noms
>> > de fichiers NTFS (évite l'écrasement)

>> > On 16 déc, 10:51, wrote:
>> >> Salut,

>> >> Si je fais une recherche full text, moss trouve bien "présentatio n" et
>> >> "presentation"
>> >> (accent insensitive)

>> >> Par contre, si je cherche sur une propriété (par exemple TITRE) , il
>> >> fait la différence, c'est à dire que "presentation" ne trouve p as
>> >> "présentation"... :/

>> >> Il y a quelque chose que je devrais savoir sur la recherche ??-
>> >> Masquer le texte des messages précédents -

>> - Afficher le texte des messages précédents -- Masquer le texte de s messages précédents -

- Afficher le texte des messages précédents -


Publicité
Poster une réponse
Anonyme