[MOSS2007] BDC et Oracle

Le
e.issaly
Salut,

encore un problème bien touffu :)

J'ai crée un lien vers une base oracle, j'utilise un un compte oracle
avec accès en lecture.

Toutes les webparts BDC fonctionnent bien et j'integre mes données
oracle.
Sauf que, si un utilisateur se log sur le site, la webpart BDC echoue
à la connexion avec une erreur "12514".

En faite, cela ne semble marcher qu'avec mon compte admin :/

Des idées? il n'y a pas de SSO, mais cela ne me parait pas nécessaire
(compte oracle fixe)
j'utilise les drivers 8.1 sur une base oracle 9.x, environnement
MOSS2007 SP1+, problème KO en 32 ou 64bits.

ce qui m'embete, ce que je ne vois aucune explication rationelle au
problème :)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
e.issaly
Le #17974671
Problème réglé par la desinstallation des drivers oracles, suppressio n
des clefs dans la registry, reboot, reinstall de la 10.1 et création
d'un DSN machine avec la bonne conf.

Pas trivial, la prochaine fois je ferais du code .NET, ca ira plus
vite que par le BDC :D

On 26 nov, 15:25, wrote:
Salut,

encore un problème bien touffu :)

J'ai crée un lien vers une base oracle, j'utilise un un compte oracle
avec accès en lecture.

Toutes les webparts BDC fonctionnent bien et j'integre mes données
oracle.
Sauf que, si un utilisateur se log sur le site, la webpart BDC echoue
à la connexion avec une erreur "12514".

En faite, cela ne semble marcher qu'avec mon compte admin :/

Des idées? il n'y a pas de SSO, mais cela ne me parait pas nécessaire
(compte oracle fixe)
j'utilise les drivers 8.1 sur une base oracle 9.x, environnement
MOSS2007 SP1+, problème KO en 32 ou 64bits.

ce qui m'embete, ce que je ne vois aucune explication rationelle au
problème... :)


Etienne Legendre
Le #17998791
Merci de ce retour, pas simple en effet à trouver.
Par contre BDC avec les outils MS ou BDCmetaMan est à la portée d'un non
developpeur .NET ce qui est parfois bien utile !

EtienneL

news:
Problème réglé par la desinstallation des drivers oracles, suppression
des clefs dans la registry, reboot, reinstall de la 10.1 et création
d'un DSN machine avec la bonne conf.

Pas trivial, la prochaine fois je ferais du code .NET, ca ira plus
vite que par le BDC :D

On 26 nov, 15:25, wrote:
Salut,

encore un problème bien touffu :)

J'ai crée un lien vers une base oracle, j'utilise un un compte oracle
avec accès en lecture.

Toutes les webparts BDC fonctionnent bien et j'integre mes données
oracle.
Sauf que, si un utilisateur se log sur le site, la webpart BDC echoue
à la connexion avec une erreur "12514".

En faite, cela ne semble marcher qu'avec mon compte admin :/

Des idées? il n'y a pas de SSO, mais cela ne me parait pas nécessaire
(compte oracle fixe)
j'utilise les drivers 8.1 sur une base oracle 9.x, environnement
MOSS2007 SP1+, problème KO en 32 ou 64bits.

ce qui m'embete, ce que je ne vois aucune explication rationelle au
problème... :)


e.issaly
Le #18010641
à noter que la manière la plus simple de se connecter à oracle sur un
SSP 64 bits est de charger "oracle instant driver".

- pas d'install, on extrait dans un rep.
- le lien se fait par enregistrement d'une source ODBC (install à
part)

--> plus propre sur un serveur

Impératif, le compte du pool SSP doit avoir les privileges read /
execute sur le répertoire.
Si on indexe, le crawler aussi... etc :)

On 29 nov, 20:05, "Etienne Legendre"
XVX.COM> wrote:
Merci de ce retour, pas simple en effet à trouver.
Par contre BDC avec les outils MS ou BDCmetaMan est à la portée d'un non
developpeur .NET ce qui est parfois bien utile !

EtienneL

Problème réglé par la desinstallation des drivers oracles, suppress ion
des clefs dans la registry, reboot, reinstall de la 10.1 et création
d'un DSN machine avec la bonne conf.

Pas trivial, la prochaine fois je ferais du code .NET, ca ira plus
vite que par le BDC :D

On 26 nov, 15:25, wrote:



> Salut,

> encore un problème bien touffu :)

> J'ai crée un lien vers une base oracle, j'utilise un un compte oracle
> avec accès en lecture.

> Toutes les webparts BDC fonctionnent bien et j'integre mes données
> oracle.
> Sauf que, si un utilisateur se log sur le site, la webpart BDC echoue
> à la connexion avec une erreur "12514".

> En faite, cela ne semble marcher qu'avec mon compte admin :/

> Des idées? il n'y a pas de SSO, mais cela ne me parait pas nécessai re
> (compte oracle fixe)
> j'utilise les drivers 8.1 sur une base oracle 9.x, environnement
> MOSS2007 SP1+, problème KO en 32 ou 64bits.

> ce qui m'embete, ce que je ne vois aucune explication rationelle au
> problème... :)- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


EROL MVP MOSS
Le #18011281
Bonjour,

Merci
Au 15 Décembre "CLUB"

Pour La réunion du CLUB MOSS en Décembre 2008

Cdlt

--
P. Erol GIRAUDY
Président du Club MOSS 2007 et MUG.
Vice-Président Club UGO2007
http://clubmoss2007.org



à noter que la manière la plus simple de se connecter à oracle sur un
SSP 64 bits est de charger "oracle instant driver".

- pas d'install, on extrait dans un rep.
- le lien se fait par enregistrement d'une source ODBC (install à
part)

--> plus propre sur un serveur

Impératif, le compte du pool SSP doit avoir les privileges read /
execute sur le répertoire.
Si on indexe, le crawler aussi... etc :)

On 29 nov, 20:05, "Etienne Legendre"
XVX.COM> wrote:
Merci de ce retour, pas simple en effet à trouver.
Par contre BDC avec les outils MS ou BDCmetaMan est à la portée d'un non
developpeur .NET ce qui est parfois bien utile !

EtienneL

denews:
Problème réglé par la desinstallation des drivers oracles, suppression
des clefs dans la registry, reboot, reinstall de la 10.1 et création
d'un DSN machine avec la bonne conf.

Pas trivial, la prochaine fois je ferais du code .NET, ca ira plus
vite que par le BDC :D

On 26 nov, 15:25, wrote:



> Salut,

> encore un problème bien touffu :)

> J'ai crée un lien vers une base oracle, j'utilise un un compte oracle
> avec accès en lecture.

> Toutes les webparts BDC fonctionnent bien et j'integre mes données
> oracle.
> Sauf que, si un utilisateur se log sur le site, la webpart BDC echoue
> à la connexion avec une erreur "12514".

> En faite, cela ne semble marcher qu'avec mon compte admin :/

> Des idées? il n'y a pas de SSO, mais cela ne me parait pas nécessaire
> (compte oracle fixe)
> j'utilise les drivers 8.1 sur une base oracle 9.x, environnement
> MOSS2007 SP1+, problème KO en 32 ou 64bits.

> ce qui m'embete, ce que je ne vois aucune explication rationelle au
> problème... :)- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -





roukhou Hors ligne
Le #24669011
Le mercredi 26 Novembre 2008 à 15:25 par e.issaly :
Salut,

encore un problème bien touffu :)

J'ai crée un lien vers une base oracle, j'utilise un un compte oracle
avec accès en lecture.

Toutes les webparts BDC fonctionnent bien et j'integre mes données
oracle.
Sauf que, si un utilisateur se log sur le site, la webpart BDC echoue
à la connexion avec une erreur "12514".

En faite, cela ne semble marcher qu'avec mon compte admin :/

Des idées? il n'y a pas de SSO, mais cela ne me parait pas nécessaire
(compte oracle fixe)
j'utilise les drivers 8.1 sur une base oracle 9.x, environnement
MOSS2007 SP1+, problème KO en 32 ou 64bits.

ce qui m'embete, ce que je ne vois aucune explication rationelle au
problème... :)


svp vous pouvez me dire comment créer les webparts BDC...?
Publicité
Poster une réponse
Anonyme