moyenne d'une colonne en ignorant les 0

Le
Roland
Bonjour a Tous et Toutes

Je cherche a faire la moyenne de colonne en ignorant les 0, j'y ai passé
beaucoup de temps !!! sans résultats!!!
Merci d'avance
Cordialement

Bonnes Fêtes de Fin d'Année
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sam
Le #20694311
Bonjour, voici un exemple de solution
=SOMME(B1:B5)/NB.SI(B1:B5;"<>0")
Cordialement
Michel dit "Sam"

"Roland"
Bonjour a Tous et Toutes

Je cherche a faire la moyenne de colonne en ignorant les 0, j'y ai passé
beaucoup de temps !!! sans résultats!!!
Merci d'avance
Cordialement

Bonnes Fêtes de Fin d'Année


Jacky
Le #20694561
Bonsoir

Permet également les vides.

=SOMME(plage)/SOMMEPROD((plage<>"")*(plage<>0))
--
Salutations
JJ


"Roland"
Bonjour a Tous et Toutes

Je cherche a faire la moyenne de colonne en ignorant les 0, j'y ai passé
beaucoup de temps !!! sans résultats!!!
Merci d'avance
Cordialement

Bonnes Fêtes de Fin d'Année


Garnote
Le #20694771
Bonsoir,

Essaie cette formule :
=MOYENNE(SI(B1:B10=0;"";B1:B10))
(à valider par Ctrl+Maj+Entrée)

Serge

"Roland"
Bonjour a Tous et Toutes

Je cherche a faire la moyenne de colonne en ignorant les 0, j'y ai passé
beaucoup de temps !!! sans résultats!!!
Merci d'avance
Cordialement

Bonnes Fêtes de Fin d'Année


Garnote
Le #20695011
Salut Jacky,

=SOMME(plage)/SOMMEPROD(1*(plage<>0))
donnerait le même résultat, non ?

Serge



"Jacky"
Bonsoir

Permet également les vides.

=SOMME(plage)/SOMMEPROD((plage<>"")*(plage<>0))
--
Salutations
JJ


"Roland" news:
Bonjour a Tous et Toutes

Je cherche a faire la moyenne de colonne en ignorant les 0, j'y ai passé
beaucoup de temps !!! sans résultats!!!
Merci d'avance
Cordialement

Bonnes Fêtes de Fin d'Année






Jacky
Le #20695431
Salut Serge

Certes oui, mais dans le lot, j'aurais une préférence pour ta réponse avec
moyenne
Bien que validation matricielle, elle est plus parlante par rapport à la
question "moyenne d'une colonne en ignorant les 0"
Tests ici
http://www.cijoint.fr/cjlink.php?file=cj200912/cijlHLcMtc.xls


A Roland de choisir ;o))
--
Salutations
JJ


"Garnote"
Salut Jacky,

=SOMME(plage)/SOMMEPROD(1*(plage<>0))
donnerait le même résultat, non ?

Serge



"Jacky"
Bonsoir

Permet également les vides.

=SOMME(plage)/SOMMEPROD((plage<>"")*(plage<>0))
--
Salutations
JJ


"Roland" news:
Bonjour a Tous et Toutes

Je cherche a faire la moyenne de colonne en ignorant les 0, j'y ai passé
beaucoup de temps !!! sans résultats!!!
Merci d'avance
Cordialement

Bonnes Fêtes de Fin d'Année










Caetera
Le #20697871
"Roland"

Je cherche a faire la moyenne de colonne en ignorant les 0, j'y ai passé
beaucoup de temps !!! sans résultats!!!



*************

Seule une solution matricielle employant MOYENNE(SI( permettra de se mettre à
l'abri de la présence de valeur de texte dans la plage.
On ne sait jamais.....

=MOYENNE(SI(plage<>0;plage))

Etc
Publicité
Poster une réponse
Anonyme