Moyenne "mobile"

Le
Esox38
Bonsoir,

J'ai une base de donnée alimentée quotidiennement avec 3 colonnes.
J'ai donné un nom à chacune des colonnes :
ÞCALER('Nom feuille'!$A$2;0;0;NBVAL('Nom feuille'!$A:$A)-1)
La première correspond aux codifications = CodValHisto
La 2eme : aux dates ÚtValHisto
la 3eme aux valeurs = ValHisto
Ex : E03M 01/01/2007 3.63
etc

Dans une autre feuille, je veux pouvoir calculer la moyenne des 3 derniers
mois sur la colonne 3 (valeurs) à partir d'une date qui peut être modifier
chaque jour.

J'ai commencé en utilisant cette formule :
=ARRONDI((MOYENNE.GEOMETRIQUE((CodValHisto=$D$1)*(DatValHisto=MOIS.DECALER($B$2;-3));ValHisto));3)

J'ai le retour suivant dans la cellule #NOMBRE!

Avez vous une idée?

Merci
Bonne soirée
--
Esox38
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
AH60
Le #4233961
Bonsoir

Essaie avec cette formule

=MOYENNE(DECALER(C2;NBVAL(C:C)-2;0;-3))

Abed_H




Bonsoir,

J'ai une base de donnée alimentée quotidiennement avec 3 colonnes.
J'ai donné un nom à chacune des colonnes :
ÞCALER('Nom feuille'!$A$2;0;0;NBVAL('Nom feuille'!$A:$A)-1)
La première correspond aux codifications = CodValHisto
La 2eme : aux dates ÚtValHisto
la 3eme aux valeurs = ValHisto
Ex : E03M 01/01/2007 3.63
etc......

Dans une autre feuille, je veux pouvoir calculer la moyenne des 3 derniers
mois sur la colonne 3 (valeurs) à partir d'une date qui peut être modifier
chaque jour.

J'ai commencé en utilisant cette formule :
=ARRONDI((MOYENNE.GEOMETRIQUE((CodValHisto=$D$1)*(DatValHisto=MOIS.DECALER($B$2;-3));ValHisto));3)

J'ai le retour suivant dans la cellule #NOMBRE!

Avez vous une idée?

Merci
Bonne soirée
--
Esox38


Gaston
Le #4239701
Bonjour Esox38,

Dans AA1 tu écris la date que tu veux commencer ta moyenne
Dans AA2 tu écris: =Mois.Decaler(AA1;3) '3 mois
Dans AB1 tu écris: = Equiv(AA1;DatValHisto)
Dans AB2 tu écris: = Equiv(AA2;DatValHisto)
Dans AB3 tu écris: =
Moyenne(Decaler(Decaler(DatValHisto;;;1;);AB2;1;AB2-AB1;))
Ta moyenne devrait être en AB3
Bye

Gaston


"AH60" wrote:

Bonsoir

Essaie avec cette formule

=MOYENNE(DECALER(C2;NBVAL(C:C)-2;0;-3))

Abed_H




Bonsoir,

J'ai une base de donnée alimentée quotidiennement avec 3 colonnes.
J'ai donné un nom à chacune des colonnes :
ÞCALER('Nom feuille'!$A$2;0;0;NBVAL('Nom feuille'!$A:$A)-1)
La première correspond aux codifications = CodValHisto
La 2eme : aux dates ÚtValHisto
la 3eme aux valeurs = ValHisto
Ex : E03M 01/01/2007 3.63
etc......

Dans une autre feuille, je veux pouvoir calculer la moyenne des 3 derniers
mois sur la colonne 3 (valeurs) à partir d'une date qui peut être modifier
chaque jour.

J'ai commencé en utilisant cette formule :
=ARRONDI((MOYENNE.GEOMETRIQUE((CodValHisto=$D$1)*(DatValHisto=MOIS.DECALER($B$2;-3));ValHisto));3)

J'ai le retour suivant dans la cellule #NOMBRE!

Avez vous une idée?

Merci
Bonne soirée
--
Esox38




Esox38
Le #4237351
Bonsoir Gaston,

Merci pour ta réponse, mais je n'arrive pas a avoir de résultat.

Il est pas fait référence à la codification (CodValHisto) car je peux avoir
la moyenne des 3 derniers mois pour E03M ou bien E01M ou bien E12M etc....

Dans ma feuille de calcul Résultat j'ai les références à :
La date de départ en B2
La codification en liste déroulante en D1 de CodValHisto
La moyenne des 3 derniers mois en U3

Dans ma feuille Base de données j'ai :
CodValHisto en colonne A
DatValHisto en colonne B
ValHisto en colonne C

Ta formule fait uniquement référence à la colonne B.

Merci encore
Cordialement
--
Esox38



Bonjour Esox38,

Dans AA1 tu écris la date que tu veux commencer ta moyenne
Dans AA2 tu écris: =Mois.Decaler(AA1;3) '3 mois
Dans AB1 tu écris: = Equiv(AA1;DatValHisto)
Dans AB2 tu écris: = Equiv(AA2;DatValHisto)
Dans AB3 tu écris: =
Moyenne(Decaler(Decaler(DatValHisto;;;1;);AB2;1;AB2-AB1;))
Ta moyenne devrait être en AB3
Bye

Gaston


"AH60" wrote:

Bonsoir

Essaie avec cette formule

=MOYENNE(DECALER(C2;NBVAL(C:C)-2;0;-3))

Abed_H




Bonsoir,

J'ai une base de donnée alimentée quotidiennement avec 3 colonnes.
J'ai donné un nom à chacune des colonnes :
ÞCALER('Nom feuille'!$A$2;0;0;NBVAL('Nom feuille'!$A:$A)-1)
La première correspond aux codifications = CodValHisto
La 2eme : aux dates ÚtValHisto
la 3eme aux valeurs = ValHisto
Ex : E03M 01/01/2007 3.63
etc......

Dans une autre feuille, je veux pouvoir calculer la moyenne des 3 derniers
mois sur la colonne 3 (valeurs) à partir d'une date qui peut être modifier
chaque jour.

J'ai commencé en utilisant cette formule :
=ARRONDI((MOYENNE.GEOMETRIQUE((CodValHisto=$D$1)*(DatValHisto=MOIS.DECALER($B$2;-3));ValHisto));3)

J'ai le retour suivant dans la cellule #NOMBRE!

Avez vous une idée?

Merci
Bonne soirée
--
Esox38






Gaston
Le #4237061
Bonjour Esox38

Je n'avais pas bien compris la question, je pense que j'ai trouvé
Dans AA1 tu écris le code que tu veux rechercher
Dans AA2 tu écris la date que tu veux commencer ta moyenne
Dans AA3 tu écris: =Mois.Decaler(AA2;3) '3 mois
Dans AA4 tu écris:
=SOMMEPROD((CodValHistoª1)*(DatValHisto>ª2)*(DatValHisto<ª3);ValHisto)/SOMMEPROD((CodValHistoª1)*(DatValHisto>ª2)*(DatValHisto<ª3))
La moyenne des codes de "AA1" pour les 3 mois suivant la date "AA2" devrait
être en "AA4"
Bye
Gaston


"Esox38" wrote:

Bonsoir Gaston,

Merci pour ta réponse, mais je n'arrive pas a avoir de résultat.

Il est pas fait référence à la codification (CodValHisto) car je peux avoir
la moyenne des 3 derniers mois pour E03M ou bien E01M ou bien E12M etc....

Dans ma feuille de calcul Résultat j'ai les références à :
La date de départ en B2
La codification en liste déroulante en D1 de CodValHisto
La moyenne des 3 derniers mois en U3

Dans ma feuille Base de données j'ai :
CodValHisto en colonne A
DatValHisto en colonne B
ValHisto en colonne C

Ta formule fait uniquement référence à la colonne B.

Merci encore
Cordialement
--
Esox38



Bonjour Esox38,

Dans AA1 tu écris la date que tu veux commencer ta moyenne
Dans AA2 tu écris: =Mois.Decaler(AA1;3) '3 mois
Dans AB1 tu écris: = Equiv(AA1;DatValHisto)
Dans AB2 tu écris: = Equiv(AA2;DatValHisto)
Dans AB3 tu écris: =
Moyenne(Decaler(Decaler(DatValHisto;;;1;);AB2;1;AB2-AB1;))
Ta moyenne devrait être en AB3
Bye

Gaston


"AH60" wrote:

Bonsoir

Essaie avec cette formule

=MOYENNE(DECALER(C2;NBVAL(C:C)-2;0;-3))

Abed_H




Bonsoir,

J'ai une base de donnée alimentée quotidiennement avec 3 colonnes.
J'ai donné un nom à chacune des colonnes :
ÞCALER('Nom feuille'!$A$2;0;0;NBVAL('Nom feuille'!$A:$A)-1)
La première correspond aux codifications = CodValHisto
La 2eme : aux dates ÚtValHisto
la 3eme aux valeurs = ValHisto
Ex : E03M 01/01/2007 3.63
etc......

Dans une autre feuille, je veux pouvoir calculer la moyenne des 3 derniers
mois sur la colonne 3 (valeurs) à partir d'une date qui peut être modifier
chaque jour.

J'ai commencé en utilisant cette formule :
=ARRONDI((MOYENNE.GEOMETRIQUE((CodValHisto=$D$1)*(DatValHisto=MOIS.DECALER($B$2;-3));ValHisto));3)

J'ai le retour suivant dans la cellule #NOMBRE!

Avez vous une idée?

Merci
Bonne soirée
--
Esox38








Esox38
Le #4330481
Bonsoir Gaston,

Merci pour ta réponse, pile poile ce que je désirais.

Bien cordialement
--
Esox38



Bonjour Esox38

Je n'avais pas bien compris la question, je pense que j'ai trouvé
Dans AA1 tu écris le code que tu veux rechercher
Dans AA2 tu écris la date que tu veux commencer ta moyenne
Dans AA3 tu écris: =Mois.Decaler(AA2;3) '3 mois
Dans AA4 tu écris:
=SOMMEPROD((CodValHistoª1)*(DatValHisto>ª2)*(DatValHisto<ª3);ValHisto)/SOMMEPROD((CodValHistoª1)*(DatValHisto>ª2)*(DatValHisto<ª3))
La moyenne des codes de "AA1" pour les 3 mois suivant la date "AA2" devrait
être en "AA4"
Bye
Gaston


"Esox38" wrote:

Bonsoir Gaston,

Merci pour ta réponse, mais je n'arrive pas a avoir de résultat.

Il est pas fait référence à la codification (CodValHisto) car je peux avoir
la moyenne des 3 derniers mois pour E03M ou bien E01M ou bien E12M etc....

Dans ma feuille de calcul Résultat j'ai les références à :
La date de départ en B2
La codification en liste déroulante en D1 de CodValHisto
La moyenne des 3 derniers mois en U3

Dans ma feuille Base de données j'ai :
CodValHisto en colonne A
DatValHisto en colonne B
ValHisto en colonne C

Ta formule fait uniquement référence à la colonne B.

Merci encore
Cordialement
--
Esox38



Bonjour Esox38,

Dans AA1 tu écris la date que tu veux commencer ta moyenne
Dans AA2 tu écris: =Mois.Decaler(AA1;3) '3 mois
Dans AB1 tu écris: = Equiv(AA1;DatValHisto)
Dans AB2 tu écris: = Equiv(AA2;DatValHisto)
Dans AB3 tu écris: =
Moyenne(Decaler(Decaler(DatValHisto;;;1;);AB2;1;AB2-AB1;))
Ta moyenne devrait être en AB3
Bye

Gaston


"AH60" wrote:

Bonsoir

Essaie avec cette formule

=MOYENNE(DECALER(C2;NBVAL(C:C)-2;0;-3))

Abed_H




Bonsoir,

J'ai une base de donnée alimentée quotidiennement avec 3 colonnes.
J'ai donné un nom à chacune des colonnes :
ÞCALER('Nom feuille'!$A$2;0;0;NBVAL('Nom feuille'!$A:$A)-1)
La première correspond aux codifications = CodValHisto
La 2eme : aux dates ÚtValHisto
la 3eme aux valeurs = ValHisto
Ex : E03M 01/01/2007 3.63
etc......

Dans une autre feuille, je veux pouvoir calculer la moyenne des 3 derniers
mois sur la colonne 3 (valeurs) à partir d'une date qui peut être modifier
chaque jour.

J'ai commencé en utilisant cette formule :
=ARRONDI((MOYENNE.GEOMETRIQUE((CodValHisto=$D$1)*(DatValHisto=MOIS.DECALER($B$2;-3));ValHisto));3)

J'ai le retour suivant dans la cellule #NOMBRE!

Avez vous une idée?

Merci
Bonne soirée
--
Esox38










Publicité
Poster une réponse
Anonyme