Moyenne.si

Le
loamar67
Bonjour
Dans une feuille j'ai les données annuelles suivantes :
Date Jour Chiffre d'affaire
01/01/2009 Mardi 300
02/01/2009 Mercredi 250

31/12/2009 Jeudi 500

Je cherche une fommule qui me donne le nombre de jour supérieur à la
moyenne par jour

Exemple Mardi 2 <- =Moyenne.si ?
Mercredi 5

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FdeCourt
Le #20766121
Salut,
En supposant :
Dans la colonne A le jour (Lundi, Mardi, Mercredi...)
Dans la colonne B le CA

puis un tableau récapitulatif avec lundi, mardi, dans la colonne F....
et dans la colonne d'a coté la formule suivante :

=SOMMEPROD(N(F1=$A$1:$A$30)*N($B$1:$B$30>MOYENNE($B$1:$B$30)))

Ou pour éviter d'avoir une colonne supplémentaire pour afficher le
jour :
=SOMMEPROD(N(F1=JOURSEM($A$1:$A$30;2))*N($B$1:$B$30<=MOYENNE($B$1:$B
$30)))

Cordialement,

F.
MANU
Le #20766111
Bonjour,

A quoi sert la fonction N ?

Merci

Manu

"FdeCourt"
Salut,
En supposant :
Dans la colonne A le jour (Lundi, Mardi, Mercredi...)
Dans la colonne B le CA

puis un tableau récapitulatif avec lundi, mardi, dans la colonne F....
et dans la colonne d'a coté la formule suivante :

=SOMMEPROD(N(F1=$A$1:$A$30)*N($B$1:$B$30>MOYENNE($B$1:$B$30)))

Ou pour éviter d'avoir une colonne supplémentaire pour afficher le
jour :
=SOMMEPROD(N(F1=JOURSEM($A$1:$A$30;2))*N($B$1:$B$30<=MOYENNE($B$1:$B
$30)))

Cordialement,

F.
FdeCourt
Le #20766081
A transformer VRAI en 1 et FAUX en 0.

Cordialement,

F.
Caetera
Le #20766351
"loamar67"
Bonjour
Dans une feuille j'ai les données annuelles suivantes :
Date Jour Chiffre d'affaire
01/01/2009 Mardi 300
02/01/2009 Mercredi 250
...
31/12/2009 Jeudi 500

Je cherche une fommule qui me donne le nombre de jour supérieur à la
moyenne par jour

**************
Si comme ça semble être le cas, à chaque jour un montant ...

Matricielle
=NB(SI(Montants>MOYENNE(Montants);Montants))

Etc
loamar67
Le #20767401
Merci !
Ca marche très bien !
Mais j'ai du mal à comprendre pourquoi il faut mettre le N !
loa

On 14 déc, 13:34, FdeCourt
Salut,
En supposant :
Dans la colonne A le jour (Lundi, Mardi, Mercredi...)
Dans la colonne B le CA

puis un tableau récapitulatif avec lundi, mardi, dans la colonne F....
et dans la colonne d'a coté la formule suivante :

=SOMMEPROD(N(F1=$A$1:$A$30)*N($B$1:$B$30>MOYENNE($B$1:$B$30)))

Ou pour éviter d'avoir une colonne supplémentaire pour afficher le
jour :
=SOMMEPROD(N(F1=JOURSEM($A$1:$A$30;2))*N($B$1:$B$30<=MOYENNE($B$1:$ B
$30)))

Cordialement,

F.


MANU
Le #20767531
Merci
et la fonction T, je suppose que c'est l'inverse...

"FdeCourt"
A transformer VRAI en 1 et FAUX en 0.

Cordialement,

F.


FdeCourt
Le #20767521
Salut,

Le N permet de rendre possible une opérationp arithmétique.
Excel te donne deux possibilités pour transformer un résultat boolean
en numérique:
- la fonction N
- Multiplier par 1

Parceque VRAI x 1 ne veux rien dire alors que 1 x 1 donne bien 1, donc
pour transformer VRAI en 1 (ou FAUX en 0), tu peux utiliser la
fonction N

La formule permet de tester si plusieurs conditions sont réalisées.
Virtuellement, le résultat est le suivant (c'est un exemple) :
VRAI FAUX
FAUX VRAI
VRAI VRAI
VRAI FAUX
FAUX FAUX
VRAI VRAI

Il y a deux colonne parcequ'il y a deux conditions dans la formule (F1=
$A$1:$A$30 et $B$1:$B$30>MOYENNE($B$1:$B$30)
Par contre, VRAI multiplié par FAUX ne veut rien dire, alors que 1
multiplié par 0 signifie quelque chose
Ainsi, en utilisant la formule N, le resultat de la formule se
transforme en
1 0
0 1
1 1
1 0
0 0
1 1

Dans la formule, il y a une multiplication entre le deux conditions.
Ainsi si on avance dans la résolution de la formule, on obtient au
final :
0 (puisque 1 x 0 = 0)
0 (puisque 1 x 0 = 0)
1 (puisque 1 x 1 = 1)
0 (puisque 1 x 0 = 0)
0 (puisque 1 x 0 = 0)
1 (puisque 1 x 1 = 1)

Et le résultat final de la formule sera alors 2 (la somme de 0 + 0 + 1
+ 0 + 0 + 1)

Cordialement,

F.
FdeCourt
Le #20767731
Nop, ce n'est pas la même chose.

=T(1) ne renvoit pas VRAI !

alors que

=N(VRAI) renvoit bien 1

Cordialement,

F.
loamar67
Le #20767711
Merci de ton explication
Effectivement, avec sommeprod avec ";" il faut le N
Mais =SOMMEPROD(N($A18='2009'!$N$1:$N$366);N('2009'!$E$1:$E$366>MOYENNE
('2009'!$E$1:$E$366)))
et =SOMMEPROD(($A18='2009'!$N$1:$N$366)*('2009'!$E$1:$E$366>MOYENNE
('2009'!$E$1:$E$366)))
donne le même resultat
A +
On 14 déc, 17:33, FdeCourt
Salut,

Le N permet de rendre possible une opérationp arithmétique.
Excel te donne deux possibilités pour transformer un résultat boolean
en numérique:
- la fonction N
- Multiplier par 1

Parceque VRAI x 1 ne veux rien dire alors que 1 x 1 donne bien 1, donc
pour transformer VRAI en 1 (ou FAUX en 0), tu peux utiliser la
fonction N

La formule permet de tester si plusieurs conditions sont réalisées.
Virtuellement, le résultat est le suivant (c'est un exemple) :
VRAI   FAUX
FAUX  VRAI
VRAI   VRAI
VRAI   FAUX
FAUX  FAUX
VRAI   VRAI

Il y a deux colonne parcequ'il y a deux conditions dans la formule (F1=
$A$1:$A$30 et $B$1:$B$30>MOYENNE($B$1:$B$30)
Par contre, VRAI multiplié par FAUX ne veut rien dire, alors que 1
multiplié par 0 signifie quelque chose
Ainsi, en utilisant la formule N, le resultat de la formule se
transforme en
1   0
0   1
1   1
1   0
0   0
1   1

Dans la formule, il y a une multiplication entre le deux conditions.
Ainsi si on avance dans la résolution de la formule, on obtient au
final :
0 (puisque 1 x 0 = 0)
0 (puisque 1 x 0 = 0)
1 (puisque 1 x 1 = 1)
0 (puisque 1 x 0 = 0)
0 (puisque 1 x 0 = 0)
1 (puisque 1 x 1 = 1)

Et le résultat final de la formule sera alors 2 (la somme de 0 + 0 + 1
+ 0 + 0 + 1)

Cordialement,

F.


MANU
Le #20767801
Tres clair, merci, mais je n'ai tjrs pas pigé la fonction T

Manu

"FdeCourt"
Salut,

Le N permet de rendre possible une opérationp arithmétique.
Excel te donne deux possibilités pour transformer un résultat boolean
en numérique:
- la fonction N
- Multiplier par 1

Parceque VRAI x 1 ne veux rien dire alors que 1 x 1 donne bien 1, donc
pour transformer VRAI en 1 (ou FAUX en 0), tu peux utiliser la
fonction N

La formule permet de tester si plusieurs conditions sont réalisées.
Virtuellement, le résultat est le suivant (c'est un exemple) :
VRAI FAUX
FAUX VRAI
VRAI VRAI
VRAI FAUX
FAUX FAUX
VRAI VRAI

Il y a deux colonne parcequ'il y a deux conditions dans la formule (F1 $A$1:$A$30 et $B$1:$B$30>MOYENNE($B$1:$B$30)
Par contre, VRAI multiplié par FAUX ne veut rien dire, alors que 1
multiplié par 0 signifie quelque chose
Ainsi, en utilisant la formule N, le resultat de la formule se
transforme en
1 0
0 1
1 1
1 0
0 0
1 1

Dans la formule, il y a une multiplication entre le deux conditions.
Ainsi si on avance dans la résolution de la formule, on obtient au
final :
0 (puisque 1 x 0 = 0)
0 (puisque 1 x 0 = 0)
1 (puisque 1 x 1 = 1)
0 (puisque 1 x 0 = 0)
0 (puisque 1 x 0 = 0)
1 (puisque 1 x 1 = 1)

Et le résultat final de la formule sera alors 2 (la somme de 0 + 0 + 1
+ 0 + 0 + 1)

Cordialement,

F.
Publicité
Poster une réponse
Anonyme