Mupacs + Giac/Xcas

Le
Jellyroll
Bonsoir,

Je cherche à installer (avec Emacs sous GNU/linux Debian Sarge) Mupacs
(http://mupacs.sourceforge.net/) pour le faire fonctionner avec Xcas
(http://www-fourier.ujf-grenoble.fr/~parisse/giac_fr.html). Je n'arrive pas
à compiler Mupacs car je n'ai pas de licence Mupad. Comment puis-je faire ?

Si un spécialiste peut m'indiquer la méthode pas à pas (car je suis un grand
débutant) pour installer Mupacs, je le remercie par avance.

Jellyroll.
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier
Le #21780031
Jellyroll a écrit :
Bonsoir,

Je cherche à installer (avec Emacs sous GNU/linux Debian Sarge) Mupacs
(http://mupacs.sourceforge.net/) pour le faire fonctionner avec Xcas
(http://www-fourier.ujf-grenoble.fr/~parisse/giac_fr.html). Je n'arrive pas
à compiler Mupacs car je n'ai pas de licence Mupad. Comment puis-je faire ?



Il n'y a rien à compiler !
Ah, on mis un script d'installation automatique,
mais il suffit de changer les variables à la main.
Je n'ai plus le script toinstall de Nicolas
(c'est bien celui qui plante, non ?).
Il doit chercher mupad pour trouver l'executable,
et les fichiers d'infos. Il doit suffire de
commenter ces passages.

Bon, le script d'install de Nicolas est très
sioux si j'ai bonne mémoire, parce qu'il installe
cela sur toutes les architectures ---

Mais on a tout développé pour linux/emacs
donc, donc, tu es dans le bon cadran :-p

Presque toutes les variables sont
dans mupad.el, mais sinon, il suffit de lire
le script "configure".

Bon, j'essaie de rester à l'écoute sur cette
liste :-)
Amitiés,
Olivier

-----
Sinon, j'ai arrêté de développer ce script
lorque mupad est devenu partie de windows.
Et je n'ai pas donné mon copyrigth à la FSF
pour que ce script ne devienne pas partie
de la distribution standard d'emacs. Bref,
mupad => plonk. Mais si il s'agit de détourner
notre travail pour du libre, je suis partant :-p --
Jellyroll
Le #21780001
Olivier a écrit :

Jellyroll a écrit :
Bonsoir,

Je cherche à installer (avec Emacs sous GNU/linux Debian Sarge) Mupacs
(http://mupacs.sourceforge.net/) pour le faire fonctionner avec Xcas
(http://www-fourier.ujf-grenoble.fr/~parisse/giac_fr.html). Je n'arrive
pas à compiler Mupacs car je n'ai pas de licence Mupad. Comment puis-je
faire ?



Il n'y a rien à compiler !
Ah, on mis un script d'installation automatique,
mais il suffit de changer les variables à la main.
Je n'ai plus le script toinstall de Nicolas
(c'est bien celui qui plante, non ?).
Il doit chercher mupad pour trouver l'executable,
et les fichiers d'infos. Il doit suffire de
commenter ces passages.

Bon, le script d'install de Nicolas est très
sioux si j'ai bonne mémoire, parce qu'il installe
cela sur toutes les architectures ---

Mais on a tout développé pour linux/emacs
donc, donc, tu es dans le bon cadran :-p

Presque toutes les variables sont
dans mupad.el, mais sinon, il suffit de lire
le script "configure".

Bon, j'essaie de rester à l'écoute sur cette
liste :-)
Amitiés,
Olivier

-----
Sinon, j'ai arrêté de développer ce script
lorque mupad est devenu partie de windows.
Et je n'ai pas donné mon copyrigth à la FSF
pour que ce script ne devienne pas partie
de la distribution standard d'emacs. Bref,
mupad => plonk. Mais si il s'agit de détourner
notre travail pour du libre, je suis partant :-p --




Il n'y a pas de script "toinstall" mais dans le fichier "INSTALL" il est
indiqué de faire la séquence classique : configure -> make -> make install
(en "root" sans doute).

Dans le fichier "configure" que faut-il modifier ?

Merci pour l'aide.
Olivier
Le #21779991
Bon, c'est vraiment du hack :-p
Mais bon, voici :

-------------------------------------------------------------------
Il y a deux changements a faire pour utiliser
mupacs avec giac :

=============== 1er changement ========================
Editer le fichier mupad-run.el et remplacer
----------------------------------------------
(defcustom mupad-run-pgm "mupad"
"Command to run mupad"
:type 'string :group 'mupad-run)
----------------------------------------------
(defcustom mupad-run-pgm "giac"
"Command to run mupad"
:type 'string :group 'mupad-run)
----------------------------------------------

=============== 2nd changement ========================
Editer le fichier mupad-run.el et remplacer
----------------------------------------------
(defcustom mupad-run-pgm-opt
'("-E" "-U" "EMACS")
"Options given to the mupad process.
In fact other options can be given but one of these two blocks
should be present."
:type '(choice (const ("-R" "-U" "EMACS")) (const ("-E" "-U" "EMACS")))
:initialize 'custom-initialize-default
:set 'mupad-run-set-options
:group 'mupad-run)

------------------------------------------------
par
-----------------------------------------------
(defcustom mupad-run-pgm-opt
'("--emacs")
"Options given to the mupad process.
In fact other options can be given but one of these two blocks
should be present."
:type '(choice (const ("-R" "-U" "EMACS")) (const ("-E" "-U"
"EMACS")) (const "--emacs"))
:initialize 'custom-initialize-default
:set 'mupad-run-set-options
:group 'mupad-run)
-----------------------------------------------

================================================
Ensuite recompiler mupad-run.el ou eliminer le mupad-run.elc.
---------------------------------------------------------------------------

Bon, j'ai essayer, ça tourne un peu mais c'est moche :-(
En particulier, des qu'on lance MuPAD, c'est à dire giac,
il n'est pas très content du "TEXTWIDTHy:" qu'on envoie pour dire
à giac la largeur de l'écran, mais ce n'est pas grave.

Je demande à François (Maltey) si il n'a pas une meilleure version.
Et je reposte ici si oui (mais il est peut être en vacances --).
Amitiés,
Olivier
Olivier
Le #21779981
Olivier a écrit :
[...]
Je demande à François (Maltey) si il n'a pas une meilleure version.



Résultat des course : non, ya pas.
Si, si il y a une bonne raison, par exemple plus
de trois personnes qui utilisent xcas (mais j'ai
quand même l'impression que sage va prendre le pas),
je pourrais remettre la main à la pâte --
Mais comme je n'ai jamais utilisé giac, ça va
quand même prendre du temps --

Amitiés,
Olivier
Olivier
Le #21779971
Olivier a écrit :
[...]
Et vu la quantité de suivi, travailler sur
ce projet serait comme de pisser dans un violon --
Exit, donc :-) A.O.
Jellyroll
Le #21779961
Olivier a écrit :

Bon, c'est vraiment du hack :-p
Mais bon, voici :

-------------------------------------------------------------------
Il y a deux changements a faire pour utiliser
mupacs avec giac :

=============== 1er changement ======================== >
Editer le fichier mupad-run.el et remplacer
----------------------------------------------
(defcustom mupad-run-pgm "mupad"
"Command to run mupad"
:type 'string :group 'mupad-run)
----------------------------------------------
(defcustom mupad-run-pgm "giac"
"Command to run mupad"
:type 'string :group 'mupad-run)
----------------------------------------------

=============== 2nd changement ======================== >
Editer le fichier mupad-run.el et remplacer
----------------------------------------------
(defcustom mupad-run-pgm-opt
'("-E" "-U" "EMACS")
"Options given to the mupad process.
In fact other options can be given but one of these two blocks
should be present."
:type '(choice (const ("-R" "-U" "EMACS")) (const ("-E" "-U" "EMACS")))
:initialize 'custom-initialize-default
:set 'mupad-run-set-options
:group 'mupad-run)

------------------------------------------------
par
-----------------------------------------------
(defcustom mupad-run-pgm-opt
'("--emacs")
"Options given to the mupad process.
In fact other options can be given but one of these two blocks
should be present."
:type '(choice (const ("-R" "-U" "EMACS")) (const ("-E" "-U"
"EMACS")) (const "--emacs"))
:initialize 'custom-initialize-default
:set 'mupad-run-set-options
:group 'mupad-run)
-----------------------------------------------

================================================ >
Ensuite recompiler mupad-run.el ou eliminer le mupad-run.elc.



---------------------------------------------------------------------------

Bon, j'ai essayer, ça tourne un peu mais c'est moche :-(
En particulier, des qu'on lance MuPAD, c'est à dire giac,
il n'est pas très content du "TEXTWIDTHy:" qu'on envoie pour dire
à giac la largeur de l'écran, mais ce n'est pas grave.

Je demande à François (Maltey) si il n'a pas une meilleure version.
Et je reposte ici si oui (mais il est peut être en vacances --).
Amitiés,
Olivier



J'ai bien effectué le premier changement, mais concernant le deuxième, il
n'y a pas de ligne commençant par "(defcustom mupad-run-pgm-opt" dans le
fichier "mupacs-run.el".

Merci pour l'aide.

Jellyroll.
Olivier
Le #21779941
Désolé, je crois que Nicolas a changé cela de façon
un chouia hussardesque; Voilà comment cela est géré :
-----------------------------------------------------------------------
(defcustom mupad-run-commandline
"mupad -R -U EMACS=TRUE"
"The command-line for the mupad process.

One of the '-R' or '-E' options is mandatory. Both tell MuPAD to use
its raw communication protocol. The -E options allows for some extra
features (e.g. P in the debugger), but requires MuPAD >= 2.5.1.

The '-U EMACS=TRUE' option is not mandatory, but this is the standard
and recommended way for telling MuPAD programms (typically in the user
initialization file) that MuPAD is currently running under emacs."
:type '(choice (const "mupad -R -U EMACS=TRUE")
(const "mupad -E -U EMACS=TRUE")
(string :tag "Manual input"))
:initialize 'custom-initialize-default
:set 'mupad-run-set-options
:group 'mupad-run)
-----------------------------------------------------------------------

Oui, cela fait double emploi avec mupad-run-pgm, mais bon --
Du coup, tu changes "mupad -R -U EMACS=TRUE" en
"giac --emacs" et ça doit rouler.
Ou, sous emacs, customize cette variable, choisis
"Manual input" et mets "giac --emacs".

Ouf :-)
Amitiés,
Olivier
Jellyroll
Le #21779771
Olivier a écrit :
Désolé, je crois que Nicolas a changé cela de façon
un chouia hussardesque; Voilà comment cela est géré :
-----------------------------------------------------------------------
(defcustom mupad-run-commandline
"mupad -R -U EMACS=TRUE"
"The command-line for the mupad process.

One of the '-R' or '-E' options is mandatory. Both tell MuPAD to use
its raw communication protocol. The -E options allows for some extra
features (e.g. P in the debugger), but requires MuPAD >= 2.5.1.

The '-U EMACS=TRUE' option is not mandatory, but this is the standard
and recommended way for telling MuPAD programms (typically in the user
initialization file) that MuPAD is currently running under emacs."
:type '(choice (const "mupad -R -U EMACS=TRUE")
(const "mupad -E -U EMACS=TRUE")
(string :tag "Manual input"))
:initialize 'custom-initialize-default
:set 'mupad-run-set-options
:group 'mupad-run)
-----------------------------------------------------------------------

Oui, cela fait double emploi avec mupad-run-pgm, mais bon --
Du coup, tu changes "mupad -R -U EMACS=TRUE" en
"giac --emacs" et ça doit rouler.
Ou, sous emacs, customize cette variable, choisis
"Manual input" et mets "giac --emacs".

Ouf :-)
Amitiés,
Olivier



Les solutions que vous proposez ne fonctionnent pas chez moi (pourquoi ?
je ne sais pas) et j'abandonne provisoirement d'essayer d'utiliser
Mupacs avec giac/Xcas. Merci néanmoins pour les réponses que vous avez
données ici.

Jellyroll.
Guillaume Connan
Le #21779751
Le 17 février 2008 à 09:02, Olivier aurait pu téléphoner mais a préféré
m'écrire le doux billet suivant :

Si, si il y a une bonne raison, par exemple plus
de trois personnes qui utilisent xcas (mais j'ai
quand même l'impression que sage va prendre le pas),
je pourrais remettre la main à la pâte --
Mais comme je n'ai jamais utilisé giac, ça va
quand même prendre du temps --




Euh, là, faudrait pas exagérer ! Je n'ai pas visité le forum emacs
depuis un moment, mais ce genre de remarque me fait un peu bondir. Sage
est très intéressant, mais pour le secondaire et le premier cycle
universitaire, ce n'est pas encore très adapté, contrairement à
giac/xcas qui a plus de trois utilisateurs... Le microcosme CAS snobe
Bernard Parisse car il est en dehors du sérail, mais son outil est plus
que performant. Cependant, je ne crois pas que son utilisation sous
emacs soit fort utile, car on perd l'une des spécificités de xcas, à
savoir "la session" : on peut faire travailler ensemble géométrie,
calcul, programmation et tout est réévalué à chaque changement.


--
Guillaume CONNAN

http://gconnan.free.fr
Olivier
Le #21779651
Guillaume Connan a écrit :
[...]
Euh, là, faudrait pas exagérer ! Je n'ai pas visité le forum emacs
depuis un moment, mais ce genre de remarque me fait un peu bondir. Sage
est très intéressant, mais pour le secondaire et le premier cycle
universitaire, ce n'est pas encore très adapté, contrairement à
giac/xcas qui a plus de trois utilisateurs...



C'était le nombre de personnes qui avaient participé au fil :-p --
J'aurais du dire "xcas sous emacs", c'est vrai.

Le microcosme CAS snobe
Bernard Parisse car il est en dehors du sérail, mais son outil est plus
que performant. Cependant, je ne crois pas que son utilisation sous
emacs soit fort utile, [...]



Ben voilà :-)
Amitiés,
Olivier
Publicité
Poster une réponse
Anonyme