NB.SI avec deux conditions

Le
ishtar
Bonsoir,
pour un sondage je souhaiterais extraire des renseignements par catégorie:
la première homme ou femme et la deuxième par tranche d'âge. J'arrive à
extraire la catégorie d'âge et compter le nombre d'individus dans cette
tranche, mais lorsque j'essaie de mettre une deuxième condition pour extraire
uniquement les hommes ou femmes de cette tranche d'âge. je n'y arrive pas
on me réclame des parenthèse, on me dit que j'en ai trop.. et pourant
je m'applique :-) avez-vous une idée de la manière dont je dois procéder ?

=NB.SI(Sondage!G$2:G$1000;"plus de 15 ans");(Sondage!B$2:B$1000;"femme")

Ma question vous semblera simplette, mais je ne suis pas un pro et je
nage !!! Merci de votre aide
Ishtar
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LE TROLL
Le #16712261
Bonjour,

Pas certain de ma réponse, mais j'ai ça dans mon pense-bête :

=nb.si(et(condition1; condition2); true; false)

if c1 + c2 = true then ...

=NB.SI(et(Sondage!G$2:G$1000 = "plus de 15 ans"; Sondage!B$2:B$1000 =
"femme"); "ok"; "mauvais")

???

------
Romans, logiciels, email, site personnel
http://irolog.free.fr/joe.htm
------------------------------------------------------------------------------------




"ishtar"
| Bonsoir,
| pour un sondage je souhaiterais extraire des renseignements par catégorie:
| la première homme ou femme et la deuxième par tranche d'âge. J'arrive à
| extraire la catégorie d'âge et compter le nombre d'individus dans cette
| tranche, mais lorsque j'essaie de mettre une deuxième condition pour
extraire
| uniquement les hommes ou femmes de cette tranche d'âge.... je n'y arrive
pas
| on me réclame des parenthèse, on me dit que j'en ai trop........ et
pourant
| je m'applique :-) avez-vous une idée de la manière dont je dois procéder ?
|
| =NB.SI(Sondage!G$2:G$1000;"plus de 15 ans");(Sondage!B$2:B$1000;"femme")
|
| Ma question vous semblera simplette, mais je ne suis pas un pro... et je
| nage !!! Merci de votre aide
| Ishtar
Francois L
Le #16712451
ishtar a écrit :

Bonjour,

Il est temps pour toi de découvrir les joies de la fonction SOMMEPROD

Supposons que tu ais :
en A2:A29 le sexe sous la forme M ou F
en B2:B29 l'âge de chaque individu

la formule
=SOMMEPROD(($A2:$A$29="M")*($B$2:$B$29<16))
te donnera le nombre d'individus de sexe masculin de moins de 16 ans.

Attention, dans SOMMEPROD, les séries doivent être de même dimension et
ne peuvent pas être des colonnes entières. Pour mieux comprendre les
possibilités de SOMMEPROD, vas voir
http://www.excelabo.net/
et aussi
http://xlwiki.free.fr/wiki/wakka.php?wiki=PageAccueil

--
François L


Bonsoir,
pour un sondage je souhaiterais extraire des renseignements par catégorie:
la première homme ou femme et la deuxième par tranche d'âge. J'arrive à
extraire la catégorie d'âge et compter le nombre d'individus dans cette
tranche, mais lorsque j'essaie de mettre une deuxième condition pour extraire
uniquement les hommes ou femmes de cette tranche d'âge.... je n'y arrive pas
on me réclame des parenthèse, on me dit que j'en ai trop........ et pourant
je m'applique :-) avez-vous une idée de la manière dont je dois procéder ?

=NB.SI(Sondage!G$2:G$1000;"plus de 15 ans");(Sondage!B$2:B$1000;"femme")

Ma question vous semblera simplette, mais je ne suis pas un pro... et je
nage !!! Merci de votre aide
Ishtar


LSteph
Le #16712651
Bonjour,

=sommeprod((G2:g1000="plus de 15 ans")*(B$2:B$1000="femme"))

--
lSteph

ishtar a écrit :
Bonsoir,
pour un sondage je souhaiterais extraire des renseignements par catégorie:
la première homme ou femme et la deuxième par tranche d'âge. J'arrive à
extraire la catégorie d'âge et compter le nombre d'individus dans cette
tranche, mais lorsque j'essaie de mettre une deuxième condition pour extraire
uniquement les hommes ou femmes de cette tranche d'âge.... je n'y arrive pas
on me réclame des parenthèse, on me dit que j'en ai trop........ et pourant
je m'applique :-) avez-vous une idée de la manière dont je dois procéder ?

=NB.SI(Sondage!G$2:G$1000;"plus de 15 ans");(Sondage!B$2:B$1000;"femme")

Ma question vous semblera simplette, mais je ne suis pas un pro... et je
nage !!! Merci de votre aide
Ishtar


Jacquouille
Le #16714091
Stéphane,
On t'a déjà dit > !!!!!!
-))

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"LSteph"
Bonjour,

=sommeprod((G2:g1000="plus de 15 ans")*(B$2:B$1000="femme"))

--
lSteph

ishtar a écrit :
Bonsoir,
pour un sondage je souhaiterais extraire des renseignements par
catégorie: la première homme ou femme et la deuxième par tranche d'âge.
J'arrive à extraire la catégorie d'âge et compter le nombre d'individus
dans cette tranche, mais lorsque j'essaie de mettre une deuxième
condition pour extraire uniquement les hommes ou femmes de cette tranche
d'âge.... je n'y arrive pas on me réclame des parenthèse, on me dit que
j'en ai trop........ et pourant je m'applique :-) avez-vous une idée de
la manière dont je dois procéder ?

=NB.SI(Sondage!G$2:G$1000;"plus de 15 ans");(Sondage!B$2:B$1000;"femme")

Ma question vous semblera simplette, mais je ne suis pas un pro... et je
nage !!! Merci de votre aide Ishtar




ishtar
Le #16714051
Bonjour vous êtes géniaux.... ça marche.... promis je vais aller me
familiariser avec sommeprod :-)

Merci donc à Le Troll (pour la VBA.... je pense que je ne suis pas encore
apte à me lancer) Merci à LSteph et François L

Bonne journée à toutes et tous
--
ishtar


"LSteph" a écrit :

Bonjour,

=sommeprod((G2:g1000="plus de 15 ans")*(B$2:B$1000="femme"))

--
lSteph

ishtar a écrit :
> Bonsoir,
> pour un sondage je souhaiterais extraire des renseignements par catégorie:
> la première homme ou femme et la deuxième par tranche d'âge. J'arrive à
> extraire la catégorie d'âge et compter le nombre d'individus dans cette
> tranche, mais lorsque j'essaie de mettre une deuxième condition pour extraire
> uniquement les hommes ou femmes de cette tranche d'âge.... je n'y arrive pas
> on me réclame des parenthèse, on me dit que j'en ai trop........ et pourant
> je m'applique :-) avez-vous une idée de la manière dont je dois procéder ?
>
> =NB.SI(Sondage!G$2:G$1000;"plus de 15 ans");(Sondage!B$2:B$1000;"femme")
>
> Ma question vous semblera simplette, mais je ne suis pas un pro... et je
> nage !!! Merci de votre aide
> Ishtar



LSteph
Le #16720501
Mais non! plus de 15 ans que l'on sommeprod ...avec ou sans conditions

;-)

Jacquouille a écrit :
Stéphane,
On t'a déjà dit > !!!!!!
-))



s
Sam
Le #16722971
"LSteph" %
Mais non! plus de 15 ans que l'on sommeprod ...avec ou sans conditions

;-)




C'est une atteinte aux bonnes mours.
Monseigneur pardonnez lui car il ne sait pas ce qu'il fait !
;-)

Cordialement
Michel dit "Sam"
Publicité
Poster une réponse
Anonyme