Nb.si avec morceau de texte comme condition

Le
Pierre F.
Bonjour à toutes et à tous;

Dans la plage E3:E302, j'ai des cellules vides ou qui contiennent des
nombres entiers (de 1 à 5) seuls ou séparés par des ,

Exemple:

E4 --> 1, 2, 4
E12 --> 3, 5
E21 --> 2
E43 --> 1, 2, 4, 5
E102 --> 1, 4



Je souhaiterais en entrant par exemple 2 dans la cellule L1 qu'il
m'affiche le nombre de fois que 2 figure dans la plage, seul ou
accompagné (Dans l'exemple ci-dessus, --> 3)

Or si je fais NB.SI(E3:E302;2) en entrant 2 dans L1, il ne compte que
celles où "2" est seul et m'affiche donc 1.

Quelle est la bonne syntaxe ?

Merci.

Cordialement,
Pierre F.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4799901
Bonsoir,

=NB.SI(A1:G14;"*1*")+NB.SI(A1:G14;"1")
=NB.SI(A2:G15;"*"&K1&"*")+NB.SI(A2:G15;K1) si 1 en K1

http://cjoint.com/?iwuphX6Uor

JB

On 22 août, 19:40, "Pierre F."
Bonjour à toutes et à tous;

Dans la plage E3:E302, j'ai des cellules vides ou qui contiennent des
nombres entiers (de 1 à 5) seuls ou séparés par des ,

Exemple:

E4 --> 1, 2, 4
E12 --> 3, 5
E21 --> 2
E43 --> 1, 2, 4, 5
E102 --> 1, 4
...

Je souhaiterais en entrant par exemple 2 dans la cellule L1 qu'il
m'affiche le nombre de fois que 2 figure dans la plage, seul ou
accompagné (Dans l'exemple ci-dessus, --> 3)

Or si je fais NB.SI(E3:E302;2) en entrant 2 dans L1, il ne compte que
celles où "2" est seul et m'affiche donc 1.

Quelle est la bonne syntaxe ?

Merci.

Cordialement,
Pierre F.


Pierre F.
Le #4799881
Bonsoir,

=NB.SI(A1:G14;"*1*")+NB.SI(A1:G14;"1")
=NB.SI(A2:G15;"*"&K1&"*")+NB.SI(A2:G15;K1) si 1 en K1

http://cjoint.com/?iwuphX6Uor


C'était trop "simple" !!!!!
Y'a des fois où on sent un peu c..

Merci JB

Cordialement,
Pierre F.

Jacquouille
Le #4673341
Bonjour
Sans rien enlever à la qualité de la réponse de JB, voici une solution de
chez Brico.
Recopier la colonne avec les chiffres.
Ensuite, remplacer 2 par Z
Ensuite, NB.SI(plage;"*Z*")
Bonne chance

--
Bien amicalmement,
Vivement conseillés:
- Un plus gros marteau et un verre de vin d'Alsace....et tout ira mieux.

Jacquouille.

"Pierre F." c656e$46cc7e82$55da2ea5$
Bonsoir,

=NB.SI(A1:G14;"*1*")+NB.SI(A1:G14;"1")
=NB.SI(A2:G15;"*"&K1&"*")+NB.SI(A2:G15;K1) si 1 en K1

http://cjoint.com/?iwuphX6Uor


C'était trop "simple" !!!!!
Y'a des fois où on sent un peu c..

Merci JB

Cordialement,
Pierre F.



Pierre F.
Le #4673071
Sans rien enlever à la qualité de la réponse de JB, voici une solution de
chez Brico.
Recopier la colonne avec les chiffres.
Ensuite, remplacer 2 par Z
Ensuite, NB.SI(plage;"*Z*")
Bonjour,

Merci pour cette variante que je garde pour une autre occasion (les
colonnes proches sont occupées).

Cordialement,
Pierre F.

Publicité
Poster une réponse
Anonyme