nbsi

Le
marc
Bonjour à vous tous
Voici mon problème
Dans la colonne A, j'ai des âges et dans la colonne B, le titre. J'aimerais
avoir dans la cellule E2, le nombre de personnes qui répondent au critères
suivant.
age doit être <i
titre doit être C1

Je cherche une formule, pas une macro en vba, svp.

Voici un fichier pour vous aider à mieux comprendre.
http://cjoint.com/?dvojcP5urc

merci de votre aide
Marc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #5223721
Bonsour® marc avec ferveur ;o))) vous nous disiez :

Dans la colonne A, j'ai des âges et dans la colonne B, le titre.
J'aimerais avoir dans la cellule E2, le nombre de personnes qui
répondent au critères suivant.
age doit être <i
titre doit être C1

Je cherche une formule, pas une macro en vba, svp.


=SOMMEPROD(($A$2:$A$82<i)*($B$2:$B$82Á))

--
--
@+
;o)))

eneric
Le #5332551
eneric vous demande
soit =NB.SI($A$2:$A$82;"<i")
soit Ò&NB.SI($A$2:$A$82;"<i") (D2 'le nombre est:)

--
eneric
Ellimac
Le #5332531
Bonjour,

=SOMMEPROD((A2:A12<i)*(B2:B12=$C$1))

Camille

"marc" %
Bonjour à vous tous
Voici mon problème
Dans la colonne A, j'ai des âges et dans la colonne B, le titre.
J'aimerais avoir dans la cellule E2, le nombre de personnes qui répondent
au critères suivant.
age doit être <i
titre doit être C1

Je cherche une formule, pas une macro en vba, svp.

Voici un fichier pour vous aider à mieux comprendre.
http://cjoint.com/?dvojcP5urc

merci de votre aide
Marc





LE TROLL
Le #5332521
Bonjour

List1.visibleúlse
List1.clear

for i = 2 to 82
if A(i) < 69 and B(i) = "C' then list1.additem
A(i) & B(i)
next i

Tu effaces toutes tes celluls (A2 : B82)
Tu balances la liste1 dedans les cellules

For i = 0 to list1.mistcount-1
celluleA(i+2) = mid(List1.list(i+2), 1, 2)
celluleB(i+2) = mid(List1.list(i+2), 3, 2)
next i

NB: je ne onnais pas le vbA.
Tu dois savoir comment on range, extrait, efface
les cellules je présume :o)

Sinon, tu peux aussi faire ça en boucle, avec un
tri bulle, mais c'est plus compliqué...

--
Merci beaucoup, au revoir et à bientôt :o)
------
Romans, logiciels, email, site personnel
http://irolog.free.fr/joe.htm
------------------------------------------------------------------------------------
"marc" news: %
| Bonjour à vous tous
| Voici mon problème
| Dans la colonne A, j'ai des âges et dans la
colonne B, le titre. J'aimerais
| avoir dans la cellule E2, le nombre de personnes
qui répondent au critères
| suivant.
| age doit être <i
| titre doit être C1
|
| Je cherche une formule, pas une macro en vba,
svp.
|
| Voici un fichier pour vous aider à mieux
comprendre.
| http://cjoint.com/?dvojcP5urc
|
| merci de votre aide
| Marc
|
|
marc
Le #5332511
Bonjour à vous trois
Merci énormément de votre aide.
Par curiosité,si j'avais voulu utiliser la fonction nb.si, avec les deux
critères, comment aurais-je pu écrire cette fonction.
Merci encore pour votre réponse
Marc

"Ellimac"
Bonjour,

=SOMMEPROD((A2:A12<i)*(B2:B12=$C$1))

Camille

"marc" %
Bonjour à vous tous
Voici mon problème
Dans la colonne A, j'ai des âges et dans la colonne B, le titre.
J'aimerais avoir dans la cellule E2, le nombre de personnes qui répondent
au critères suivant.
age doit être <i
titre doit être C1

Je cherche une formule, pas une macro en vba, svp.

Voici un fichier pour vous aider à mieux comprendre.
http://cjoint.com/?dvojcP5urc

merci de votre aide
Marc









Ellimac
Le #5332501
Pas possible avec Nb.si

Camille

"marc"
Bonjour à vous trois
Merci énormément de votre aide.
Par curiosité,si j'avais voulu utiliser la fonction nb.si, avec les deux
critères, comment aurais-je pu écrire cette fonction.
Merci encore pour votre réponse
Marc

"Ellimac"
Bonjour,

=SOMMEPROD((A2:A12<i)*(B2:B12=$C$1))

Camille

"marc" %
Bonjour à vous tous
Voici mon problème
Dans la colonne A, j'ai des âges et dans la colonne B, le titre.
J'aimerais avoir dans la cellule E2, le nombre de personnes qui
répondent au critères suivant.
age doit être <i
titre doit être C1

Je cherche une formule, pas une macro en vba, svp.

Voici un fichier pour vous aider à mieux comprendre.
http://cjoint.com/?dvojcP5urc

merci de votre aide
Marc














Modeste
Le #5332491
Bonsour® marc avec ferveur ;o))) vous nous disiez :

Par curiosité,si j'avais voulu utiliser la fonction nb.si, avec les
deux critères, comment aurais-je pu écrire cette fonction.


;-((
NB.SI n'admet qu'un seul critère !!!

contournement possible en créant en colonne C
=1*(B2=$C$1)
etendre vers le bas autant que nécessaire
la formule à utiliser( sera alors :
=SOMME.SI(A2:A82;"<i";C2:C82)



--
--
@+
;o)))

Modeste
Le #5332481
Bonsour® LE TROLL avec ferveur ;o))) vous nous disiez :

List1.visibleúlse
List1.clear
for i = 2 to 82
if A(i) < 69 and B(i) = "C' then list1.additem
A(i) & B(i)
next i
Tu effaces toutes tes celluls (A2 : B82)
Tu balances la liste1 dedans les cellules
For i = 0 to list1.mistcount-1
celluleA(i+2) = mid(List1.list(i+2), 1, 2)
celluleB(i+2) = mid(List1.list(i+2), 3, 2)
next i
NB: je ne onnais pas le vbA.
Tu dois savoir comment on range, extrait, efface
les cellules je présume :o)
Sinon, tu peux aussi faire ça en boucle, avec un
tri bulle, mais c'est plus compliqué...


cela frise le calcul astronomique ;o)))

--
--
@+
;o)))

marc
Le #5332391
Bonjour
Voici une formule que j'ai trouvé dans un autre document.
C'est une formule matricielle qui utilse la fonction NB.SI
Par contre, si vous prenez le même document que j'ai envoyé, en utilisant la
fonction suivante
{=NB.SI(A2:A82;"C1")*(B2:B82<i)}
j'arrive à un résultat de 18. Quand je fais un filtre, la réponse est 15.
Est-ce que quelqu'un peut m'aider, svp.
Merci encore de votre aide
Marc

"Modeste"
Bonsour® marc avec ferveur ;o))) vous nous disiez :

Par curiosité,si j'avais voulu utiliser la fonction nb.si, avec les
deux critères, comment aurais-je pu écrire cette fonction.


;-((
NB.SI n'admet qu'un seul critère !!!

contournement possible en créant en colonne C
=1*(B2=$C$1)
etendre vers le bas autant que nécessaire
la formule à utiliser( sera alors :
=SOMME.SI(A2:A82;"<i";C2:C82)



--
--
@+
;o)))





isabelle
Le #5332381
bonjour Marc,

d'après le classeur que tu as mit en ligne
la formule est : {=NB.SI(B2:B82;"C1")*(A2:A82<i)}
qui donne 18
et le filtre donne aussi 18

isabelle

Bonjour
Voici une formule que j'ai trouvé dans un autre document.
C'est une formule matricielle qui utilse la fonction NB.SI
Par contre, si vous prenez le même document que j'ai envoyé, en utilisant la
fonction suivante
{=NB.SI(A2:A82;"C1")*(B2:B82<i)}
j'arrive à un résultat de 18. Quand je fais un filtre, la réponse est 15.
Est-ce que quelqu'un peut m'aider, svp.
Merci encore de votre aide
Marc

"Modeste"
Bonsour® marc avec ferveur ;o))) vous nous disiez :

Par curiosité,si j'avais voulu utiliser la fonction nb.si, avec les
deux critères, comment aurais-je pu écrire cette fonction.
;-((

NB.SI n'admet qu'un seul critère !!!

contournement possible en créant en colonne C
=1*(B2=$C$1)
etendre vers le bas autant que nécessaire
la formule à utiliser( sera alors :
=SOMME.SI(A2:A82;"<i";C2:C82)



--
--
@+
;o)))









Publicité
Poster une réponse
Anonyme