nbval et sommeprod

Le
J
Bonjour à tous

Avec sommeprod je somme des montants en colonne D quand une certaine
date apparait dans le texte en colonne B

=SOMMEPROD((DROITE(B2:B200;4)=TEXTE(H2;"aaaa"))*D2:D200)

Cela fonctionne bien.
Mais, svp, comment pourrais-je obtenir le nbre de valeurs qui ont été
additionnées?

=nbval((DROITE(B2:B200;4)=TEXTE(H2;"aaaa")))
si je fais égale, j'ai 1
si je fais ctrl maj enter j'ai 199
tout est faux.

Merci pour l'aide
@+
J@@
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Charabeuh
Le #17805771
Bonjour,

Sur la même base que le sommeprod:
=SOMMEPROD(--(DROITE(B2:B200;4)=TEXTE(H2;"aaaa")))
devrait le faire.

Au Revoir



"J@@"
Bonjour à tous

Avec sommeprod je somme des montants en colonne D quand une certaine date apparait dans le texte en colonne B

=SOMMEPROD((DROITE(B2:B200;4)=TEXTE(H2;"aaaa"))*D2:D200)

Cela fonctionne bien.
Mais, svp, comment pourrais-je obtenir le nbre de valeurs qui ont été additionnées?

=nbval((DROITE(B2:B200;4)=TEXTE(H2;"aaaa")))
si je fais égale, j'ai 1
si je fais ctrl maj enter j'ai 199
tout est faux.

Merci pour l'aide
@+
J@@


J
Le #17805931
Bonjour Charabeuh
et merci
excellent
:-)
@+
J@@

Charabeuh a écrit :
Bonjour,

Sur la même base que le sommeprod:
=SOMMEPROD(--(DROITE(B2:B200;4)=TEXTE(H2;"aaaa")))
devrait le faire.

Au Revoir



"J@@" news:%
Bonjour à tous

Avec sommeprod je somme des montants en colonne D quand une certaine
date apparait dans le texte en colonne B

=SOMMEPROD((DROITE(B2:B200;4)=TEXTE(H2;"aaaa"))*D2:D200)

Cela fonctionne bien.
Mais, svp, comment pourrais-je obtenir le nbre de valeurs qui ont été
additionnées?

=nbval((DROITE(B2:B200;4)=TEXTE(H2;"aaaa")))
si je fais égale, j'ai 1
si je fais ctrl maj enter j'ai 199
tout est faux.

Merci pour l'aide
@+
J@@





Publicité
Poster une réponse
Anonyme