Nombre d'occurence différentes

Le
Jol
Bonjour,

Sous Excel 2010 existe-t-il une fonction ou méthode équivalente à NB.DIFF de
Morefun ?
Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #23321951
Bonjour,

Différentes formules pour diverses situations :

Compter le nombre de données différentes
Pour compter le nombre de données différentes dans la plage A1:A10,
=SOMMEPROD(1/NB.SI(A1:A10;A1:A10))

Un autre exemple par formule matricielle (à valider en appuyant
simultanément sur les touches Ctrl + Maj + Entrée).
=SOMME(SI(FREQUENCE(EQUIV(A1:A10;A1:A10;0);EQUIV(A1:A10;A1:A10;0))>0;1))

Une autres solution, dans le cas où il y aurait des cellules vides
dans la plage (A valider par Ctrl + Maj + Entrée):
=SOMMEPROD(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))

Les fonctions suivantes comptent le nombre de valeurs numériques
différentes dans la plage A1:A10.
Remarque: La plage A1:A10 peut contenir du texte et des cellules vides.
=SOMME(SI(FREQUENCE(A1:A10;A1:A10)>0;1))
=SOMME(N(FREQUENCE(A1:A10;A1:A10)>0))

Une autre possibilité par formule matricielle (à valider en
appuyant simultanément sur les touches Ctrl + Maj + Entrée).
=SOMME(SI(ESTNUM(A1:A10);1/NB.SI(A1:A10;A1:A10)))

Un autre exemple qui ne prend pas en compte les 0
(Formule matricielle à valider par Ctrl + Maj + Entrée).
=SOMME(SI(A1:A10>0;1/NB.SI(A1:A10;A1:A10)))


MichD
--------------------------------------------
Jol
Le #23328181
Merci MichD, c'est encore une fois perfect !

"MichD" news:iph1jl$mik$
Bonjour,

Différentes formules pour diverses situations :

Compter le nombre de données différentes
Pour compter le nombre de données différentes dans la plage A1:A10,
=SOMMEPROD(1/NB.SI(A1:A10;A1:A10))

Un autre exemple par formule matricielle (à valider en appuyant
simultanément sur les touches Ctrl + Maj + Entrée).
=SOMME(SI(FREQUENCE(EQUIV(A1:A10;A1:A10;0);EQUIV(A1:A10;A1:A10;0))>0;1))

Une autres solution, dans le cas où il y aurait des cellules vides
dans la plage (A valider par Ctrl + Maj + Entrée):
=SOMMEPROD(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))

Les fonctions suivantes comptent le nombre de valeurs numériques
différentes dans la plage A1:A10.
Remarque: La plage A1:A10 peut contenir du texte et des cellules vides.
=SOMME(SI(FREQUENCE(A1:A10;A1:A10)>0;1))
=SOMME(N(FREQUENCE(A1:A10;A1:A10)>0))

Une autre possibilité par formule matricielle (à valider en
appuyant simultanément sur les touches Ctrl + Maj + Entrée).
=SOMME(SI(ESTNUM(A1:A10);1/NB.SI(A1:A10;A1:A10)))

Un autre exemple qui ne prend pas en compte les 0
(Formule matricielle à valider par Ctrl + Maj + Entrée).
=SOMME(SI(A1:A10>0;1/NB.SI(A1:A10;A1:A10)))


MichD
--------------------------------------------

Publicité
Poster une réponse
Anonyme