Nombre de valeurs différentes dans une liste

Le
R1
Bonjour,

J'ai une plage de données avec des valeurs qui parfois sont en doublon (ou
plus).
J'aimerais déterminer le nombre de valeurs différentes de cette plage.
Quelle est la fonction adéquate?

R1
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
AH60
Le #4330601
Bonsoir

Format mise en forme conditionnelle
La formule est :
=NB.SI($A:$A;A1)=0
Puis choisir une mise en forme de police ou autre pour mettre en évidence.

Abed_H





Bonjour,

J'ai une plage de données avec des valeurs qui parfois sont en doublon (ou
plus).
J'aimerais déterminer le nombre de valeurs différentes de cette plage.
Quelle est la fonction adéquate?

R1



Jacky
Le #4330591
Bonsoir,
J'aimerais déterminer le nombre de valeurs différentes de cette plage.


=SOMME(SI(NBCAR(plage);1/NB.SI(plage;plage)))

Matricielle: valider par Ctrl+majuscule+entrée
--
Salutations
JJ


"R1"
Bonjour,

J'ai une plage de données avec des valeurs qui parfois sont en doublon (ou
plus).
J'aimerais déterminer le nombre de valeurs différentes de cette plage.
Quelle est la fonction adéquate?

R1


R1
Le #4328711
AH60 wrote:

Bonsoir

Format mise en forme conditionnelle
La formule est :
=NB.SI($A:$A;A1)=0
Puis choisir une mise en forme de police ou autre pour mettre en
évidence.

Abed_H

Je ne vois pas en quoi la mise en forme conditionnelle m'aidera pour

connaître (j'ai pas précisé: dans une autre cellule) le nombre de valeurs
sans doublon. Visuellement, ça aide, OK

R1


Bonjour,

J'ai une plage de données avec des valeurs qui parfois sont en doublon
(ou plus).
J'aimerais déterminer le nombre de valeurs différentes de cette plage.
Quelle est la fonction adéquate?

R1





R1
Le #4328701
Jacky wrote:

Bonsoir,
J'aimerais déterminer le nombre de valeurs différentes de cette plage.


=SOMME(SI(NBCAR(plage);1/NB.SI(plage;plage)))

Matricielle: valider par Ctrl+majuscule+entrée


Je teste demain et vous tiens au courant.
Merci
R1


R1
Le #4245531
R1 wrote:

Jacky wrote:

Bonsoir,
J'aimerais déterminer le nombre de valeurs différentes de cette plage.


=SOMME(SI(NBCAR(plage);1/NB.SI(plage;plage)))

Matricielle: valider par Ctrl+majuscule+entrée


Je teste demain et vous tiens au courant.
Merci
R1


Ca ne fonctionne pas: j'obtiens des valeurs 0,33 (ce n'est pas étonnant avec
le 1/x).
Quel est le rôle du NBCAR?
R1



Jacky
Le #4245461
Re...

Ca ne fonctionne pas
Ha bon!!!!! Etonnant


Voir ici
http://cjoint.com/?dqttuz5IvO

Quel est le rôle du NBCAR?
Voir s'il y a des cellules vides


--
Salutations
JJ


"R1" eX6LZN$
R1 wrote:

Jacky wrote:

Bonsoir,
J'aimerais déterminer le nombre de valeurs différentes de cette plage.


=SOMME(SI(NBCAR(plage);1/NB.SI(plage;plage)))

Matricielle: valider par Ctrl+majuscule+entrée


Je teste demain et vous tiens au courant.
Merci
R1


Ca ne fonctionne pas: j'obtiens des valeurs 0,33 (ce n'est pas étonnant
avec
le 1/x).
Quel est le rôle du NBCAR?
R1





R1
Le #4325181
Jacky wrote:

Re...

Ca ne fonctionne pas
Ha bon!!!!! Etonnant


Voir ici
http://cjoint.com/?dqttuz5IvO

Quel est le rôle du NBCAR?
Voir s'il y a des cellules vides


Ca y est, j'ai réussi

En fait mon problème était plus compliqué que dans l'exemple puisque la
plage concernée varie à chaque ligne et est située sur une autre feuille:
Feuille 1:
Colonne A: Une série de dates, avec les doublons, classées par ordre
chronologique (et dans tous les cas, en plus, le 1er du mois)
Colonne E: Le 1er du mois correspondant à la date en A

Feuille 2:
Colonne A: la liste des 1er du mois, par ordre chonologique
Colonne B: L'indice de la première ligne du mois dans le feuille 1
=EQUIV(MOIS.DECALER($A2;0);Feuille1.$A$2:$A$1001;0)+2
Colonne C: L'indice de la dernière ligne du mois dans le feuille 2
=EQUIV(MOIS.DECALER($A2;1);Feuille1.$A$2:$A$1001;0)
Comme certains mois n'ont que le premier (pas de date dans le mois) il
arrive que C<B...
Colonne D: Nombre de dates du mois présent en A
Ligne 2: =SI(C2>B2;SOMME(1/NB.SI(INDIRECT(CONCATENER("$Feuille1.$A$";B2;"
$A$";C2));INDIRECT(CONCATENER("$Feuille1.$A$";B2;":$A$";C2))));0) en
matriciel
Puis recopie par Copier/coller manuel de la première ligne sur les autres
(la recopie incrémentale ne modifie pas l'indice de ligne des B2 et C2)

Merci pour votre aide

R1


Publicité
Poster une réponse
Anonyme