nouveau user : problèma avec clavier français

Le
Bernard
Bonjour,

Heureuse année à toutes et à tous !

Etant sous Debian Lenny depuis septembre, utilisateur de Gnome depuis
cette époque (auparavant Sarge et fvwm), c'est la première fois que
j'ouvre un "new user account" sous cet environnement. Auparavant, je
faisais cela sous la console mais avec mon Gnome, je ne sais même
plus comment aller sur la console

Donc, j'ai voulu faire usage des fonctionalités de Gnome pour ouvrir un
compte supplémentaire. Tout s'est bien déroulé, à ceci près que, dans le
nouveau bureau, mon clavier ne gère pas les caractères accentués. Une
pression sur le caractère "é" par exemple, ne génère rien du tout dans
un terminal ni dans la fenêtre de n'importe quelle application.
Apparemment, les options trouvées dans les terminaux (définir le codage
des caractères) sont identiques à celles de mon bureau sous l'user
habituel (locale = UTF8 etc). Quant à définir le clavier
(Système/préférences/clavier/agencement), je trouve, dans mon bureau par
défaut: Modèle de clavier : IBM RAPID ACCESS, Agencement : France. Dans
le bureau de mon nouvel user account, c'est "clavier générique". Si
j'essaye de changer, j'obtiens un message d'erreur. En un mot, pas moyen
d'avoir les accents dans ce nouvel account.

Et si, au boot, j'entre directement dans ce nouveau compte, j'obtiens
d'emblée une erreur clavier, la même que celle qui s'affiche lorsque
j'essaye de changer l'agencement :

"Error activating XKB configuration. It can happen in various
circumstances :

- a bug in libxklavier library
- a bug in X server (ckbcomp
X server version data - xmod map utilities
The X.Org foundation
10402000

in bug report, include result of :"

voici les tests effectués et leurs résultats :

~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc102", "fr", "fr", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc102", "fr", "fr", ""
~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
layouts = []
model = rapidaccess
overrideSettings = true
options = []


Merci d'avance pour votre aide.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Frédéric Boiteux
Le #20901511
Le Tue, 05 Jan 2010 11:51:41 +0100,
Bernard
Bonjour,

Heureuse année à toutes et à tous !

Etant sous Debian Lenny depuis septembre, utilisateur de Gnome depuis
cette époque (auparavant Sarge et fvwm), c'est la première fois que
j'ouvre un "new user account" sous cet environnement. Auparavant, je
faisais cela sous la console... mais avec mon Gnome, je ne sais même
plus comment aller sur la console...

…

voici les tests effectués et leurs résultats :

~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc102", "fr", "fr", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc102", "fr", "fr", ""
~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
layouts = []
model = rapidaccess
overrideSettings = true
options = []



Salut,

Je ne sais pas où se situe ton problème, mais tu peux toujours
essayer d'ouvrir une console depuis la session de ton nouvel
utilisateur (dans le menu Application->Accessoires) et :

— regarder ta config clavier actuelle :

$ setxkbmap -print

Chez moi, cela donne :

xkb_keymap {
xkb_keycodes { include "xfree86+aliases(azerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete+ledscroll(group_lock)" };
xkb_symbols { include "pc+fr(bepo)+inet(tm2030USB)+fr(oss):2+us:3+group( shifts_toggle)" };
xkb_geometry { include "typematrix(tm2030USB)" };
};


– tenter de forcer une config française :

$ setxkbmap fr oss


Fred.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Bernard
Le #20902311
Frédéric Boiteux wrote:
Le Tue, 05 Jan 2010 11:51:41 +0100,
Bernard

Bonjour,

Heureuse année à toutes et à tous !

Etant sous Debian Lenny depuis septembre, utilisateur de Gnome depuis
cette époque (auparavant Sarge et fvwm), c'est la première fois que
j'ouvre un "new user account" sous cet environnement. Auparavant, je
faisais cela sous la console... mais avec mon Gnome, je ne sais même
plus comment aller sur la console...



voici les tests effectués et leurs résultats :

~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc102", "fr", "fr", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc102", "fr", "fr", ""
~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
layouts = []
model = rapidaccess
overrideSettings = true
options = []




Salut,

Je ne sais pas où se situe ton problème, mais tu peux toujours
essayer d'ouvrir une console depuis la session de ton nouvel
utilisateur (dans le menu Application->Accessoires)


Je n'ai aucun problème pour ouvrir un terminal X. Lorsque je parlais de
ne plus savoir comment ouvrir une "console", il s'agissait en réalité de
quitter l'environnement X pour aller sur... la console (sans
environnement graphique). Sous fvwm, il y avait une fonction permettant
de le faire, et, de toutes façons, on pouvait toujours faire
CTRL-ALT-BACKSTEP. Sous Gnome, tout au moins dans ma config, l'appel à
CTRL-ALT-BACKSTEP ou toute autre stratégie pour quitter l'environnement
graphique de Gnome, n'aboutit qu'à une proposition de se reconnecter à
gnome sous un autre login. Il y a quelques semaines j'avais trouvé une
astuce, il suffisait, pour retourner sur la console, de faire - si je me
souviens bien - CTRL-ALT-F6 ou quelque chose du genre... mais cela ne
fonctionne plus depuis la dernière mise à jour du système.


et :

— regarder ta config clavier actuelle :




ce que je viens de faire dans un terminal X
$ setxkbmap -print

Chez moi, cela donne :

xkb_keymap {
xkb_keycodes { include "xfree86+aliases(azerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete+ledscroll(group_lock)" };
xkb_symbols { include "pc+fr(bepo)+inet(tm2030USB)+fr(oss):2+us:3+group(shifts_toggle)" };
xkb_geometry { include "typematrix(tm2030USB)" };
};


– tenter de forcer une config française :

$ setxkbmap fr oss


Fred.




Chez moi, çà donne ceci :

dans mon nouveau user :

~$ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "xfree86+aliases(azerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+fr(fr)" };
xkb_geometry { include "pc(pc102)" };
};
~$ set xkbmap fr oss
~$ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "xfree86+aliases(azerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+fr(fr)" };
xkb_geometry { include "pc(pc102)" };
};

On voit que l'appel à "setxkbmap fr oss" n'a rien changé.

Avec mon user account habituel :

~$ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "xfree86+aliases(azerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include
"pc+fr+inet(rapidaccess)+level3(ralt_switch_for_alts_toggle)+group(alts_toggle)"
};
xkb_geometry { include "pc(pc104)" };
};

ce n'est pas tout à fait la même chose que chez toi, mais çà fonctionne.

Une précision : dans l'environnement de mon nouveau user, là où les
caractères accentués ne fonctionnent pas, la disposition du clavier
reste malgré tout en "azerty".

Je vais tenter de détruire mon nouveau user, puis de trouver un moyen
d'aller sur la console et de re-créer un nouvel user depuis la console
avec "adduser". Je te tiendrai au courant. Mais si toi ou quelqu'un
d'autre a une meilleure idée, je suis preneur.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
giggzounet
Le #20902301
[snip]

Je ne sais pas où se situe ton problème, mais tu peux toujours
essayer d'ouvrir une console depuis la session de ton nouvel
utilisateur (dans le menu Application->Accessoires)


Je n'ai aucun problème pour ouvrir un terminal X. Lorsque je parlais de
ne plus savoir comment ouvrir une "console", il s'agissait en réalité de
quitter l'environnement X pour aller sur... la console (sans
environnement graphique). Sous fvwm, il y avait une fonction permettant
de le faire, et, de toutes façons, on pouvait toujours faire
CTRL-ALT-BACKSTEP. Sous Gnome, tout au moins dans ma config, l'appel à
CTRL-ALT-BACKSTEP ou toute autre stratégie pour quitter l'environnement
graphique de Gnome, n'aboutit qu'à une proposition de se reconnecter à
gnome sous un autre login. Il y a quelques semaines j'avais trouvé une
astuce, il suffisait, pour retourner sur la console, de faire - si je me
souviens bien - CTRL-ALT-F6 ou quelque chose du genre... mais cela ne
fonctionne plus depuis la dernière mise à jour du système.





CTRL ALT F1 appuyé longtemps ne marche pas ??? ensuite alt F7 pour
revenir en graphique.

Bye

[snip]

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Denis Barbier
Le #20902421
Le 5 janvier 2010 15:46, Bernard [...]
~$ setxkbmap -print
xkb_keymap {
      xkb_keycodes  { include "xfree86+aliases(azerty )"       };
      xkb_types     { include "complete"      };
      xkb_compat    { include "complete"      };
      xkb_symbols   { include "pc+fr(fr)"      };
      xkb_geometry  { include "pc(pc102)"      };
};
~$ set xkbmap fr oss


[...]

Bonjour,

Supprime l'espace entre set et xkbmap.

Denis

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Bernard
Le #20902751
giggzounet wrote:
[snip]


Je ne sais pas où se situe ton problème, mais tu peux toujours
essayer d'ouvrir une console depuis la session de ton nouvel
utilisateur (dans le menu Application->Accessoires)



Je n'ai aucun problème pour ouvrir un terminal X. Lorsque je parlais de
ne plus savoir comment ouvrir une "console", il s'agissait en réalité de
quitter l'environnement X pour aller sur... la console (sans
environnement graphique). Sous fvwm, il y avait une fonction permettant
de le faire, et, de toutes façons, on pouvait toujours faire
CTRL-ALT-BACKSTEP. Sous Gnome, tout au moins dans ma config, l'appel à
CTRL-ALT-BACKSTEP ou toute autre stratégie pour quitter l'environnement
graphique de Gnome, n'aboutit qu'à une proposition de se reconnecter à
gnome sous un autre login. Il y a quelques semaines j'avais trouvé une
astuce, il suffisait, pour retourner sur la console, de faire - si je me
souviens bien - CTRL-ALT-F6 ou quelque chose du genre... mais cela ne
fonctionne plus depuis la dernière mise à jour du système.






CTRL ALT F1 appuyé longtemps ne marche pas ??? ensuite alt F7 pour
revenir en graphique.




NON ! Cà marchait ; çà ne marche plus... depuis que j'ai laissé faire
une des mises à jour proposées à chaque boot. Je reviens tout juste
d'aller voir ce qu'on trouvait là dessus sur Google : apparemment dans
les nouvelles versions linuxiennes, il est devenu très difficile d'aller
sur la console. Plusieurs personnes ont posé des questions. Il paraît
que depuis "Ubuntu Jaunty Jackalope", la possibilité de quitter
l'environnement graphique et d'aller sur la console en faisant
CTRL-ALT-F1 a été désactivée ; fortes sont les chances pour qu'il en
soit de même sous Debian Lenny. Aux questions posées par les
utilisateurs lambda, ceux qui ont répondu paraissent avoir botté en
touche : ils n'ont fourni aucune méthode pour aller sur la console, à la
place ils ont donné des astuces pour éviter d'avoir à le faire, selon la
raison donnée pour souhaiter utiliser cet environnement. Peut-être
est-il possible de trouver d'autres réponses, mais je n'en n'ai pas
encore trouvées.

J'en sais trop pour me résigner à ne jamais plus faire usage de la
console, mais je n'en sais pas assez pour trouver facilement un moyen
d'y aller. Au bon vieux temps de lilo, j'aurais, dans lilo.conf, mis une
boot option pour arrêter au niveau 5 (sans l'environnement
graphique)... mais, de toutes façons, de ce temps là il suffisait de
faire CTRL-ALT-BACKSTEP. Aujourd'hui je ne vois rien d'évident dans
/boot/grub/menu.lst qui permette de limiter le boot au stade 5. Il y a
bien les noyaux 'one user', mais ce sont des recovery modes, et tout
n'est pas actif.

Je n'aime pas du tout cette désactivation autoritaire de CTRL-ALT-F1 et
l'obligation de rester en environnement graphique. Et ces mises à jour
quasiment autoritaires ne me disent rien qui vaille non plus. Autrefois,
je conservais un système environ 3 ou 4 ans sans update, sauf update
ponctuelle d'une application particulière en cas de nécessité, l'update
générale se faisant lorsque je changeais de système, ce qui,
généralement, coïncidait avec l'achat d'un nouveau PC. Ainsi donc,
depuis mon installation de Lenny en septembre 2009, j'ai fait une et une
seule mise à jour... et le résultat a été en accord avec mes
appréhensions : impossible de re-booter !!! J'ai passé une journée
entière à pouvoir relancer mon système après un boot en recovery mode
avec "system rescue CD", ce qui m'a permis de voir que le programme
d'update avait modifié mon /boot/grub/menu.lst et mis en première ligne
un noyau ancien incompatible avec l'initramfs etc... Quel foutoir il y
avait dans "menu.lst" ! J'avais, heureusement, des sauvegardes et j'ai
dû tout restaurer. Si j'avais eu une installation par défaut et que je
n'aie jamais eu bidouillé grub après avoir recompilé un noyau modifié,
je suppose que la mise à jour se serait passée sans histoire... mais
alors les distro récentes paraissent impliquer qu'on ne doive plus
toucher à rien, comme sous MSWIN !

Et donc c'est depuis cette mise à jour que CTRL-ALT-F1 ne fonctionne
plus, non pas parce que la maj se serait mal déroulée, mais parce que la
désactivation de cette possibilité était voulue (voir plus haut, Ubuntu
Jaunty Jackalope etc...). Je suis également fondé de supposer que cette
maj est responsable du fait que, en créant un nouveau 'user', le nouvel
environnement ne prenne pas en compte mon clavier, alors qu'à
l'installation initiale de Lenny en septembre dernier, mon premier 'user
account' avait bien tout intégré.

Veuillez m'excuser pour ce "coup de gueule", mais parfois cela fait du
bien. Que les bénévoles qui travaillent à ces développements ne se
sentent pas critiqués, car nul doute que les choses sont aujourd'hui
bien plus compliquées qu'à l'époque de RedHat 6 où il y avait bien moins
d'applications.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
agnes
Le #20903011
Bernard a écrit :
giggzounet wrote:

CTRL ALT F1 appuyé longtemps ne marche pas ??? ensuite alt F7 pour
revenir en graphique.




NON ! Cà marchait ; çà ne marche plus...


Bonjour,

J'ai une lenny "de base", sous gnome, avec les mises à jour au fil de
l'eau : ctrl+alt+F1 fonctionne sans problème (et alt+F7 pour revenir en
mode graphique).

--
Agnès

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Kenny
Le #20903001
Bonjour Bernard,

Bernard wrote:
CTRL ALT F1 appuyé longtemps ne marche pas ??? ensuite alt F7 pour
revenir en graphique.




NON ! Cà marchait ; çà ne marche plus... depuis que j'ai laissé faire
une des mises à jour proposées à chaque boot. Je reviens tout juste
d'aller voir ce qu'on trouvait là dessus sur Google : apparemment dans
les nouvelles versions linuxiennes, il est devenu très difficile d'aller
sur la console. Plusieurs personnes ont posé des questions. Il paraît
que depuis "Ubuntu Jaunty Jackalope", la possibilité de quitter
l'environnement graphique et d'aller sur la console en faisant
CTRL-ALT-F1 a été désactivée ; fortes sont les chances pour qu'il en
soit de même sous Debian Lenny. Aux questions posées par les
utilisateurs lambda, ceux qui ont répondu paraissent avoir botté en
touche : ils n'ont fourni aucune méthode pour aller sur la console, à la
place ils ont donné des astuces pour éviter d'avoir à le faire, selon la
raison donnée pour souhaiter utiliser cet environnement. Peut-être
est-il possible de trouver d'autres réponses, mais je n'en n'ai pas
encore trouvées.




Je suis assez étonné par cette remarque.
J'emploie régulièrement les ctrl + alt + 1-7 sans aucun problème. Je
n'ai rien activé de spécial.
Je peux faire ça depuis la page de login ou depuis n'importe quel compte
où je suis connecté.
Cela fonctionne avec mon debian lenny, debian testing, ubuntu jackalope
et mon ubuntu karmic..

Ne plus employer la console?! C'est horrible de juste y penser :)

J'en sais trop pour me résigner à ne jamais plus faire usage de la
console, mais je n'en sais pas assez pour trouver facilement un moyen
d'y aller. Au bon vieux temps de lilo, j'aurais, dans lilo.conf, mis une
boot option pour arrêter au niveau 5 (sans l'environnement
graphique)... mais, de toutes façons, de ce temps là il suffisait de
faire CTRL-ALT-BACKSTEP. Aujourd'hui je ne vois rien d'évident dans
/boot/grub/menu.lst qui permette de limiter le boot au stade 5. Il y a
bien les noyaux 'one user', mais ce sont des recovery modes, et tout
n'est pas actif.



CTRL-ALT-BACKSTEP sert à tuer la session graphique en cours (et donc
revenir à la page de login).. enfin, je l'ai toujours connu comme ça..


Je n'aime pas du tout cette désactivation autoritaire de CTRL-ALT-F1 et
l'obligation de rester en environnement graphique. Et ces mises à jour
quasiment autoritaires ne me disent rien qui vaille non plus. Autrefois,
je conservais un système environ 3 ou 4 ans sans update, sauf update
ponctuelle d'une application particulière en cas de nécessité, l'update
générale se faisant lorsque je changeais de système, ce qui,
généralement, coïncidait avec l'achat d'un nouveau PC. Ainsi donc,
depuis mon installation de Lenny en septembre 2009, j'ai fait une et une
seule mise à jour... et le résultat a été en accord avec mes
appréhensions : impossible de re-booter !!! J'ai passé une journée
entière à pouvoir relancer mon système après un boot en recovery mode
avec "system rescue CD", ce qui m'a permis de voir que le programme
d'update avait modifié mon /boot/grub/menu.lst et mis en première ligne
un noyau ancien incompatible avec l'initramfs etc... Quel foutoir il y
avait dans "menu.lst" ! J'avais, heureusement, des sauvegardes et j'ai
dû tout restaurer. Si j'avais eu une installation par défaut et que je
n'aie jamais eu bidouillé grub après avoir recompilé un noyau modifié,
je suppose que la mise à jour se serait passée sans histoire... mais
alors les distro récentes paraissent impliquer qu'on ne doive plus
toucher à rien, comme sous MSWIN !

Et donc c'est depuis cette mise à jour que CTRL-ALT-F1 ne fonctionne
plus, non pas parce que la maj se serait mal déroulée, mais parce que la
désactivation de cette possibilité était voulue (voir plus haut, Ubuntu
Jaunty Jackalope etc...). Je suis également fondé de supposer que cette
maj est responsable du fait que, en créant un nouveau 'user', le nouvel
environnement ne prenne pas en compte mon clavier, alors qu'à
l'installation initiale de Lenny en septembre dernier, mon premier 'user
account' avait bien tout intégré.

Veuillez m'excuser pour ce "coup de gueule", mais parfois cela fait du
bien. Que les bénévoles qui travaillent à ces développements ne se
sentent pas critiqués, car nul doute que les choses sont aujourd'hui
bien plus compliquées qu'à l'époque de RedHat 6 où il y avait bien moins
d'applications.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Bernard
Le #20902991
Denis Barbier wrote:
Le 5 janvier 2010 15:46, Bernard [...]

~$ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "xfree86+aliases(azerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+fr(fr)" };
xkb_geometry { include "pc(pc102)" };
};
~$ set xkbmap fr oss



[...]

Bonjour,

Supprime l'espace entre set et xkbmap.

Denis




Oups ! Là était mon erreur ! un nouvel essai avec setxkbmap fr oss m'a
permis d'utiliser les caractères accentués dans l'environnement gnome de
ce nouvel user :

Voici ce que donnait setxkbmap -print avant la modif (pas tout à fait
pareil que ce que j'ai affiché dans mon précédent message, mais entre
temps j'ai détruit puis recréé ce nouvel user) :

xkb_keymap {
xkb_keycodes { include "xfree86+aliases(azerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+fr(fr)" };
xkb_geometry { include "pc(pc102)" };
};

et voilà ce que çà donne après la commande 'set xkbmap fr oss' :

xkb_keymap {
xkb_keycodes { include "xfree86+aliases(azerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+fr(oss)" };
xkb_geometry { include "pc(pc102)" };
};

Depuis lors, les caractères accentués sont accessibles sur ce nouveau
compte.

Merci à vous tous.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Denis Barbier
Le #20903091
Le 5 janvier 2010 17:53, Bernard
Denis Barbier wrote:

Le 5 janvier 2010 15:46, Bernard [...]


~$ setxkbmap -print
xkb_keymap {
     xkb_keycodes  { include "xfree86+aliases(azert y)"       };
     xkb_types     { include "complete"      };
     xkb_compat    { include "complete"      };
     xkb_symbols   { include "pc+fr(fr)"      };
     xkb_geometry  { include "pc(pc102)"      };
};
~$ set xkbmap fr oss




[...]

Bonjour,

Supprime l'espace entre set et xkbmap.

Denis





Oups !  Là était mon erreur !  un nouvel essai avec s etxkbmap fr oss m'a
permis d'utiliser les caractères accentués dans l'environnement gnome de ce
nouvel user :

Voici ce que donnait setxkbmap -print avant la modif (pas tout à fai t pareil
que ce que j'ai affiché dans mon précédent message, mais e ntre temps j'ai
détruit puis recréé ce nouvel user) :

xkb_keymap {
      xkb_keycodes  { include "xfree86+aliases(azerty )"       };
      xkb_types     { include "complete"      };
      xkb_compat    { include "complete"      };
      xkb_symbols   { include "pc+fr(fr)"      };
      xkb_geometry  { include "pc(pc102)"      };
};



L'erreur est ici, tu as une Variant "fr" du Layout "fr", ce qui
n'existe pas (ou plus), et quand tu modifies le Model, l'erreur
persiste, d'où le message d'erreur de GNOME. Une fois que c'est
corrigé par setxkbmap, tu devrais essayer de revenir dans l'outil de
configuration du clavier, cette fois tu devrais pouvoir faire les
changements et enregistrer la bonne configuration.
Quand tu es dans le gestionnaire de session (gdm ?), as-tu les
caractères accentués ?

Denis

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Bernard
Le #20906771
Kenny wrote:
Bonjour Bernard,

Bernard wrote:
CTRL ALT F1 appuyé longtemps ne marche pas ??? ensuite alt F7 pour
revenir en graphique.




NON ! Cà marchait ; çà ne marche plus... depuis que j'ai laissé
faire une des mises à jour proposées à chaque boot. Je reviens tout
juste d'aller voir ce qu'on trouvait là dessus sur Google :
apparemment dans les nouvelles versions linuxiennes, il est devenu
très difficile d'aller sur la console. Plusieurs personnes ont posé
des questions. Il paraît que depuis "Ubuntu Jaunty Jackalope", la
possibilité de quitter l'environnement graphique et d'aller sur la
console en faisant CTRL-ALT-F1 a été désactivée ; fortes sont les
chances pour qu'il en soit de même sous Debian Lenny. Aux questions
posées par les utilisateurs lambda, ceux qui ont répondu paraissent
avoir botté en touche : ils n'ont fourni aucune méthode pour aller
sur la console, à la place ils ont donné des astuces pour éviter
d'avoir à le faire, selon la raison donnée pour souhaiter utiliser
cet environnement. Peut-être est-il possible de trouver d'autres
réponses, mais je n'en n'ai pas encore trouvées.




Je suis assez étonné par cette remarque.
J'emploie régulièrement les ctrl + alt + 1-7 sans aucun problème. Je
n'ai rien activé de spécial.



En tous cas, chez moi cela ne fonctionne plus, et, apparemment je ne
suis pas le seul à m'en plaindre, si j'en crois les déboires des
utilisateurs de Ubuntu Jaunty Jackalope qui se sont exprimés dans des
forums relayés par Google. Peut-être, dans mon cas particulier, ceci est
il dû au fait qu'au lieu de faire les mises à jour à chaque proposition,
j'ai fait tout d'un coup, il y a environ un mois..;
Je peux faire ça depuis la page de login ou depuis n'importe quel
compte où je suis connecté.
Cela fonctionne avec mon debian lenny, debian testing, ubuntu
jackalope et mon ubuntu karmic..

Ne plus employer la console?! C'est horrible de juste y penser :)

J'en sais trop pour me résigner à ne jamais plus faire usage de la
console, mais je n'en sais pas assez pour trouver facilement un moyen
d'y aller. Au bon vieux temps de lilo, j'aurais, dans lilo.conf, mis
une boot option pour arrêter au niveau 5 (sans l'environnement
graphique)... mais, de toutes façons, de ce temps là il suffisait de
faire CTRL-ALT-BACKSTEP. Aujourd'hui je ne vois rien d'évident dans
/boot/grub/menu.lst qui permette de limiter le boot au stade 5. Il y
a bien les noyaux 'one user', mais ce sont des recovery modes, et
tout n'est pas actif.



CTRL-ALT-BACKSTEP sert à tuer la session graphique en cours (et donc
revenir à la page de login).. enfin, je l'ai toujours connu comme ça..


Oui, moi aussi, mais en l'absence d'autre alternative, çà pouvait servir
de sauf-conduit pour revenir à la console.


Je n'aime pas du tout cette désactivation autoritaire de CTRL-ALT-F1
et l'obligation de rester en environnement graphique. Et ces mises à
jour quasiment autoritaires ne me disent rien qui vaille non plus.
Autrefois, je conservais un système environ 3 ou 4 ans sans update,
sauf update ponctuelle d'une application particulière en cas de
nécessité, l'update générale se faisant lorsque je changeais de
système, ce qui, généralement, coïncidait avec l'achat d'un nouveau
PC. Ainsi donc, depuis mon installation de Lenny en septembre 2009,
j'ai fait une et une seule mise à jour... et le résultat a été en
accord avec mes appréhensions : impossible de re-booter !!! J'ai
passé une journée entière à pouvoir relancer mon système après un
boot en recovery mode avec "system rescue CD", ce qui m'a permis de
voir que le programme d'update avait modifié mon /boot/grub/menu.lst
et mis en première ligne un noyau ancien incompatible avec
l'initramfs etc... Quel foutoir il y avait dans "menu.lst" ! J'avais,
heureusement, des sauvegardes et j'ai dû tout restaurer. Si j'avais
eu une installation par défaut et que je n'aie jamais eu bidouillé
grub après avoir recompilé un noyau modifié, je suppose que la mise à
jour se serait passée sans histoire... mais alors les distro récentes
paraissent impliquer qu'on ne doive plus toucher à rien, comme sous
MSWIN !

Et donc c'est depuis cette mise à jour que CTRL-ALT-F1 ne fonctionne
plus, non pas parce que la maj se serait mal déroulée, mais parce que
la désactivation de cette possibilité était voulue (voir plus haut,
Ubuntu Jaunty Jackalope etc...). Je suis également fondé de supposer
que cette maj est responsable du fait que, en créant un nouveau
'user', le nouvel environnement ne prenne pas en compte mon clavier,
alors qu'à l'installation initiale de Lenny en septembre dernier, mon
premier 'user account' avait bien tout intégré.

Veuillez m'excuser pour ce "coup de gueule", mais parfois cela fait
du bien. Que les bénévoles qui travaillent à ces développements ne se
sentent pas critiqués, car nul doute que les choses sont aujourd'hui
bien plus compliquées qu'à l'époque de RedHat 6 où il y avait bien
moins d'applications.







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme