Nvidia : j'ai encore tout cassé !!!

Le
Nicolas FRANCOIS
Salut.

Après un long détour par Ubuntu (que j'avais préféré à Debian p=
ar goût
du risque et des packages récents) qui s'est terminé à la suite d'une
profonde déception lors de la dernière mise à jour (je DÉTESTE
Unity !!!), je reviens vers Debian.

Bon, évidemment, j'ai pris de TRÈS mauvaises habitudes avec Ubuntu, et
la première chose que j'ai voulu faire, c'est d'ajouter des dépots
testing et unstable à mon fichiers sources.list.

Évidemment, ça a tout cassé, maintenant, je ne suis même pas capabl=
e de
dire en quelle version je suis. Un mélange de testing et unstable, il
me semble

Bref, pour en venir à mon problème : j'aime bien jouer à Civilization=
4
sous Wine, et cette version marchait fort bien avec la version "stable"
du driver Nvidia (195.quelque chose). La version que j'ai me propose
une mouture plus récente (270.qqc), qui provoque des soucis avec les
graphiques. Je voudrais donc revenir à la version stable du driver.

Mais si j'arrive bien à imposer l'installation de la version stable du
paquet nvidia-kernel-source (en ajoutant /stable à la commande
apt-get), lors de l'utilisation de module-assistant, je ne peux
compiler que la dernière version :-(

Quelqu'un peut-il m'aider à démêler cet écheveau incompréhensible=
pour
moi, avant que je me décide à tout réinstaller ?

D'avance merci !

bye (tout penaud :-(

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20110523020815.3a3293c8@gaston
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas FRANCOIS
Le #23384901
Le Mon, 23 May 2011 02:08:15 +0200,
Nicolas FRANCOIS
Salut.

Après un long détour par Ubuntu (que j'avais préféré à Debian par goût
du risque et des packages récents) qui s'est terminé à la suite d'u ne
profonde déception lors de la dernière mise à jour (je DÉTESTE
Unity !!!), je reviens vers Debian.

Bon, évidemment, j'ai pris de TRÈS mauvaises habitudes avec Ubuntu, et
la première chose que j'ai voulu faire, c'est d'ajouter des dépots
testing et unstable à mon fichiers sources.list.

Évidemment, ça a tout cassé, maintenant, je ne suis même pas capa ble
de dire en quelle version je suis. Un mélange de testing et unstable,
il me semble...



Et ce alors que le bouquin (cahier de l'admin' Debian 2ème édition) qui
m'a conseillé de faire cela m'affirmait que cela ne changerait rien, et
me permettrait juste d'ajouter des versions plus récentes de certains
paquets SI je le forçais avec apt-get !!! Si on ne peut plus faire
confiance aux bouquins !!:

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Basile Starynkevitch
Le #23384891
On Mon, 23 May 2011 08:02:29 +0200
Nicolas FRANCOIS
> Évidemment, ça a tout cassé, maintenant, je ne suis même pas ca pable
> de dire en quelle version je suis. Un mélange de testing et unstable,
> il me semble...



A mon avis ça devrait marcher. JE n'ai plus de nvidia, mais avec une
carte ATI, et un melange de unstable et parfois experimental, ça marche
bien.

Autrefois (il y a 2 ans) j'avais une Nvidia qui marchait bien en unstable.

J'aurais essayé un aptitude update
puis aptitude upgrade
puis aptitude install nvidia-support

Cordialement
--
Basile STARYNKEVITCH http://starynkevitch.net/Basile/
email: basile<at>starynkevitch<dot>net mobile: +33 6 8501 2359
8, rue de la Faiencerie, 92340 Bourg La Reine, France
*** opinions {are only mine, sont seulement les miennes} ***

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
aishen
Le #23385121
Ubuntu natty classic marche très bien (version gnome2.32) : J'ai
installé ugr et ça me permet d'avoir gnome 3 sous unity /ubuntu classic,
tout marche très bien même fusion-icon avec emerald (il y a un tutoriel
pour compiler emerald )
Bon courage :)

Le lundi 23 mai 2011 à 08:02 +0200, Nicolas FRANCOIS a écrit :
Le Mon, 23 May 2011 02:08:15 +0200,
Nicolas FRANCOIS
> Salut.
>
> Après un long détour par Ubuntu (que j'avais préféré à Debian par goût
> du risque et des packages récents) qui s'est terminé à la suite d'une
> profonde déception lors de la dernière mise à jour (je DÉTESTE
> Unity !!!), je reviens vers Debian.
>
> Bon, évidemment, j'ai pris de TRÈS mauvaises habitudes avec Ubuntu, et
> la première chose que j'ai voulu faire, c'est d'ajouter des dépots
> testing et unstable à mon fichiers sources.list.
>
> Évidemment, ça a tout cassé, maintenant, je ne suis même pas capable
> de dire en quelle version je suis. Un mélange de testing et unstable,
> il me semble...

Et ce alors que le bouquin (cahier de l'admin' Debian 2ème édition) qui
m'a conseillé de faire cela m'affirmait que cela ne changerait rien, et
me permettrait juste d'ajouter des versions plus récentes de certains
paquets SI je le forçais avec apt-get !!! Si on ne peut plus faire
confiance aux bouquins !!:

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
giggzounet
Le #23385461
Le 23/05/2011 02:08, Nicolas FRANCOIS a écrit :
Salut.

Après un long détour par Ubuntu (que j'avais préféré à Debian par goût
du risque et des packages récents) qui s'est terminé à la suite d'une
profonde déception lors de la dernière mise à jour (je DÉTESTE
Unity !!!), je reviens vers Debian.

Bon, évidemment, j'ai pris de TRÈS mauvaises habitudes avec Ubuntu, et
la première chose que j'ai voulu faire, c'est d'ajouter des dépots
testing et unstable à mon fichiers sources.list.

Évidemment, ça a tout cassé, maintenant, je ne suis même pas capable de
dire en quelle version je suis. Un mélange de testing et unstable, il
me semble...

Bref, pour en venir à mon problème : j'aime bien jouer à Civilization 4
sous Wine, et cette version marchait fort bien avec la version "stable"
du driver Nvidia (195.quelque chose). La version que j'ai me propose
une mouture plus récente (270.qqc), qui provoque des soucis avec les
graphiques. Je voudrais donc revenir à la version stable du driver.

Mais si j'arrive bien à imposer l'installation de la version stable du
paquet nvidia-kernel-source (en ajoutant /stable à la commande
apt-get), lors de l'utilisation de module-assistant, je ne peux
compiler que la dernière version :-(

Quelqu'un peut-il m'aider à démêler cet écheveau incompréhensible pour
moi, avant que je me décide à tout réinstaller ?

D'avance merci !

bye (tout penaud :-(




Bon si je cormprends bien tu veux juste désinstaller le driver nvidia
d'instable et installer celui de stalbe non ?

bon déjà avec les driver nvidia proprio il faut désinstaller avant de
réinstaller...pourquoi ? aucune idée...donc il va falloir travailler en
console virtuelle. Donc tu désinstalles tout ce qui a rapport à
nvidia...utilises tu le paquet dkms ?

ensuite tu fais du pinning pour que le paquet nvidia que tu réinstalles
soit celui de stable...

bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/irdb4l$tkm$
Nicolas FRANCOIS
Le #23386251
Le Mon, 23 May 2011 08:14:56 +0200,
Basile Starynkevitch
On Mon, 23 May 2011 08:02:29 +0200
Nicolas FRANCOIS > > Évidemment, ça a tout cassé, maintenant, je ne suis même pas
> > capable de dire en quelle version je suis. Un mélange de testing
> > et unstable, il me semble...

A mon avis ça devrait marcher. JE n'ai plus de nvidia, mais avec une
carte ATI, et un melange de unstable et parfois experimental, ça
marche bien.

Autrefois (il y a 2 ans) j'avais une Nvidia qui marchait bien en
unstable.

J'aurais essayé un aptitude update
puis aptitude upgrade
puis aptitude install nvidia-support

Cordialement



Entendons-nous bien : J'AI un driver Nvidia, en l'occurrence le
dernier, mais il ne me convient pas, je voudrais revenir à la version
précédente (celle de stable). Or si je suis tes instructions, je vais
me retrouver avec la version instable.

Donc il faut que je dise à m-a de compiler et installer la version
précédente, mais je ne sais pas "comment lui dire" (merci France Gall).
Je sais avec apt-get (c'est le pinning, c'est bien cela ?), mais pas
avec m-a.

De plus, même si je réinstalle la bonne version des paquets, il y en a
trois : nvidia-kernel-common, nvidia-kernel-sources et nvidia-glx.
Dois-je prendre trois fois la même version ? Et si les numéros ne
correspondent pas ? Et si ils ne sont pas compatibles avec mon noyau
actuel (un 2.6.39 et des brouettes...) ? Tant de questions
angoissantes...

Donc si vous aviez un peu plus de précisions à m'apporter, je vous en
serai infiniment (ou presque) reconnaissant.

Et après, je vire tout, et je refais une install propre. Parce que là,
c'est franchement le bazar !

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
tv.debian
Le #23386651
Le 23/05/2011 16:54, Nicolas FRANCOIS a écrit :
Le Mon, 23 May 2011 08:14:56 +0200,
Basile Starynkevitch
On Mon, 23 May 2011 08:02:29 +0200
Nicolas FRANCOIS
Évidemment, ça a tout cassé, maintenant, je ne suis même pas
capable de dire en quelle version je suis. Un mélange de testing
et unstable, il me semble...





A mon avis ça devrait marcher. JE n'ai plus de nvidia, mais avec une
carte ATI, et un melange de unstable et parfois experimental, ça
marche bien.

Autrefois (il y a 2 ans) j'avais une Nvidia qui marchait bien en
unstable.

J'aurais essayé un aptitude update
puis aptitude upgrade
puis aptitude install nvidia-support

Cordialement



Entendons-nous bien : J'AI un driver Nvidia, en l'occurrence le
dernier, mais il ne me convient pas, je voudrais revenir à la version
précédente (celle de stable). Or si je suis tes instructions, je vais
me retrouver avec la version instable.

Donc il faut que je dise à m-a de compiler et installer la version
précédente, mais je ne sais pas "comment lui dire" (merci France Gall).
Je sais avec apt-get (c'est le pinning, c'est bien cela ?), mais pas
avec m-a.



Télécharge le paquet source de la version que tu veux compiler, lance
l'interface ncurses de m-a et fait directement un "select" puis un
"build", la version présente sera compilée. Ou en ligne de commande :

apt-get -t stable install nvidia-kernel-source
m-a build nvidia

Il te faut aussi linux-headers-$(uname -r).

De plus, même si je réinstalle la bonne version des paquets, il y en a
trois : nvidia-kernel-common, nvidia-kernel-sources et nvidia-glx.
Dois-je prendre trois fois la même version ?



Oui.

Et si les numéros ne
correspondent pas ? Et si ils ne sont pas compatibles avec mon noyau
actuel (un 2.6.39 et des brouettes...) ? Tant de questions
angoissantes...



Seuls les paquets nvidia-kernel-$(version_noyau) seront incompatibles si
$(uname -r) ≠ $(version_noyau). L'intérêt de la méthode m-a ou de dkms
qui la remplace avantageusement dans la plupart des cas c'est que ça
fonctionne avec (presque) tous les noyaux, même compilés perso.


Donc si vous aviez un peu plus de précisions à m'apporter, je vous en
serai infiniment (ou presque) reconnaissant.

Et après, je vire tout, et je refais une install propre. Parce que là,
c'est franchement le bazar !

bye




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme