Obtenir le maximum d'une plage de cellules contenant le résultat ..

Le
SweetEd
Slt à tous,

J'essayes d'obtenir le max d'une plage de cellule dont les valeurs sont le
résultat d'une formule mais ça ne marche pas.
Si A$6:A$515 est la plage, MAX(A$6:A$515) me donne 0 alors que j'ai
visiblement des valeurs > à 0.
Si par contre je supprime toutes les formules des cellules A$7:A$515 et que
j'entre des valeurs manuellement, MAX(A$7:A$515) fonctionne. Cela ne
fonctionne plus si j'indique la plage A$6:A$515 (car dans la cellule A$6,
j'ai maintenu une formule)!!!

En fait les cellules A$6:A$515 doivent donner un numéro en fonction du
contenu de B$6:B$515 avec la formulle suivante :

=SI(A5<>"";SI(NB.SI(B$6:B$515;B6)=1;MAX(A$6:A$515)+1;INDEX(A$6:A$515;EQUIV(B6;B$6:B$515;0)));SI(B6<>"";SI(NB.SI(B$6:B$515;B6)=1;MAX(A$6:A$515)+1;INDEX(A$6:A$515;EQUIV(B6;B$6:B$515;0)));""))

Merci de me donner un coup de main, svp.


Cdlt.

SweetEd.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrick
Le #5156001
Bonjour,

Est-ce que le contenu des cellules est vraiment des nombres et non du texte ?


--
Patrick


"SweetEd" wrote:

Slt à tous,

J'essayes d'obtenir le max d'une plage de cellule dont les valeurs sont le
résultat d'une formule mais ça ne marche pas.
Si A$6:A$515 est la plage, MAX(A$6:A$515) me donne 0 alors que j'ai
visiblement des valeurs > à 0.
Si par contre je supprime toutes les formules des cellules A$7:A$515 et que
j'entre des valeurs manuellement, MAX(A$7:A$515) fonctionne. Cela ne
fonctionne plus si j'indique la plage A$6:A$515 (car dans la cellule A$6,
j'ai maintenu une formule)!!!

En fait les cellules A$6:A$515 doivent donner un numéro en fonction du
contenu de B$6:B$515 avec la formulle suivante :

=SI(A5
Merci de me donner un coup de main, svp.


Cdlt.

SweetEd.



Daniel.C
Le #5155991
Bonjour.
J'avoue que j'ai du mal à suivre...Peux-tu mettre un classeur exemple sur
www.cjoint.com en ôtant les données confidentuelles et poster l'adresse
générée ?
Cordialement.
Daniel
"SweetEd" news:
Slt à tous,

J'essayes d'obtenir le max d'une plage de cellule dont les valeurs sont le
résultat d'une formule mais ça ne marche pas.
Si A$6:A$515 est la plage, MAX(A$6:A$515) me donne 0 alors que j'ai
visiblement des valeurs > à 0.
Si par contre je supprime toutes les formules des cellules A$7:A$515 et
que
j'entre des valeurs manuellement, MAX(A$7:A$515) fonctionne. Cela ne
fonctionne plus si j'indique la plage A$6:A$515 (car dans la cellule A$6,
j'ai maintenu une formule)!!!

En fait les cellules A$6:A$515 doivent donner un numéro en fonction du
contenu de B$6:B$515 avec la formulle suivante :

=SI(A5
Merci de me donner un coup de main, svp.


Cdlt.

SweetEd.



SweetEd
Le #5155881
Patrick, j'ai bien un format standard et non texte. De plus en remplaçant les
formules par une valeur (toujours au format "Standard"), ça marche.

Donc ce n'est pas là le pb.

Merci tout de même.


Bonjour,

Est-ce que le contenu des cellules est vraiment des nombres et non du texte ?


--
Patrick


"SweetEd" wrote:

Slt à tous,

J'essayes d'obtenir le max d'une plage de cellule dont les valeurs sont le
résultat d'une formule mais ça ne marche pas.
Si A$6:A$515 est la plage, MAX(A$6:A$515) me donne 0 alors que j'ai
visiblement des valeurs > à 0.
Si par contre je supprime toutes les formules des cellules A$7:A$515 et que
j'entre des valeurs manuellement, MAX(A$7:A$515) fonctionne. Cela ne
fonctionne plus si j'indique la plage A$6:A$515 (car dans la cellule A$6,
j'ai maintenu une formule)!!!

En fait les cellules A$6:A$515 doivent donner un numéro en fonction du
contenu de B$6:B$515 avec la formulle suivante :

=SI(A5
Merci de me donner un coup de main, svp.


Cdlt.

SweetEd.





Publicité
Poster une réponse
Anonyme