OpenVPN

Le
geoffrey
Bonjour,
J'ai dans l'intention de faire un VPN pour mon lan (méthode routed)
Ce que je veux , c'est acceder a mon réseau a partir de l'extérieur.
Le serveur est une debian les clients sont des ArchLinux.

Voici la config serveur
server.conf:
-
ca /etc/openvpn/ca.crt
cert /etc/openvpn/debianvpn.crt
client-to-client
comp-lzo
dev tun
dh /etc/openvpn/dh1024.pem
group openvpn
ifconfig-pool-persist /etc/openvpn/ipp.txt
keepalive 10 120
log-append log/openvpnappend.log
log log/openvpn.log
max-clients 2
persist-key
persist-tun
port 1398
proto udp
server 192.168.0.0 255.255.255.0
status log/openvpn-status.log
user openvpn
verb 5
-
Voici le client.conf

dev tun
client
pull
proto udp
remote 15.10.10.45 1398
resolv-retry infinite
user openvpn
group openvpn
persist-key
persist-tun
ca ca.crt
cert debianvpncl.crt
key debianvpncl.key
tls-client
tls-auth /etc/openvpn/ta.key 1
comp-lzo
cipher BF-CBC
verb 3
port 1398
nobind

tun-mtu 1300
--
La configuration reseau du serveur est comme suit
interface eth0 sur le serveur 15.10.10.0/24
interface tun0 sur le serveur 192.168.0.0/24
La table de routage du serveur :
Destination Passerelle Genmask Indic Metric Ref Use
Iface
192.168.0.2 0.0.0.0 255.255.255.255 UH 0 0 0 tun0
15.10.10.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.0.0 15.10.10.1 255.255.255.0 UG 0 0 0 eth0
0.0.0.0 15.10.10.1 0.0.0.0 UG 0 0 0 eth0

La table de routage sur routeur principale (passerelle internet):

213.49.239.1 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
15.10.10.0 0.0.0.0 255.255.255.0 U 0 0 0 br0
192.168.0.0 15.10.10.45 255.255.255.0 UG 0 0 0 br0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 br0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 213.49.239.1 0.0.0.0 UG 0 0

La connection VPN au serveur se fait bien , mais je suis dans
l'incapacité de pinger le serveur VPN avec l'interface tun0 du client =>
ping -I tun0 192.168.0.1
Je vous egalement la table de routage du client une fois la connection
VPN etablie
client table de routage :
192.168.0.5 0.0.0.0 255.255.255.255 UH 0 0 0 tun0
15.10.10.0 0.0.0.0 255.255.255.0 U 0 0 0
wlan0
192.168.0.0 192.168.0.5 255.255.255.0 UG 0 0 0 tun0
192.168.0.0 15.10.10.45 255.255.255.0 UG 0 0 0
wlan0
0.0.0.0 15.10.10.1 0.0.0.0 UG 0 0 0
wlan0

en regardant cette table de routage y a qqch qui me frappe c'est la
passerelle 192.168.0.5 et je ne sais pas ou il va chercher ca .
Puisque j'ai défini dans le server 192.168.0.1
Je ne sais d'ailleur pas pourquoi il ajoute ces tables dans mon routage
alors que j'ai desactivé le push sur le server.

ifconfig du client apres connection VPN etablie :
-
tun0 Link encap:UNSPEC HWaddr
00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:192.168.0.6 P-t-P:192.168.0.5 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1300 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:2268 (2.2 Kb
--
Le P-t-p ne devrais pas etre a 192.168.0.1 ???

J'ai flusher totalement Netfilters afin d'isolé le probleme et d'être
certain que cela ne vient pas du firewall .

de plus chose étrange également

sur le serveur je veux ecouter le traffic sur l'interface tun0
donc => tcpdump -n -i tun0
et rien , on dirait que l'interface ne répond pas
pourtant j'arrive bien a pinger cette ip par ping ⁻I wlan0 192.168.0.1
mais tcpdump reste muet quand a l'envoi d'echo.


Je pense que le probleme vient vraiment de ce routage mais je m'en mele
vraiment les pinceaux a ne plus m'y retrouvé c'est pourquoi je sollicite
votre aide si possible.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Francois Cartegnie
Le #19305521
geoffrey wrote:
ifconfig du client apres connection VPN etablie :
-------------------------------------
tun0 Link encap:UNSPEC HWaddr
00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:192.168.0.6 P-t-P:192.168.0.5 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1300 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:2268 (2.2 Kb
--------------------------------------------------
Le P-t-p ne devrais pas etre a 192.168.0.1 ???


Non. La gate vers le reseau vpn est bien le cote distant du tunnel.

C'est tres confus, mais deja la config client devrait pointer sur l'IP
publique du serveur... la le client tente de se connecter sur un reseau
interne 10..x pour obtenir un vpn sur 192..x.

Pour le reste, sans les ip des interfaces et l'architecture du reseau
(il de quel cote routeur/gateway internet ?).


--
Ce message est transmis sur Usenet à titre non commercial.
Toute reprise par un média non conforme à la RFC1036
(suppression partielle ou totale des entetes, non respect des messages
de controle le concernant), dénaturation ou exploitation commerciale
par insertion publicitaire, obfuscation ou changement du groupe ou du
destinataire initial est prohibée et contrevient à mon droit d'auteur.
geoffrey
Le #19305731
Rebonjour,
Alors en effet l'utilité de cette configuration est nul , mais je test
ceci en local tout d'abord afin de m'assurer que cela fonctionne .
D'ou le remote sur le serveur en local.
il de quel cote routeur/gateway internet ?) => du meme pour le moment
puisqu'en local.
Si vous avez besoin d'eclaircissement hésitez pas.
Merci

Francois Cartegnie a écrit :
geoffrey wrote:
ifconfig du client apres connection VPN etablie :
-------------------------------------
tun0 Link encap:UNSPEC HWaddr
00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:192.168.0.6 P-t-P:192.168.0.5 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1300 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:2268 (2.2 Kb
--------------------------------------------------
Le P-t-p ne devrais pas etre a 192.168.0.1 ???


Non. La gate vers le reseau vpn est bien le cote distant du tunnel.

C'est tres confus, mais deja la config client devrait pointer sur l'IP
publique du serveur... la le client tente de se connecter sur un reseau
interne 10..x pour obtenir un vpn sur 192..x.

Pour le reste, sans les ip des interfaces et l'architecture du reseau
(il de quel cote routeur/gateway internet ?).




Francois Cartegnie
Le #19305871
geoffrey wrote:
Rebonjour,
Alors en effet l'utilité de cette configuration est nul , mais je test
ceci en local tout d'abord afin de m'assurer que cela fonctionne .
D'ou le remote sur le serveur en local.
il de quel cote routeur/gateway internet ?) => du meme pour le moment
puisqu'en local.
Si vous avez besoin d'eclaircissement hésitez pas.



Dans ce cas, faut les interfaces et ip du serveur et routeur.
Ainsi que ce que voit le serveur sur eth0 avec un ping sur son IP VPN et
propre. Ca permettra aussi de valider les règles nat.

--
Ce message est transmis sur Usenet à titre non commercial.
Toute reprise par un média non conforme à la RFC1036
(suppression partielle ou totale des entetes, non respect des messages
de controle le concernant), dénaturation ou exploitation commerciale
par insertion publicitaire, obfuscation ou changement du groupe ou du
destinataire initial est prohibée et contrevient à mon droit d'auteur.
geoffrey
Le #19307281
Rebonjour, Francois
Alors pour les interface du serveur c'est ceci , (je pensais avoir tout
mis dans mon 1er post.
-------------------------------------------------------
eth0 Link encap:Ethernet HWaddr 00:30:18:b0:3f:74
inet adr:15.10.10.45 Bcast:15.10.10.255 Masque:255.255.255.0
adr inet6: fe80::230:18ff:feb0:3f74/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:78215795 errors:0 dropped:0 overruns:0 frame:0
TX packets:80430469 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:2981986602 (2.7 GiB) TX bytes:2972957235 (2.7 GiB)
Interruption:23 Adresse de base:0xb400

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6725 errors:0 dropped:0 overruns:0 frame:0
TX packets:6725 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:4373345 (4.1 MiB) TX bytes:4373345 (4.1 MiB)

tun0 Link encap:UNSPEC HWaddr
00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet adr:192.168.0.1 P-t-P:192.168.0.2 Masque:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:100
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
-----------------------------------------------------

mon routeur:

br0 Link encap:Ethernet HWaddr 00:22:6B:74:1A:23
inet addr:15.10.10.1 Bcast:15.10.10.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1551746 errors:0 dropped:0 overruns:0 frame:0
TX packets:1521383 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:141459504 (134.9 MiB) TX bytes:209696914 (199.9 MiB)

br0:0 Link encap:Ethernet HWaddr 00:22:6B:74:1A:23
inet addr:169.254.255.1 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

eth0 Link encap:Ethernet HWaddr 00:22:6B:74:1A:23
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1414487 errors:0 dropped:0 overruns:0 frame:0
TX packets:1410757 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:219593103 (209.4 MiB) TX bytes:171613700 (163.6 MiB)
Interrupt:4

eth1 Link encap:Ethernet HWaddr 00:22:6B:74:1A:25
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1531020 errors:0 dropped:0 overruns:0 frame:378630
TX packets:1540083 errors:5 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:159437717 (152.0 MiB) TX bytes:227058316 (216.5 MiB)
Interrupt:2 Base address:0x5000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MULTICAST MTU:16436 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1730 (1.6 KiB) TX bytes:1730 (1.6 KiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:213.49.239.4 P-t-P:213.49.239.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING MULTICAST MTU:1492 Metric:1
RX packets:1385676 errors:0 dropped:0 overruns:0 frame:0
TX packets:1395330 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:173531690 (165.4 MiB) TX bytes:128075849 (122.1 MiB)

vlan0 Link encap:Ethernet HWaddr 00:22:6B:74:1A:23
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:21260 errors:0 dropped:0 overruns:0 frame:0
TX packets:7874 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3574445 (3.4 MiB) TX bytes:1138070 (1.0 MiB)

vlan1 Link encap:Ethernet HWaddr 00:22:6B:74:1A:24
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1393236 errors:0 dropped:0 overruns:0 frame:0
TX packets:1402893 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:190537832 (181.7 MiB) TX bytes:164611641 (156.9 MiB)

wds0.1 Link encap:Ethernet HWaddr 00:22:6B:74:1A:25
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

------------------------------------------------------------------
le wds correspond au mode client bridger entre deux point d'acces .
le routeur est un linksys DD-WRT(firmware).

Je tiens a te tenir au courant de ma table netfilters.

iptables -t nat -L :
-------------------------------------
Chain PREROUTING (policy ACCEPT)
target prot opt source destination

Chain POSTROUTING (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
-------------------------------
îptables -L
-----------------
target prot opt source destination
DROP all -- 91.86.66.18 anywhere
DROP all -- vim62-1-88-173-65-76.fbx.proxad.net anywhere

DROP all -- 126.21.196-77.rev.gaoland.net anywhere
DROP all -- adsl-84-226-36-180.adslplus.ch anywhere
DROP all -- 239.177-200-80.adsl-dyn.isp.belgacom.be anywhere

DROP all -- 107.208-246-81.adsl-dyn.isp.belgacom.be anywhere

DROP all -- host-213-213-248-250.brutele.be anywhere

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
------------------
Quelque ip rebarbative qui tente du bruteforce.

Si je n'arrive pas a pinger la passerelle , dans ce cas ci le serveur
VPN , en quoi le prerouting ou postrouting intervienne.
car la j'avoue que je ne te suis pas.
je reprecise que je test d'abord en local avant de tester en remote !!
faut que ca fonctionne en local ensuite je ferai les regles adhoc niveau
firewall et NAT .
Bien à toi
Francois Cartegnie
Le #19312461
geoffrey wrote:
Rebonjour, Francois
Alors pour les interface du serveur c'est ceci , (je pensais avoir tout
mis dans mon 1er post.



Sur le serveur:
- Supprime le "192.168.0.0/24 via 15.10.10.1 eth0"
- Change le "192.168.0.2/32 tun0" sur le serveur en "192.168.0.0/24 tun0"
Il n'y a pas de raison de faire passer le traffic VPN par une gate qui
est sur la couche du dessous, et donc invisible.

Pareil sur le routeur:
- 192.168.0.0/24 via 15.10.10.45 br0
me semble pas utile, le traffic étant dans le canal vpn en direction du
serveur, le routeur ne voit jamais le contenu.

--
Ce message est transmis sur Usenet à titre non commercial.
Toute reprise par un média non conforme à la RFC1036
(suppression partielle ou totale des entetes, non respect des messages
de controle le concernant), dénaturation ou exploitation commerciale
par insertion publicitaire, obfuscation ou changement du groupe ou du
destinataire initial est prohibée et contrevient à mon droit d'auteur.
Pascal Hambourg
Le #19313401
Salut,

geoffrey a écrit :
interface eth0 sur le serveur 15.10.10.0/24



C'est chez Hewlett-Packard (à qui cette plage d'adresses appartient) ?
geoffrey
Le #19394551
Bonjour, et désolé du retard de la réponse
Mais je trouve que vos contribution mérite respect et la moindre des
choses est de répondre.

Sachez que mon probleme est résolu,
le probleme venait bien des route , j'ai donc desactivé le push ( peut
utile dans mon cas car un seul client moi se connectera a se VPN).

Pour répondre a pascale, c'est vrai que ce n'est pas standard comme ip ,
seulement derriere un NAT vu que ca n'a pas d'importance, je l'utilise
plus par habitude, ce n'est pas selon les convention pour une adresse C
mais changé ces habitude sont difficile :-).

Pascal Hambourg a écrit :
Salut,

geoffrey a écrit :
interface eth0 sur le serveur 15.10.10.0/24



C'est chez Hewlett-Packard (à qui cette plage d'adresses appartient) ?


Pascal Hambourg
Le #19395071
geoffrey a écrit :

Pour répondre a pascale, c'est vrai que ce n'est pas standard comme ip ,



Il n'y a d'adresses IP "standard", il y a des adresses attribuées à des
organisations comme HP et des adresses réservées pour certains usages,
comme les plages d'adresses privées.

seulement derriere un NAT vu que ca n'a pas d'importance,



Pas d'importance tant que tu n'as pas besoin de communiquer avec une
machine chez HP dont l'adresse se situe dans la plage que tu utilises.
Ce n'est pas pour rien que des adresses particulières ont été réservées
pour l'usage privé, c'est pour éviter ce genre de conflit potentiel.
Publicité
Poster une réponse
Anonyme