Opera, page précédente et position dans la page

Le
siger
Bonjour,
Depuis 2 versions (environ) d'Opera, il m'arrive de cliquer sur "pae
précédente" et de me retrouver en haut de la page alors que j'étais au
milieu.

Je ne me souviens pas avoir vu ça avant. Y a t-il quelque chose à
faire, avez vous vu ça aussi ? (9.52 avec XP)

--
siger
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
siger
Le #16643581
siger a écrit :

Bonjour,
Depuis 2 versions (environ) d'Opera, il m'arrive de cliquer sur
"pae précédente" et de me retrouver en haut de la page alors que
j'étais au milieu.

Je ne me souviens pas avoir vu ça avant. Y a t-il quelque chose à
faire, avez vous vu ça aussi ? (9.52 avec XP)



J'ajoute que depuis la même période, en cliquant sur précédent,
l'affichage ne correspond pas à ce que voit la souris, je m'en aperçois
avec les liens. Je dois dans ce cas faire F5 et l'affichage se remet
"en face".

--
siger
Pierre Maurette
Le #16646991
siger, le 27/08/2008 a écrit :
siger a écrit :

Bonjour,
Depuis 2 versions (environ) d'Opera, il m'arrive de cliquer sur
"pae précédente" et de me retrouver en haut de la page alors que
j'étais au milieu.

Je ne me souviens pas avoir vu ça avant. Y a t-il quelque chose à
faire, avez vous vu ça aussi ? (9.52 avec XP)



J'ajoute que depuis la même période, en cliquant sur précédent,
l'affichage ne correspond pas à ce que voit la souris, je m'en aperçois
avec les liens. Je dois dans ce cas faire F5 et l'affichage se remet
"en face".



Opera 9.52, sous XP x64, Ubuntu 8.04, Ubuntu-VirtualBox-XP x32,
XP-VirtualBox-Vista: pas de problème pour la manip suivante:
site cliquer un lien, monter descendre, puis "page précédente".
Mais ce n'est qu'un test ponctuel, je n'ai même pas vraiment fait le
singe. Et habituellement, j'utilise presque systématiquement
l'ouverture dans un nouvel onglet. Si vous voulez vraiment lever le
doute, communiquez une démarche reproductible menant au problème.

--
Pierre Maurette
rm
Le #16659021
Le mercredi 27 août 2008 à 20:21, siger a écrit :

siger a écrit :

Bonjour,





Salut siger,

Depuis 2 versions (environ) d'Opera, il m'arrive de cliquer sur
"pae précédente" et de me retrouver en haut de la page alors que
j'étais au milieu.

Je ne me souviens pas avoir vu ça avant. Y a t-il quelque chose à
faire, avez vous vu ça aussi ? (9.52 avec XP)



J'ajoute que depuis la même période, en cliquant sur précédent,
l'affichage ne correspond pas à ce que voit la souris, je m'en aperçois
avec les liens. Je dois dans ce cas faire F5 et l'affichage se remet
"en face".



Pourrais tu indiquer une url précise où ce phénomène apparaît ?
Et indiquer si tu as modifié les réglages par défaut de gestion du cache et
de l'historique surtout.

@+
--
rm
siger
Le #16820531
siger a écrit :

siger a écrit :



Depuis 2 versions (environ) d'Opera, il m'arrive de cliquer sur
"page précédente" et de me retrouver en haut de la page alors que
j'étais au milieu.

Je ne me souviens pas avoir vu ça avant. Y a t-il quelque chose à
faire, avez vous vu ça aussi ? (9.52 avec XP)





J'ajoute que depuis la même période, en cliquant sur précédent,
l'affichage ne correspond pas à ce que voit la souris, je m'en
aperçois avec les liens. Je dois dans ce cas faire F5 et
l'affichage se remet "en face".



Je reviens avec ça : pas moyen de trouver une page accessible au public
qui fasse ça. J'ai constaté que ce sont des pages accessibles en
s'identifiant, souvent des forum phpbb, mais pas seulement. Par
ailleurs, c'est aléatoire

--
siger
siger
Le #16820521
siger a écrit :

siger a écrit :



Depuis 2 versions (environ) d'Opera, il m'arrive de cliquer sur
"page précédente" et de me retrouver en haut de la page alors que
j'étais au milieu.

Je ne me souviens pas avoir vu ça avant. Y a t-il quelque chose à
faire, avez vous vu ça aussi ? (9.52 avec XP)





J'ajoute que depuis la même période, en cliquant sur précédent,
l'affichage ne correspond pas à ce que voit la souris, je m'en
aperçois avec les liens. Je dois dans ce cas faire F5 et
l'affichage se remet "en face".



Je reviens avec ça : pas moyen de trouver une page accessible au public
qui fasse ça. J'ai constaté que ce sont des pages accessibles en
s'identifiant, souvent des forum phpbb, mais pas seulement.

Ça semblait aléatoire, mais j'ai constaté que ça ne le fait pas si je
ne "scrolle" pas sur la page avant de revenir en arrière : si je ne
touche à rien et que je clique sur "page précédente", j'arrive au bon
endroit.

--
siger
siger
Le #17366351
siger a écrit :

Depuis 2 versions (environ) d'Opera, il m'arrive de cliquer sur
"page précédente" et de me retrouver en haut de la page alors
que j'étais au milieu.
Je ne me souviens pas avoir vu ça avant. Y a t-il quelque chose
à faire, avez vous vu ça aussi ? (9.52 avec XP)







J'ajoute que depuis la même période, en cliquant sur précédent,
l'affichage ne correspond pas à ce que voit la souris, je m'en
aperçois avec les liens. Je dois dans ce cas faire F5 et
l'affichage se remet "en face".





Je reviens avec ça : pas moyen de trouver une page accessible au
public qui fasse ça. J'ai constaté que ce sont des pages
accessibles en s'identifiant, souvent des forum phpbb, mais pas
seulement.

Ça semblait aléatoire, mais j'ai constaté que ça ne le fait pas si
je ne "scrolle" pas sur la page avant de revenir en arrière : si
je ne touche à rien et que je clique sur "page précédente",
j'arrive au bon endroit.



Bon, finalement ça le fait aussi si je ne touche pas la page avant de
revenir en arrière.

--
siger
siger
Le #18242661
siger a écrit :

siger a écrit :

Bonjour,
Depuis 2 versions (environ) d'Opera, il m'arrive de cliquer sur
"pae précédente" et de me retrouver en haut de la page alors que
j'étais au milieu.

Je ne me souviens pas avoir vu ça avant. Y a t-il quelque chose à
faire, avez vous vu ça aussi ? (9.52 avec XP)





J'ajoute que depuis la même période, en cliquant sur précédent,
l'affichage ne correspond pas à ce que voit la souris, je m'en
aperçois avec les liens. Je dois dans ce cas faire F5 et
l'affichage se remet "en face".



Je viens enfin de trouver une page accessible à tous qui reproduit ce
problème, notamment le 2ème indiqué ci-dessus.

http://www.sensomusic.com/forums/index.php
- je descend un peu la page
- clique sur "Touch-screen edition & Quick Skin" à gauche
- page précédente
- à l'affichage, je vois que la page est en haut et pas là où je
l'avais laissé
- je glisse le curseur sur la droite et regarde à quel moment il
trouve un lien, et je regarde de quel lien il s'agit, soit dans la
barre en bas, soit parce que le lien change de couleur. En glissant le
curseur de haut en bas, je vois qu'il y a un écart correspondant à la
distance avec laquelle j'ai bougé la page. C'est à dire que le curseur
ne voit pas la même chose que moi, pour lui la page est restée
descendue.
- Pour finir je clique sur F5 ce qui remet tout dans l'ordre.
(Opera 9.63 et XP-SP3)

--
siger
rm
Le #18247841
Le lundi 29 décembre 2008 à 11:39, siger a écrit :

siger a écrit :

siger a écrit :

Bonjour,
Depuis 2 versions (environ) d'Opera, il m'arrive de cliquer sur
"pae précédente" et de me retrouver en haut de la page alors que
j'étais au milieu.

Je ne me souviens pas avoir vu ça avant. Y a t-il quelque chose à
faire, avez vous vu ça aussi ? (9.52 avec XP)





J'ajoute que depuis la même période, en cliquant sur précédent,
l'affichage ne correspond pas à ce que voit la souris, je m'en
aperçois avec les liens. Je dois dans ce cas faire F5 et
l'affichage se remet "en face".





Salut siger,

Je viens enfin de trouver une page accessible à tous qui reproduit ce
problème, notamment le 2ème indiqué ci-dessus.

http://www.sensomusic.com/forums/index.php
- je descend un peu la page
- clique sur "Touch-screen edition & Quick Skin" à gauche
- page précédente
- à l'affichage, je vois que la page est en haut et pas là où je
l'avais laissé
- je glisse le curseur sur la droite et regarde à quel moment il
trouve un lien, et je regarde de quel lien il s'agit, soit dans la
barre en bas, soit parce que le lien change de couleur. En glissant le
curseur de haut en bas, je vois qu'il y a un écart correspondant à la
distance avec laquelle j'ai bougé la page. C'est à dire que le curseur
ne voit pas la même chose que moi, pour lui la page est restée
descendue.
- Pour finir je clique sur F5 ce qui remet tout dans l'ordre.
(Opera 9.63 et XP-SP3)



Je ne parviens pas à reproduire le problème sur ce site avec Opera v.9.63
ou v.10 alpha 1, en profil vierge, sous XP aussi. Après avoir cliqué sur
n'importe quel lien de cette page, [<-Page précédente] me ramène à la bonne
position antérieure dans la page.
Donc, il se peut que cela vienne de ta configuration ou d'une problème avec
les fichiers liès à l'historique ou à la session.

Si tu accèdes à ce site par une session mémorisée, essaye de voir si le
problème persiste en accès direct ou depuis un banal signet.
Si tu utilises des extensions (userjs), essaye de les désactiver pour voir
si le problème persiste.
Essaye aussi de purger toutes les données non persistentes (caches,
indexation textuelle, favicônes et compagnie) en supprimant tous les
fichiers situés sous %userprofile%Local SettingsApplication DataOpera
Après, tu peux, pour commencer, ré-initialiser l'option
opera:config#UserPrefs|HistoryNavigationMode à sa valeur par défaut (=1),
voire supprimer le fichier (contenant l'historique globale) dont le chemin
est indiqué en opera:config#UserPrefs|GlobalHistoryFile.
Si cela ne suffit pas à rétablir un fonctionnement nominal, tu pourras
renommer le fichier opera6.ini afin de restaurer la configuration initiale.
Si cela ne suffit toujours pas, renomme le dossier de profil, dont le
chemin est indiqué via opera:about et teste... Dans ce dernier cas tu
devras récupérer toute tes données utiles (signets, skin, config de menu,
toolbar personnalisés...) depuis l'ancien profil.

Voila quelques pistes pour tenter d'élucider ce petit mystère ;)

Bon courage et @+
--
rm
Publicité
Poster une réponse
Anonyme