paquet acroread install

Le
Frederic Baldit
Bonjour,
je cherche à résoudre le problème suivant: le paquet acrore=
ad est
installé mais au lancement dans un terminal j'ai le message:

/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: error while
loading shared libraries: libpixman-1.so.0: cannot open shared object
file: No such file or directory

Or la librairie en question est bien présente, en l'occurence
dans /usr/lib:
ls -al /usr/lib | grep libpixman renvoit:
lrwxrwxrwx 1 root root 21 jui 13 01:48 libpixman-1.so.0
->libpixman-1.so.0.10.0
-rw-r--r-- 1 root root 183856 avr 17 2008 libpixman-1.so.0.10.0

Je suis bloqué et ne voit pas comment progresser. Je suis sur un
installation "fraîche" sur un portable DELL (Precision M6400), à=
savoir:
- à la base une lenny en amd64 (installateur 5.02, netinst)
- noyau 2.6.30 de debian-backport pour activer ma carte wifi (intel
5300 agn)
- qqes paquets de sid (nvidia-kernel-source et nvidia-glx) qui m'ont
permis d'installer "proprement" le pilote nvidia de ma carte

Rq1: j'ai construit mon "sources.list" et un fichier "preferences" de
façon à être en stable, mais à pouvoir le cas éch=
éant demander
l'installation de paquets disponibles ailleurs (ici en sid)
Rq2: je sais que je peux lire des pdf autrement qu'avec acroread, mais
j'aimerais comprendre

Ce qui est bizarre c'est que je ne vois pas d'erreur de raisonnemen dans
ma démarche, ce qui me pousse à me demander si je n'ai pas dÃ=
©tecté un
bug.

Si quelqu'un a une idée, ou veut plus d'info, ou peut me conseiller=
un
lien, je le remercie d'avance.

F.Baldit.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
serge
Le #19752221
Le Monday 13 July 2009 23:34:51 Frederic Baldit, vous avez écrit :
Bonjour,
je cherche à résoudre le problème suivant: le paquet acror ead est
installé mais au lancement dans un terminal j'ai le message:

/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: error while
loading shared libraries: libpixman-1.so.0: cannot open shared object
file: No such file or directory

Or la librairie en question est bien présente, en l'occurence
dans /usr/lib:
ls -al /usr/lib | grep libpixman renvoit:
lrwxrwxrwx 1 root root 21 jui 13 01:48 libpixman-1.so.0
->libpixman-1.so.0.10.0
-rw-r--r-- 1 root root 183856 avr 17 2008 libpixman-1.so.0.10.0

Je suis bloqué et ne voit pas comment progresser. Je suis sur un
installation "fraîche" sur un portable DELL (Precision M6400), à   savoir:
- à la base une lenny en amd64 (installateur 5.02, netinst)
- noyau 2.6.30 de debian-backport pour activer ma carte wifi (intel
5300 agn)
- qqes paquets de sid (nvidia-kernel-source et nvidia-glx) qui m'ont
permis d'installer "proprement" le pilote nvidia de ma carte

Rq1: j'ai construit mon "sources.list" et un fichier "preferences" de
façon à être en stable, mais à pouvoir le cas éc héant demander
l'installation de paquets disponibles ailleurs (ici en sid)
Rq2: je sais que je peux lire des pdf autrement qu'avec acroread, mais
j'aimerais comprendre...

Ce qui est bizarre c'est que je ne vois pas d'erreur de raisonnemen dans
ma démarche, ce qui me pousse à me demander si je n'ai pas dà ©tecté un
bug.

Si quelqu'un a une idée, ou veut plus d'info, ou peut me conseiller un
lien, je le remercie d'avance.

F.Baldit.



Salut,

Je n'utilise pas ce programme, mais si il lui manque une librairie, le mieu x
pour savoir où il les recherche est d'interroger 'ldd':

% ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread

--
(o_
(/)_
S e r g e

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Frederic Baldit
Le #19756381
Le mardi 14 juillet 2009 à 04:14 +0200, a écri t :
Le Monday 13 July 2009 23:34:51 Frederic Baldit, vous avez écrit :
> Bonjour,
> je cherche à résoudre le problème suivant: le paquet ac roread est
> installé mais au lancement dans un terminal j'ai le message:
>
> /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: error while
> loading shared libraries: libpixman-1.so.0: cannot open shared object
> file: No such file or directory
>
> Or la librairie en question est bien présente, en l'occurence
> dans /usr/lib:
> ls -al /usr/lib | grep libpixman renvoit:
> lrwxrwxrwx 1 root root 21 jui 13 01:48 libpixman-1.so.0
> ->libpixman-1.so.0.10.0
> -rw-r--r-- 1 root root 183856 avr 17 2008 libpixman-1.so.0.10.0
>
> Je suis bloqué et ne voit pas comment progresser. Je suis sur un
> installation "fraîche" sur un portable DELL (Precision M6400), à savoir:
> - à la base une lenny en amd64 (installateur 5.02, netinst)
> - noyau 2.6.30 de debian-backport pour activer ma carte wifi (intel
> 5300 agn)
> - qqes paquets de sid (nvidia-kernel-source et nvidia-glx) qui m'ont
> permis d'installer "proprement" le pilote nvidia de ma carte
>
> Rq1: j'ai construit mon "sources.list" et un fichier "preferences" de
> façon à être en stable, mais à pouvoir le cas à ©chéant demander
> l'installation de paquets disponibles ailleurs (ici en sid)
> Rq2: je sais que je peux lire des pdf autrement qu'avec acroread, mais
> j'aimerais comprendre...
>
> Ce qui est bizarre c'est que je ne vois pas d'erreur de raisonnemen da ns
> ma démarche, ce qui me pousse à me demander si je n'ai pas détecté un
> bug.
>
> Si quelqu'un a une idée, ou veut plus d'info, ou peut me conseill er un
> lien, je le remercie d'avance.
>
> F.Baldit.

Salut,

Je n'utilise pas ce programme, mais si il lui manque une librairie, le mieux
pour savoir où il les recherche est d'interroger 'ldd':

% ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread


Bonjour,
j'avais essayé cette commande et constaté qu'elle répond qu e le fichier
n'existe pas, alors qu'il est là. En ligne de commande sous root si je
tape:

ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread

j'ai:

/usr/bin/ldd: line
117: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
fichier ou répertoire de ce type

Or le fichier existe bel et bien:
ls -al /usr/lib/Adobe/Reader8/Reader/intellinux/bin/
total 16120
drwxr-xr-x 2 root root 4096 jui 14 02:02 .
drwxr-xr-x 9 root root 4096 jui 13 19:27 ..
-rwxr-xr-x 1 root root 15613784 mai 28 15:04 acroread
-rwxr-xr-x 1 root root 1377 mai 28 15:04 SynchronizerApp
-rwxr-xr-x 1 root root 853500 mai 28 15:04 SynchronizerApp-binary

J'ai essayé de refaire ldd après un ldconfig mais ça ne cha nge rien.
Cdlt,
F.B.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
serge
Le #19756611
Le Tuesday 14 July 2009 22:11:39 Frederic Baldit, vous avez écrit  :
Le mardi 14 juillet 2009 à 04:14 +0200, a écr it :
> Le Monday 13 July 2009 23:34:51 Frederic Baldit, vous avez écrit :
> > Bonjour,
> > je cherche à résoudre le problème suivant: le paquet a croread est
> > installé mais au lancement dans un terminal j'ai le message:
> >
> > /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: error while
> > loading shared libraries: libpixman-1.so.0: cannot open shared object
> > file: No such file or directory
> >
> > Or la librairie en question est bien présente, en l'occurence
> > dans /usr/lib:
> > ls -al /usr/lib | grep libpixman renvoit:
> > lrwxrwxrwx 1 root root 21 jui 13 01:48 libpixman-1.so.0
> > ->libpixman-1.so.0.10.0
> > -rw-r--r-- 1 root root 183856 avr 17 2008 libpixman-1.so.0.10.0
> >
> > Je suis bloqué et ne voit pas comment progresser. Je suis sur un
> > installation "fraîche" sur un portable DELL (Precision M6400), à
> > savoir: - à la base une lenny en amd64 (installateur 5.02, netin st)
> > - noyau 2.6.30 de debian-backport pour activer ma carte wifi (intel
> > 5300 agn)
> > - qqes paquets de sid (nvidia-kernel-source et nvidia-glx) qui m'ont
> > permis d'installer "proprement" le pilote nvidia de ma carte
> >
> > Rq1: j'ai construit mon "sources.list" et un fichier "preferences" de
> > façon à être en stable, mais à pouvoir le cas à ©chéant demander
> > l'installation de paquets disponibles ailleurs (ici en sid)
> > Rq2: je sais que je peux lire des pdf autrement qu'avec acroread, mais
> > j'aimerais comprendre...
> >
> > Ce qui est bizarre c'est que je ne vois pas d'erreur de raisonnemen
> > dans ma démarche, ce qui me pousse à me demander si je n'ai pas détecté
> > un bug.
> >
> > Si quelqu'un a une idée, ou veut plus d'info, ou peut me conseil ler un
> > lien, je le remercie d'avance.
> >
> > F.Baldit.
>
> Salut,
>
> Je n'utilise pas ce programme, mais si il lui manque une librairie, le
> mieux pour savoir où il les recherche est d'interroger 'ldd':
>
> % ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread

Bonjour,
j'avais essayé cette commande et constaté qu'elle répond q ue le fichier
n'existe pas, alors qu'il est là. En ligne de commande sous root si je
tape:

ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread

j'ai:

/usr/bin/ldd: line
117: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
fichier ou répertoire de ce type

Or le fichier existe bel et bien:
ls -al /usr/lib/Adobe/Reader8/Reader/intellinux/bin/
total 16120
drwxr-xr-x 2 root root 4096 jui 14 02:02 .
drwxr-xr-x 9 root root 4096 jui 13 19:27 ..
-rwxr-xr-x 1 root root 15613784 mai 28 15:04 acroread
-rwxr-xr-x 1 root root 1377 mai 28 15:04 SynchronizerApp
-rwxr-xr-x 1 root root 853500 mai 28 15:04 SynchronizerApp-binary

J'ai essayé de refaire ldd après un ldconfig mais ça ne ch ange rien.
Cdlt,
F.B.



Comme je le disais, je n'ai pas ce programme, mais si 'ldd' ne dit rien alo rs
qu'il est bien là, c'est que 'ldd' n'est pas l'outil car ce ficher est
peut-être, par exemple, un script '/bin/sh' ?

En continuant sur cette idée, pourquoi pas le lancer en tant qu'utilis ateur
normale ( root n'utilise pas Adobe ) en mode bavard:

% file /path/...

Si c'est un script 'bash':

% sh -x /path/script.sh
[..]

Et regarder ce qui ne va pas...

@+

--
(o_
(/)_
S e r g e

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
serge
Le #19756811
Le Tuesday 14 July 2009 23:08:02 Frederic Baldit, vous avez écrit  :
Le mardi 14 juillet 2009 à 22:51 +0200, a écr it :
> Le Tuesday 14 July 2009 22:11:39 Frederic Baldit, vous avez écrit :
> > Le mardi 14 juillet 2009 à 04:14 +0200, a à ©crit :
> > > Le Monday 13 July 2009 23:34:51 Frederic Baldit, vous avez écr it :
> > > > Bonjour,
> > > > je cherche à résoudre le problème suivant: le paqu et acroread est
> > > > installé mais au lancement dans un terminal j'ai le message:
> > > >
> > > > /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: error while
> > > > loading shared libraries: libpixman-1.so.0: cannot open shared
> > > > object file: No such file or directory
> > > >
> > > > Or la librairie en question est bien présente, en l'occurence
> > > > dans /usr/lib:
> > > > ls -al /usr/lib | grep libpixman renvoit:
> > > > lrwxrwxrwx 1 root root 21 jui 13 01:48 libpixman-1.so.0
> > > > ->libpixman-1.so.0.10.0
> > > > -rw-r--r-- 1 root root 183856 avr 17 2008
> > > > libpixman-1.so.0.10.0
> > > >
> > > > Je suis bloqué et ne voit pas comment progresser. Je suis su r un
> > > > installation "fraîche" sur un portable DELL (Precision M6400 ), à
> > > > savoir: - à la base une lenny en amd64 (installateur 5.02, n etinst)
> > > > - noyau 2.6.30 de debian-backport pour activer ma carte wifi
> > > > (intel 5300 agn)
> > > > - qqes paquets de sid (nvidia-kernel-source et nvidia-glx) qui
> > > > m'ont permis d'installer "proprement" le pilote nvidia de ma carte
> > > >
> > > > Rq1: j'ai construit mon "sources.list" et un fichier "preferences"
> > > > de façon à être en stable, mais à pouvoir le cas échéant demander
> > > > l'installation de paquets disponibles ailleurs (ici en sid) Rq2: je
> > > > sais que je peux lire des pdf autrement qu'avec acroread, mais
> > > > j'aimerais comprendre...
> > > >
> > > > Ce qui est bizarre c'est que je ne vois pas d'erreur de raisonnem en
> > > > dans ma démarche, ce qui me pousse à me demander si je n'ai pas
> > > > détecté un bug.
> > > >
> > > > Si quelqu'un a une idée, ou veut plus d'info, ou peut me con seiller
> > > > un lien, je le remercie d'avance.
> > > >
> > > > F.Baldit.
> > >
> > > Salut,
> > >
> > > Je n'utilise pas ce programme, mais si il lui manque une librairie,
> > > le mieux pour savoir où il les recherche est d'interroger 'ldd ':
> > >
> > > % ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
> >
> > Bonjour,
> > j'avais essayé cette commande et constaté qu'elle répo nd que le fichier
> > n'existe pas, alors qu'il est là. En ligne de commande sous root si je
> > tape:
> >
> > ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
> >
> > j'ai:
> >
> > /usr/bin/ldd: line
> > 117: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
> > fichier ou répertoire de ce type
> >
> > Or le fichier existe bel et bien:
> > ls -al /usr/lib/Adobe/Reader8/Reader/intellinux/bin/
> > total 16120
> > drwxr-xr-x 2 root root 4096 jui 14 02:02 .
> > drwxr-xr-x 9 root root 4096 jui 13 19:27 ..
> > -rwxr-xr-x 1 root root 15613784 mai 28 15:04 acroread
> > -rwxr-xr-x 1 root root 1377 mai 28 15:04 SynchronizerApp
> > -rwxr-xr-x 1 root root 853500 mai 28 15:04 SynchronizerApp-binary
> >
> > J'ai essayé de refaire ldd après un ldconfig mais ça n e change rien.
> > Cdlt,
> > F.B.
>
> Comme je le disais, je n'ai pas ce programme, mais si 'ldd' ne dit rien
> alors qu'il est bien là, c'est que 'ldd' n'est pas l'outil car ce ficher
> est peut-être, par exemple, un script '/bin/sh' ?
>
> En continuant sur cette idée, pourquoi pas le lancer en tant
> qu'utilisateur normale ( root n'utilise pas Adobe ) en mode bavard:

Je savais que c'est un exécutable, file me confirme que c'est un ex écutable
32bits:

/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: ELF 32-bit LSB
executable, Intel 80386, version 1 (SYSV), dynamically linked (uses
shared libs), for GNU/Linux 2.2.5, stripped




et que dit 'ldd' ?

Le plus étonnant (pour moi) cest que je n'arrive pas à l'é xécuter (en
tant que non root dans un terminal):



Bonne nouvelle ! Ce n'est pas un outil pour root.

Tu as utilisé 'sudo' ou 'su root -c "/path/bin...", ou même une s ession X ?

Les variables d'environnement ne sont pas les mêmes.

$ /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
bash: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
fichier ou répertoire de ce type

Donc là je n'y comprends plus rien!!!

F.B.



Donc il fonctionne pour les utilisateurs ? Seul 'root' ne parvient pas à   le
lancer ( programme nécessitant le mode graphique, $TMPDIR, etc... ) ?


--
(o_
(/)_
S e r g e

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
serge
Le #19756901
Le Tuesday 14 July 2009 23:33:12 , vous avez écrit  :
Le Tuesday 14 July 2009 23:08:02 Frederic Baldit, vous avez écrit  :
> Le mardi 14 juillet 2009 à 22:51 +0200, a é crit :
> > Le Tuesday 14 July 2009 22:11:39 Frederic Baldit, vous avez écri t :
> > > Le mardi 14 juillet 2009 à 04:14 +0200, a écrit :
> > > > Le Monday 13 July 2009 23:34:51 Frederic Baldit, vous avez é crit :
> > > > > Bonjour,
> > > > > je cherche à résoudre le problème suivant: le pa quet acroread est
> > > > > installé mais au lancement dans un terminal j'ai le messag e:
> > > > >
> > > > > /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: error
> > > > > while loading shared libraries: libpixman-1.so.0: cannot open
> > > > > shared object file: No such file or directory
> > > > >
> > > > > Or la librairie en question est bien présente, en l'occure nce
> > > > > dans /usr/lib:
> > > > > ls -al /usr/lib | grep libpixman renvoit:
> > > > > lrwxrwxrwx 1 root root 21 jui 13 01:48 libpixman-1.so.0
> > > > > ->libpixman-1.so.0.10.0
> > > > > -rw-r--r-- 1 root root 183856 avr 17 2008
> > > > > libpixman-1.so.0.10.0
> > > > >
> > > > > Je suis bloqué et ne voit pas comment progresser. Je suis sur un
> > > > > installation "fraîche" sur un portable DELL (Precision M64 00), à
> > > > > savoir: - à la base une lenny en amd64 (installateur 5.02,
> > > > > netinst) - noyau 2.6.30 de debian-backport pour activer ma carte
> > > > > wifi (intel 5300 agn)
> > > > > - qqes paquets de sid (nvidia-kernel-source et nvidia-glx) qui
> > > > > m'ont permis d'installer "proprement" le pilote nvidia de ma
> > > > > carte
> > > > >
> > > > > Rq1: j'ai construit mon "sources.list" et un fichier
> > > > > "preferences" de façon à être en stable, mais à pouvoir le cas
> > > > > échéant demander l'installation de paquets disponible s ailleurs
> > > > > (ici en sid) Rq2: je sais que je peux lire des pdf autrement
> > > > > qu'avec acroread, mais j'aimerais comprendre...
> > > > >
> > > > > Ce qui est bizarre c'est que je ne vois pas d'erreur de
> > > > > raisonnemen dans ma démarche, ce qui me pousse à me d emander si
> > > > > je n'ai pas détecté un bug.
> > > > >
> > > > > Si quelqu'un a une idée, ou veut plus d'info, ou peut me
> > > > > conseiller un lien, je le remercie d'avance.
> > > > >
> > > > > F.Baldit.
> > > >
> > > > Salut,
> > > >
> > > > Je n'utilise pas ce programme, mais si il lui manque une librairi e,
> > > > le mieux pour savoir où il les recherche est d'interroger 'l dd':
> > > >
> > > > % ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
> > >
> > > Bonjour,
> > > j'avais essayé cette commande et constaté qu'elle ré pond que le
> > > fichier n'existe pas, alors qu'il est là. En ligne de commande sous
> > > root si je tape:
> > >
> > > ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
> > >
> > > j'ai:
> > >
> > > /usr/bin/ldd: line
> > > 117: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
> > > fichier ou répertoire de ce type
> > >
> > > Or le fichier existe bel et bien:
> > > ls -al /usr/lib/Adobe/Reader8/Reader/intellinux/bin/
> > > total 16120
> > > drwxr-xr-x 2 root root 4096 jui 14 02:02 .
> > > drwxr-xr-x 9 root root 4096 jui 13 19:27 ..
> > > -rwxr-xr-x 1 root root 15613784 mai 28 15:04 acroread
> > > -rwxr-xr-x 1 root root 1377 mai 28 15:04 SynchronizerApp
> > > -rwxr-xr-x 1 root root 853500 mai 28 15:04 SynchronizerApp-binary
> > >
> > > J'ai essayé de refaire ldd après un ldconfig mais ça ne change rien.
> > > Cdlt,
> > > F.B.
> >
> > Comme je le disais, je n'ai pas ce programme, mais si 'ldd' ne dit ri en
> > alors qu'il est bien là, c'est que 'ldd' n'est pas l'outil car ce
> > ficher est peut-être, par exemple, un script '/bin/sh' ?
> >
> > En continuant sur cette idée, pourquoi pas le lancer en tant
> > qu'utilisateur normale ( root n'utilise pas Adobe ) en mode bavard:
>
> Je savais que c'est un exécutable, file me confirme que c'est un
> exécutable 32bits:
>
> /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: ELF 32-bit LSB
> executable, Intel 80386, version 1 (SYSV), dynamically linked (uses
> shared libs), for GNU/Linux 2.2.5, stripped

et que dit 'ldd' ?

> Le plus étonnant (pour moi) cest que je n'arrive pas à l'à ©xécuter (en
> tant que non root dans un terminal):

Bonne nouvelle ! Ce n'est pas un outil pour root.

Tu as utilisé 'sudo' ou 'su root -c "/path/bin...", ou même une session X ?

Les variables d'environnement ne sont pas les mêmes.

> $ /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
> bash: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
> fichier ou répertoire de ce type
>
> Donc là je n'y comprends plus rien!!!
>
> F.B.

Donc il fonctionne pour les utilisateurs ? Seul 'root' ne parvient pas à le
lancer ( programme nécessitant le mode graphique, $TMPDIR, etc... ) ?


--
(o_
(/)_
S e r g e



Désolé pour le message ci-dessus, je viens de comprendre que j'av ais mal
regarder ton message :-(

Donc il se lance en tant que 'root', mais les utilisateurs standard, eux, n 'y
arrivent pas ?

Y-a-t-il un problème de droit ( seul 'root' pourrait exécuter le binaire ) ?

--
(o_
(/)_
S e r g e

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Frederic Baldit
Le #19757061
Bonsoir (maintenant c'est plutôt bonjour!!vu l'heure)

Je récapitule les résultats des commandes (mes essais sont faits à
partir d'un terminal ouvert sous gnome, en root ou non. L'icône du
Reader est bien installée dans les menus de gnome, mais si on veut
lancer acroread rien ne se passe):

1) en ligne de commande (root ou non) /usr/bin/acroread (script shell)
se plaint d'une bibliothèque soit-disant inexistante:

/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: error while
loading shared libraries: libpixman-1.so.0: cannot open shared object
file: No such file or directory

Or cette bibliothèque existe:
locate *libpixman* répond (entre autre):

/usr/lib/libpixman-1.so.0
/usr/lib/libpixman-1.so.0.10.0

puis la commande file /usr/lib/libpixman-1.so.0 répond:

/usr/lib/libpixman-1.so.0: symbolic link to `libpixman-1.so.0.10.0'

et file /usr/lib/libpixman-1.so.0.10.0 répond:

/usr/lib/libpixman-1.so.0.10.0: ELF 64-bit LSB shared object, x86-64,
version 1 (SYSV), dynamically linked, stripped

2) visiblement le fichier
/usrlib/Adobe/Reader8/Reader/intellinux/bin/acroread est bien un
exécutable 32 bits:
la commande file lib/Adobe/Reader8/Reader/intellinux/bin/acroread
renvoit:

/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: ELF 32-bit LSB
executable, Intel 80386, version 1 (SYSV), dynamically linked (uses
shared libs), for GNU/Linux 2.2.5, stripped

3) Pour une raison que je ne comprends pas ldd me jette en me disant que
le fichier n'existe pas:
la commande (en root)
ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
renvoit:

/usr/bin/ldd: line
117: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
fichier ou répertoire de ce type

(alors que, par exemple, lld /usr/bin/aptitude me donne bien la liste
des lib liées à aptitude)

4) Encore plus bizarre, même en tant qu'utilisateur normal (mais c'es t
pareil en root), je ne peux exécuter ce binaire (qui a pourtant le dr oit
d'être exécuté par tous):
/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
renvoit:

bash: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
fichier ou répertoire de ce type

De ce qui précède je remarque que /usr/lib/libpixman-1.so.0.10.0 est une
bibliothèque 64 bits, ce qui ne doit pas coller avec le fait que le
binaire acroread est 32 bits. Là il doit bien y avoir un bug, puisque
tous les paquets ont été installés "classiquement" (aptitud e ou
synaptic). Mais ça ne me dit pas comment résoudre le problè me.

Merci pour votre patience et votre aide! Si vous avez toujours des
idées/conseils/pistes je suis preneur.
Cdlt,
F.B.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
giggzounet
Le #19757791
Frederic Baldit a écrit :
Bonsoir (maintenant c'est plutôt bonjour!!vu l'heure)

Je récapitule les résultats des commandes (mes essais sont faits à
partir d'un terminal ouvert sous gnome, en root ou non. L'icône du
Reader est bien installée dans les menus de gnome, mais si on veut
lancer acroread rien ne se passe):

1) en ligne de commande (root ou non) /usr/bin/acroread (script shell)
se plaint d'une bibliothèque soit-disant inexistante:

/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: error while
loading shared libraries: libpixman-1.so.0: cannot open shared object
file: No such file or directory

Or cette bibliothèque existe:
locate *libpixman* répond (entre autre):

/usr/lib/libpixman-1.so.0
/usr/lib/libpixman-1.so.0.10.0

puis la commande file /usr/lib/libpixman-1.so.0 répond:

/usr/lib/libpixman-1.so.0: symbolic link to `libpixman-1.so.0.10.0'

et file /usr/lib/libpixman-1.so.0.10.0 répond:

/usr/lib/libpixman-1.so.0.10.0: ELF 64-bit LSB shared object, x86-64,
version 1 (SYSV), dynamically linked, stripped

2) visiblement le fichier
/usrlib/Adobe/Reader8/Reader/intellinux/bin/acroread est bien un
exécutable 32 bits:
la commande file lib/Adobe/Reader8/Reader/intellinux/bin/acroread
renvoit:

/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: ELF 32-bit LSB
executable, Intel 80386, version 1 (SYSV), dynamically linked (uses
shared libs), for GNU/Linux 2.2.5, stripped

3) Pour une raison que je ne comprends pas ldd me jette en me disant que
le fichier n'existe pas:
la commande (en root)
ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
renvoit:

/usr/bin/ldd: line
117: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
fichier ou répertoire de ce type

(alors que, par exemple, lld /usr/bin/aptitude me donne bien la liste
des lib liées à aptitude)

4) Encore plus bizarre, même en tant qu'utilisateur normal (mais c'est
pareil en root), je ne peux exécuter ce binaire (qui a pourtant le droit
d'être exécuté par tous):
/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
renvoit:

bash: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
fichier ou répertoire de ce type

De ce qui précède je remarque que /usr/lib/libpixman-1.so.0.10.0 est une
bibliothèque 64 bits, ce qui ne doit pas coller avec le fait que le
binaire acroread est 32 bits. Là il doit bien y avoir un bug, puisque
tous les paquets ont été installés "classiquement" (aptitude ou
synaptic). Mais ça ne me dit pas comment résoudre le problème.

Merci pour votre patience et votre aide! Si vous avez toujours des
idées/conseils/pistes je suis preneur.
Cdlt,
F.B.




tu l as installé comment ce acroread ? avec les paquets de marillat ? ou
à la main ?

ça peut être un fichier corrompu sur ton disque. moi mon pc étant
vieillissant ça m'arrive parfois. Installe debsums et lance le avec les
options qui te conviennent. Il cherchera si tu as des paquets qui se
sont corrompus. Bon ça ne résoudra pas directement ton pb.

Pour acroread j'ai testé chez moi. ça fonctionne. j'ai les mêmes droits
que toi sur les fichiers et un ldd me renvoie bien ce qu'il doit renvoyer.

Ce que je ferai dans l'immédiat :
installe debsums
teste et regarde s'il te dit que tu as des paquets po bons.
reinstalle les paquets po bons
desinstalle acroread a fond. vire les fichiers cachés correspondant dans
ton home.
resintalle. et crois les doigts :)

bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Vincent Danjean
Le #19758521
Frederic Baldit wrote:
Bonsoir (maintenant c'est plutôt bonjour!!vu l'heure)

Je récapitule les résultats des commandes (mes essais sont faits à
partir d'un terminal ouvert sous gnome, en root ou non. L'icône du
Reader est bien installée dans les menus de gnome, mais si on veut
lancer acroread rien ne se passe):

1) en ligne de commande (root ou non) /usr/bin/acroread (script shell)
se plaint d'une bibliothèque soit-disant inexistante:

/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: error while
loading shared libraries: libpixman-1.so.0: cannot open shared object
file: No such file or directory

Or cette bibliothèque existe:
locate *libpixman* répond (entre autre):

/usr/lib/libpixman-1.so.0
/usr/lib/libpixman-1.so.0.10.0

puis la commande file /usr/lib/libpixman-1.so.0 répond:

/usr/lib/libpixman-1.so.0: symbolic link to `libpixman-1.so.0.10.0'

et file /usr/lib/libpixman-1.so.0.10.0 répond:

/usr/lib/libpixman-1.so.0.10.0: ELF 64-bit LSB shared object, x86-64,
version 1 (SYSV), dynamically linked, stripped

2) visiblement le fichier
/usrlib/Adobe/Reader8/Reader/intellinux/bin/acroread est bien un
exécutable 32 bits:
la commande file lib/Adobe/Reader8/Reader/intellinux/bin/acroread
renvoit:

/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: ELF 32-bit LSB
executable, Intel 80386, version 1 (SYSV), dynamically linked (uses
shared libs), for GNU/Linux 2.2.5, stripped

3) Pour une raison que je ne comprends pas ldd me jette en me disant que
le fichier n'existe pas:
la commande (en root)
ldd /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
renvoit:

/usr/bin/ldd: line
117: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
fichier ou répertoire de ce type

(alors que, par exemple, lld /usr/bin/aptitude me donne bien la liste
des lib liées à aptitude)

4) Encore plus bizarre, même en tant qu'utilisateur normal (mais c'est
pareil en root), je ne peux exécuter ce binaire (qui a pourtant le droit
d'être exécuté par tous):
/usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread
renvoit:

bash: /usr/lib/Adobe/Reader8/Reader/intellinux/bin/acroread: Aucun
fichier ou répertoire de ce type

De ce qui précède je remarque que /usr/lib/libpixman-1.so.0.10.0 est une
bibliothèque 64 bits, ce qui ne doit pas coller avec le fait que le
binaire acroread est 32 bits. Là il doit bien y avoir un bug, puisque
tous les paquets ont été installés "classiquement" (aptitude ou
synaptic). Mais ça ne me dit pas comment résoudre le problème.



acroread est un logiciel propriétaire => seul le binaire 32 bits existe.
Pour l'utiliser, il faut donc les versions 32 bits des bibliothèques.
/usr/bin/acroread est un script qui, vraisemblablement, positionne les
variables d'environnement 'qui vont bien' pour aller chercher les
bibliothèques 32 bits (probablement LD_LIBRARY_PATH qui pointe vers
/usr/lib32 et/ou /emul/ia32-linux/ )
Il faut avoir les versions 32bits des bibliothèques nécessaires à acroread
(qui NE seront PAS installées dans /usr/lib sur amd64)
À mon avis, le problème peut venir :
- de l'installation d'acroread qui n'a pas tiré ses dépendances correctement
(que ça soit avec APT ou avec un installeur perso)
- ou du bordel actuel avec les lib32 sur amd64 en unstable

Merci pour votre patience et votre aide! Si vous avez toujours des
idées/conseils/pistes je suis preneur.



De manière très crade (ie ne passera pas les mises à jour, laissera des
fichiers sans paquet propriétaire sur ton système, ... mais qui devrait
permettre de résoudre ton pb) : prend le paquet Debian i386 qui contient
ta bibliothèque manquante, extrait le dans un répertoire temporaire
(dpkg -x lib.....deb /tmp/extraction), va chercher la/les bibliothèques
qui te manque, copie/déplace les dans /usr/lib32 et/ou /emul/ia32-linux/

A+
Vincent

Cdlt,
F.B.





--
Vincent Danjean GPG key ID 0x9D025E87
GPG key fingerprint: FC95 08A6 854D DB48 4B9A 8A94 0BF7 7867 9D02 5E87
Unofficial pacakges: http://moais.imag.fr/membres/vincent.danjean/deb.html
APT repo: deb http://perso.debian.org/~vdanjean/debian unstable main

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
YOUNOUSS Abba Soungui
Le #19763641
--nextPart1745783.ZQsfL0xbJZ
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour,

Installe le paquet ia32libs et éssayes à nouveau

--nextPart1745783.ZQsfL0xbJZ
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkpeNk4ACgkQyVjEFylGLtTv4wCfXrlSvVWyjk2pCwYtegKUclbb
SY0AnjSwOpgt8XJY46KEh5gY0HwtiD7H
=mbUW
-----END PGP SIGNATURE-----

--nextPart1745783.ZQsfL0xbJZ--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
serge
Le #19763871
Salut;

* En suivant ce lien ( ubuntu.fr ) tu trouveras des informations pour
installer/configurer/problèmes possibles avec 'acroread' sur une x86 e t entre
autre, une astuce pour combler le manque de la
librairie '/usr/lib/xulrunner-1.9' en 32bits:


En espérant que cela te donne un "coup de pouce"...
--
(o_
(/)_
S e r g e

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme