parametre

Le
Michel
Bonjour,
La ligne ci-dessous fonctionne bien
Range("f2").FormulaLocal = "=SI(D2<>"""";DATEDIF(D2;G2;""D"");""Jamais
ouverte"")"

Maintenant je voudrais faire un truc du genre

For i = 2 to derligne (c'est la derniere ligne du classeur)
Range("f2").FormulaLocal = "=SI(D2<>"""";DATEDIF(D2;G2;""D"");""Jamais
ouverte"")"
Next i

Ma question est la suivante: Comment passer la variable i à la place de
D2 (D reste constant et seul le numéro doit changer en fonction de i.
(j'espère avoir été clair).
Je galère
Merci de l'aide
M.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #19022291
bonjour Michel,

Range("f2").FormulaLocal = "=SI(D" & i "&
"2<>"""";DATEDIF(D2;G2;""D"");""Jamais ouverte"")"

si il faut le mettre au 2 places ;

Range("f2").FormulaLocal = "=SI(D" & i "& "2<>"""";DATEDIF(D" & i "&
";G2;""D"");""Jamais ouverte"")"

isabelle

Michel a écrit :
Bonjour,
La ligne ci-dessous fonctionne bien
Range("f2").FormulaLocal = "=SI(D2<>"""";DATEDIF(D2;G2;""D"");""Jamais
ouverte"")"

Maintenant je voudrais faire un truc du genre
---------------------------------------------------------------------
For i = 2 to derligne (c'est la derniere ligne du classeur)
Range("f2").FormulaLocal = "=SI(D2<>"""";DATEDIF(D2;G2;""D"");""Jamais
ouverte"")"
Next i
---------------------------------------------------------------------
Ma question est la suivante: Comment passer la variable i à la place de
D2 (D reste constant et seul le numéro doit changer en fonction de i.
(j'espère avoir été clair).
Je galère
Merci de l'aide
M.




isabelle
Le #19022251
correction :

Range("f2").FormulaLocal = "=SI(D" & i &
"2<>"""";DATEDIF(D2;G2;""D"");""Jamais ouverte"")"

'si il faut le mettre au 2 places ;

Range("f2").FormulaLocal = "=SI(D" & i & "2<>"""";DATEDIF(D" & i &
";G2;""D"");""Jamais ouverte"")"

isabelle

isabelle a écrit :
bonjour Michel,

Range("f2").FormulaLocal = "=SI(D" & i "&
"2<>"""";DATEDIF(D2;G2;""D"");""Jamais ouverte"")"

si il faut le mettre au 2 places ;

Range("f2").FormulaLocal = "=SI(D" & i "& "2<>"""";DATEDIF(D" & i "&
";G2;""D"");""Jamais ouverte"")"

isabelle

Michel a écrit :
Bonjour,
La ligne ci-dessous fonctionne bien
Range("f2").FormulaLocal =
"=SI(D2<>"""";DATEDIF(D2;G2;""D"");""Jamais ouverte"")"

Maintenant je voudrais faire un truc du genre
---------------------------------------------------------------------
For i = 2 to derligne (c'est la derniere ligne du classeur)
Range("f2").FormulaLocal =
"=SI(D2<>"""";DATEDIF(D2;G2;""D"");""Jamais ouverte"")"
Next i
---------------------------------------------------------------------
Ma question est la suivante: Comment passer la variable i à la place de
D2 (D reste constant et seul le numéro doit changer en fonction de i.
(j'espère avoir été clair).
Je galère
Merci de l'aide
M.






Michel
Le #19022741
isabelle a émis l'idée suivante :
correction :



si il faut le mettre au 2 places ;

Range("f2").FormulaLocal = "=SI(D" & i "& "2<>"""";DATEDIF(D" & i "&
";G2;""D"");""Jamais ouverte"")"





Super ça fonctionne (juste un petit 2 en trop avant <>) et j'avais
oublié d'incrémenter F


Range("f" & i).FormulaLocal = "=SI(D" & i & "<>"""";DATEDIF(D" & i &
";G2;""D"");""Jamais ouverte"")"

Merci beaucoup Isabelle


Michel
Ellimac
Le #19023821
Bonjour,

Il serait plus rapide d'éviter la boucle avec une recopie vers le bas
jusqu'à derligne :

Range("f2").AutoFill Destination:=Range("F2:F" & derligne)

Camille

"Michel"
Bonjour,
La ligne ci-dessous fonctionne bien
Range("f2").FormulaLocal = "=SI(D2<>"""";DATEDIF(D2;G2;""D"");""Jamais
ouverte"")"

Maintenant je voudrais faire un truc du genre
---------------------------------------------------------------------
For i = 2 to derligne (c'est la derniere ligne du classeur)
Range("f2").FormulaLocal = "=SI(D2<>"""";DATEDIF(D2;G2;""D"");""Jamais
ouverte"")"
Next i
---------------------------------------------------------------------
Ma question est la suivante: Comment passer la variable i à la place de
D2 (D reste constant et seul le numéro doit changer en fonction de i.
(j'espère avoir été clair).
Je galère
Merci de l'aide
M.




Michel
Le #19022721
Michel a couché sur son écran :

Merci à Tous c'est parfait
Publicité
Poster une réponse
Anonyme