Partage de connexion internet par Airport : le DHCP ne marche pas

Le
cfranco
Bonjour à tous,

Pour celles et ceux qui ont suivi, la suite du feuilleton "internet en
vacances".

Je me retrouve donc avec un point de connexion à internet (par cable
ethernet), un MacBook pro, et un PC Shuttle doté d'une carte WiFi (qui
marche très bien). Pour des raisons pratiques, il m'est quasiment
impossible de connecter le PC par cable, je souhaiterais donc utiliser
le partage de connexion internet du mac, en connectant le MBP par ce
câble, et en le configurant pour créer un réseau Ad-Hoc.

La connexion internet sur le mac fonctionne. Airport fonctionne, le PC
se connecte dessus (avec une clé WEP 128bit), mais le PC n'obtient pas
d'adresse IP (il est bien sûr configuré en DHCP).

Y a-t-il un réglage particulier sur le mac pour que avec le partage de
connexion on ait le serveur DHCP activé ? Je pensais que c'était
automatique.

--
Christophe Franco
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nina Popravka
Le #2568401
On Sun, 9 Sep 2007 20:17:28 +0200, (Christophe
Franco) wrote:

Y a-t-il un réglage particulier sur le mac pour que avec le partage de
connexion on ait le serveur DHCP activé ? Je pensais que c'était
automatique.


Oui c'est automatique et oui ça marche, mais faut surtout pas
contrarier le Mac : pour lui, le réseau partagé c'est 10.0.2.0/24,
l'interface Airport c'est 10.0.2.1 et si tu essaies de le faire
changer d'avis, ça marche plus.
--
Nina

cfranco
Le #2568381
Nina Popravka
Y a-t-il un réglage particulier sur le mac pour que avec le partage de
connexion on ait le serveur DHCP activé ? Je pensais que c'était
automatique.


Oui c'est automatique et oui ça marche, mais faut surtout pas
contrarier le Mac : pour lui, le réseau partagé c'est 10.0.2.0/24,
l'interface Airport c'est 10.0.2.1 et si tu essaies de le faire
changer d'avis, ça marche plus.


Oui, pour ça pas de problème, sur le mac l'airport est bien sur
10.0.2.1, mais le PC ne voit aucun serveur DHCP... Et même si je met
manuellement au PC une IP du genre 10.0.2.2, il ne voit pas le mac...

--
Christophe Franco


Nina Popravka
Le #2568371
On Sun, 9 Sep 2007 20:46:36 +0200, (Christophe
Franco) wrote:

Oui, pour ça pas de problème, sur le mac l'airport est bien sur
10.0.2.1, mais le PC ne voit aucun serveur DHCP... Et même si je met
manuellement au PC une IP du genre 10.0.2.2, il ne voit pas le mac...


Vérifie ta clé WEP, je pense que tu n'es pas connecté.
Je viens de tester entre MacOSX et Vista, ça fonctionne sans souci.
D'autre part, attention, tu es sur un Mac, donc avec la conception à
la con d'Apple de ce qu'est une clé WEP.
J'ai fait un post récemment là dessus, j'essaie de te le retrouver.
--
Nina

Nina Popravka
Le #2568361
On Sun, 09 Sep 2007 20:48:05 +0200, Nina Popravka

J'ai fait un post récemment là dessus, j'essaie de te le retrouver.


Voilà...
--
Nina

cfranco
Le #2568351
Nina Popravka
Oui, pour ça pas de problème, sur le mac l'airport est bien sur
10.0.2.1, mais le PC ne voit aucun serveur DHCP... Et même si je met
manuellement au PC une IP du genre 10.0.2.2, il ne voit pas le mac...


Vérifie ta clé WEP, je pense que tu n'es pas connecté.
Je viens de tester entre MacOSX et Vista, ça fonctionne sans souci.
D'autre part, attention, tu es sur un Mac, donc avec la conception à
la con d'Apple de ce qu'est une clé WEP.
J'ai fait un post récemment là dessus, j'essaie de te le retrouver.


Pour la clé WEP, j'ai eu quelques soucis, dans la mesure où le mac me
propose 40 ou 128 bit, et le PC n'accepte que 64 ou 128 bit, mais en
mettant 128 bit (avec une clé à 13 caractères, tous des lettres), et en
définissant explicitement la connexion comme une connexion AdHoc (dans
la config du PC), le PC m'annonce qu'il est connecté à 54Mbps, donc ça a
l'air d'aller...

J'ai même essayé en désactivant totalement le WEP (le truc qu'il faut
pas faire...), ça se connecte exactement de la même manière... mais sans
DHCP.

--
Christophe Franco


Nina Popravka
Le #2568341
On Sun, 9 Sep 2007 20:59:02 +0200, (Christophe
Franco) wrote:

(dans
la config du PC), le PC m'annonce qu'il est connecté à 54Mbps, donc ça a
l'air d'aller...


Non. C'est une spécialité de XP. Quand la clé est fausse, il te
prétend connecté quand même :-)
--
Nina

cfranco
Le #2568331
Nina Popravka
Oui, pour ça pas de problème, sur le mac l'airport est bien sur
10.0.2.1, mais le PC ne voit aucun serveur DHCP... Et même si je met
manuellement au PC une IP du genre 10.0.2.2, il ne voit pas le mac...


Vérifie ta clé WEP, je pense que tu n'es pas connecté.
Je viens de tester entre MacOSX et Vista, ça fonctionne sans souci.
D'autre part, attention, tu es sur un Mac, donc avec la conception à
la con d'Apple de ce qu'est une clé WEP.
J'ai fait un post récemment là dessus, j'essaie de te le retrouver.


Pour la clé WEP, j'ai eu quelques soucis, dans la mesure où le mac me
propose 40 ou 128 bit, et le PC n'accepte que 64 ou 128 bit, mais en
mettant 128 bit (avec une clé à 13 caractères, tous des lettres), et en
définissant explicitement la connexion comme une connexion AdHoc (dans
la config du PC), le PC m'annonce qu'il est connecté à 54Mbps, donc ça a
l'air d'aller...

J'ai même essayé en désactivant totalement le WEP (le truc qu'il faut
pas faire...), ça se connecte exactement de la même manière... mais sans
DHCP.

Conclusion, je ne pense pas que le problème vienne d'une absence de
connexion WiFi...

--
Christophe Franco


cfranco
Le #2568141
Nina Popravka
(dans
la config du PC), le PC m'annonce qu'il est connecté à 54Mbps, donc ça a
l'air d'aller...


Non. C'est une spécialité de XP. Quand la clé est fausse, il te
prétend connecté quand même :-)


C'est pas du XP, c'est du 2000. Mais c'est peut-être pareil...

Cela étant... je pense que tu as raison, le PC m'annonce que la
connexion WiFi est active quelle que soit la clé que je tape, je peux
mettre n'importe quoi, aussi bien "1234567890abcdef" que "zorglub", le
PC dit toujours que c'est connecté...

--
Christophe Franco


Nina Popravka
Le #2568121
On Sun, 9 Sep 2007 21:15:34 +0200, (Christophe
Franco) wrote:

C'est pas du XP, c'est du 2000. Mais c'est peut-être pareil...

Cela étant... je pense que tu as raison, le PC m'annonce que la
connexion WiFi est active quelle que soit la clé que je tape, je peux
mettre n'importe quoi, aussi bien "1234567890abcdef" que "zorglub", le
PC dit toujours que c'est connecté...


En tout cas, là, je te cause d'un 2k connecté au partage du Mac, avec
12345678901234567890abcdef comme clé WEP.
Avec l'utilitaire de ma clé wiif, pas le truc intégré de w2k, y a des
limites à l'abnégation ;->
--
Nina

cfranco
Le #2568101
Nina Popravka
C'est pas du XP, c'est du 2000. Mais c'est peut-être pareil...

Cela étant... je pense que tu as raison, le PC m'annonce que la
connexion WiFi est active quelle que soit la clé que je tape, je peux
mettre n'importe quoi, aussi bien "1234567890abcdef" que "zorglub", le
PC dit toujours que c'est connecté...


En tout cas, là, je te cause d'un 2k connecté au partage du Mac, avec
12345678901234567890abcdef comme clé WEP.
Avec l'utilitaire de ma clé wiif, pas le truc intégré de w2k, y a des
limites à l'abnégation ;->


Il y a un truc intégré dans 2000 pour les clés WEP ? perso je n'ai que
le logiciel de Linksys...

Bon, là je me suis arrivé à un point où ce fameux driver Linksys ne voit
même plus aucun réseau WiFi, même pas ceux des voisins (qu'il voyait
encore il y a 1/2 heure). Je renonce, tant pis ça sera le PC branché
avec un cable, et le mac avec un cable à côté... même si c'est pas
pratique...

--
Christophe Franco


Publicité
Poster une réponse
Anonyme