Partitions avec fausses notes

Le
Michel Giacomazzi
Bonjour,

Je sèche sur l'explication d'un dysfonctionnement, malgré une relecture
attentive des oeuvres de JCB et d'autres sur le sujet.

Pour refaire l'installation complète d'un PC, j'ai créé (Partition Magic
8) les partitions suivantes sur un DD :

C: (MS-DOS) - FAT16 - Primaire - Bootable - 100 Mo
Partition étendue :
D: (Win2K) - FAT32 - 4,5 Go
E: (Données) - FAT32 - 7 Go
Swap Linux - 512 Mo
/ - ext3 - 3 Go
/home - ext3 - le reste du DD

Juste pour être complet : un 2ème DD comporte une seule partition
étendue encapsulant une partition logique (F:) en FAT32.
Rien de très exotique, me semble-t-il.

Au cours de la ré-installation de W2K, je fais de temps en temps une
image de D: avec Drive Image 5 (que j'utilise depuis

fort longtemps)
Après ré-installation complète de Win2k, je veux vérifier que la
partition D: peut bien être restaurée à partir de son image.
Et là, Drive image me dit qu'il ne sait pas gérer ce système de fichiers
(erreur 510) ; vu que c'est du FAT32 qui n'est pas vraiment récent
Ghost 7 fait pire : lui aussi crée bien l'image, démarre la
restauration, mais se fige au bout de 25 % environ
Par contre, DriveImage XML (sur Ultimate Boot CD Win) crée l'image et la
restaure correctement.

Ce que me raconte PTEDIT sur le 1er DD me semble conforme à ce que je
voulais :
FAT16B (Type 06) - 100 MB Bootable (Boot 80)
ExtendedX (Type 0F) - 17429 MB
FAT32 (Type 0B) - 4502 MB
Extended (Type 05) - 7004 MB
FAT32 (Type 0B) - 7004 MB
Extended (Type 05) - 517 MB
Linux swap (Type 82) - 517 MB
Extended (Type 05) - 3004 MB
Linux native (Type 83) - 3004 MB
Extended (Type 05) - 2400 MB
Linux native (Type 83) - 2400 MB

Si on supprime les 2 partitions en ext3 *sans rien changer d'autre* (en
particulier, la partition étendue "enveloppante" fait

toujours 17 Go), Drive Image ou Ghost restaurent alors correctement la
partition D:.
Pour le moment ce n'est pas gênant car Linux n'a pas été réinstallé,
mais après ça le sera beaucoup plus

Je suis tenté d'adopter l'une des solutions suivantes :
- Utiliser DriveImage XML
Mais, d'une part vu le temps de chargement d'"Ultimate boot CD" c'est
assez décourageant, d'autre part la partition DOS

devient quasiment inutile (son but est justement d'éviter des boot sur
CD, clé USB, carte perforée, )
- Sortir mon chéquier pour acquérir une version récente d'un Ghost ou
équivalent
Mais comme je n'ai pas l'explication de ce qui se passe, je ne suis
pas sûr que cela résolve le problème.
- Transformer les partitions ext3 en partitions primaires
A priori, ça pourrait fonctionner dans ce cas, mais d'une part ce
n'est qu'une solution de contournement (avec une

partition de plus, ça ne marche plus), et d'autre part, je ne suis pas
sûr que DOS traite cela correctement

Je soupçonne quelque chose lié au LBA, mais c'est purement intuitif.
Ce qui est curieux (et anormal, à mon avis) et que DI et Ghost arrivent
très bien à faire une image exploitable (elles ont

été restaurées finalement), mais ne sachent plus la restaurer dans la
même configuration.

Merci d'avance à celui ou celle qui saura me fournir l'explication.

--
Michel Giacomazzi
http://www.giacomazzi.fr/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
William Marie
Le #309144
"Michel Giacomazzi" 46548dd6$0$27403$
Bonjour,

Je sèche sur l'explication d'un dysfonctionnement, malgré une relecture
attentive des oeuvres de JCB et d'autres sur le sujet.

J'ai aussi donné dans ces misères ! Bien simple : je sauvegardais,

redimensionnais, copiais mes partitions avec PM 8.05 et Ghost 2003 jusqu'au
jour... où je me suis offert des disques de 250 Go. Là rien n'allait plus.
Qu'ils soient SATAniques ou PATAnique. C'était même plus vicelard : tout
semblait bien se passer mais Windows ne redétectait pas certains disques
comme il le fait toujours lorsqu'on a effectué quelques modifs pendant qu'il
roupillait. Et pas de redétection, pas de Windows qui fonctionne.

Pas trouvé d'explication causale, mais c'est lié à la taille globale du
disque et avec les derniers logiciels d'Acronis (Director Partition suite et
True Image) tout se passe à nouveau très bien.
--
=================================== William Marie
Attention antiSpam remplacer trapellun.invalid
par free.fr
Web : http://wmarie.free.fr
http://www.pandemonium.dnsalias.org (site expérimental)
====================================

geo cherchetout
Le #309100
Le 23.05.2007 20:54, *Michel Giacomazzi* a écrit fort à propos :
Bonjour,


Bonsoir,
Et merci pour ta table des matières Elektor que je récupère tous les
ans. :-)

Merci d'avance à celui ou celle qui saura me fournir l'explication.


Aucune explication à te proposer mais pourquoi n'essaierais tu pas
partimage ?
http://www.partimage.org/Index.fr.html

jerome balti
Le #309099
Bonjour,


je fais une copie vers "stockage"

les problemes de DD sont chiants, c'est bien de les regrouper un peu
dans le forum dédiés pour que les discussions y soient archivées !



Par contre, DriveImage XML (sur Ultimate Boot CD Win) crée l'image et la
restaure correctement.



j ai des problemes avec driveimage XML , les backups/images se font
bien , mais ça plante a chaque fois ...




Je suis tenté d'adopter l'une des solutions suivantes :
- Utiliser DriveImage XML
Mais, d'une part vu le temps de chargement d'"Ultimate boot CD" c'est
assez décourageant, d'autre part la partition DOS


j utilise driveimage xml avec un boot cd créé avec bart PE builder, si
tu as un CD xp recent, il suffit d utiliser le builder et d integrer
le plug in drive image xml

ça marche bien , je veux dire le cd PE et dxml , mais j ai toujours un
plantage (figé) avant la fin de la restauration sur mon disque c:

pas cool , donc,



- Sortir mon chéquier pour acquérir une version récente d'un Ghost ou
équivalent


faut que j essaie un autre truc

acronis true image a une demo 15 jours, je sais pas si c est
completement fonctionnel (?)




--
Vacances à Oléron !
http://www.26266.ikoula.org/oleron/

Th.A.C
Le #309830
j'ai eu un problème similaire avec une mandrake 9.x.

Au final, j'en ai conclu que l'install de linux créait des partitions
que DriveImage (et aussi partition magique) ne reconnaissaient pas.
Ou plus exactement, que les partitions avaient des valeurs jugées
incorrectes.

J'ai fini par créer des partitions pour linux (avec partition magic)
avant de l'installer, en me contentant juste de reformater les
partitions pendant l'installation.

J'ai remarqué plusieurs fois (et encore assez récemment) que les outils
de linux ne gèrent pas toujours les disques/partitions de la même manière.
Il semble que c'est du à la manière dont le bios est configuré. En
particulier quand le bios gère le disque dur en mode CHS au lieu du mode
LBA. Les derniers noyaux sont censés contourner ce problème, mais ce
n'est pas toujours le cas.

Normalement, le bios devrait toujours gérer le disque en mode LBA, c'est
la solutions la plus logique et la plus propre, mais certains bios ont
une config par défaut en mode CHS.
Philippe ANDRE
Le #309829


acronis true image a une demo 15 jours, je sais pas si c est
completement fonctionnel (?)
Bonjour


Totalement fonctionnel : je viens de l'utiliser pour faire une sauvegarde puis restauration de partitions sur un autre DD.

Philippe

Michel Giacomazzi
Le #309725
J'en profite pour répondre à d'autres contributeurs, car tout cela est
un peu lié.
j'ai eu un problème similaire avec une mandrake 9.x.

Au final, j'en ai conclu que l'install de linux créait des partitions
que DriveImage (et aussi partition magique) ne reconnaissaient pas.
Ou plus exactement, que les partitions avaient des valeurs jugées
incorrectes.

J'ai fini par créer des partitions pour linux (avec partition magic)
avant de l'installer, en me contentant juste de reformater les
partitions pendant l'installation.

J'ai adopté la même solution, mais avec un diagnostic différent (sur la

précédente config.) : en essayant d'installer KLA (dérivée de
Knoppix/Debian) j'ai commencé par essayer de partitionner avec QParted,
mais je n'ai jamais réussi : je voulais une swap, une "/" et une "/home"
... et je n'ai jamais pu créer la dernière.
D'où une création avec PM 8 puis un formatage au cours de l'installation
par Linux.
Pour répondre à "geo cherchetout" :
Les tests que j'ai fait il y a quelques temps avec Partimage étaient
concluants, y compris sur des partitions FAT32.
Mais je ne retiens pas cette solution pour 2 raisons :
- Ces utilitaires sont en version 0.x, donc pas encore stables, et je
veux le maximum de sécurité (c'est la dernière chance en cas de problème)
- J'ai fait une petite partition "MS-DOS" pour éviter d'utiliser un CD
ou une clé USB. Si je voulais utiliser Partimage, il faudrait que cette
partition soit "Linux" (avec tous les utilitaires appropriés ... il n'y
a pas tout aujourd'hui) et changer mon système de boot (ça c'est a
priori faisable avec GAG, par exemple)

Pour répondre à "William Marie" :
Dans mon cas, la taille ne semble pas être le problème : le DD fait 20 Go.
Puisque tout fonctionne correctement dès que je supprime 2 partitions
(vides), je vois 2 genres d'hypothèses :
- le nombre de partitions en "poupée russe" dans la partition étendue
- une tentative d'adressage des partitions "vides"
Mais pourquoi est-ce que ça fonctionne à la sauvegarde ? Mystère ...
[...]
Normalement, le bios devrait toujours gérer le disque en mode LBA, c'est
la solutions la plus logique et la plus propre, mais certains bios ont
une config par défaut en mode CHS.
Je suis bien d'accord : dans une période transitoire, on pouvait

admettre un CHS natif "translaté" en LBA, mais aujourd'hui c'est "quick
and dirty" comme solution.
Peut-être que l'explication n'est pas technique mais financière : pas
cher et vendable ...

Pour mon problème, d'après ce que j'ai lu, il ne semble pas y avoir
d'explication, mais que la solution passe par l'utilisation d'un autre
logiciel de sauvegarde/restauration.
Je vais tenter Savepart (libre et apparemment éprouvé).
Si ça ne marche pas, j'essaierai True Image (Acronis ) et Drive Backup
(Paragon), mais je n'aime guère les sauvegardes "à la volée" et j'ai
l'impression que pour les sauvegardes/restaurations en monotâche ces
logiciels ont leur propre OS "standalone", donc pas MS-DOS.
Je conçois que pour un serveur fonctionnant 24h/24 et 7j/7 il faille une
solution "à la volée" ; j'ai vu ça dans une de mes dernières missions
professionnelles ... mais le coût était en dizaines de milliers d'euros
rien que pour le matériel+logiciel.
L'argument de la sauvegarde "à chaud" pour les 2 logiciels cités me
paraît donc plus marketing que technique.

Je vous tiens au courant de mes essais

--
Michel Giacomazzi
http://www.giacomazzi.fr/

Michel Giacomazzi
Le #309681
[...]
Je vais tenter Savepart (libre et apparemment éprouvé).
Je rectifie : il n'est pas libre mais gratuit

[...]
Je vous tiens au courant de mes essais

Avec SAVEPART 3.4, la sauvegarde ET la restauration ont pu être

effectuées en ayant toutes les partitions présentes (ce que ne savaient
pas faire Drive image 5 et Ghost 7).
Avec un taux de compression analogue à celui du taux maximum de DI5 (la
partition sauvegardée fait 4,5 Go dont 3,1 Go utilisés, l'image fait 1,7
Go), le temps de sauvegarde est identique à celui de DI5 (16 mn), par
contre la restauration est plus longue (16 mn contre 10 mn)
J'en ai profité pour tester (avec succès) la sauvegarde/restauration du
MBR et de la Table de partitions et la restauration unitaire de fichiers
à partir de l'image.
Pas de conclusion définitive, car il faut s'assurer du bon
fonctionnement sur "une certaine durée", mais ça semble résoudre mon
problème.
Mais ça ne donne pas l'explication de ce qui s'est passé ...

--
Michel Giacomazzi
http://www.giacomazzi.fr/

Publicité
Poster une réponse
Anonyme