Pas de son sur les Applis JAVA !

Le
titim3 Hors ligne
Bonjour,

Je suis sur Linux depuis une semaine et je n'y connait pas grand chose.
Mon probléme est simple j'ai télecharger un jeu utilisant JAVA (le jeu est Minecraft) et je n'ai tout simplement aucun son sur le jeu. Pourtant lorsque je vais sur youtube ou d'autres sites le son est bien là!!
En cherchant un peu partout sur les forum j'ai trouver une solution à ce probléme.
Apparament linux utilise ALSA par défaut pour lire le son, et JAVA utilise OSS ce qui explique le probléme de son sur les applis JAVA.
On ma conseiller d'utiliser l'émulateur OSS que je pense avoir correctement télecharger dans: Systéme->Administration->Gestionnaire de paquets synaptic.
Le ficher que j'ai télecharger s'appel "AUDIOOSS".
Mais je ne sait pas comment le faire fonctionner.
Donc j'ai voulu supprimer un paquet Alsa (Alsa base je croit) et j'ai télecharger le paquet Oss Base, mais le son ne fonctionne toujours pas.
Enfin lorsque je vais dans: Systéme->Préférences->Son
L'écran affiche "Attente de réponse du sytéme sonore"
Et avant de faire mais bidouillages, toujours dans:
Systéme->Préférences->Son->Application
L'écran affichait Alsa en appli puis lorsque j'ai supprimer une parti d'Alsa il ne m'afficher plus rien dans: Systéme->Préférences->Son->Application

Ensuite lorsque je vais dans:
Systéme->Administration->Pilotes de périphériques
L'écran affiche: "Aucun pilote propriétaire n'est utilisé sur ce système." Et c'est tout, l'icône est modéliser avec un cadena et le bouton activer est grisé!!
Que faire!!!
J'attend vos réponses avec impatience.
Merci de m'avoir lu jusqu'ici et excusé mes fautes d'orthographes.

Titim3
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Jacques Gerbaud
Le #23173231
Le 03/03/2011 16:24, titim3 a écrit :

Bonjour,

Je suis sur Linux depuis une semaine et je n'y connait pas grand chose.
Mon probléme est simple j'ai télecharger un jeu utilisant JAVA (le jeu est
Minecraft) et je n'ai tout simplement aucun son sur le jeu. Pourtant lorsque je
vais sur youtube ou d'autres sites le son est bien là!!
En cherchant un peu partout sur les forum j'ai trouver une solution à ce
probléme.
Apparament linux utilise ALSA par défaut pour lire le son, et JAVA utilise OSS
ce qui explique le probléme de son sur les applis JAVA.
On ma conseiller d'utiliser l'émulateur OSS que je pense avoir correctement
télecharger dans: Systéme->Administration->Gestionnaire de paquets synaptic.
Le ficher que j'ai télecharger s'appel "AUDIOOSS".
Mais je ne sait pas comment le faire fonctionner.
Donc j'ai voulu supprimer un paquet Alsa (Alsa base je croit) et j'ai
télecharger le paquet Oss Base, mais le son ne fonctionne toujours pas.
Enfin lorsque je vais dans: Systéme->Préférences->Son
L'écran affiche "Attente de réponse du sytéme sonore"
Et avant de faire mais bidouillages, toujours dans:
Systéme->Préférences->Son->Application
L'écran affichait Alsa en appli puis lorsque j'ai supprimer une parti d'Alsa
il ne m'afficher plus rien dans: Systéme->Préférences->Son->Application

Ensuite lorsque je vais dans:
Systéme->Administration->Pilotes de périphériques
L'écran affiche: "Aucun pilote propriétaire n'est utilisé sur ce système." Et
c'est tout, l'icône est modéliser avec un cadena et le bouton activer est
grisé!!
Que faire!!!
J'attend vos réponses avec impatience.
Merci de m'avoir lu jusqu'ici et excusé mes fautes d'orthographes.

Titim3




Bonjour Titim3

Pas de panique, effectivement il peut y avoir des problèmes de son sous
Linux on trouve toujours une solution.

Mais il nous faut quelques renseignements :

Quelle distribution Linux, quel environnement graphique (KDE ou Gnome) ?

Tu n'aurais peut être pas dû supprimer Alsa car Oss est vraiment obsolète et
je suis à peu près sûr que ton jeu aurait fonctionné avec Alsa.

Il y a quand même quelque chose que tu peux faire en attendant.
Lancer alsamixer

Pour ce faire : Touche Alt + (en même temps F2 ---> la touche F2 qui se
trouve tout en haut du clavier.

Il y a une petite fenêtre qui s'ouvre et tu écris "alsamixer" (sans les
guilletmets :-). Il faut aussi cocher "lancer dans un terminal"

Tu arrives sur une fenêtre tout en noir avec des cartouches verticaux.

Tout en haut : ta carte son (si ce n'est pas la bonne, tu peux la modifier
en appuyant sur F6 ---> tu connais déjà F2, tu connaîtras donc en même temps
F6 !

Sur les cartouches verticaux, il y a en premier "Master" et, un peu plus
loin "PCM". Il faut que les deux soient "ouverts"n, c'est à dire non-muets.
Ceux qui sont muets sont marqués "MM". Pour les rendre "non-muets", il
suffit d'appuyer sur la touche "m".

Si un des deux était muet, c'est normal que tu n'aies pas de son.

Si tu n'entends toujours pas de son, vérifies quand même que les hauts
parleurs soient allumés et ... Il m'est arrivé de ne pas avoir de son et je
me suis aperçu, après pas mal de galère, que les hauts parleurs étaient
éteints !

Allez, bonne chance, et réponds aux questions que je t'ai posées plus haut
et ajoutes tout renseignement qui pourrait nous être utile.

A bientôt

--
Jean-Jacques Gerbaud
entre Dauphiné et PACA
titim3 Hors ligne
Le #23175521
Jean-Jacques Gerbaud a écrit le 03/03/2011 à 16h45 :
Le 03/03/2011 16:24, titim3 a écrit :

Bonjour,

Je suis sur Linux depuis une semaine et je n'y connait pas grand chose.
Mon probléme est simple j'ai télecharger un jeu utilisant JAVA
(le jeu est
Minecraft) et je n'ai tout simplement aucun son sur le jeu. Pourtant lorsque
je
vais sur youtube ou d'autres sites le son est bien là!!
En cherchant un peu partout sur les forum j'ai trouver une solution à
ce
probléme.
Apparament linux utilise ALSA par défaut pour lire le son, et JAVA
utilise OSS
ce qui explique le probléme de son sur les applis JAVA.
On ma conseiller d'utiliser l'émulateur OSS que je pense avoir
correctement
télecharger dans: Systéme->Administration->Gestionnaire de
paquets synaptic.
Le ficher que j'ai télecharger s'appel "AUDIOOSS".
Mais je ne sait pas comment le faire fonctionner.
Donc j'ai voulu supprimer un paquet Alsa (Alsa base je croit) et j'ai
télecharger le paquet Oss Base, mais le son ne fonctionne toujours pas.
Enfin lorsque je vais dans:
Systéme->Préférences->Son
L'écran affiche "Attente de réponse du sytéme
sonore"
Et avant de faire mais bidouillages, toujours dans:
Systéme->Préférences->Son->Application
L'écran affichait Alsa en appli puis lorsque j'ai supprimer une parti
d'Alsa
il ne m'afficher plus rien dans:
Systéme->Préférences->Son->Application

Ensuite lorsque je vais dans:
Systéme->Administration->Pilotes de périphériques
L'écran affiche: "Aucun pilote propriétaire n'est
utilisé sur ce système." Et
c'est tout, l'icône est modéliser avec un cadena et le bouton
activer est
grisé!!
Que faire!!!
J'attend vos réponses avec impatience.
Merci de m'avoir lu jusqu'ici et excusé mes fautes d'orthographes.

Titim3





Bonjour Titim3

Pas de panique, effectivement il peut y avoir des problèmes de son sous
Linux on trouve toujours une solution.

Mais il nous faut quelques renseignements :

Quelle distribution Linux, quel environnement graphique (KDE ou Gnome) ?

Tu n'aurais peut être pas dû supprimer Alsa car Oss est vraiment
obsolète et
je suis à peu près sûr que ton jeu aurait fonctionné
avec Alsa.

Il y a quand même quelque chose que tu peux faire en attendant.
Lancer alsamixer

Pour ce faire : Touche Alt + (en même temps F2 ---> la touche F2 qui
se
trouve tout en haut du clavier.

Il y a une petite fenêtre qui s'ouvre et tu écris
"alsamixer" (sans les
guilletmets :-). Il faut aussi cocher "lancer dans un terminal"

Tu arrives sur une fenêtre tout en noir avec des cartouches verticaux.

Tout en haut : ta carte son (si ce n'est pas la bonne, tu peux la modifier
en appuyant sur F6 ---> tu connais déjà F2, tu
connaîtras donc en même temps
F6 !

Sur les cartouches verticaux, il y a en premier "Master" et, un peu
plus
loin "PCM". Il faut que les deux soient "ouverts"n, c'est
à dire non-muets.
Ceux qui sont muets sont marqués "MM". Pour les rendre
"non-muets", il
suffit d'appuyer sur la touche "m".

Si un des deux était muet, c'est normal que tu n'aies pas de son.

Si tu n'entends toujours pas de son, vérifies quand même que les
hauts
parleurs soient allumés et ... Il m'est arrivé de ne pas avoir de
son et je
me suis aperçu, après pas mal de galère, que les hauts
parleurs étaient
éteints !

Allez, bonne chance, et réponds aux questions que je t'ai posées
plus haut
et ajoutes tout renseignement qui pourrait nous être utile.

A bientôt

--
Jean-Jacques Gerbaud
entre Dauphiné et PACA


Bonjour,
Merci de répondre à mon message.
J'ai fait ce que tu me dit de faire dans alsamixer et les deux cartouches était bien activer, de plus comme je l'ai dit dans mon premier message j'ai bien du son partout sauf sur mes applications Java (et mes hauts parleurs son bien allumés! ).
Ma configuration est: "Ubuntu, Linux 2.6.32-24-generic"
Mais comment connaitre mon environnement graphique?
Et dois-je réinstaller Alsa (si oui comment faire)?
Je pense que la solution serait d'utiliser l'émulateur Oss mais je ne sait pas l'utiliser.
Merci

Titim3
DeVice
Le #23175701
titim3 a écrit :
Bonjour,

Je suis sur Linux depuis une semaine et je n'y connait pas grand chose.
Mon probléme est simple j'ai télecharger un jeu utilisant JAVA (le jeu est
Minecraft) et je n'ai tout simplement aucun son sur le jeu. Pourtant lorsque je
vais sur youtube ou d'autres sites le son est bien là!!
En cherchant un peu partout sur les forum j'ai trouver une solution à ce
probléme.
Apparament linux utilise ALSA par défaut pour lire le son, et JAVA utilise OSS
ce qui explique le probléme de son sur les applis JAVA.



Salut titim,


Effectivement le son est important dans ce jeu, il faut que tu puisses
entendre les petits sifflements qui viennent de derrière toi et
annoncent souvent un gros boum :)


Juste pour être sur qu'on part bien du bon problème, est-ce que tu peux
lancer minecraft dans un terminal et nous communiquer ce qui s'affiche
dans ledit terminal ?

La commande "java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame" devrait faire l'affaire (Si tu as
téléchargé le jeu avec firefox, l'emplacement par défaut est
/home/USERNAME/Téléchargements/minecraft.jar).


Ma configuration est: "Ubuntu, Linux 2.6.32-24-generic"
Mais comment connaitre mon environnement graphique?



Personnellement je n'ai pas de problème pour le son de minecraft sous
Ubuntu, avec gnome, sans modifier les réglages sonores.

Pour savoir si tu utilises kde ou gnome (ou autre) cherches dans tes
menus "démarrer" tu doit avoir une entrée "A propos de gnome" ou autre.
Sinon poste nous le résultat de la commande "env | sort" lancée dans un
terminal X, les différents systèmes graphiques laissent un trace dans
les variables d'environnement.

--
/dev/audio
titim3 Hors ligne
Le #23176361
DeVice a écrit le 04/03/2011 à 12h24 :
titim3 a écrit :
Bonjour,

Je suis sur Linux depuis une semaine et je n'y connait pas grand chose.
Mon probléme est simple j'ai télecharger un jeu utilisant JAVA
(le jeu est
Minecraft) et je n'ai tout simplement aucun son sur le jeu. Pourtant lorsque
je
vais sur youtube ou d'autres sites le son est bien là!!
En cherchant un peu partout sur les forum j'ai trouver une solution à
ce
probléme.
Apparament linux utilise ALSA par défaut pour lire le son, et JAVA
utilise OSS
ce qui explique le probléme de son sur les applis JAVA.




Salut titim,


Effectivement le son est important dans ce jeu, il faut que tu puisses
entendre les petits sifflements qui viennent de derrière toi et
annoncent souvent un gros boum :)


Juste pour être sur qu'on part bien du bon problème, est-ce que tu
peux
lancer minecraft dans un terminal et nous communiquer ce qui s'affiche
dans ledit terminal ?

La commande "java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame" devrait faire l'affaire (Si tu as
téléchargé le jeu avec firefox, l'emplacement par
défaut est
/home/USERNAME/Téléchargements/minecraft.jar).


Ma configuration est: "Ubuntu, Linux 2.6.32-24-generic"
Mais comment connaitre mon environnement graphique?




Personnellement je n'ai pas de problème pour le son de minecraft sous
Ubuntu, avec gnome, sans modifier les réglages sonores.

Pour savoir si tu utilises kde ou gnome (ou autre) cherches dans tes
menus "démarrer" tu doit avoir une entrée "A
propos de gnome" ou autre.
Sinon poste nous le résultat de la commande "env | sort"
lancée dans un
terminal X, les différents systèmes graphiques laissent un trace
dans
les variables d'environnement.

--
/dev/audio


Bonjour,

Alors mon environnement graphique est "gnome".

Et lorsque je tape "java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame" dans le terminal voila ce qu'il me sort:



:~$ java -cp /chemin/du/launcher/Minecraft.jar

Usage: java [-options] class [args...]
(to execute a class)
or java [-options] -jar jarfile [args...]
(to execute a jar file)
where options include:
-d32 use a 32-bit data model if available
-d64 use a 64-bit data model if available
-client to select the "client" VM
-server to select the "server" VM
-cacao to select the "cacao" VM
-zero to select the "zero" VM
-hotspot is a synonym for the "client" VM [deprecated]
The default VM is client.

-cp <class search path of directories and zip/jar files>
-classpath <class search path of directories and zip/jar files>
A : separated list of directories, JAR archives,
and ZIP archives to search for class files.
-D<name>=<value>
set a system property
-verbose[:class|gc|jni]
enable verbose output
-version print product version and exit
-version:<value>
require the specified version to run
-showversion print product version and continue
-jre-restrict-search | -jre-no-restrict-search
include/exclude user private JREs in the version search
-? -help print this help message
-X print help on non-standard options
-ea[: -enableassertions[: enable assertions with specified granularity
-da[: -disableassertions[: disable assertions with specified granularity
-esa | -enablesystemassertions
enable system assertions
-dsa | -disablesystemassertions
disable system assertions
-agentlib:<libname>[=<options>]
load native agent library <libname>, e.g. -agentlib:hprof
see also, -agentlib:jdwp=help and -agentlib:hprof=help
-agentpath:<pathname>[=<options>]
load native agent library by full pathname
-javaagent:<jarpath>[=<options>]
load Java programming language agent, see java.lang.instrument
-splash:<imagepath>
show splash screen with specified image
See http://java.sun.com/javase/reference for more details.
:~$ net.minecraft.LauncherFrame
net.minecraft.LauncherFrame : commande introuvable
:~$


Merci pour votre aide.
Titim3
DeVice
Le #23182441
titim3 a écrit :

Bonjour,

Alors mon environnement graphique est "gnome".

Et lorsque je tape "java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame" dans le terminal voila ce qu'il me sort:



:~$ java -cp /chemin/du/launcher/Minecraft.jar

Usage: java [-options] class [args...]
(to execute a class)
or java [-options] -jar jarfile [args...]
(to execute a jar file)


[snip]


Merci pour votre aide.
Titim3



Ah, il faut taper la commande en une seule ligne, remplaces le retour à
la ligne par un espace STP.

--
/dev/null
titim3 Hors ligne
Le #23183111
DeVice a écrit le 07/03/2011 à 10h39 :
titim3 a écrit :

Bonjour,

Alors mon environnement graphique est "gnome".

Et lorsque je tape "java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame" dans le terminal voila ce qu'il me sort:



:~$ java -cp /chemin/du/launcher/Minecraft.jar

Usage: java [-options] class [args...]
(to execute a class)
or java [-options] -jar jarfile [args...]
(to execute a jar file)



[snip]


Merci pour votre aide.
Titim3




Ah, il faut taper la commande en une seule ligne, remplaces le retour à
la ligne par un espace STP.

--
/dev/null


Bonjour,

Alors lorsque je tape "java -cp /chemin/du/launcher/Minecraft.jar net.minecraft.LauncherFrame"
Avec un espace a la place d'un retour a la ligne, voila se qu'il me sort:


:~$ java -cp /chemin/du/launcher/Minecraft.jar net.minecraft.LauncherFrame
Exception in thread "main" java.lang.NoClassDefFoundError: net/minecraft/LauncherFrame
Caused by: java.lang.ClassNotFoundException: net.minecraft.LauncherFrame
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: net.minecraft.LauncherFrame. Program will exit.
:~$


Titim3
DeVice
Le #23185511
titim3 a écrit :
DeVice a écrit le 07/03/2011 à 10h39 :
titim3 a écrit :

Bonjour,

Alors mon environnement graphique est "gnome".

Et lorsque je tape "java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame" dans le terminal voila ce qu'il me sort:



:~$ java -cp /chemin/du/launcher/Minecraft.jar

Usage: java [-options] class [args...]
(to execute a class)
or java [-options] -jar jarfile [args...]
(to execute a jar file)



[snip]

Merci pour votre aide.
Titim3




Ah, il faut taper la commande en une seule ligne, remplaces le retour à
la ligne par un espace STP.

--
/dev/null


Bonjour,

Alors lorsque je tape "java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame"
Avec un espace a la place d'un retour a la ligne, voila se qu'il me sort:


:~$ java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame
Exception in thread "main" java.lang.NoClassDefFoundError:
net/minecraft/LauncherFrame
Caused by: java.lang.ClassNotFoundException: net.minecraft.LauncherFrame
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: net.minecraft.LauncherFrame. Program will exit.
:~$


Titim3



Tu as bien remplacé "/chemin/du/launcher/" par le vrai chemin d'accès au
fichier minecraft.jar ? Comment est-ce que tu lance minecraft
habituellement ?

--
/dev/not/found
titim3 Hors ligne
Le #23204281
DeVice a écrit le 08/03/2011 à 09h18 :
titim3 a écrit :
DeVice a écrit le 07/03/2011 à 10h39 :
titim3 a écrit :

Bonjour,

Alors mon environnement graphique est "gnome".

Et lorsque je tape "java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame" dans le terminal voila ce qu'il me sort:



:~$ java -cp /chemin/du/launcher/Minecraft.jar

Usage: java [-options] class [args...]
(to execute a class)
or java [-options] -jar jarfile [args...]
(to execute a jar file)




[snip]

Merci pour votre aide.
Titim3





Ah, il faut taper la commande en une seule ligne, remplaces le retour
à
la ligne par un espace STP.

--
/dev/null



Bonjour,

Alors lorsque je tape "java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame"
Avec un espace a la place d'un retour a la ligne, voila se qu'il me sort:


:~$ java -cp /chemin/du/launcher/Minecraft.jar
net.minecraft.LauncherFrame
Exception in thread "main" java.lang.NoClassDefFoundError:
net/minecraft/LauncherFrame
Caused by: java.lang.ClassNotFoundException: net.minecraft.LauncherFrame
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: net.minecraft.LauncherFrame. Program will exit.
:~$


Titim3




Tu as bien remplacé "/chemin/du/launcher/" par le vrai chemin
d'accès au
fichier minecraft.jar ? Comment est-ce que tu lance minecraft
habituellement ?

--
/dev/not/found


Bonjour,
non je n'ai pas remplacer chemin du launcher par le vrai chemin d'accés, je n'avait pas compris que je devait le faire.
Je lance le jeu dans:
Raccourcis-Télechargement-click droit sur minecraft.jar-ouvrir avec Sun Java 6 runtime.
Que dois-je taper exactement dans le terminal svp?

Titim3
Jean-Jacques Gerbaud
Le #23204441
Le 14/03/2011 18:12, titim3 a écrit :

DeVice a écrit le 08/03/2011 à 09h18 :
titim3 a écrit :
DeVice a écrit le 07/03/2011 à 10h39 :
titim3 a écrit :

Bonjour,

Alors mon environnement graphique est "gnome".











.....[snip ..................



Tu as bien remplacé "/chemin/du/launcher/" par le vrai chemin
d'accès au
fichier minecraft.jar ? Comment est-ce que tu lance minecraft
habituellement ?

--
/dev/not/found


Bonjour,
non je n'ai pas remplacer chemin du launcher par le vrai chemin d'accés, je
n'avait pas compris que je devait le faire.
Je lance le jeu dans:
Raccourcis-Télechargement-click droit sur minecraft.jar-ouvrir avec Sun Java 6
runtime.
Que dois-je taper exactement dans le terminal svp?

Titim3




Bonjour Titim.

Dis nous si tu as enfin réussi à lancer ton jeu préféré avec une commande
simple.

--
Jean-Jacques Gerbaud
entre Dauphiné et PACA
DeVice
Le #23206031




Tu as bien remplacé "/chemin/du/launcher/" par le vrai chemin
d'accès au
fichier minecraft.jar ? Comment est-ce que tu lance minecraft
habituellement ?

--
/dev/not/found


Bonjour,
non je n'ai pas remplacer chemin du launcher par le vrai chemin d'accés, je
n'avait pas compris que je devait le faire.
Je lance le jeu dans:
Raccourcis-Télechargement-click droit sur minecraft.jar-ouvrir avec Sun Java 6
runtime.
Que dois-je taper exactement dans le terminal svp?

Titim3



Salut Titim,

Essayes ça :
java -cp Téléchargements/minecraft.jar net.minecraft.LauncherFrame

Attention à la casse, j'ai vu des minecraft.jar avec un grand M.

--
DeVice
Publicité
Poster une réponse
Anonyme