pas de templates avec emacs23

Le
jj.retorre
Je suis sous Debian/testing.

J'ai installé template.el, mais in ne fonctionne pas sous emacs23 alors
qu'il marche parfaitement sous emacs22 (j'utilise template depuis longtemps).

D'autre part, j'ai le message «apply: Wrong type argument:
number-or-marker-p, nil» même si je lance
emacs23 --no-init-file --no-site-file
Je ne sais pas si les deux sont liés, mais je me suis aperçu de ces deux
dysfonctionnements il y a peu. Il est vrai que je n'avais pas prêté
une grande attention au message de l'initialisation qui me semblait sans
conséquences.

Mes observations sont-elles partagées ? Avez-vous rencontré et résolu ce
problème ?

Je me suis fais un .emacs de circonstance dans lequel il n'y a que
(require 'template) (template-initialize) et l'ajout du chemin dans le
load-path.

template.el est assez ancien, peut-être y a-t-il des choses à actualiser
dans le template.el, je n'ai pas le courage d'y aller voir et sans doute
pas les compétences.

--
JJR.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean Magnan de Bornier
Le #21763871
Le 19 janvier à 09:51:54 (JJ. Rétorrà ©) écrit
notamment:

| Je suis sous Debian/testing.



| J'ai installé template.el, mais in ne fonctionne pas sous emacs23 al ors
| qu'il marche parfaitement sous emacs22 (j'utilise template depuis
| longtemps).



| D'autre part, j'ai le message «apply: Wrong type argument:
| number-or-marker-p, nil» même si je lance
| emacs23 --no-init-file --no-site-file
| Je ne sais pas si les deux sont liés, mais je me suis aperçu de ces deux
| dysfonctionnements il y a peu. Il est vrai que je n'avais pas prêt é
| une grande attention au message de l'initialisation qui me semblait sans
| conséquences.



| Mes observations sont-elles partagées ? Avez-vous rencontré et résolu ce
| problème ?



| Je me suis fais un .emacs de circonstance dans lequel il n'y a que
| (require 'template) (template-initialize) et l'ajout du chemin dans le
| load-path.



| template.el est assez ancien, peut-être y a-t-il des choses à a ctualiser
| dans le template.el, je n'ai pas le courage d'y aller voir et sans doute
| pas les compétences.

Ici, sous le dernier xubuntu et avec un template.el d'au moins 2006 (qui m'a
donné satisfaction avec emacs 21 et 22), emacs23 n'a aucune difficult é.

Il y a peut-être autre chose...
--
Jean
Blue.Dian
Le #21763861
Salut,

Pour moi, sous emacs 23.1.1, template.el (version 3.1c) marche
parfaitement.
Si tu n'as pas cette version, je peux te la poster par mail.
J'utilise aussi yasnippet pour les macros.

BlueDian
jj.retorre
Le #21763841
""
Salut,

Pour moi, sous emacs 23.1.1, template.el (version 3.1c) marche
parfaitement.
Si tu n'as pas cette version, je peux te la poster par mail.
J'utilise aussi yasnippet pour les macros.

BlueDian



Merci, je vais continuer mes investigations, mais je n'ai pas trop de
pistes...

C'est très important de savoir que ça ne vient pas du code. J'ai aussi
la version 3.1c.


--
JJR.
jj.retorre
Le #21763801
Jean Magnan de Bornier
Le 19 janvier à 09:51:54 (JJ. Rétorré) écrit
notamment:

| Je suis sous Debian/testing.



| J'ai installé template.el, mais in ne fonctionne pas sous emacs23 alors
| qu'il marche parfaitement sous emacs22 (j'utilise template depuis
| longtemps).



| D'autre part, j'ai le message «apply: Wrong type argument:
| number-or-marker-p, nil» même si je lance
| emacs23 --no-init-file --no-site-file
| Je ne sais pas si les deux sont liés, mais je me suis aperçu de ces deux
| dysfonctionnements il y a peu. Il est vrai que je n'avais pas prêté
| une grande attention au message de l'initialisation qui me semblait sans
| conséquences.



| Mes observations sont-elles partagées ? Avez-vous rencontré et résolu ce
| problème ?



| Je me suis fais un .emacs de circonstance dans lequel il n'y a que
| (require 'template) (template-initialize) et l'ajout du chemin dans le
| load-path.



| template.el est assez ancien, peut-être y a-t-il des choses à actualiser
| dans le template.el, je n'ai pas le courage d'y aller voir et sans doute
| pas les compétences.

Ici, sous le dernier xubuntu et avec un template.el d'au moins 2006 (qui m'a
donné satisfaction avec emacs 21 et 22), emacs23 n'a aucune difficulté.

Il y a peut-être autre chose...



C'est ce que je me dis ... mais je n'ai pas trop de pistes. J'ai
vérifié que sur mon eeepc sous Ubuntu, je n'ai effectivement pas ce
problème. Peut-être un bug Debian. Ça m'étonne un peu aussi.
Je vais poursuivre mes investigations.

--
JJR.
jj.retorre
Le #21763781
(JJ. Rétorré) disait le 01/20/10 que :

Jean Magnan de Bornier


Ici, sous le dernier xubuntu et avec un template.el d'au moins 2006 (qui m'a
donné satisfaction avec emacs 21 et 22), emacs23 n'a aucune difficulté.

Il y a peut-être autre chose...



C'est ce que je me dis ... mais je n'ai pas trop de pistes. J'ai
vérifié que sur mon eeepc sous Ubuntu, je n'ai effectivement pas ce
problème. Peut-être un bug Debian. Ça m'étonne un peu aussi.
Je vais poursuivre mes investigations.



Ayé j'ai trouvé. Je pensais un peu naïvement qu'en démarrant avec
--no-init-file et --no-site-file, l'erreur, si elle était locale,
devrait disparaître. En démarrant avec --debug-init, j'ai trouvé un
.abbrev_defs qui semait sa zone.

Merci de l'aide qui m'a permis de trouver et d'apprendre sur le
comportement d'Emacs.

--
JJR.
Publicité
Poster une réponse
Anonyme