passer un nom d'onglet dans une fonction

Le
pascal
Bonsoir a tous et toutes,

j'ai beau chercher je n'avance pas, je cherche un moyen de rentrer
un nom d'onglet dans une fonction de calcul:

=NB.SI('nom_onglet 1'!$O:$O;C$3) en l'occurrence le nombre de
'A' (en C$3) dans la colonne 'O' de l'onglet 'nom_onglet 1'


A
nom_onglet 1 3 <= ce qui donne 3 avec la formule telle
qu'ecrite plus haut
nom_onglet 2 7


Si je tente =NB.SI('indirect(B4)'!$O:$O;C$3) en remplacant
'nom_onglet 1' par le contenu de B4 ('nom_onglet 1')

j'obtiens un bon gros #VALEUR!

Qu'est-ce que je fais de mal? il me manque des " et autres
& quelque part pour introduire cet indirect(B4)?

Quelqu'un pourrait m'eclairer ? Merci d'avance.

Pascal
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #23049771
Bonjour,

Si tu cherches le nombre de cellules contenant au moins la lettre a

Tu adaptes le nom de la feuille et de la plage de cellules
=SOMMEPROD((ESTNUM(CHERCHE("a";Feuil2!A1:A10))*1))

Si tu cherches le nombre de cellules contenant la lettre a
=SOMMEPROD((Feuil2!A1:A10="a")*1)



MichD
--------------------------------------------
"pascal" a écrit dans le message de groupe de discussion :


Bonsoir a tous et toutes,

j'ai beau chercher je n'avance pas, je cherche un moyen de rentrer
un nom d'onglet dans une fonction de calcul:

=NB.SI('nom_onglet 1'!$O:$O;C$3) en l'occurrence le nombre de
'A' (en C$3) dans la colonne 'O' de l'onglet 'nom_onglet 1'


A
nom_onglet 1 3 <= ce qui donne 3 avec la formule telle
qu'ecrite plus haut
nom_onglet 2 7
...

Si je tente =NB.SI('indirect(B4)'!$O:$O;C$3) en remplacant
'nom_onglet 1' par le contenu de B4 ('nom_onglet 1')

j'obtiens un bon gros #VALEUR!

Qu'est-ce que je fais de mal? il me manque des " et autres
& quelque part pour introduire cet indirect(B4)?

Quelqu'un pourrait m'eclairer ? Merci d'avance.

Pascal
Frederic LE GUEN
Le #23050001
On Jan 24, 9:56 pm, pascal
Bonsoir a tous et toutes,

   j'ai beau chercher je n'avance pas, je cherche un moyen de rentrer
un nom d'onglet dans une fonction de calcul:

=NB.SI('nom_onglet 1'!$O:$O;C$3)    en l'occurrence le nombre de
'A' (en C$3)  dans la colonne 'O' de l'onglet 'nom_onglet 1'

                         A
nom_onglet 1      3     <=    ce qui donne 3 avec la form ule telle
qu'ecrite plus haut
nom_onglet 2      7
...

  Si je tente =NB.SI('indirect(B4)'!$O:$O;C$3)     en remplacant
'nom_onglet 1' par le contenu de B4  ('nom_onglet 1')

                    j'obtiens un bon gros #VALEUR!

Qu'est-ce que je fais de mal?            il me manque des " e t autres
& quelque part pour introduire cet indirect(B4)?

Quelqu'un pourrait m'eclairer ?   Merci d'avance.

Pascal



Tu places mal ta fonction INDIRECT
J'ai fait une fiche d'apprentissage ici http://www.excel-exercice.com/index .php?lang=1&var1=5-1-3
mais dans ton pb tu dois écrire toute la référence à une cellule o ù à
une plage de cellules dans la parenthèse de ta fonction INDIRECT
Ensuite, la partie fixe (genre colonne O) doit être entre guillemet et
la partie variable, ne doit pas être entre guillemets
Un peu qque chose du style =NB.SI(INDIRECT(B4&"!O:O");C$3)
pascal
Le #23050361
Super Frederic,

C'est exactement ce que je cherchais; merci d'avoir compris ma
prose et d'y avoir si pertinemment répondu.

Bonne journée.

Pascal

On 25 jan, 00:25, Frederic LE GUEN
On Jan 24, 9:56 pm, pascal

> Bonsoir a tous et toutes,

>    j'ai beau chercher je n'avance pas, je cherche un moyen de rentr er
> un nom d'onglet dans une fonction de calcul:

> =NB.SI('nom_onglet 1'!$O:$O;C$3)    en l'occurrence le nombre de
> 'A' (en C$3)  dans la colonne 'O' de l'onglet 'nom_onglet 1'

>                          A
> nom_onglet 1      3     <=    ce qui donne 3 avec la fo rmule telle
> qu'ecrite plus haut
> nom_onglet 2      7
> ...

>   Si je tente =NB.SI('indirect(B4)'!$O:$O;C$3)     en remplacan t
> 'nom_onglet 1' par le contenu de B4  ('nom_onglet 1')

>                     j'obtiens un bon gros #VALEUR!

> Qu'est-ce que je fais de mal?            il me manque des " et autres
> & quelque part pour introduire cet indirect(B4)?

> Quelqu'un pourrait m'eclairer ?   Merci d'avance.

> Pascal

Tu places mal ta fonction INDIRECT
J'ai fait une fiche d'apprentissage icihttp://www.excel-exercice.com/inde x.php?lang=1&var1=5-1-3
mais dans ton pb tu dois écrire toute la référence à une cellule où à
une plage de cellules dans la parenthèse de ta fonction INDIRECT
Ensuite, la partie fixe (genre colonne O) doit être entre guillemet et
la partie variable, ne doit pas être entre guillemets
Un peu qque chose du style =NB.SI(INDIRECT(B4&"!O:O");C$3)
pascal
Le #23050351
Merci Michel pour la réponse.

Ce n'est pas exactement ce que je cherchais (appel d'une fonction dans
un fonction) mais Frederic y a parfaitement répondu.

Bonne journée,

Pascal

On 24 jan, 23:20, "michdenis"
Bonjour,

Si tu cherches le nombre de cellules contenant au moins la lettre a

Tu adaptes le nom de la feuille et de la plage de cellules
=SOMMEPROD((ESTNUM(CHERCHE("a";Feuil2!A1:A10))*1))

Si tu cherches le nombre de cellules contenant la lettre a
=SOMMEPROD((Feuil2!A1:A10="a")*1)

MichD
--------------------------------------------
"pascal"  a écrit dans le message de groupe de discussion :


Bonsoir a tous et toutes,

   j'ai beau chercher je n'avance pas, je cherche un moyen de rentrer
un nom d'onglet dans une fonction de calcul:

=NB.SI('nom_onglet 1'!$O:$O;C$3)    en l'occurrence le nombre de
'A' (en C$3)  dans la colonne 'O' de l'onglet 'nom_onglet 1'

                 A
nom_onglet 1      3     <=    ce qui donne 3 avec la form ule telle
qu'ecrite plus haut
nom_onglet 2      7
...

  Si je tente =NB.SI('indirect(B4)'!$O:$O;C$3)     en remplacant
'nom_onglet 1' par le contenu de B4  ('nom_onglet 1')

                    j'obtiens un bon gros #VALEUR!

Qu'est-ce que je fais de mal?            il me manque des " e t autres
& quelque part pour introduire cet indirect(B4)?

Quelqu'un pourrait m'eclairer ?   Merci d'avance.

Pascal
Publicité
Poster une réponse
Anonyme