Passer outre une erreur dans une sommeprod

Le
bertrouf
Bonjour,

J'utilise souvent la fonction Sommeprod() parce qu'elle permet de mettre des
conditions dans une addition.
Sur une liste assez longue, je veux ajouter les nbre d'interventions au
cours d'un mois donné.
Ma formule est :
=Sommeprod((MOIS(A2:A50))*(ANNEE(A2:A50) 07)*(B2:B50))
Sauf que j'ai certaines cellules dans la zone qui ne sont pas des dates.
J'ai donc des erreurs.
Comment faire pour que ces cellules là ne soient pas comptées ?

J'ai essayé de mettre des SI() au sein de la formule mais ça marche pas.
Et j’ai essayé avec ESTERREUR(), il passe au dessus des erreurs mais ne
multiplie pas par 0 donc il oublie les conditions. C’est normal, « Janvier
» renvoie « false », ce n’est pas une erreur donc ESTERREURúlse donc on
additionne.

=SOMMEPROD((NON(ESTERREUR(MOIS(A2:A50))))*(NON(ESTERREUR(ANNEE(A2:A50) 07)))*(B2:B50))

Quelqu'un aurait une idée ?
Merci d'avance

Bertrouf
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #5153081
Bonsour® bertrouf avec ferveur ;o))) vous nous disiez :

Ma formule est :
=Sommeprod((MOIS(A2:A50))*(ANNEE(A2:A50) 07)*(B2:B50))
Sauf que j'ai certaines cellules dans la zone qui ne sont pas des
dates. J'ai donc des erreurs.


=Sommeprod(ESTNUM(A2:A50)*(MOIS(A2:A50))*(ANNEE(A2:A50) 07)*(B2:B50))

ajouter éventuellement également une matrice ESTNUM(B2:B50)

--
--
@+
;o)))

JB
Le #5153021
Bonjour,

=SOMME(SI(ESTNUM(A1:A12);
(MOIS(A1:A12)=4)*(ANNEE(A1:A12) 07))*B1:B12)
Valider avec Maj+Ctrl+entrée

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#EliminationNA

JB
http://boisgontierjacques.free.fr

On 7 fév, 23:58, bertrouf
Bonjour,

J'utilise souvent la fonction Sommeprod() parce qu'elle permet de mettre d es
conditions dans une addition.
Sur une liste assez longue, je veux ajouter les nbre d'interventions au
cours d'un mois donné.
Ma formule est :
=Sommeprod((MOIS(A2:A50))*(ANNEE(A2:A50) 07)*(B2:B50))
Sauf que j'ai certaines cellules dans la zone qui ne sont pas des dates.
J'ai donc des erreurs.
Comment faire pour que ces cellules là ne soient pas comptées ?

J'ai essayé de mettre des SI() au sein de la formule mais ça marche pa s.
Et j'ai essayé avec ESTERREUR(), il passe au dessus des erreurs mais ne
multiplie pas par 0 donc il oublie les conditions. C'est normal, << Janvie r
renvoie << false >>, ce n'est pas une erreur donc ESTERREURúlse don c on
additionne.



=SOMMEPROD((NON(ESTERREUR(MOIS(A2:A50))))*(NON(ESTERREUR(ANNEE(A2:A 50)=2-007)))*(B2:B50))

Quelqu'un aurait une idée ?
Merci d'avance

Bertrouf




bertrouf
Le #5153001
Ca marche, Merci.
Par contre je voulais que cette formule soit recopiée grace à une macro, je
ne sais pas faire Maj+Ctrl+entrée dans une macro.

nf = Dir(DOSSIER_CIBLE & "*.xls")
i = 2
Do While nf <> ""
CHAINE_A = "'[" & nf & "]" & FEUILLE_CIBLE & " '!$A$11:$A$504"
CHAINE_B = "'[" & nf & "]" & FEUILLE_CIBLE & " '!$B$11:$B$504"
Cells(i, 1) = nf
Cells(i, 2).Formula = "=SOMME(SI(ESTNUM(" & CHAINE_A & ");(MOIS(" &
CHAINE_A & ")=" & Num_Mois & ")* (ANNEE(" & CHAINE_A & ")=" & Num_Annee &
")*(" & CHAINE_B & "))"
i = i + 1
nf = Dir
Loop
Cells(1, 2) = "ÚTE(" & Num_Annee & "; " & Num_Mois & "; 1)"

Que me manque -til ?
Bertrouf

"JB" wrote:

Bonjour,

=SOMME(SI(ESTNUM(A1:A12);
(MOIS(A1:A12)=4)*(ANNEE(A1:A12) 07))*B1:B12)
Valider avec Maj+Ctrl+entrée

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#EliminationNA

JB
http://boisgontierjacques.free.fr

On 7 fév, 23:58, bertrouf
Bonjour,

J'utilise souvent la fonction Sommeprod() parce qu'elle permet de mettre des
conditions dans une addition.
Sur une liste assez longue, je veux ajouter les nbre d'interventions au
cours d'un mois donné.
Ma formule est :
=Sommeprod((MOIS(A2:A50))*(ANNEE(A2:A50) 07)*(B2:B50))
Sauf que j'ai certaines cellules dans la zone qui ne sont pas des dates.
J'ai donc des erreurs.
Comment faire pour que ces cellules là ne soient pas comptées ?

J'ai essayé de mettre des SI() au sein de la formule mais ça marche pas.
Et j'ai essayé avec ESTERREUR(), il passe au dessus des erreurs mais ne
multiplie pas par 0 donc il oublie les conditions. C'est normal, << Janvier
renvoie << false >>, ce n'est pas une erreur donc ESTERREURúlse donc on
additionne.



=SOMMEPROD((NON(ESTERREUR(MOIS(A2:A50))))*(NON(ESTERREUR(ANNEE(A2:A50)=2-007)))*(B2:B50))

Quelqu'un aurait une idée ?
Merci d'avance

Bertrouf








JB
Le #5152981
FormulaArray

Faire de l'enregistrement Auto de la formule pour obtenir la syntaxe.
(noms de fonctions en anglais)

JB

On 8 fév, 08:46, bertrouf
Ca marche, Merci.
Par contre je voulais que cette formule soit recopiée grace à une macr o, je
ne sais pas faire Maj+Ctrl+entrée dans une macro.

  nf = Dir(DOSSIER_CIBLE & "*.xls")
  i = 2
  Do While nf <> ""
    CHAINE_A = "'[" & nf & "]" & FEUILLE_CIBLE & " '!$A$11:$A$504"
    CHAINE_B = "'[" & nf & "]" & FEUILLE_CIBLE & " '!$B$11:$B$504"
    Cells(i, 1) = nf
    Cells(i, 2).Formula = "=SOMME(SI(ESTNUM(" & CHAINE_A & ");(MOI S(" &
CHAINE_A & ")=" & Num_Mois & ")* (ANNEE(" & CHAINE_A & ")=" & Num_Anne e &
")*(" & CHAINE_B & "))"
    i = i + 1
    nf = Dir
  Loop
  Cells(1, 2) = "ÚTE(" & Num_Annee & "; " & Num_Mois & "; 1)"

Que me manque -til ?
Bertrouf



"JB" wrote:
Bonjour,

=SOMME(SI(ESTNUM(A1:A12);
(MOIS(A1:A12)=4)*(ANNEE(A1:A12) 07))*B1:B12)
Valider avec Maj+Ctrl+entrée

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#EliminationNA

JB
http://boisgontierjacques.free.fr

On 7 fév, 23:58, bertrouf
Bonjour,

J'utilise souvent la fonction Sommeprod() parce qu'elle permet de mett re des
conditions dans une addition.
Sur une liste assez longue, je veux ajouter les nbre d'interventions a u
cours d'un mois donné.
Ma formule est :
 =Sommeprod((MOIS(A2:A50))*(ANNEE(A2:A50) 07)*(B2:B50))
Sauf que j'ai certaines cellules dans la zone qui ne sont pas des date s.
J'ai donc des erreurs.
Comment faire pour que ces cellules là ne soient pas comptées ?

J'ai essayé de mettre des SI() au sein de la formule mais ça march e pas.
Et j'ai essayé avec ESTERREUR(), il passe au dessus des erreurs mais ne
multiplie pas par 0 donc il oublie les conditions. C'est normal, << Ja nvier
renvoie << false >>, ce n'est pas une erreur donc ESTERREURúlse donc on
additionne.



=SOMMEPROD((NON(ESTERREUR(MOIS(A2:A50))))*(NON(ESTERREUR(ANNEE( A2:A50)=2­-007)))*(B2:B50))

Quelqu'un aurait une idée ?
Merci d'avance

Bertrouf- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -






Pounet95
Le #5152971
Bonjour,
Sauf erreur de ma part, pour valider Shift Ctrl Entrée, il faut utiliser
cells(i,2).formulaArray= .......... la formule
Mais c'est sans certitude aucune

Pounet95

"bertrouf" news:
Ca marche, Merci.
Par contre je voulais que cette formule soit recopiée grace à une macro,
je
ne sais pas faire Maj+Ctrl+entrée dans une macro.

nf = Dir(DOSSIER_CIBLE & "*.xls")
i = 2
Do While nf <> ""
CHAINE_A = "'[" & nf & "]" & FEUILLE_CIBLE & " '!$A$11:$A$504"
CHAINE_B = "'[" & nf & "]" & FEUILLE_CIBLE & " '!$B$11:$B$504"
Cells(i, 1) = nf
Cells(i, 2).Formula = "=SOMME(SI(ESTNUM(" & CHAINE_A & ");(MOIS(" &
CHAINE_A & ")=" & Num_Mois & ")* (ANNEE(" & CHAINE_A & ")=" & Num_Annee &
")*(" & CHAINE_B & "))"
i = i + 1
nf = Dir
Loop
Cells(1, 2) = "ÚTE(" & Num_Annee & "; " & Num_Mois & "; 1)"

Que me manque -til ?
Bertrouf

"JB" wrote:

Bonjour,

=SOMME(SI(ESTNUM(A1:A12);
(MOIS(A1:A12)=4)*(ANNEE(A1:A12) 07))*B1:B12)
Valider avec Maj+Ctrl+entrée

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#EliminationNA

JB
http://boisgontierjacques.free.fr

On 7 fév, 23:58, bertrouf
Bonjour,

J'utilise souvent la fonction Sommeprod() parce qu'elle permet de
mettre des
conditions dans une addition.
Sur une liste assez longue, je veux ajouter les nbre d'interventions au
cours d'un mois donné.
Ma formule est :
=Sommeprod((MOIS(A2:A50))*(ANNEE(A2:A50) 07)*(B2:B50))
Sauf que j'ai certaines cellules dans la zone qui ne sont pas des
dates.
J'ai donc des erreurs.
Comment faire pour que ces cellules là ne soient pas comptées ?

J'ai essayé de mettre des SI() au sein de la formule mais ça marche
pas.
Et j'ai essayé avec ESTERREUR(), il passe au dessus des erreurs mais ne
multiplie pas par 0 donc il oublie les conditions. C'est normal, <<
Janvier
renvoie << false >>, ce n'est pas une erreur donc ESTERREURúlse
donc on
additionne.



=SOMMEPROD((NON(ESTERREUR(MOIS(A2:A50))))*(NON(ESTERREUR(ANNEE(A2:A50)=2-007)))*(B2:B50))

Quelqu'un aurait une idée ?
Merci d'avance

Bertrouf










Publicité
Poster une réponse
Anonyme