Pb Calcul de date

Le
Calou
Bonjour,
Travaillant beaucoup avec les dates, je suis encore confront un
problme sur des dates.
Je voulais si quelqu'un du forum a deja rgl ce problme.

Je voudrais ajouter une date un nombre de jours, mais l o je
coince c'est que je voudrais qu'excel considere que tous les mois ont
30 jours car tous mes calculs sont en trentime. En effet, j'utilise
beaucoup la fonction JOURS360.

Un grand merci par avance pour votre aide.

Bonne journe.

Philippe
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FFO
Le #20520131
Salut Philippe

La Date en A1, le nombre à rajouter en B1

Mets cette formule en C1 :

=SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+30)1;A1+B1+1;SI(JOUR(DATE(ANNEE
(A1);MOIS(A1);1)+28)=1;A1+B1-2;SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+29)
=1;A1+B1-1;A1+B1)))

fais des essais avec différentes dates et nombres
et dis moi !!!!!!
Calou
Le #20520231
On 9 nov, 11:17, FFO
Salut Philippe

La Date en A1, le nombre à rajouter en B1

Mets cette formule en C1 :

=SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+30)1;A1+B1+1;SI(JOUR(DATE(ANNEE
(A1);MOIS(A1);1)+28)=1;A1+B1-2;SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+29)
=1;A1+B1-1;A1+B1)))

fais des essais avec différentes dates et nombres
et dis moi !!!!!!



Bonjour,

Je teste ca et je te dis ! Merci pour ton aide.

A +

Philippe
michel-m
Le #20522331
Calou a écrit le 09/11/2009 à 11h43 :
On 9 nov, 11:17, FFO wrote:
Salut Philippe

La Date en A1, le nombre à rajouter en B1

Mets cette formule en C1 :

=SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+30)1;A1+B1+1;SI(JOUR(DATE(ANNEE
(A1);MOIS(A1);1)+28)=1;A1+B1-2;SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+29)
=1;A1+B1-1;A1+B1)))

fais des essais avec différentes dates et nombres
et dis moi !!!!!!




Bonjour,

Je teste ca et je te dis ! Merci pour ton aide.

A +

Philippe


Bonjour

autre formule (auteur : Monique_XLD)

TE(ANNEE(A1)+ENT(B1/360);MOIS(A1)+(MOD(B1;360)-MOD(B1;30))/30;JOUR(A1)+MOD(B1;30))
Philou36
Le #20524861
Bonsoir,
Ta formule ne marchait pas a tous les coups. J'y retravaille !
Bonne soirée
Philippe

"Calou"
On 9 nov, 11:17, FFO
Salut Philippe

La Date en A1, le nombre à rajouter en B1

Mets cette formule en C1 :

=SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+30)1;A1+B1+1;SI(JOUR(DATE(ANNEE
(A1);MOIS(A1);1)+28)=1;A1+B1-2;SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+29)
=1;A1+B1-1;A1+B1)))

fais des essais avec différentes dates et nombres
et dis moi !!!!!!



Bonjour,

Je teste ca et je te dis ! Merci pour ton aide.

A +

Philippe
Calou
Le #20526071
On 9 nov, 22:54, "Philou36"
Bonsoir,
Ta formule ne marchait pas a tous les coups. J'y retravaille !
Bonne soirée
Philippe

"Calou"
On 9 nov, 11:17, FFO
> Salut Philippe

> La Date en A1, le nombre à rajouter en B1

> Mets cette formule en C1 :

> =SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+30)1;A1+B1+1;SI(JOUR(DATE(ANN EE
> (A1);MOIS(A1);1)+28)=1;A1+B1-2;SI(JOUR(DATE(ANNEE(A1);MOIS(A1);1)+29)
> =1;A1+B1-1;A1+B1)))

> fais des essais avec différentes dates et nombres
> et dis moi !!!!!!

Bonjour,

Je teste ca et je te dis ! Merci pour ton aide.

A +

Philippe



Bonjour,
J'ai trouvé ca :
=SI((B2-(ENT(B2/30)*30)+JOUR(A2))<30;DATE(ANNEE(A2);MOIS(A2)+ENT
(B2/30);JOUR(A2)+B2-(ENT(B2/30)*30));DATE(ANNEE(A2);MOIS(A2)+1+ENT
(B2/30);JOUR(A2)+B2-(ENT(B2/30)*30)-30))
Cela me semble mieux. Je continue mes tests et je vous dis.
Bonne journée
Philippe
Publicité
Poster une réponse
Anonyme