pb clavier emacs fedora 4

Le
francois.patte
Bonjour,

J'ai un problème de clavier sous emacs: je n'arrive pas à me servir de
la touche "morte": ^ Quand je m'en sers, rien ne se passe (c'est
normal) mais si je tape un "a", un "e", etc. après, je n'obtiens pas
la lettre accentuée.

Config:

(set-language-environment 'utf-8)
(progn (set-terminal-coding-system 'utf-8)
(set-keyboard-coding-system 'utf-8)
(set-selection-coding-system 'utf-8))

Autre question, comment obtient-on une ligature oe?

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sébastien Kirche
Le #21788371
Le 19 mars 2007 à 08:30, francois vraute :

Bonjour,



Bonjour,

J'ai un problème de clavier sous emacs: je n'arrive pas à me servir de
la touche "morte": ^ Quand je m'en sers, rien ne se passe (c'est
normal) mais si je tape un "a", un "e", etc. après, je n'obtiens pas
la lettre accentuée....

Config:

(set-language-environment 'utf-8)
(progn (set-terminal-coding-system 'utf-8)
(set-keyboard-coding-system 'utf-8)
(set-selection-coding-system 'utf-8))



Je me demande si ce n'est pas plus un problème de conf X11 que d'Emacs.
Je n'ai aucun réglage concernant les touches mortes dans ma config et je
n'ai pas de souci pour utiliser ^ (^ espace) ou ô ê (^ o, ^ e) avec mon
clavier azerty. Voici ma section "InputDevice" (/etc/X11/xorg.conf)

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection


Autre question, comment obtient-on une ligature oe?



Je ne vois cette pas ligature dans C-x 8 aussi je pense que le plus
simple est de passer par la touche compose (compose
o e -> ½), si tu as configuré X11 en conséquence.

Par exemple pour avoir compose sur la touche windows de droite d'un
clavier pc105 avec XOrg, voir l'option compose:rwin dans l'extrait de
xorg.conf que j'ai posté plus haut.

Sinon tu peux passer par une méthode de saisie comme latin-prefix
(/ o -> ½) mais si tu n'en as pas l'utilité par ailleurs, ça risque plus
de t'embêter qu'autre chose. Sur un clavier qwerty par exemple
latin-1-postfix est un bonheur pour saisir du français, mais bizarrement
'½' (oe) n'y est pas, alors que 'æ' (ae) si.


Hope zat helpse.
--
Sébastien Kirche
francois.patte
Le #21788361
On 19 mar, 14:34, Sébastien Kirche
Le 19 mars 2007 à 08:30, francois vraute :

> Bonjour,

Bonjour,

> J'ai un problème de clavier sous emacs: je n'arrive pas à me servir de
> la touche "morte": ^ Quand je m'en sers, rien ne se passe (c'est
> normal) mais si je tape un "a", un "e", etc. après, je n'obtiens pas
> la lettre accentuée....

> Config:

> (set-language-environment 'utf-8)
> (progn (set-terminal-coding-system 'utf-8)
> (set-keyboard-coding-system 'utf-8)
> (set-selection-coding-system 'utf-8))

Je me demande si ce n'est pas plus un problème de conf X11 que d'Emacs.



Ben, dans la mesure où le problème n'existe qu'avec Emacs.... (les
terminaux répondent au touches mortes, le courrier aussi, cet éditeur
via google aussi: â...)

Je n'ai aucun réglage concernant les touches mortes dans ma config et je
n'ai pas de souci pour utiliser ^ (^ espace) ou ô ê (^ o, ^ e) avec m on
clavier azerty. Voici ma section "InputDevice" (/etc/X11/xorg.conf)

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection



Là, ça râle quand je me logue après modif: "le réglage clavier X11
diffère de celui de Gnome" me dit-on.... J'ai essayé le réglge X11 à
la pace du Gnome et rien n'a changé.... Du coup, serait-ce un pb
Gnome? Mais je ne vois pas.

Hope zat helpse.



Pas zencore, mais ça va viendre peut-être.

--
François Patte
Sébastien Kirche
Le #21788351
Le 19 mars 2007 à 11:33, francois a formulé :

Là, ça râle quand je me logue après modif: "le réglage clavier X11
diffère de celui de Gnome" me dit-on.... J'ai essayé le réglge X11 à
la pace du Gnome et rien n'a changé.... Du coup, serait-ce un pb
Gnome? Mais je ne vois pas.



Aïe, il y a sans doute une gestion de Gnome par dessus celle du X11
standard. Je ne peux pas trop aider pour Gnome, je n'utilise pas de
gestionnaire de bureau (KDE / Gnome / XFCE) mais un gestionnaire de
fenêtre simple.

J'ai peut-être trouvé une idée dans la faq du groupe :

(define-key function-key-map dead-circumflex 'compose-circumflex-map)

Mais vu certains autres conseils comme iso-accents ou
standard-display-european celui concernant dead-circumflex est peut-être
aussi obsolète ?

--
Sébastien Kirche
Publicité
Poster une réponse
Anonyme