Pb de fonctionnement apres install de Tomcat sur Linux

Le
Allo Tobus
Bonjour,

je cherche a installer Tomcat5 sur un serveur fedora core 6.

J'ai installé, via yum install tomcat5.i386

Apres avoir lancé le service /etc/init.d/tomcat5 start
=> j'ai rien sur le navigateur en port 8080, il ne répond pas

- Ce package installe t-il le jdk de Java ?
(rien dans usr/java) mais la commande java - version me repond:

java version "1.4.2"
gij (GNU libgcj) version 4.1.2 20070626 (Red Hat 4.1.2-13)
Copyright (C) 2006 Free Software Foundation, Inc.

- J'ai installé ensuite le java jdk 1.4.12 en rpm et cette fois
il est bien sous usr/java

- Est-ce que je dois desinstaller tomcat puis le reinstaller ensuite,
afin qu'il utilise le jdk 1.4.12 au bon endroit ?

- J'avais entendu parler du fonctionnement d'apache avec le mod_webapp
qui permettait d'utiliser le même apache que pour php ou perl, par
exemple Mais rien trouvé de récent la dessus

Merci pour vos infos
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Isammoc
Le #228891
Bonjour,


bonjour,

je cherche a installer Tomcat5 sur un serveur fedora core 6.


Je connais ni la version 5 ni fedora. Mais j'ai installé Tomcat5.5 sur
Debian etch.

J'ai installé, via yum install tomcat5.i386


je suppose que yum est le gestionnaire de paquets chez Fedora.

Apres avoir lancé le service /etc/init.d/tomcat5 start
=> j'ai rien sur le navigateur en port 8080, il ne répond pas...


Es-tu sur que ca écoute sur le port 8080 ?
Par exemple, chez moi, c'est le port 8180 par défaut.
Regarde dans le fichier server.xml à quel port il écoute.
Au pire, avec la commande netstat tu devrais pouvoir découvrir le port.

- Ce package installe t-il le jdk de Java ?
(rien dans usr/java) mais la commande java - version me repond:


Cela dépend de ton manager de paquet. Je ne connais pas yum.
Mais si il gère correctement les dépendances des paquets, cela devrait
le faire. De plus, pour tourner, tomcat n'a pas besoin de jdk (kit de
développement) mais de jvm (La machine virtuelle java) et de jre (les
runtimes, les classes de base)

java version "1.4.2"
gij (GNU libgcj) version 4.1.2 20070626 (Red Hat 4.1.2-13)
Copyright (C) 2006 Free Software Foundation, Inc.


Ceci n'a pas l'air d'être la version de Sun, mais une compatible 1.4.2.
Cela peut peut-etre etre un probleme. Il existe les paquets de la 1.5 de
Sun (en tous cas sur Debian).

- J'ai installé ensuite le java jdk 1.4.12 en rpm et cette fois
il est bien sous usr/java


Normalement, usr/java n'est qu'un lien symbolique vers les classes de base.

- Est-ce que je dois desinstaller tomcat puis le reinstaller ensuite,
afin qu'il utilise le jdk 1.4.12 au bon endroit ?


Non, par contre, regarde ton /etc/alternatives/java pour qu'il pointe
bien vers le bon.
# update-alternatives -config java


- J'avais entendu parler du fonctionnement d'apache avec le mod_webapp
qui permettait d'utiliser le même apache que pour php ou perl, par
exemple... Mais rien trouvé de récent la dessus...


mod_webapp, je ne connais pas du tout.
mod_jk qui permet de se connecter au serveur tomcat, par contre, je connais.


Merci pour vos infos...


Si ca peut aider...

--
Isammoc

Publicité
Poster une réponse
Anonyme