pb install

Le
Cyrille
Bonjour

Installation de nuxeo client via le git.
Pas de problème lors de l'install. Debian stable, python 2.7
par contre au lancement ça se plante



trollfest:~$ ndrive
2014-01-23 16:14:52,734 2322 139764809373440 INFO alembic.migration Co=
ntext impl SQLiteImpl.
2014-01-23 16:14:52,734 2322 139764809373440 INFO alembic.migration Wi=
ll assume non-transactional DDL.
Traceback (most recent call last):
File "/usr/local/bin/ndrive", line 6, in <module>
sys.exit(main())
File "/usr/local/lib/python2.7/dist-packages/nxdrive/commandline.py", lin=
e 505, in main
return CliHandler().handle(argv)
File "/usr/local/lib/python2.7/dist-packages/nxdrive/commandline.py", lin=
e 314, in handle
timeout=options.timeout)
File "/usr/local/lib/python2.7/dist-packages/nxdrive/controller.py", line=
159, in __init__
migrate_db(self._engine)
File "/usr/local/lib/python2.7/dist-packages/nxdrive/migration.py", line =
18, in migrate_db
upgrade(config, engine, 'head')
File "/usr/local/lib/python2.7/dist-packages/nxdrive/migration.py", line =
39, in upgrade
run_migration(engine)
File "/usr/local/lib/python2.7/dist-packages/nxdrive/migration.py", line =
71, in run_migration
head_rev = context.get_head_revision()
File "<string>", line 7, in get_head_revision
File "/usr/local/lib/python2.7/dist-packages/alembic/environment.py", lin=
e 148, in get_head_revision
return self.script._as_rev_number("head")
File "/usr/local/lib/python2.7/dist-packages/alembic/script.py", line 122=
, in as_revision_number
id_ = self.get_current_head()
File "/usr/local/lib/python2.7/dist-packages/alembic/script.py", line 255=
, in get_current_head
current_heads = self.get_heads()
File "/usr/local/lib/python2.7/dist-packages/alembic/script.py", line 284=
, in get_heads
for script in self._revision_map.values():
File "/usr/local/lib/python2.7/dist-packages/alembic/util.py", line 233, =
in __get__
obj.__dict__[self.__name__] = result = self.fget(obj)
File "/usr/local/lib/python2.7/dist-packages/alembic/script.py", line 208=
, in _revision_map
for file_ in os.listdir(self.versions):
OSError: [Errno 2] No such file or directory:
'/usr/local/lib/python2.7/dist-packages/alembic/versions'



Voici le contenu du répertoire incriminé
ls /usr/local/lib/python2.7/dist-packages/alembic
autogenerate compat.py config.pyc ddl __init__.py migra=
tion.pyc op.py script.pyc util.pyc
command.py compat.pyc context.py environment.py __init__.pyc opera=
tions.py op.pyc templates
command.pyc config.py context.pyc environment.pyc migration.py
operations.pyc script.py util.py


Auriez vous des pistes ?

Merci,
Cyrille

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20140123162409.4bd5b8c2@trollfest.trollfest.panic
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Michel OLTRA
Le #25951022
Bonjour,


Le jeudi 23 janvier 2014, Cyrille a écrit...


File "/usr/local/lib/python2.7/dist-packages/alembic/script.py", line 208, in _revision_map
for file_ in os.listdir(self.versions):
OSError: [Errno 2] No such file or directory:
'/usr/local/lib/python2.7/dist-packages/alembic/versions'

Voici le contenu du répertoire incriminé
ls /usr/local/lib/python2.7/dist-packages/alembic
autogenerate compat.py config.pyc ddl __init__.py migration.pyc op.py script.pyc util.pyc
command.py compat.pyc context.py environment.py __init__.pyc operations.py op.pyc templates
command.pyc config.py context.pyc environment.pyc migration.py
operations.pyc script.py util.py

Auriez vous des pistes ?



Il te manque un fichier ou dossier versions (un répertoire,
probablement)dans dist-packages/alembic

Tu peux regarder le code de ce script.py pour voir ce qu'il compte faire
avec ce qui se trouve dans alembic/versions.
Tu peux également créer ce répertoire, pour voir ce que ça va donner
ensuite…

--
jm

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Cyrille
Le #25951682
Il te manque un fichier ou dossier versions (un répertoire,
probablement)dans dist-packages/alembic



OK je l'avais fait hier en y mettant le numéro de version d'Alembic ma is ça ne passait pas pour autant.


Tu peux regarder le code de ce script.py pour voir ce qu'il compte faire
avec ce qui se trouve dans alembic/versions.
Tu peux également créer ce répertoire, pour voir ce que ça va donner
ensuite…


je vais jeter un oeil de ce côté

Merci
++
C

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Cyrille
Le #25952532
> avec ce qui se trouve dans alembic/versions.
> Tu peux également créer ce répertoire, pour voir ce que ça va donner
> ensuite…


OK nickel ça roule j'ai créé le répertoire ça passe
Marrant sur le git ce répertoire existe, mais il n'a pas été rapatrié lors de l'install.
En tout cas merci

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #25952702
Le vendredi 24 janvier 2014 20:01:23 Cyrille a écrit :
[…]
Marrant sur le git ce répertoire existe, mais il n'a pas ét é
rapatrié lors de l'install.



Normal, git ne s’occupe pas des répertoires, seulement d es
fichiers, donc les répertoires vides sont zappés.

Les répertoires ne sont pas dans le dépôt Git (en gros , dans
le .git) en tant que tels, ils n’y sont qu’en tant que partie
des noms de fichiers.
S’il y a des répertoires vides dans la _visualisation_ du dépôt
d’origine, c’est qu’ils ont été crà ©Ã©s séparément ou pas
nettoyés.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Cyrille
Le #25952832
S’il y a des répertoires vides dans la _visualisation_ du d épôt
d’origine, c’est qu’ils ont été crà ©Ã©s séparément ou pas
nettoyés


merci pour l'explication, je comprends ainsi mieux le pourquoi du comment, ;-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme