Pb lecture CDs et fichiers musicaux avec Etch4.0r1

Le
Christophe MUSSEAU
=_Part_8498_13210825.1196343356947
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour à tous,

Il y a quelques jours j'avais écrit:

"Il y a quelques temps encore j'utilisais ETCH 4.0, puis je suis passé =
à
ETCH 4.0r1 .
Pour cela j'ai réalisé une réinstallation de ETCH car je souhaitais r=
epartir
sur quelque chose de "propre" (si je peux parler ainsi).

Bref me voilà donc avec un nouveau noyau ( 2.6.18-5-486) et à refaire t=
oute
ma configuration. J'en arrive à la question du son. Et là je ne peux li=
re
les CDs musicaux (alors que je pouvais avec ETCH 4.0). Je cherche pourquoi.
Je ne trouve pas. Je finis par refaire une installation Je vous laisse
donc ici la procédure que j'ai suivi quand je me suis attaqué au chapit=
re
"Musique". Peut-être quelqu'un pourra-t-il m'éclairer sur ce que j'ai p=
u
oublier ou mal faire. Merci par avance.

Autre précision, ma carte son = VIA AC'97 Enhanced Audio Controller

1 - # aptitude install alsa-base
==) Installation des paquets alsa-utils, linux-sound-base & alsa-base
==) Lors de la configuration de linux-sound-base je demande que le syst=
ème
de gestion du son soit assuré par ALSA.

2 - # alsaconf
==) - Following card(s) are found on your system = VIA Technologies, =
Inc.
VT8233/A/8
==) - Do you want to modify /etc/modprobe.d/sound ? = Oui

3 - # alsamixer
Je m'assure qu'il y ait du volume pour le CD

4 - # alsactl store
Pour conserver cette configuration.

5 - # aptitude install w32codecs via le dépôt de debian-multimedia.o=
rg .
==) Installation des paquets gcc-3.3-base, libstdc++5 & w32codecs

6 - # aptitude install rhythmbox sound-juicer
==) Sur les forums on me dit d'installer xmms, mais moi j'aime bien ces=
deux
applications et en plus je les maîtrise assez bien. Alors pourquoi change=
r.
En plus elles s'intègrent bien avec Gnome que j'utilise.
==) Installation des paquets avahi-daemon, gnome-volume-manager,
gstreamer0.10-gnomevfs, gstreamer0.10-plugins-ugly, gthumb, hal,
liba52-0.7.4, libavahi-core4, libavcodec0d, libdvdread3, libgphoto2-2,
libgphoto2-post0, libgpod-common, libgpod0, libgpod1, libgsm1, libid3tag0,
liblircclient0, libmad0, libmng1, libmodplug0c2, libpmpeg2-4,
libmusicbrainz4c2a, libnss-mdns, libpostmoc0d, libsidplay1, libsysfs2,
libxine1, libxvmc1, pmount, rhythmbox, sound-juicer, totem, totem-mozilla &
totem-xine.

7 - Ensuite je m'assure que mon login d'utilisateur soit bien dans les
groupes audio & cdrom

8 - # chmod 666 /dev/hdc

Voilà je n'ai plus qu'à poursuivre en m'écoutant un de mes CDs préf=
érés. Et
bien non. Quand je lance le CD, sound-juicer se lance à son tour. Les pis=
tes
sont reconnues (titres, etc). Tout semble se lancer et puis ça bloque.
Aucun message d'erreur.
Plusieurs recherches sur le net ne m'ont rien donné de plus.
Donc je me tourne vers cette liste de diffusion en espérant que l'un d'en=
tre
vous puisse éclairer ma lanterne.



PS: Si quelqu'un connait une application pour lire des CDs musicaux en
console, merci de bien vouloir m'en faire part par la même occasion. "



Depuis j'ai pris le temps de traiter les suggestions qui m'ont été fai=
tes
pour résoudre ce problème. Je dois avouer que tout ceci n'a pas été
concluant:

1 - On me demande si je n'ai pas un "butineur ouvert avec une page contenan=
t
du flash et
donc, s'accaparant le son ? ".
La réponse est non. Je n'ai d'ailleurs aucune application qui cherche à
s'accaparer le son en parallèle.

2 - On me suggère de regarder dans "gstreamer-properties si c'est bien al=
sa
qui est
utiliser par defaut"
Je me suis aussi assuré de cela.

3 - Ai-je d'autres sons ? Et bien là c'est un peu compliqué: j'ai des s=
ons
pour des applications du genre planet-penguin-racer (le pingouin fou qui
dévale les pentes enneigées) par exemple. Mais je n'ai aucun son dès =
qu'il
s'agit de fichiers musicaux (MP3 ou ogg-vorbis). J'ai d'ailleurs le même
souci qu'avec les CDs musicaux. A savoir que l'application semble avoir du
mal à lire le fichier souhaité. C'est-à-dire que je ne vois pas la ba=
rre de
défilement avancer lors de la lecture du fichier.

4 - On me suggère aussi d'installer le module cdfs.
Je lance alors:
# m-a a-i cdfs
Installation de paquets supplémentaires: cdfs & kernel-packages
Bref, cela ne résoud en rien mon problème.

5 - J'ai aussi installé divers paquets gstreamer, comme
gstreamer0.10-fluendo.mp3 ou gstreamer0.10-lame, mais toujours rien.

Voilà, suis-je donc condamné à travailler en silence ou y a-t-il ré=
ellement
une possibilité d'écouter de la musique avec Etch4.0r1 ?

--
@ + Christophe MUSSEAU
ossau.net

(sous Etch)

=_Part_8498_13210825.1196343356947
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour à tous,<br><br>Il y a quelques jours j&#39;avais écrit:<br><br>=
&quot;<span style="font-style: italic; color: rgb(153, 102, 51);">Il y a =
quelques temps encore j&#39;utilisais ETCH 4.0, puis je suis passé à ET=
CH 4.0r1




.</span><br style="font-style: italic; color: rgb(153, 102, 51);"><span s=
tyle="font-style: italic; color: rgb(153, 102, 51);">Pour
cela j&#39;ai réalisé une réinstallation de ETCH car je souhaitais re=
partir
sur quelque chose de &quot;propre&quot; (si je peux parler ainsi).
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><br styl=
e="font-style: italic; color: rgb(153, 102, 51);"><span style="font-sty=
le: italic; color: rgb(153, 102, 51);">Bref me voilà donc avec un nouveau=
noyau (
2.6.18-5-486) et à
refaire toute ma configuration. J&#39;en arrive à la question du son. Et =

je ne peux lire les CDs musicaux (alors que je pouvais avec ETCH 4.0).
Je cherche pourquoi. Je ne trouve pas. Je finis par refaire une
installation Je vous laisse donc ici la procédure que j&#39;ai suivi
quand je me suis attaqué au chapitre &quot;Musique&quot;. Peut-être que=
lqu&#39;un
pourra-t-il m&#39;éclairer sur ce que j&#39;ai pu oublier ou mal faire. M=
erci
par avance.
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><br styl=
e="font-style: italic; color: rgb(153, 102, 51);"><span style="font-sty=
le: italic; color: rgb(153, 102, 51);">Autre précision, ma carte son = =
VIA AC&#39;97 Enhanced Audio Controller
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><br styl=
e="font-style: italic; color: rgb(153, 102, 51);"><span style="font-sty=
le: italic; color: rgb(153, 102, 51);">1 - # aptitude install alsa-base<br>=
==) Installation des paquets alsa-utils, linux-sound-base &amp; alsa-ba=
se
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><span st=
yle="font-style: italic; color: rgb(153, 102, 51);">==) Lors de la co=
nfiguration de linux-sound-base je demande que le système de gestion du s=
on soit assuré par ALSA.
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><br styl=
e="font-style: italic; color: rgb(153, 102, 51);"><span style="font-sty=
le: italic; color: rgb(153, 102, 51);">2 - # alsaconf<br>
==) - Following card(s) are found on your system = VIA Technologies, =
Inc. VT8233/A/8</span><br style="font-style: italic; color: rgb(153, 102,=
51);"><span style="font-style: italic; color: rgb(153, 102, 51);">
) - Do you want to modify /etc/modprobe.d/sound ?
= Oui</span><br style="font-style: italic; color: rgb(153, 102, 51);"><=
br style="font-style: italic; color: rgb(153, 102, 51);"><span style="f=
ont-style: italic; color: rgb(153, 102, 51);">3 - # alsamixer<br>Je m&#39;a=
ssure qu&#39;il y ait du volume pour le CD
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><br styl=
e="font-style: italic; color: rgb(153, 102, 51);"><span style="font-sty=
le: italic; color: rgb(153, 102, 51);">4 - # alsactl store
<br>Pour conserver cette configuration.</span><br style="font-style: ital=
ic; color: rgb(153, 102, 51);"><br style="font-style: italic; color: rgb(=
153, 102, 51);"><span style="font-style: italic; color: rgb(153, 102, 51)=
;">




5 - # aptitude install w32codecs &nbsp;&nbsp; via le dépôt de
<a href="http://debian-multimedia.org/" target="_blank" onclick="retu=
rn top.js.OpenExtLink(window,event,this)">debian-multimedia.org</a> .<br>=
==) Installation des paquets gcc-3.3-base, libstdc++5 &amp; w32codecs
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><br styl=
e="font-style: italic; color: rgb(153, 102, 51);"><span style="font-sty=
le: italic; color: rgb(153, 102, 51);">6 - # aptitude install rhythmbox sou=
nd-juicer
<br>==)
Sur les forums on me dit d&#39;installer xmms, mais moi j&#39;aime bien ces
deux applications et en plus je les maîtrise assez bien. Alors pourquoi
changer. En plus elles s&#39;intègrent bien avec Gnome que j&#39;utilise.
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><span st=
yle="font-style: italic; color: rgb(153, 102, 51);">==) Installation =
des paquets avahi-daemon, gnome-volume-manager,
gstreamer0.10-gnomevfs, gstreamer0.10-plugins-ugly, gthumb, hal,
liba52-0.7.4, libavahi-core4, libavcodec0d, libdvdread3, libgphoto2-2,
libgphoto2-post0, libgpod-common, libgpod0, libgpod1, libgsm1,
libid3tag0, liblircclient0, libmad0, libmng1, libmodplug0c2,
libpmpeg2-4, libmusicbrainz4c2a, libnss-mdns, libpostmoc0d,
libsidplay1, libsysfs2, libxine1, libxvmc1, pmount, rhythmbox,
sound-juicer, totem, totem-mozilla &amp; totem-xine.
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><br styl=
e="font-style: italic; color: rgb(153, 102, 51);"><span style="font-sty=
le: italic; color: rgb(153, 102, 51);">7 - Ensuite je m&#39;assure que mon =
login d&#39;utilisateur soit bien dans les groupes audio &amp; cdrom
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><br styl=
e="font-style: italic; color: rgb(153, 102, 51);"><span style="font-sty=
le: italic; color: rgb(153, 102, 51);">8 - # chmod 666 /dev/hdc<br><br>
Voilà je n&#39;ai plus qu&#39;à poursuivre en m&#39;écoutant un de me=
s CDs
préférés. Et bien non. Quand je lance le CD, sound-juicer se lance =
à
son tour. Les pistes sont reconnues (titres, etc). Tout semble se
lancer et puis ça bloque. Aucun message d&#39;erreur.
</span><br style="font-style: italic; color: rgb(153, 102, 51);"><span st=
yle="font-style: italic; color: rgb(153, 102, 51);">Plusieurs recherches =
sur le net ne m&#39;ont rien donné de plus.</span><br style="font-style=
: italic; color: rgb(153, 102, 51);">




<span style="font-style: italic; color: rgb(153, 102, 51);">Donc je me to=
urne vers cette liste de diffusion en espérant que l&#39;un d&#39;entre v=
ous puisse éclairer ma lanterne.</span><br style="font-style: italic; c=
olor: rgb(153, 102, 51);">




<br style="font-style: italic; color: rgb(153, 102, 51);"><br style="fo=
nt-style: italic; color: rgb(153, 102, 51);"><br style="font-style: itali=
c; color: rgb(153, 102, 51);"><span style="font-style: italic; color: rgb=
(153, 102, 51);">




PS:
Si quelqu&#39;un connait une application pour lire des CDs musicaux en
console, merci de bien vouloir m&#39;en faire part par la même occasion.
</span>&quot;<br><br><span style="font-style: italic;"><span style="fon=
t-style: italic;"></span><br><span style="font-style: italic;"></span></s=
pan><span style="font-style: italic;"><span style="font-style: italic;"=
></span>
<br></span>



<span style="font-style: italic;">
<span style="font-style: italic;"></span></span>Depuis j&#39;ai pris le t=
emps de traiter les suggestions qui m&#39;ont été faites pour résoudr=
e ce problème. Je dois avouer que tout ceci n&#39;a pas été concluant=
:<br><br>




1 - On me demande si je n&#39;ai pas un &quot;b<span style="font-style: i=
talic;">utineur ouvert avec une page contenant du flash et</span><br style=
="font-style: italic;"><span style="font-style: italic;">donc, s&#39;ac=
caparant le son ?
</span>&quot;. <br>La réponse est non. Je n&#39;ai d&#39;ailleurs aucune =
application qui cherche à s&#39;accaparer le son en parallèle.<br><br>2=
- On me suggère de regarder dans &quot;<span style="font-style: italic=
;">gstreamer-properties si c&#39;est bien alsa qui est
</span><br style="font-style: italic;"><span style="font-style: italic;=
">utiliser par defaut</span>&quot;<br>Je me suis aussi assuré de cela.=
<br><br>3 - Ai-je d&#39;autres sons ? Et bien là c&#39;est un peu compliq=
ué: j&#39;ai des sons pour des applications du genre
<span style="font-style: italic;">planet-penguin-racer</span> (le pingoui=
n fou qui dévale les pentes enneigées) par exemple. Mais je n&#39;ai au=
cun son dès qu&#39;il s&#39;agit de fichiers musicaux (MP3 ou ogg-vorbis)=
. J&#39;ai d&#39;ailleurs le même souci qu&#39;avec les CDs musicaux. A s=
avoir que l&#39;application semble avoir du mal à lire le fichier souhait=
é. C&#39;est-à-dire que je ne vois pas la barre de défilement avancer=
lors de la lecture du fichier.
<br><br>4 - On me suggère aussi d&#39;installer le module cdfs.<br>Je la=
nce alors:<br># m-a a-i cdfs<br> Installation de paquets supplémentair=
es: cdfs &amp; kernel-packages<br>Bref, cela ne résoud en rien mon probl=
ème.
<br><br>5 - J&#39;ai aussi installé divers paquets <span style="font-st=
yle: italic;">gstreamer</span>, comme <span style="font-style: italic;">g=
streamer0.10-fluendo.mp3</span> ou <span style="font-style: italic;">gstr=
eamer0.10-lame
</span>, mais toujours rien.<br><br>Voilà, suis-je donc condamné à tr=
availler en silence ou y a-t-il réellement une possibilité d&#39;écou=
ter de la musique avec Etch4.0r1 ?<br clear="all"><br>-- <br>@ + Christop=
he MUSSEAU
<br><a href="http://ossau.net" target="_blank" onclick="return top.js=
.OpenExtLink(window,event,this)">

ossau.net</a><br><br>(sous Etch)

=_Part_8498_13210825.1196343356947--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Hugues LARRIVE
Le #9740101
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigD0212B426C4105D45B5D0406
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Christophe MUSSEAU a écrit :
Bonjour à tous,


Bonjour,

Il y a quelques jours j'avais écrit:

"Il y a quelques temps encore j'utilisais ETCH 4.0, puis je suis passé
à ETCH 4.0r1 .


Etch c'est etch, le résultat est le même... juste avec l'installeur 4 .0
tu as un peu plus de mises à jour à faire juste après l'installatio n.
Pour cela j'ai réalisé une réinstallation de ETCH car je souhaita is
repartir sur quelque chose de "propre" (si je peux parler ainsi).

Bref me voilà donc avec un nouveau noyau ( 2.6.18-5-486) et à refai re
toute ma configuration. J'en arrive à la question du son. Et là je ne
peux lire les CDs musicaux (alors que je pouvais avec ETCH 4.0). Je
cherche pourquoi. Je ne trouve pas. Je finis par refaire une
installation... Je vous laisse donc ici la procédure que j'ai suivi
quand je me suis attaqué au chapitre "Musique". Peut-être quelqu'un
pourra-t-il m'éclairer sur ce que j'ai pu oublier ou mal faire. Merci
par avance.

Autre précision, ma carte son = VIA AC'97 Enhanced Audio Controller

1 - # aptitude install alsa-base
==) Installation des paquets alsa-utils, linux-sound-base & alsa-ba se
==) Lors de la configuration de linux-sound-base je demande que le
système de gestion du son soit assuré par ALSA.

2 - # alsaconf
==) - Following card(s) are found on your system = VIA Technologi es,
Inc. VT8233/A/8
==) - Do you want to modify /etc/modprobe.d/sound ? = Oui

3 - # alsamixer
Je m'assure qu'il y ait du volume pour le CD

4 - # alsactl store
Pour conserver cette configuration.

5 - # aptitude install w32codecs via le dépôt de
debian-multimedia.org ==) Installation des paquets gcc-3.3-base, libstdc++5 & w32codecs

6 - # aptitude install rhythmbox sound-juicer
==) Sur les forums on me dit d'installer xmms, mais moi j'aime bien
ces deux applications et en plus je les maîtrise assez bien. Alors
pourquoi changer. En plus elles s'intègrent bien avec Gnome que
j'utilise.
==) Installation des paquets avahi-daemon, gnome-volume-manager,
gstreamer0.10-gnomevfs, gstreamer0.10-plugins-ugly, gthumb, hal,
liba52-0.7.4, libavahi-core4, libavcodec0d, libdvdread3, libgphoto2-2,
libgphoto2-post0, libgpod-common, libgpod0, libgpod1, libgsm1,
libid3tag0, liblircclient0, libmad0, libmng1, libmodplug0c2,
libpmpeg2-4, libmusicbrainz4c2a, libnss-mdns, libpostmoc0d,
libsidplay1, libsysfs2, libxine1, libxvmc1, pmount, rhythmbox,
sound-juicer, totem, totem-mozilla & totem-xine.

7 - Ensuite je m'assure que mon login d'utilisateur soit bien dans les
groupes audio & cdrom


Je ne suis pas sûr mais pour les cd audio il faut peut-être plugdev e n
plus...
As-tu récupéré ton home de l'ancienne installation ? si oui as-tu e ssayé
avec un autre utilisateur ?

8 - # chmod 666 /dev/hdc



Ça ça n'est pas conservé après le redémarrage (udev).
Voilà je n'ai plus qu'à poursuivre en m'écoutant un de mes CDs
préférés. Et bien non. Quand je lance le CD, sound-juicer se lanc e à
son tour. Les pistes sont reconnues (titres, etc...). Tout semble se
lancer et puis ça bloque. Aucun message d'erreur.
Plusieurs recherches sur le net ne m'ont rien donné de plus.
Donc je me tourne vers cette liste de diffusion en espérant que l'un
d'entre vous puisse éclairer ma lanterne.



PS: Si quelqu'un connait une application pour lire des CDs musicaux en
console, merci de bien vouloir m'en faire part par la même occasion. "



cdtool


Depuis j'ai pris le temps de traiter les suggestions qui m'ont été
faites pour résoudre ce problème. Je dois avouer que tout ceci n'a pas
été concluant:

1 - On me demande si je n'ai pas un "butineur ouvert avec une page
contenant du flash et
donc, s'accaparant le son ? ".
La réponse est non. Je n'ai d'ailleurs aucune application qui cherche
à s'accaparer le son en parallèle.



Tu peux aussi faire lsof | grep snd pour voir si une application se
l'accapare, normalement tu ne dois voir que mixer_app....
A propos tu peux régler le son avec gnome-volume-control ?
2 - On me suggère de regarder dans "gstreamer-properties si c'est bie n
alsa qui est
utiliser par defaut..."
Je me suis aussi assuré de cela.


Et en cliquant sur test ça donne quoi ?

3 - Ai-je d'autres sons ? Et bien là c'est un peu compliqué: j'ai d es
sons pour des applications du genre planet-penguin-racer (le pingouin
fou qui dévale les pentes enneigées) par exemple. Mais je n'ai aucu n
son dès qu'il s'agit de fichiers musicaux (MP3 ou ogg-vorbis). J'ai
d'ailleurs le même souci qu'avec les CDs musicaux. A savoir que
l'application semble avoir du mal à lire le fichier souhaité.
C'est-à-dire que je ne vois pas la barre de défilement avancer lors de
la lecture du fichier.


En générale c'est qu'elle attend que le périphérique soit libér é, tu
dois donc avoir quelque chose qui occupe la carte son et tu devrais pour
trouver quoi avec lsof.


@+

4 - On me suggère aussi d'installer le module cdfs.
Je lance alors:
# m-a a-i cdfs
... Installation de paquets supplémentaires: cdfs & kernel-packages
Bref, cela ne résoud en rien mon problème.

5 - J'ai aussi installé divers paquets gstreamer, comme
gstreamer0.10-fluendo.mp3 ou gstreamer0.10-lame , mais toujours rien.

Voilà, suis-je donc condamné à travailler en silence ou y a-t-il
réellement une possibilité d'écouter de la musique avec Etch4.0r1 ?

--
@ + Christophe MUSSEAU
ossau.net
(sous Etch)





--------------enigD0212B426C4105D45B5D0406
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHTtY/NdTZuHWpgVIRAm7PAJ9XrErcXuMj8QoRfCBbQPQYzKlwbACfZwF7
vKSBAL3Eg+o+Ki2jJxIXIDE SgO
-----END PGP SIGNATURE-----

--------------enigD0212B426C4105D45B5D0406--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Christophe MUSSEAU
Le #9739791
------=_Part_4182_14361083.1196545607793
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour,

Toujours mon problème de lecture de CDs musicaux...



Le 29/11/07, Hugues LARRIVE

Christophe MUSSEAU a écrit :
> Bonjour à tous,
Bonjour,
>
> Il y a quelques jours j'avais écrit:
>
> "Il y a quelques temps encore j'utilisais ETCH 4.0, puis je suis pass é
> à ETCH 4.0r1 .
Etch c'est etch, le résultat est le même... juste avec l'installeur 4 .0
tu as un peu plus de mises à jour à faire juste après l'installatio n.
> Pour cela j'ai réalisé une réinstallation de ETCH car je souhaita is
> repartir sur quelque chose de "propre" (si je peux parler ainsi).
>
> Bref me voilà donc avec un nouveau noyau ( 2.6.18-5-486) et à refai re
> toute ma configuration. J'en arrive à la question du son. Et là je ne
> peux lire les CDs musicaux (alors que je pouvais avec ETCH 4.0). Je
> cherche pourquoi. Je ne trouve pas. Je finis par refaire une
> installation... Je vous laisse donc ici la procédure que j'ai suivi
> quand je me suis attaqué au chapitre "Musique". Peut-être quelqu'un
> pourra-t-il m'éclairer sur ce que j'ai pu oublier ou mal faire. Merci
> par avance.
>
> Autre précision, ma carte son = VIA AC'97 Enhanced Audio Controller
>
> 1 - # aptitude install alsa-base
> ==) Installation des paquets alsa-utils, linux-sound-base & alsa-ba se
> ==) Lors de la configuration de linux-sound-base je demande que le
> système de gestion du son soit assuré par ALSA.
>
> 2 - # alsaconf
> ==) - Following card(s) are found on your system = VIA Technologi es,
> Inc. VT8233/A/8
> ==) - Do you want to modify /etc/modprobe.d/sound ? = Oui
>
> 3 - # alsamixer
> Je m'assure qu'il y ait du volume pour le CD
>
> 4 - # alsactl store
> Pour conserver cette configuration.
>
> 5 - # aptitude install w32codecs via le dépôt de
> debian-multimedia.org > ==) Installation des paquets gcc-3.3-base, libstdc++5 & w32codecs
>
> 6 - # aptitude install rhythmbox sound-juicer
> ==) Sur les forums on me dit d'installer xmms, mais moi j'aime bien
> ces deux applications et en plus je les maîtrise assez bien. Alors
> pourquoi changer. En plus elles s'intègrent bien avec Gnome que
> j'utilise.
> ==) Installation des paquets avahi-daemon, gnome-volume-manager,
> gstreamer0.10-gnomevfs, gstreamer0.10-plugins-ugly, gthumb, hal,
> liba52-0.7.4, libavahi-core4, libavcodec0d, libdvdread3, libgphoto2-2,
> libgphoto2-post0, libgpod-common, libgpod0, libgpod1, libgsm1,
> libid3tag0, liblircclient0, libmad0, libmng1, libmodplug0c2,
> libpmpeg2-4, libmusicbrainz4c2a, libnss-mdns, libpostmoc0d,
> libsidplay1, libsysfs2, libxine1, libxvmc1, pmount, rhythmbox,
> sound-juicer, totem, totem-mozilla & totem-xine.
>
> 7 - Ensuite je m'assure que mon login d'utilisateur soit bien dans les
> groupes audio & cdrom
Je ne suis pas sûr mais pour les cd audio il faut peut-être plugdev e n
plus...




C'est quoi plugdev ? un paquet ? je n'ai aucune info à ce sujet


As-tu récupéré ton home de l'ancienne installation ?


Non.


si oui as-tu essayé
avec un autre utilisateur ?
>
> 8 - # chmod 666 /dev/hdc
>
Ça ça n'est pas conservé après le redémarrage (udev).
> Voilà je n'ai plus qu'à poursuivre en m'écoutant un de mes CDs
> préférés. Et bien non. Quand je lance le CD, sound-juicer se lanc e à
> son tour. Les pistes sont reconnues (titres, etc...). Tout semble se
> lancer et puis ça bloque. Aucun message d'erreur.
> Plusieurs recherches sur le net ne m'ont rien donné de plus.
> Donc je me tourne vers cette liste de diffusion en espérant que l'un
> d'entre vous puisse éclairer ma lanterne.
>
>
>
> PS: Si quelqu'un connait une application pour lire des CDs musicaux en
> console, merci de bien vouloir m'en faire part par la même occasion. "
>
cdtool
>
>
> Depuis j'ai pris le temps de traiter les suggestions qui m'ont été
> faites pour résoudre ce problème. Je dois avouer que tout ceci n'a pas
> été concluant:
>
> 1 - On me demande si je n'ai pas un "butineur ouvert avec une page
> contenant du flash et
> donc, s'accaparant le son ? ".
> La réponse est non. Je n'ai d'ailleurs aucune application qui cherche
> à s'accaparer le son en parallèle.
>
Tu peux aussi faire lsof | grep snd pour voir si une application se
l'accapare, normalement tu ne dois voir que mixer_app....




J'ai un nombre de lignes assez conséquent débutant par "mixer-app...". Que
dois-je réellement chercher ?

A propos tu peux régler le son avec gnome-volume-control ?


Oui.

2 - On me suggère de regarder dans "gstreamer-properties si c'est bien
> alsa qui est
> utiliser par defaut..."
> Je me suis aussi assuré de cela.
Et en cliquant sur test ça donne quoi ?




1 - Default Output Plugin
- Output = ALSA
- Pipeline = alsask
==) Test = j'ai du son (Bip Bip Bip...)

2 - Default Input Plugin
- Input = ALSA
- Pipeline = alsasrc
==) Test = Aucun son. Message d'erreur = "Error - Failed to constru ct test
pipeline for 'ALSA'".



> 3 - Ai-je d'autres sons ? Et bien là c'est un peu compliqué: j'ai d es
> sons pour des applications du genre planet-penguin-racer (le pingouin
> fou qui dévale les pentes enneigées) par exemple. Mais je n'ai aucu n
> son dès qu'il s'agit de fichiers musicaux (MP3 ou ogg-vorbis). J'ai
> d'ailleurs le même souci qu'avec les CDs musicaux. A savoir que
> l'application semble avoir du mal à lire le fichier souhaité.
> C'est-à-dire que je ne vois pas la barre de défilement avancer lors de
> la lecture du fichier.
En générale c'est qu'elle attend que le périphérique soit libér é, tu
dois donc avoir quelque chose qui occupe la carte son et tu devrais pour
trouver quoi avec lsof.


@+
>
> 4 - On me suggère aussi d'installer le module cdfs.
> Je lance alors:
> # m-a a-i cdfs
> ... Installation de paquets supplémentaires: cdfs & kernel-packages
> Bref, cela ne résoud en rien mon problème.
>
> 5 - J'ai aussi installé divers paquets gstreamer, comme
> gstreamer0.10-fluendo.mp3 ou gstreamer0.10-lame , mais toujours rien.
>
> Voilà, suis-je donc condamné à travailler en silence ou y a-t-il
> réellement une possibilité d'écouter de la musique avec Etch4.0r1 ?
>
> ----------------------------------








--
@ + Christophe MUSSEAU
ossau.net

(sous Etch)

------=_Part_4182_14361083.1196545607793
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour, &gt; 4.0 4.0). Je debian-multimedia.org <br>&gt; libgphoto2-post0, libgpod-common, libgpod0, libgpod1, libgsm1,<br> &gt; libid3tag0, liblircclient0, libmad0, libmng1, libmodplug0c2,<br>&gt; l ibpmpeg2-4, libmusicbrainz4c2a, libnss-mdns, libpostmoc0d,<br>&gt; libsidpl ay1, libsysfs2, libxine1, libxvmc1, pmount, rhythmbox,
As-tu récupéré ton home de l&#39;ancienne installation ? si oui as-tu essayé J&#39;ai un nombre de lignes assez conséquent débutant par &quot;mixer- app...&quot;. Que dois-je réellement chercher ? A propos tu peux régler le son avec gnome-volume-control ? &gt; 2 - On me suggère de regarder dans &quot;gstreamer-properties si c&# 39;est bien </blockquote><div><br><span style="color: rgb(102, 51, 255);">1 - Default Output Plugin</span><br style="color: rgb(102, 51, 255);"><span style= "color: rgb(102, 51, 255);">- Output = ALSA</span><br style="color: rgb (102, 51, 255);">
<br style="color: rgb(102, 51, 255);"><span style="color: rgb(102, 51, 255);">2 - Default Input Plugin</span><br style="color: rgb(102, 51, 255) ;"><span style="color: rgb(102, 51, 255);">- Input = ALSA</span><br sty le="color: rgb(102, 51, 255);">
<span style="color: rgb(102, 51, 255);">- Pipeline = alsasrc</span><br style="color: rgb(102, 51, 255);"><span style="color: rgb(102, 51, 255) ;">==) Test = Aucun son. Message d&#39;erreur = &quot;Error - Faile d to construct test pipeline for &#39;ALSA&#39;&quot;.
&gt;<br>&gt; 3 - Ai-je d&#39;autres sons ? Et bien là c&#39;est un peu co mpliqué: j&#39;ai des<br>&gt; sons pour des applications du genre planet- penguin-racer (le pingouin<br>&gt; fou qui dévale les pentes enneigées) par exemple. Mais je n&#39;ai aucun

------=_Part_4182_14361083.1196545607793--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Hugues LARRIVE
Le #9739651
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigF286AA8568758D2DBB248787
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Christophe MUSSEAU a écrit :
Bonjour,

Toujours mon problème de lecture de CDs musicaux...



Le 29/11/07, *Hugues LARRIVE*

Christophe MUSSEAU a écrit :
>
> 7 - Ensuite je m'assure que mon login d'utilisateur soit bien
dans les
> groupes audio & cdrom
Je ne suis pas sûr mais pour les cd audio il faut peut-être
plugdev en
plus...


C'est quoi plugdev ? un paquet ? je n'ai aucune info à ce sujet


plugdev est le group pour les médias amovibles genre clé USB, mais en
fait je me suis gouré, ça ne devrait pas être utile pour le cdrom.


As-tu récupéré ton home de l'ancienne installation ?


Non.


si oui as-tu essayé
avec un autre utilisateur ?
>
> 8 - # chmod 666 /dev/hdc
>
Ça ça n'est pas conservé après le redémarrage (udev).



...

>
> PS: Si quelqu'un connait une application pour lire des CDs
musicaux en
> console, merci de bien vouloir m'en faire part par la même
occasion. "
>
cdtool



Tu as essayé ?

>
>
> Depuis j'ai pris le temps de traiter les suggestions qui m'ont é té
> faites pour résoudre ce problème. Je dois avouer que tout cec i
n'a pas
> été concluant:
>
> 1 - On me demande si je n'ai pas un "butineur ouvert avec une pag e
> contenant du flash et
> donc, s'accaparant le son ? ".
> La réponse est non. Je n'ai d'ailleurs aucune application qui
cherche
> à s'accaparer le son en parallèle.
>
Tu peux aussi faire lsof | grep snd pour voir si une application se
l'accapare, normalement tu ne dois voir que mixer_app....


J'ai un nombre de lignes assez conséquent débutant par "mixer-app.. .".
Que dois-je réellement chercher ?


Ça c'est louche, moi je n'en ais qu'une :
mixer_app 3503 hugues 41u CHR 116,0
5329 /dev/snd/controlC0

Si je le fais pendant un test de gstreamer-properties (lecture) j'en ai 4 :
mixer_app 3503 hugues 41u CHR 116,0
5329 /dev/snd/controlC0
gstreamer 24136 hugues mem CHR 116,16
5303 /dev/snd/pcmC0D0p
gstreamer 24136 hugues 15r CHR 116,33
4980 /dev/snd/timer
gstreamer 24136 hugues 16u CHR 116,16
5303 /dev/snd/pcmC0D0p

Bien sur je n'en ais qu'un à cause du filtrage par grep, sinon j'en ai
un paquet aussi.

Ce qu'il faut chercher c'est ce qui accapare les périphériques :
/dev/snd/pcm*, /dev/dsp, /dev/audio, enfin tout ce qui appartient au
group audio dans /dev. En particulier /dev/dsp (oss), s'il est utilisé,
alasa ne foncitonne plus.

A propos tu peux régler le son avec gnome-volume-control ?


Oui.

> 2 - On me suggère de regarder dans "gstreamer-properties si
c'est bien
> alsa qui est
> utiliser par defaut..."
> Je me suis aussi assuré de cela.
Et en cliquant sur test ça donne quoi ?


1 - Default Output Plugin
- Output = ALSA
- Pipeline = alsask
==) Test = j'ai du son (Bip Bip Bip...)

2 - Default Input Plugin
- Input = ALSA
- Pipeline = alsasrc
==) Test = Aucun son. Message d'erreur = "Error - Failed to con struct
test pipeline for 'ALSA'".



En cherchant ce message d'erreur avec google, on trouve quelques
rapports de bug...

>
> 3 - Ai-je d'autres sons ? Et bien là c'est un peu compliqué:
j'ai des
> sons pour des applications du genre planet-penguin-racer (le
pingouin
> fou qui dévale les pentes enneigées) par exemple. Mais je n'a i
aucun
> son dès qu'il s'agit de fichiers musicaux (MP3 ou ogg-vorbis). J'ai
> d'ailleurs le même souci qu'avec les CDs musicaux. A savoir que
> l'application semble avoir du mal à lire le fichier souhaité.
> C'est-à-dire que je ne vois pas la barre de défilement avance r
lors de
> la lecture du fichier.



Tu peux essayer d'installer mpg321 qui lit les mp3 et permet de choisir
la sortie :
-o dt Set output devicetype to dt
[esd,alsa(09),arts,sun,oss]



--------------enigF286AA8568758D2DBB248787
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHUvgGNdTZuHWpgVIRAtMFAJ98NyL1dQKirODXu7t0RqyXUc8FyACfQJCz
9FV+H5bmBG6bthzW0Etfc7k =QvJR
-----END PGP SIGNATURE-----

--------------enigF286AA8568758D2DBB248787--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme