pb openldap + samba

Le
Vincent Verdon
Bonsoir à tous,

je ne sais si je frappe à la bonne porte, si je me trompe veuillez m'en
excuser mais je ne sais pas vraiment ou poster concernant des pb sur
Ldap dans un environnement Unix.

Voila, je tente d'utiliser openldap (sur Debian). Le but est d'utiliser
l'annuaire aussi bien pour des stations Unix/Linux que Windows via
Samba. Après quelques mois de recherches, la lecture su bouquin O reilly
sur ldap, etc, je ne sais plus bien que faire.

Actuellement mon annuaire fonctionne : je peux me connecter sur la
machine qui est serveur ldap en utilisant des login contenus dans
l'annuaire.

Par contre, j'ai plusieurs pb, dont je pense qu'ils peuvent être liés.
Tout d'abord, je n'arrive pas à configurer correctement les outils en
ligne de commande, genre ldapadduser. Normalement, d'après mes
nombreuses lectures, on doit pouvoir leur passer un certain nb
d'argument via le fichier /etc/ldap/ldap.conf ou ~/.ldaprc. notamment le
nom et le mot de passe de l'utilisateur aurorisé à administrer ldap, de
façon à ce que root puisse modifier l'annuaire. Cela ne fonctionne pas,
malgré toutes mes tentatives, j'obtiens un message m'indiquant que
j'effectue une connexion anonyme et qu'il n'est pas d'accord pour
m'autoriser à "bricoler" dans l'annuaire . En pasant tout en ligne de
commande, cela fonctionne. Pas grave en soi, mais je pressens que cela
peut être significatif.
Mon gros pb, c'est que je n'arrive pas à intégrer des machine Windoze XP
ou 2000 dans mon domaine Samba, alors que Samba est bien connecté à mon
annuaire ldap, puisque depuis des postes Win98, je peux me connecter
sans pb en utilisant un login contenu dans mon annuaire Ldap. Samba a
d'ailleurs été configuré pour accepter des utilisateurs enregistrés
dans l'annuaire ou dans le traditionnel fichier smbpasswd. Au passage,
je ne comprends pourquoi Samba ne vient pas essayer d'authentifier mes
machines XP dans smbpasswd (alors qu'elles y sont enregistrées) si il ne
les trouve pas dans l'annuaire ldap, alors que ce mécanisme fonctionne à
merveille pour les utilisateurs (mais sous Win98 seulement, qui ne
connait pas la notion de compte d'ordinateur)


J'ai été un peu long, mais j'espère assez clair.
Merci de me lire en tout cas.

Amicalment, Vincent Verdon
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
VANHULLEBUS Yvan
Le #117315
Vincent Verdon
Bonsoir à tous,


Salut.


je ne sais si je frappe à la bonne porte, si je me trompe veuillez
m'en excuser mais je ne sais pas vraiment ou poster concernant des pb
sur Ldap dans un environnement Unix.


Je sais pas non plus, dans le doute je vais repondre (un peu)...


Voila, je tente d'utiliser openldap (sur Debian). Le but est
d'utiliser l'annuaire aussi bien pour des stations Unix/Linux que
Windows via Samba. Après quelques mois de recherches, la lecture su
bouquin O reilly sur ldap, etc,... je ne sais plus bien que faire.


Jusque la, tres bonne initiative :-)


[ldapadduser]
J'ai toujours eu le meme probleme.....
En meme temps, j'ai du chercher a le resoudre environ 3 secondes, et
apres j'ai laisse tomber et je me suis fait un alias....

A priori, ca doit pas influer sur le reste de tes soucis.


Mon gros pb, c'est que je n'arrive pas à intégrer des machine Windoze
XP ou 2000 dans mon domaine Samba, alors que Samba est bien connecté à
mon annuaire ldap, puisque depuis des postes Win98, je peux me
connecter sans pb en utilisant un login contenu dans mon annuaire
Ldap. Samba a d'ailleurs été configuré pour accepter des utilisateurs
enregistrés dans l'annuaire ou dans le traditionnel fichier
smbpasswd. Au passage, je ne comprends pourquoi Samba ne vient pas
essayer d'authentifier mes machines XP dans smbpasswd (alors qu'elles
y sont enregistrées) si il ne les trouve pas dans l'annuaire ldap,
alors que ce mécanisme fonctionne à merveille pour les utilisateurs
(mais sous Win98 seulement, qui ne connait pas la notion de compte
d'ordinateur)...


Pareil.... enfin, a peu pres.....

Deja, y'a une grosse question importante: quelle est ta version de
Samba ?

Ils ont fait du gros boulot sur les toutes dernieres versions pour
pouvoir vraiment faire PDC, et c'etait beaucoup plus galere avant.


Sur le (tres vieux) Samba que j'utilise actuellement, j'ai reussi une
fois a integrer un Win2K sur le domaine.
En gros, les clients W2K/XP utilisent un numero, j'ai pas trop compris
comment il est genere, ni par qui.
Ce numero est utilise lors de l'enregistrement sur le domaine, et il
doit etre present dans la fiche LDAP, alors que tu ne le connais pas
encore, et alors que ca marche apparemment pas si tu mets toi meme
arbitrairement un numero dans la fiche....

La seule solution que j'avais trouve, c'etait de faire une demande
d'enregistrement sur le domaine, qui echoue lamentablement, forcement,
mais qui laisse une trace dans le log de samba (log.lamachine, je
crois), trace qui contient entre autres ledit numero.

Tu le recuperes, tu l'ajoutes dans la fiche de la machine (en
redumpant la foiche de la machine sur mon LDAP, je dirais que ca doit
etre l'attribut rid), et tu refais l'enregistrement sur le domaine,
qui devrait passer cette fois.


La ou ca se complique, c'est que j'ai voulu reessayer sur une autre
machine il y a quelques temps, et que ca n'a jamais voulu
fonctionner...


Voila, si ca peut aider......


A +

VANHU.

Vincent Verdon
Le #117314
Bonsoir,

Vincent Verdon
Bonsoir à tous,


Salut.


je ne sais si je frappe à la bonne porte, si je me trompe veuillez
m'en excuser mais je ne sais pas vraiment ou poster concernant des pb
sur Ldap dans un environnement Unix.


Je sais pas non plus, dans le doute je vais repondre (un peu)...


Voila, je tente d'utiliser openldap (sur Debian). Le but est
d'utiliser l'annuaire aussi bien pour des stations Unix/Linux que
Windows via Samba. Après quelques mois de recherches, la lecture su
bouquin O reilly sur ldap, etc,... je ne sais plus bien que faire.


Jusque la, tres bonne initiative :-)


[ldapadduser]
J'ai toujours eu le meme probleme.....
En meme temps, j'ai du chercher a le resoudre environ 3 secondes, et
apres j'ai laisse tomber et je me suis fait un alias....

A priori, ca doit pas influer sur le reste de tes soucis.


C'est ce que je me dis, mais je doute de tout maintenant !!!



Mon gros pb, c'est que je n'arrive pas à intégrer des machine Windoze
XP ou 2000 dans mon domaine Samba, alors que Samba est bien connecté à
mon annuaire ldap, puisque depuis des postes Win98, je peux me
connecter sans pb en utilisant un login contenu dans mon annuaire
Ldap. Samba a d'ailleurs été configuré pour accepter des utilisateurs
enregistrés dans l'annuaire ou dans le traditionnel fichier
smbpasswd. Au passage, je ne comprends pourquoi Samba ne vient pas
essayer d'authentifier mes machines XP dans smbpasswd (alors qu'elles
y sont enregistrées) si il ne les trouve pas dans l'annuaire ldap,
alors que ce mécanisme fonctionne à merveille pour les utilisateurs
(mais sous Win98 seulement, qui ne connait pas la notion de compte
d'ordinateur)...


Pareil.... enfin, a peu pres.....

Deja, y'a une grosse question importante: quelle est ta version de
Samba ?


J'ai pas mon serveur sous la main, mais il s'agit d'une Samba 3.xx.
Celle de la dernière Debian. Je regarderai demain.


Ils ont fait du gros boulot sur les toutes dernieres versions pour
pouvoir vraiment faire PDC, et c'etait beaucoup plus galere avant.


Sur le (tres vieux) Samba que j'utilise actuellement, j'ai reussi une
fois a integrer un Win2K sur le domaine.
En gros, les clients W2K/XP utilisent un numero, j'ai pas trop compris
comment il est genere, ni par qui.
Ce numero est utilise lors de l'enregistrement sur le domaine, et il
doit etre present dans la fiche LDAP, alors que tu ne le connais pas
encore, et alors que ca marche apparemment pas si tu mets toi meme
arbitrairement un numero dans la fiche....

La seule solution que j'avais trouve, c'etait de faire une demande
d'enregistrement sur le domaine, qui echoue lamentablement, forcement,
mais qui laisse une trace dans le log de samba (log.lamachine, je
crois), trace qui contient entre autres ledit numero.

Tu le recuperes, tu l'ajoutes dans la fiche de la machine (en
redumpant la foiche de la machine sur mon LDAP, je dirais que ca doit
etre l'attribut rid), et tu refais l'enregistrement sur le domaine,
qui devrait passer cette fois.



Quelle simplicité !!!!!



La ou ca se complique, c'est que j'ai voulu reessayer sur une autre
machine il y a quelques temps, et que ca n'a jamais voulu
fonctionner...


Voila, si ca peut aider......


Merci beaucoup ! enfin, j'ai toujours espoir que quelqu'un me donne une
solution rationnelle qui fonctionne simplement !

Ce qui est quand même bizarre, c'est que smb.conf contient toutes les
options qui sont sensées permettre de créer des utilisateurs, d'ajouter
des machines,...



A +

VANHU.


Amicalement, Vincent Verdon


F. Senault
Le #117030

Mon gros pb, c'est que je n'arrive pas à intégrer des machine Windoze XP
ou 2000 dans mon domaine Samba, alors que Samba est bien connecté à mon
annuaire ldap, puisque depuis des postes Win98, je peux me connecter
sans pb en utilisant un login contenu dans mon annuaire Ldap.


(Je pars du principe que tu essaie de faire joindre les machines
automatiquement au domaine.)

As-tu un "add machine script" dans ton smb.conf ? Quelle commande
lance-t-il ?

Sur mon réseau, ça fonctionne à peu près correctement, mais il faut
savoir (en vrac) :

- Tu dois faire l'ajout via un user renseigné dans les "admin users" de
smb.conf, si je ne me trompe.
- La création de la machine doit faire, dans l'ordre :
- Ajouter la machine en tant que user Unix (avec un $ au bout du
nom) - si ta base d'utilisateurs utilise un backend LDAP avec
NSS, tu crées du coup automatiquement la fiche LDAP ; sinon, il
faut créer une fiche LDAP avec uid = machine$.
- Lancer smbpasswd -m.
- Parfois, l'ajout ne fonctionne pas "du premier coup" ; en clair, en
tapant mon user / password admin du domaine, au premier coup, j'ai
un message d'erreur abscons ; au second essai, "bienvenue dans le
domaine" sans avoir fait la moindre manip. Je soupçonne un problème
de synchro ou de timeout. Bref.

Si tu veux faire joindre les machines au domaine "à la main", tu dois en
premier te connecter sur le serveur, créer le user Unix / LDAP, puis
faire smbpasswd -m machine$.

(Mon script d'ajout est assez sauvage ; je vais éviter de le poster ici,
pour épargner le coeur des Unixiens fragiles... :) )s

Fred
--
I've found an axe can do a lot for a paper-mangling printer. Especially
if you shout for one at the top of your voice, and then a cow orker
brings you said instrument. Suddenly, no more paper jams.
(Kai Henningsen in the SDM)

Vincent Verdon
Le #117029
Bonsoir et merci de me répondre,


Mon gros pb, c'est que je n'arrive pas à intégrer des machine Windoze XP
ou 2000 dans mon domaine Samba, alors que Samba est bien connecté à mon
annuaire ldap, puisque depuis des postes Win98, je peux me connecter
sans pb en utilisant un login contenu dans mon annuaire Ldap.


(Je pars du principe que tu essaie de faire joindre les machines
automatiquement au domaine.)

As-tu un "add machine script" dans ton smb.conf ? Quelle commande
lance-t-il ?


oui, il lance (de mémoire) :
/usr/local/bin/ldapaddmachine %u groupe_machines
(en provenance des "ldapscripts")


Sur mon réseau, ça fonctionne à peu près correctement, mais il faut
savoir (en vrac) :

- Tu dois faire l'ajout via un user renseigné dans les "admin users" de
smb.conf, si je ne me trompe.
- La création de la machine doit faire, dans l'ordre :
- Ajouter la machine en tant que user Unix (avec un $ au bout du
nom) - si ta base d'utilisateurs utilise un backend LDAP avec
NSS, tu crées du coup automatiquement la fiche LDAP ; sinon, il
faut créer une fiche LDAP avec uid = machine$.


je fais cela il me semble

- Lancer smbpasswd -m.


je crois que le pb vient de là. J'ai omis cette manip, croyant naïvement
que Samba le faisait pour moi, mais c'est vrai maintenant que qu'avant
d'utiliser Ldap, il me fallait bien utiliser cette commande pour créer
ma machine dans smbpasswd !

- Parfois, l'ajout ne fonctionne pas "du premier coup" ; en clair, en
tapant mon user / password admin du domaine, au premier coup, j'ai
un message d'erreur abscons ; au second essai, "bienvenue dans le
domaine" sans avoir fait la moindre manip. Je soupçonne un problème
de synchro ou de timeout. Bref.


Je crois qu'il y a une option pour demander à Samba d'être patient lors
de l'interrogation de ldap. J'ai lu quelque chose dans smb.conf.


Si tu veux faire joindre les machines au domaine "à la main", tu dois en
premier te connecter sur le serveur, créer le user Unix / LDAP, puis
faire smbpasswd -m machine$.


Il faut échapper le $ ?


(Mon script d'ajout est assez sauvage ; je vais éviter de le poster ici,
pour épargner le coeur des Unixiens fragiles... :) )s


Tu peux, si tu veux bien, me l'envoyer à mon adresse perso... Merci !


Fred



Amicalement, Vincent Verdon


F. Senault
Le #117025
Le 14 novembre à 18:00, sur fr.comp.os.unix, j'ai lu :

Bonsoir et merci de me répondre,


'Sévices.


- Lancer smbpasswd -m.


je crois que le pb vient de là. J'ai omis cette manip, croyant naïvement
que Samba le faisait pour moi, mais c'est vrai maintenant que qu'avant
d'utiliser Ldap, il me fallait bien utiliser cette commande pour créer
ma machine dans smbpasswd !


C'est impératif.

- Parfois, l'ajout ne fonctionne pas "du premier coup" ; en clair, en
tapant mon user / password admin du domaine, au premier coup, j'ai
un message d'erreur abscons ; au second essai, "bienvenue dans le
domaine" sans avoir fait la moindre manip. Je soupçonne un problème
de synchro ou de timeout. Bref.


Je crois qu'il y a une option pour demander à Samba d'être patient lors
de l'interrogation de ldap. J'ai lu quelque chose dans smb.conf.


Si tu retombes sur l'info, dis toujours.

Si tu veux faire joindre les machines au domaine "à la main", tu dois en
premier te connecter sur le serveur, créer le user Unix / LDAP, puis
faire smbpasswd -m machine$.


Il faut échapper le $ ?


'Dépend du shell.

(Mon script d'ajout est assez sauvage ; je vais éviter de le poster ici,
pour épargner le coeur des Unixiens fragiles... :) )s


Tu peux, si tu veux bien, me l'envoyer à mon adresse perso... Merci !


Il suit.

Fred
--
Please Take this And run far away Far as you can see I am tainted
And happiness And peace of mind Were never meant for me All these
pieces And promises And left behinds If only I could see In my
nothing (Nine Inch Nails, And All that Could Have Been)


Vincent Verdon
Le #117022
Bonsoir,


Si tu veux faire joindre les machines au domaine "à la main", tu dois en
premier te connecter sur le serveur, créer le user Unix / LDAP, puis
faire smbpasswd -m machine$.
Il faut échapper le $ ?



'Dépend du shell.


Bash


(Mon script d'ajout est assez sauvage ; je vais éviter de le poster ici,
pour épargner le coeur des Unixiens fragiles... :) )s
Tu peux, si tu veux bien, me l'envoyer à mon adresse perso... Merci !



Il suit.


Merci !


Fred


Amicalement, Vincent Verdon



Vincent Verdon
Le #119265
Bonsoir,

je me réponds à moi-même, car j'ai trouvé le pb.

En fait, j'utilise une base de donnée annuaire Ldap provenant d'un autre
serveur, ma machine étant destinée à être esclave Ldap tout en étant
serveur de domaine Samba. Je me suis rendu compte que les mots de passe
ne sont gérés de la même manière (par défaut) sur les deux serveurs
Ldap : CRYPT sur l'un et SHA sur l'autre (de mémoire). Il m'a suffit de
forcer l'utilisation de la bonne méthode par la commande appropriée dans
le fichier /etc/ldap/slapd.conf pour que tout fonctionne alors.

Merci en tout cas à tous ceux qui m'ont aidé.

Amicalement, Vincent Verdon
Publicité
Poster une réponse
Anonyme