Pbr association dans WM sous seven...

Le
momo
bonsoir
j'ai rapatrié WM de vista à seven et ça marche bien, sauf que
je ne peux pas ouvrir les .pps ou les.avi directement à partir de WM,
qui me dit qu'il n'y a pas de programme associé pour ouvrir ces fichiers,
alors que l'association est parfaitement faite, et bien visible dans la
liste des extensions avec programme associé en face:
- visionneuse powerpoint pour les pps
- vlc pour les avi
J'enregistre donc la PJ, puis un double click sur ces fichiers dans leur
dossier les ouvre sans prb

Curieusement le prb ne se produit pas avec les .pdf (associés à foxit) ni
avec les .doc
qui eux sont bien renvoyés directement à leur programme respectif.
QQ a une idée?
merci d'avance
momo
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Luc
Le #20463091
momo a écrit...

bonsoir



Bonjour,

j'ai rapatrié WM de vista à seven et ça marche bien, sauf que
je ne peux pas ouvrir les .pps ou les.avi directement à partir de WM,
qui me dit qu'il n'y a pas de programme associé pour ouvrir ces
fichiers, alors que l'association est parfaitement faite, et bien
visible dans la liste des extensions avec programme associé en face:
- visionneuse powerpoint pour les pps
- vlc pour les avi...
J'enregistre donc la PJ, puis un double click sur ces fichiers dans
leur dossier les ouvre sans prb...

Curieusement le prb ne se produit pas avec les .pdf (associés à
foxit) ni avec les .doc
qui eux sont bien renvoyés directement à leur programme respectif.
QQ a une idée?



Je n'ai pas W7 sous la main, je vais te donner la solution qui marche pour
Vista. Je pense qu'elle devrait fonctionner pour W7 mais je ne peux le
vérifier. Tu pourras confirmer ou infirmer mon préjugé.


Le problème sous Vista, c'est qu'on ne peut pas intervenir par 'Options des
dossiers' --> onglet 'Types de fichiers' comme on le fait sous XP puisque
cet onglet n'existe pas. Je suppose que sous W7, c'est la même chose donc il
faut intervenir directement dans le Registre.

--------------------------PPS et PPT-------------------

*Pour les fichiers .pps* (et probablement aussi .ppt), selon la visionneuse
que tu as installée...

----Visionneuse PowerPoint 2003---
- va dans le registre ('Démarrer' --> 'Tous les programmes' -->
'Accessoires' --> 'Exécuter' --> taper "regedit" (sans les guillemets))
- développe la branche
HKEY_CLASSES_ROOTPowerPointViewer.SlideShow.11shellShow
- renomme la clé Show en Open (clic droit sur Show --> 'Renommer')

Faire la même manoeuvre pour les fichier ppt, c'est-à-dire pour la clé
HKEY_CLASSES_ROOTPowerPointViewer.Show.11shellShow


---Visionneuse PowerPoint 2007---
- va dans le registre ('Démarrer' --> 'Tous les programmes' -->
'Accessoires' --> 'Exécuter' --> taper "regedit" (sans les guillemets))
- développe la branche
HKEY_CLASSES_ROOTPowerPointViewer.SlideShow.12shellShow
- renomme la clé Show en Open (clic droit sur Show --> 'Renommer')

Faire la même manoeuvre pour les fichier ppt, c'est-à-dire pour la clé
HKEY_CLASSES_ROOTPowerPointViewer.Show.12shellShow



----------------------AVI--------------------

*Pour les fichiers .avi associés à VLC*, il faut créer une clé
HKEY_CLASSES_ROOTVLC.avishellopen. On pourrait la créer à la main mais
comme son contenu est identique à la clé clé
HKEY_CLASSES_ROOTVLC.avishellPlay qui doit déjà exister dans ton
Registre, on peut user de la petite bidouille suivant qui sera aussi rapide
et beaucoup plus sûre (aucun risque de faire une faute de frappe) que la
création manuelle...
- exporter la clé HKEY_CLASSES_ROOTVLC.avishellPlay (clic droit -->
'Exporter')
- ouvrir le fichier .reg résultant avec le bloc.notes
- remplacer les 2 occurences de "Play" en "open" et fermer le fichier pour
sauvegarder les modifications
- double-cliquer le fichier .reg pour importer la nouvelle clé
HKEY_CLASSES_ROOTVLC.avishellopen

merci d'avance...



Padkoi

--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg
momo
Le #20467061
"Luc" news:

Je n'ai pas W7 sous la main, je vais te donner la solution qui marche pour
Vista. Je pense qu'elle devrait fonctionner pour W7 mais je ne peux le
vérifier. Tu pourras confirmer ou infirmer mon préjugé.


Le problème sous Vista, c'est qu'on ne peut pas intervenir par 'Options
des dossiers' --> onglet 'Types de fichiers' comme on le fait sous XP
puisque cet onglet n'existe pas. Je suppose que sous W7, c'est la même
chose donc il faut intervenir directement dans le Registre.



Si, sous seven, on peut: panneau de config... programmes par défaut...
'associer un type de fichier ou un protocole à un programme...'
et là les pps sont bien associés à la visionneuse powerpoint 2003

--------------------------PPS et PPT-------------------

*Pour les fichiers .pps* (et probablement aussi .ppt), selon la
visionneuse que tu as installée...

----Visionneuse PowerPoint 2003---
- va dans le registre ('Démarrer' --> 'Tous les programmes' -->
'Accessoires' --> 'Exécuter' --> taper "regedit" (sans les guillemets))
- développe la branche
HKEY_CLASSES_ROOTPowerPointViewer.SlideShow.11shellShow
- renomme la clé Show en Open (clic droit sur Show --> 'Renommer')

Faire la même manoeuvre pour les fichier ppt, c'est-à-dire pour la clé
HKEY_CLASSES_ROOTPowerPointViewer.Show.11shellShow


---Visionneuse PowerPoint 2007---
- va dans le registre ('Démarrer' --> 'Tous les programmes' -->
'Accessoires' --> 'Exécuter' --> taper "regedit" (sans les guillemets))
- développe la branche
HKEY_CLASSES_ROOTPowerPointViewer.SlideShow.12shellShow
- renomme la clé Show en Open (clic droit sur Show --> 'Renommer')

Faire la même manoeuvre pour les fichier ppt, c'est-à-dire pour la clé
HKEY_CLASSES_ROOTPowerPointViewer.Show.12shellShow



----------------------AVI--------------------

*Pour les fichiers .avi associés à VLC*, il faut créer une clé
HKEY_CLASSES_ROOTVLC.avishellopen. On pourrait la créer à la main mais
comme son contenu est identique à la clé clé
HKEY_CLASSES_ROOTVLC.avishellPlay qui doit déjà exister dans ton
Registre, on peut user de la petite bidouille suivant qui sera aussi
rapide et beaucoup plus sûre (aucun risque de faire une faute de frappe)
que la création manuelle...
- exporter la clé HKEY_CLASSES_ROOTVLC.avishellPlay (clic droit -->
'Exporter')
- ouvrir le fichier .reg résultant avec le bloc.notes
- remplacer les 2 occurences de "Play" en "open" et fermer le fichier pour
sauvegarder les modifications
- double-cliquer le fichier .reg pour importer la nouvelle clé
HKEY_CLASSES_ROOTVLC.avishellopen

merci d'avance...



Padkoi

--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg


Bonsoir luc...
eh bien ta solution marche parfaitement pour vlc et les avi, au point que je
l'ai extrapolée pour les wmv et les mpg
et ça fonctionne...
par contre pour pps et ppt, j'avais déjà eu le prb sous xp et vista
et réglé comme tu l'indiques...
mais là sous seven, après vérification soigneuse dans mon registre
j'avais bien déjà transformé la clé show en open:
HKEY_CLASSES_ROOTPowerPointViewer.SlideShow.11shellOpen
HKEY_CLASSES_ROOTPowerPointViewer.Show.11shellOpen

mais ça ne marche pas quand même et ça m'étonne fortement
puisque ça a fonctionné sous xp et vista...
bon c'est pas un drame quand même, mais je constate aussi dans la liste des
protocoles sous seven
qu'il manque mailto
ainsi que le protocole (oublié le nom) pour associer les news à winmail...
pleins de petits désagréments qui font ce ce transfert de winmail de vista à
seven n'est pas parfait...

si luc, toujours plein de ressources, tu as une solution...?
merci
Luc
Le #20467181
momo a écrit...

"Luc" de news:

Je n'ai pas W7 sous la main, je vais te donner la solution qui
marche pour Vista. Je pense qu'elle devrait fonctionner pour W7 mais
je ne peux le vérifier. Tu pourras confirmer ou infirmer mon préjugé.


Le problème sous Vista, c'est qu'on ne peut pas intervenir par
'Options des dossiers' --> onglet 'Types de fichiers' comme on le
fait sous XP puisque cet onglet n'existe pas. Je suppose que sous
W7, c'est la même chose donc il faut intervenir directement dans le
Registre.



Si, sous seven, on peut: panneau de config... programmes par défaut...
'associer un type de fichier ou un protocole à un programme...'
et là les pps sont bien associés à la visionneuse powerpoint 2003



D'accord mais je ne parle pas de 'Associer un type de fichier ou un
protocole à un programme' qui existe aussi sous Vista mais de l'onglet 'Type
de fichiers' des 'Options des dossiers' qui permet de faire le même genre de
bidouille chirurgicale que celle ci-dessous mais sans passer par le
Registre.


--------------------------PPS et PPT-------------------

*Pour les fichiers .pps* (et probablement aussi .ppt), selon la
visionneuse que tu as installée...

----Visionneuse PowerPoint 2003---
- va dans le registre ('Démarrer' --> 'Tous les programmes' -->
'Accessoires' --> 'Exécuter' --> taper "regedit" (sans les
guillemets)) - développe la branche
HKEY_CLASSES_ROOTPowerPointViewer.SlideShow.11shellShow
- renomme la clé Show en Open (clic droit sur Show --> 'Renommer')

Faire la même manoeuvre pour les fichier ppt, c'est-à-dire pour la
clé HKEY_CLASSES_ROOTPowerPointViewer.Show.11shellShow


---Visionneuse PowerPoint 2007---
- va dans le registre ('Démarrer' --> 'Tous les programmes' -->
'Accessoires' --> 'Exécuter' --> taper "regedit" (sans les
guillemets)) - développe la branche
HKEY_CLASSES_ROOTPowerPointViewer.SlideShow.12shellShow
- renomme la clé Show en Open (clic droit sur Show --> 'Renommer')

Faire la même manoeuvre pour les fichier ppt, c'est-à-dire pour la
clé HKEY_CLASSES_ROOTPowerPointViewer.Show.12shellShow



----------------------AVI--------------------

*Pour les fichiers .avi associés à VLC*, il faut créer une clé
HKEY_CLASSES_ROOTVLC.avishellopen. On pourrait la créer à la main
mais comme son contenu est identique à la clé clé
HKEY_CLASSES_ROOTVLC.avishellPlay qui doit déjà exister dans ton
Registre, on peut user de la petite bidouille suivant qui sera aussi
rapide et beaucoup plus sûre (aucun risque de faire une faute de
frappe) que la création manuelle...
- exporter la clé HKEY_CLASSES_ROOTVLC.avishellPlay (clic droit
--> 'Exporter')
- ouvrir le fichier .reg résultant avec le bloc.notes
- remplacer les 2 occurences de "Play" en "open" et fermer le
fichier pour sauvegarder les modifications
- double-cliquer le fichier .reg pour importer la nouvelle clé
HKEY_CLASSES_ROOTVLC.avishellopen

merci d'avance...



Padkoi

--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg


Bonsoir luc...
eh bien ta solution marche parfaitement pour vlc et les avi, au point
que je l'ai extrapolée pour les wmv et les mpg
et ça fonctionne...
par contre pour pps et ppt, j'avais déjà eu le prb sous xp et vista
et réglé comme tu l'indiques...
mais là sous seven, après vérification soigneuse dans mon registre
j'avais bien déjà transformé la clé show en open:
HKEY_CLASSES_ROOTPowerPointViewer.SlideShow.11shellOpen
HKEY_CLASSES_ROOTPowerPointViewer.Show.11shellOpen

mais ça ne marche pas quand même et ça m'étonne fortement
puisque ça a fonctionné sous xp et vista...



Ça m'étonne également que ça ne fonctionne pas.
Essaie de réinstaller la visionneuse 2003 par dessus elle-même ou après
l'avoir désinstallée ou essaie la visionneuse 2007 pour voir

bon c'est pas un drame quand même, mais je constate aussi dans la
liste des protocoles sous seven
qu'il manque mailto
ainsi que le protocole (oublié le nom) pour associer les news à
winmail... pleins de petits désagréments qui font ce ce transfert de
winmail de vista à seven n'est pas parfait...



> si luc, toujours plein de ressources, tu as une solution...?

Passe un coup de WMInstall de Pierre Torris, ça devrait te régler tout ça en
un clin d'oeil.
http://www.ptorris.com/outils.php

merci



Padkoi

--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg
momo
Le #20472631
"Luc" news:
momo a écrit...

Bonsoir luc...
eh bien ta solution marche parfaitement pour vlc et les avi, au point
que je l'ai extrapolée pour les wmv et les mpg
et ça fonctionne...
par contre pour pps et ppt, j'avais déjà eu le prb sous xp et vista
et réglé comme tu l'indiques...
mais là sous seven, après vérification soigneuse dans mon registre
j'avais bien déjà transformé la clé show en open:
HKEY_CLASSES_ROOTPowerPointViewer.SlideShow.11shellOpen
HKEY_CLASSES_ROOTPowerPointViewer.Show.11shellOpen

mais ça ne marche pas quand même et ça m'étonne fortement
puisque ça a fonctionné sous xp et vista...



Ça m'étonne également que ça ne fonctionne pas.
Essaie de réinstaller la visionneuse 2003 par dessus elle-même ou après
l'avoir désinstallée ou essaie la visionneuse 2007 pour voir

bon c'est pas un drame quand même, mais je constate aussi dans la
liste des protocoles sous seven
qu'il manque mailto
ainsi que le protocole (oublié le nom) pour associer les news à
winmail... pleins de petits désagréments qui font ce ce transfert de
winmail de vista à seven n'est pas parfait...



> si luc, toujours plein de ressources, tu as une solution...?

Passe un coup de WMInstall de Pierre Torris, ça devrait te régler tout ça
en un clin d'oeil.
http://www.ptorris.com/outils.php

merci



Padkoi

Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/



Hello
ça progresse peu à peu...
La réinstallation de la visionneuse plus la (re)modif des clés comme dit
ci-dessus a fonctionné...
je ne comprends pas tout du pourquoi mais bon...
par contre malgré Wminstall
les protocoles mailto et news refusent sont toujours aux abonnés absents
et donc pas associés à Win mail...

je soupçonne mon seven version d'essai d'être pas trop bien fini...
a+
momo
Luc
Le #20472801
momo a écrit...

Hello



Bonjour,

ça progresse peu à peu...
La réinstallation de la visionneuse plus la (re)modif des clés comme
dit ci-dessus a fonctionné...
je ne comprends pas tout du pourquoi mais bon...



C'est toujours ça de réglé.

par contre malgré Wminstall
les protocoles mailto et news refusent sont toujours aux abonnés
absents et donc pas associés à Win mail...



Je vais être très limité pour t'aider car, comme je te l'ai dit dans ma
première intervention, je n'ai pas W7 disponible et ne peux donc faire les
tests nécessaires.

Regarde dans ''Associer un type de fichier ou un protocole à un programme
spécifique' si tu as le choix d'associer WM aux protocoles MAILTO et NEWS
(il faut aller tout en bas de la liste pour voir la liste des protocole)

je soupçonne mon seven version d'essai d'être pas trop bien fini...
a+
momo



--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg
momo
Le #20473901
"Luc" news:OEyW3v%
momo a écrit...


par contre malgré Wminstall
les protocoles mailto et news refusent sont toujours aux abonnés
absents et donc pas associés à Win mail...



Je vais être très limité pour t'aider car, comme je te l'ai dit dans ma
première intervention, je n'ai pas W7 disponible et ne peux donc faire les
tests nécessaires.

Regarde dans ''Associer un type de fichier ou un protocole à un programme
spécifique' si tu as le choix d'associer WM aux protocoles MAILTO et NEWS
(il faut aller tout en bas de la liste pour voir la liste des protocole)

je soupçonne mon seven version d'essai d'être pas trop bien fini...
a+
momo



--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/



Bonsoir
C'est bien là que j'ai regardé et où les protocoles MAILTO et NEWS sont
absents:
je n'ai que:
FTP HTTP HTTPS -> Firefox
LDAP-> contact windows
MMS -> windows media player
SEARCH-> explorateur

Est ce dû au fait qu'il n'y a pas de logiciel de messagerie implanté par
défaut dans seven?
A un nettoyage intempestif de la base de registre?
A mon Seven d'essai?
Peut on rajouter les protocoles manquants?
a+
momo
Luc
Le #20474341
momo a écrit...

"Luc" de news:OEyW3v%
momo a écrit...


par contre malgré Wminstall
les protocoles mailto et news refusent sont toujours aux abonnés
absents et donc pas associés à Win mail...



Je vais être très limité pour t'aider car, comme je te l'ai dit dans
ma première intervention, je n'ai pas W7 disponible et ne peux donc
faire les tests nécessaires.

Regarde dans ''Associer un type de fichier ou un protocole à un
programme spécifique' si tu as le choix d'associer WM aux protocoles
MAILTO et NEWS (il faut aller tout en bas de la liste pour voir la
liste des protocole)
je soupçonne mon seven version d'essai d'être pas trop bien fini...
a+
momo



--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/



Bonsoir
C'est bien là que j'ai regardé et où les protocoles MAILTO et NEWS
sont absents:
je n'ai que:
FTP HTTP HTTPS -> Firefox
LDAP-> contact windows
MMS -> windows media player
SEARCH-> explorateur

Est ce dû au fait qu'il n'y a pas de logiciel de messagerie implanté
par défaut dans seven?
A un nettoyage intempestif de la base de registre?



L'absence de logiciel de messagerie explique l'absence de ces protocoles
mais WMInstall aurait dû les ajouter... et si tu as utilisé un "nettoyeur"
du Registre (dont on connaît trop bien les méfaits, jamais les bienfaits) on
peut soupçonner que ce "nettoyage" a été un peu trop récurant.

A mon Seven d'essai?



Je ne pense pas.

Peut on rajouter les protocoles manquants?



Ce que tu peux essayer, c'est installer Windows Live Mail
(http://www.windowslive.fr/livemail/). Peut-être les protocoles MAILTO,
NEWS, NNTP et SNEWS s'installeront-ils, associés à WL Mail normalement. Si
c'est le cas, un nouveau coup de WMInstall devrait les associer à WM.

a+
momo



--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg
momo
Le #20476861
....
Ce que tu peux essayer, c'est installer Windows Live Mail
(http://www.windowslive.fr/livemail/). Peut-être les protocoles MAILTO,
NEWS, NNTP et SNEWS s'installeront-ils, associés à WL Mail normalement. Si
c'est le cas, un nouveau coup de WMInstall devrait les associer à WM.

a+
momo



--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/



Merci pour ta persévérance, luc...
Voici l'état des courses: installation de WLM
(+configuration adresses mail, groupes de discussion, importation contacts -
tout OK)
Il m'implante bien les protocoles MAILTO, NEWS, SNEWS, NNTP
tous associés à WLM of course

exécution de WMinstall
niet, tout reste associé à WLM
redémarrage, nouvel essai_> idem

Tentative de modifier l'association 'à la main' en cliquant sur le protocole
puis 'changer le programme'
Il n' y a QUE WLM dans la liste, et pas de flèche déroulante 'autres
programmes'

exécution de WMClientsMail.reg, le tien, luc
retour au protocole il n' a toujours QUE WLM dans la liste des programmes à
choisir

Je ne sais plus...
Rester à WLM serait le plus simple !?.....

momo
Luc
Le #20477271
momo a écrit...

....
Ce que tu peux essayer, c'est installer Windows Live Mail
(http://www.windowslive.fr/livemail/). Peut-être les protocoles
MAILTO, NEWS, NNTP et SNEWS s'installeront-ils, associés à WL Mail
normalement. Si c'est le cas, un nouveau coup de WMInstall devrait
les associer à WM.
a+
momo



--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/



Merci pour ta persévérance, luc...
Voici l'état des courses: installation de WLM
(+configuration adresses mail, groupes de discussion, importation
contacts - tout OK)
Il m'implante bien les protocoles MAILTO, NEWS, SNEWS, NNTP
tous associés à WLM of course

exécution de WMinstall
niet, tout reste associé à WLM
redémarrage, nouvel essai_> idem

Tentative de modifier l'association 'à la main' en cliquant sur le
protocole puis 'changer le programme'
Il n' y a QUE WLM dans la liste, et pas de flèche déroulante 'autres
programmes'

exécution de WMClientsMail.reg, le tien, luc
retour au protocole il n' a toujours QUE WLM dans la liste des
programmes à choisir



et dans 'Programme par défaut' --> 'Choissez vos programmes par défaut', je
suppose que WM n'est pas dans la liste ?

Je ne sais plus...



Moi non plus ! :-(
WMInstall aurait dû régler toutes les questions d'association et mettre WM
comme client de messagerie et de news par défaut. C'est très surprenant
qu'il n'ait pas fonctionné.

Rester à WLM serait le plus simple !?.....



Ça laisse le problème en suspens ce qui n'est jamais très satisfaisant mais
bien sûr tu peux rester à WL Mail.

momo



--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg
momo
Le #20478791
.................................>>
Tentative de modifier l'association 'à la main' en cliquant sur le
protocole puis 'changer le programme'
Il n' y a QUE WLM dans la liste, et pas de flèche déroulante 'autres
programmes'

exécution de WMClientsMail.reg, le tien, luc
retour au protocole il n' a toujours QUE WLM dans la liste des
programmes à choisir



et dans 'Programme par défaut' --> 'Choissez vos programmes par défaut',
je suppose que WM n'est pas dans la liste ?



Non bien sûr il n' y a que WLM......

Rester à WLM serait le plus simple !?.....



Ça laisse le problème en suspens ce qui n'est jamais très satisfaisant
mais bien sûr tu peux rester à WL Mail.

--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/



Merci...
momo
Publicité
Poster une réponse
Anonyme